You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     de...@freebsd.org
Last committer: zeis...@freebsd.org
Ident:          $FreeBSD: head/graphics/gource/Makefile 351411 2014-04-16 
18:28:47Z zeising $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/91amd64-default/2014-06-19_06h15m55s/logs/gource-0.40_3.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/91amd64-default/2014-06-19_06h15m55s
Log:

====>> Building graphics/gource
build started at Thu Jun 19 17:00:45 UTC 2014
port directory: /usr/ports/graphics/gource
building for: FreeBSD 91amd64-default-job-13 9.1-RELEASE-p13 FreeBSD 
9.1-RELEASE-p13 amd64
maintained by: de...@freebsd.org
Makefile ident:      $FreeBSD: head/graphics/gource/Makefile 351411 2014-04-16 
18:28:47Z zeising $
Poudriere version: 3.1-pre
Host OSVERSION: 1100022
Jail OSVERSION: 901000

---Begin Environment---
OSVERSION=901000
UNAME_v=FreeBSD 9.1-RELEASE-p13
UNAME_r=9.1-RELEASE-p13
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/91amd64-default/ref
PKG_EXT=txz
tpid=52314
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=gource-0.40_3
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/91amd64-default/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/91amd64-default/ref/poudriere/pool
MASTERNAME=91amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-boost-system=boost_system  --with-boost-filesystem=boost_filesystem 
--prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" MAKE=gmake PKG_CONFIG=pkgconf SHELL=/bin/sh CONFIG_SHELL=/bin/sh 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" NO_PIE=yes SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="/usr/local/bin/clang33" 
CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="/usr/local/bin/clang-cpp33" 
CPPFLAGS="-I/usr/local/include"  LDFLAGS=" -L/usr/local/lib" LIBS=""  
CXX="/usr/local/bin/clang++33" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=9.1
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
DOCSDIR="share/doc/gource"
EXAMPLESDIR="share/examples/gource"
DATADIR="share/gource"
WWWDIR="www/gource"
ETCDIR="etc/gource"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/gource
DOCSDIR=/usr/local/share/doc/gource
EXAMPLESDIR=/usr/local/share/examples/gource
WWWDIR=/usr/local/www/gource
ETCDIR=/usr/local/etc/gource
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
# clean-restricted ran via poudriere.conf NO_RESTRICTED
#NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for gource-0.40_3
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   gource-0.40_3 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7_3.txz
Installing pkg-1.2.7_3... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of gource-0.40_3
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by gource-0.40_3 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by gource-0.40_3 for building
=> SHA256 Checksum OK for gource-0.40.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by gource-0.40_3 for building
===>  Extracting for gource-0.40_3
=> SHA256 Checksum OK for gource-0.40.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for gource-0.40_3
===========================================================================
=======================<phase: build-depends  >============================
===>   gource-0.40_3 depends on file: /usr/local/include/glm/glm.hpp - not found
===>    Verifying install for /usr/local/include/glm/glm.hpp in 
/usr/ports/math/glm
===>   Installing existing package /packages/All/glm-0.9.5.3.txz
Installing glm-0.9.5.3... done
===>   Returning to build of gource-0.40_3
===>   gource-0.40_3 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1...Installing gettext-0.18.3.1_1...Installing 
libiconv-1.14_3... done
 done
 done
===>   Returning to build of gource-0.40_3
===>   gource-0.40_3 depends on executable: pkgconf - not found
===>    Verifying install for pkgconf in /usr/ports/devel/pkgconf
===>   Installing existing package /packages/All/pkgconf-0.9.6.txz
Installing pkgconf-0.9.6... done
===>   Returning to build of gource-0.40_3
===>   gource-0.40_3 depends on file: /usr/local/bin/clang33 - not found
===>    Verifying install for /usr/local/bin/clang33 in /usr/ports/lang/clang33
===>   Installing existing package /packages/All/clang33-3.3_7.txz
Installing clang33-3.3_7...Installing llvm33-3.3_8...Installing 
libexecinfo-1.1_3... done
Installing perl5-5.16.3_11... done
Installing python27-2.7.6_4... done
 done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of gource-0.40_3
===========================================================================
=======================<phase: lib-depends    >============================
===>   gource-0.40_3 depends on shared library: libSDL_image.so - not found
===>    Verifying for libSDL_image.so in /usr/ports/graphics/sdl_image
===>   Installing existing package /packages/All/sdl_image-1.2.12_5.txz
Installing sdl_image-1.2.12_5...Installing jpeg-8_5... done
Installing png-1.5.18... done
Installing sdl-1.2.15_4,2...Installing aalib-1.4.r5_10... done
Installing libGLU-9.0.0...Installing libGL-7.6.1_4...Installing 
dri2proto-2.8... done
Installing expat-2.1.0... done
Installing libX11-1.6.2_2,1...Installing kbproto-1.0.6... done
Installing libXau-1.0.8_2...Installing xproto-7.0.25... done
 done
Installing libXdmcp-1.1.1_2... done
Installing libxcb-1.10_2...Installing libpthread-stubs-0.3_5... done
Installing libxml2-2.9.1_1... done
 done
 done
Installing libXdamage-1.1.4_2...Installing damageproto-1.2.1... done
Installing libXfixes-5.0.1_2...Installing fixesproto-5.0... done
 done
 done
Installing libXext-1.3.2_2,1...Installing xextproto-7.3.0... done
 done
Installing libXxf86vm-1.1.3_2...Installing xf86vidmodeproto-2.3.1... done
 done
Installing libdrm-2.4.17_1...Installing libpciaccess-0.13.2_2...Installing 
pciids-20140526... done
 done
 done
 done
 done
Installing libXrandr-1.4.2_2...Installing libXrender-0.9.8_2...Installing 
renderproto-0.11.1... done
 done
Installing randrproto-1.4.0... done
 done
 done
Installing tiff-4.0.3_3...Installing jbigkit-1.6... done
 done
Installing webp-0.4.0...Installing giflib-nox11-4.2.3_2... done
 done
 done
------------------------------------------------------------------------------
 Your SDL library has been built with libvgl support, which means that you
 can run almost any SDL application straight on your console (VESA 2.0
 compatible videocard is required).

 To do this you have to load the vesa kernel module or enable it in your
 kernel, and set environment variable "SDL_VIDEODRIVER=vgl".
------------------------------------------------------------------------------
===>   Returning to build of gource-0.40_3
===>   gource-0.40_3 depends on shared library: libfreetype.so - not found
===>    Verifying for libfreetype.so in /usr/ports/print/freetype2
===>   Installing existing package /packages/All/freetype2-2.5.3_2.txz
Installing freetype2-2.5.3_2... done
===>   Returning to build of gource-0.40_3
===>   gource-0.40_3 depends on shared library: libpcre.so - not found
===>    Verifying for libpcre.so in /usr/ports/devel/pcre
===>   Installing existing package /packages/All/pcre-8.34_1.txz
Installing pcre-8.34_1... done
===>   Returning to build of gource-0.40_3
===>   gource-0.40_3 depends on shared library: libGLEW.so - not found
===>    Verifying for libGLEW.so in /usr/ports/graphics/glew
===>   Installing existing package /packages/All/glew-1.10.0_1.txz
Installing glew-1.10.0_1...Installing libXi-1.7.2_2,1...Installing 
inputproto-2.3... done
 done
Installing libXmu-1.1.2_2,1...Installing libXt-1.1.4_2,1...Installing 
libSM-1.2.2_2,1...Installing libICE-1.0.8_2,1... done
 done
 done
 done
 done
===>   Returning to build of gource-0.40_3
===>   gource-0.40_3 depends on shared library: libboost_filesystem.so - not 
found
===>    Verifying for libboost_filesystem.so in /usr/ports/devel/boost-libs
===>   Installing existing package /packages/All/boost-libs-1.55.0_3.txz
Installing boost-libs-1.55.0_3...Installing icu-53.1... done
 done
You have built the Boost library with thread support.

Don't forget to add -pthread to your linker options when
linking your code.
===>   Returning to build of gource-0.40_3
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for gource-0.40_3
configure: loading site script /usr/ports/Templates/config.site
checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... (cached) /bin/mkdir -p
checking for gawk... (cached) /usr/bin/awk
checking whether gmake sets $(MAKE)... yes
checking build system type... amd64-portbld-freebsd9.1
checking host system type... amd64-portbld-freebsd9.1
checking whether the C++ compiler works... yes
checking for C++ compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether /usr/local/bin/clang++33 accepts -g... yes
checking for style of include used by gmake... GNU
checking dependency style of /usr/local/bin/clang++33... gcc3
checking for timegm... yes
checking for unsetenv... (cached) yes
checking how to run the C++ preprocessor... /usr/local/bin/clang++33 -E
checking for X... libraries , headers 
checking for a sed that does not truncate output... (cached) /usr/bin/sed
checking for gcc... /usr/local/bin/clang33
checking whether we are using the GNU C compiler... yes
checking whether /usr/local/bin/clang33 accepts -g... yes
checking for /usr/local/bin/clang33 option to accept ISO C89... none needed
checking dependency style of /usr/local/bin/clang33... gcc3
checking for the pthreads library -lpthreads... no
checking whether pthreads work without any flags... no
checking whether pthreads work with -Kthread... no
checking whether pthreads work with -kthread... no
checking for the pthreads library -llthread... no
checking whether pthreads work with -pthread... yes
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking if more special flags are required for pthreads... -D_THREAD_SAFE
checking how to run the C preprocessor... /usr/local/bin/clang-cpp33
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking for ANSI C header files... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking whether we are using the Microsoft C compiler... no
checking windows.h usability... no
checking windows.h presence... no
checking for windows.h... no
checking for GL/gl.h... yes
checking for OpenGL/gl.h... no
checking for OpenGL library... -lGL
checking for GL/glu.h... yes
checking for OpenGL/glu.h... no
checking for OpenGL Utility library... -lGLU
checking for varargs GLU tesselator callback function type... no
checking pkg-config is at least version 0.9.0... yes
checking for FT2... yes
checking for PCRE... yes
checking for GLEW... yes
checking for SDL... yes
checking for IMG_LoadPNG_RW... yes
checking for IMG_LoadJPG_RW... yes
checking for boostlib >= 1.46... yes
checking whether the Boost::System library is available... yes
checking for exit in -lboost_system... yes
checking whether the Boost::Filesystem library is available... yes
checking for exit in -lboost_filesystem... yes
checking glm/glm.hpp usability... yes
checking glm/glm.hpp presence... yes
checking for glm/glm.hpp... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: executing depfiles commands
===========================================================================
=======================<phase: build          >============================
===>  Building for gource-0.40_3
/usr/local/bin/clang++33 -DPACKAGE_NAME=\"Gource\" -DPACKAGE_TARNAME=\"gource\" 
-DPACKAGE_VERSION=\"0.40\" -DPACKAGE_STRING=\"Gource\ 0.40\" 
-DPACKAGE_BUGREPORT=\"acaudw...@gmail.com\" -DPACKAGE_URL=\"\" 
-DPACKAGE=\"gource\" -DVERSION=\"0.40\" -DHAVE_TIMEGM=1 -DHAVE_UNSETENV=1 
-DHAVE_PTHREAD=1 -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 
-DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 
-DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_GL_GL_H=1 
-DHAVE_GL_GLU_H=1 -DHAVE_IMG_LOADPNG_RW=1 -DHAVE_IMG_LOADJPG_RW=1 
-DHAVE_BOOST=/\*\*/ -DHAVE_BOOST_SYSTEM=/\*\*/ -DHAVE_BOOST_FILESYSTEM=/\*\*/ 
-I.  -DSDLAPP_RESOURCE_DIR=\"/usr/local/share/gource\"  -I/usr/local/include 
-D_THREAD_SAFE -pthread -D_THREAD_SAFE -pthread -I/usr/local/include/freetype2  
 -I/usr/local/include   -I/usr/local/include/GL -I/usr/local/include/drm 
-D_THREAD_SAFE -I/usr/local/include   -I/usr/local/include/SDL 
-I/usr/local/include -D_GNU_SOURCE=1 -D_REENTRANT -D_THREAD_SA
 FE   -I/usr/local/include -std=gnu++0x -Wall -Wno-sign-compare -Wno-reorder 
-Wno-unused-but-set-variable -Wno-unused-variable -O2 -pipe 
-fno-strict-aliasing -D_THREAD_SAFE -pthread -D_THREAD_SAFE -pthread -MT 
src/gource-action.o -MD -MP -MF src/.deps/gource-action.Tpo -c -o 
src/gource-action.o `test -f 'src/action.cpp' || echo './'`src/action.cpp
warning: unknown warning option '-Wno-unused-but-set-variable'; did you mean 
'-Wno-unused-variable'? [-Wunknown-warning-option]
In file included from src/action.cpp:18:
In file included from src/action.h:21:
In file included from src/user.h:21:
In file included from src/gource_settings.h:25:
In file included from src/formats/hg.h:21:
In file included from src/formats/commitlog.h:22:
In file included from src/formats/../core/seeklog.h:31:
In file included from src/formats/../core/display.h:32:
In file included from src/formats/../core/gl.h:27:
In file included from src/formats/../core/vectors.h:31:
In file included from /usr/local/include/glm/glm.hpp:88:
In file included from /usr/local/include/glm/fwd.hpp:32:
/usr/local/include/glm/detail/type_int.hpp:35:11: fatal error: 'cstdint' file 
not found
#       include <cstdint>
                ^
1 warning and 1 error generated.
gmake: *** [src/gource-action.o] Error 1
*** [do-build] Error code 1

Stop in /usr/ports/graphics/gource.
===>  Cleaning for gource-0.40_3
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to