You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     f...@shapeshifter.se
Last committer: m...@freebsd.org
Ident:          $FreeBSD: head/net-mgmt/yabm/Makefile 340722 2014-01-22 
17:00:46Z mat $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/head-i386-default/2014-06-20_09h29m24s/logs/yabm-0.2.1_2.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/head-i386-default/2014-06-20_09h29m24s
Log:

====>> Building net-mgmt/yabm
build started at Fri Jun 20 23:02:33 UTC 2014
port directory: /usr/ports/net-mgmt/yabm
building for: FreeBSD head-i386-default-job-22 11.0-CURRENT FreeBSD 
11.0-CURRENT r267600 i386
maintained by: f...@shapeshifter.se
Makefile ident:      $FreeBSD: head/net-mgmt/yabm/Makefile 340722 2014-01-22 
17:00:46Z mat $
Poudriere version: 3.1-pre
Host OSVERSION: 1100022
Jail OSVERSION: 1100023




!!! Jail is newer than host. (Jail: 1100023, Host: 1100022) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=1100023
UNAME_v=FreeBSD 11.0-CURRENT r267600
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/head-i386-default/ref
PKG_EXT=txz
tpid=88617
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=yabm-0.2.1_2
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/head-i386-default/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/head-i386-default/ref/poudriere/pool
MASTERNAME=head-i386-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" NO_PIE=yes SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe  
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS="" LIBS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
DOCSDIR="share/doc/yabm"
EXAMPLESDIR="share/examples/yabm"
DATADIR="share/yabm"
WWWDIR="www/yabm"
ETCDIR="etc/yabm"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/yabm
DOCSDIR=/usr/local/share/doc/yabm
EXAMPLESDIR=/usr/local/share/examples/yabm
WWWDIR=/usr/local/www/yabm
ETCDIR=/usr/local/etc/yabm
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
# clean-restricted via poudriere.conf NO_RESTRICTED
#NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for yabm-0.2.1_2
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   yabm-0.2.1_2 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7_3.txz
Installing pkg-1.2.7_3... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of yabm-0.2.1_2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by yabm-0.2.1_2 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by yabm-0.2.1_2 for building
=> SHA256 Checksum OK for yabm-0.2.1.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by yabm-0.2.1_2 for building
===>  Extracting for yabm-0.2.1_2
=> SHA256 Checksum OK for yabm-0.2.1.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for yabm-0.2.1_2
===>  Applying FreeBSD patches for yabm-0.2.1_2
===========================================================================
=======================<phase: build-depends  >============================
===========================================================================
=======================<phase: lib-depends    >============================
===>   yabm-0.2.1_2 depends on shared library: png15 - not found
===>    Verifying install for png15 in /usr/ports/graphics/png
===>   Installing existing package /packages/All/png-1.5.18.txz
Installing png-1.5.18... done
===>   Returning to build of yabm-0.2.1_2
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for yabm-0.2.1_2
===========================================================================
=======================<phase: build          >============================
===>  Building for yabm-0.2.1_2
cc -O2 -pipe  -fno-strict-aliasing   -Wall -I/usr/local/include 
-I/usr/local/include/libpng15 -c mylibpng.c
mylibpng.c:181:18: warning: passing 'char [8]' to parameter of type 
'png_const_bytep' (aka 'const unsigned char *') converts between pointers to 
integer types with different sign [-Wpointer-sign]
        if (png_sig_cmp(header, 0, 8)) {
                        ^~~~~~
/usr/local/include/png.h:1044:50: note: passing argument to parameter 'sig' here
PNG_EXPORT(3, int, png_sig_cmp, (png_const_bytep sig, png_size_t start,
                                                 ^
/usr/local/include/pngconf.h:311:37: note: expanded from macro 'PNG_EXPORT'
   PNG_EXPORTA(ordinal, type, name, args, PNG_EMPTY)
                                    ^
/usr/local/include/pngconf.h:301:63: note: expanded from macro 'PNG_EXPORTA'
      PNG_FUNCTION(PNG_EXPORT_TYPE(type),(PNGAPI name),PNGARG(args), \
                                                              ^
/usr/local/include/pngconf.h:91:31: note: expanded from macro 'PNGARG'
#      define PNGARG(arglist) arglist
                              ^
/usr/local/include/pngconf.h:287:75: note: expanded from macro 'PNG_FUNCTION'
#  define PNG_FUNCTION(type, name, args, attributes) attributes type name args
                                                                          ^
1 warning generated.
cc -O2 -pipe  -fno-strict-aliasing   -Wall -I/usr/local/include 
-I/usr/local/include/libpng15 -c font.c
cc -O2 -pipe  -fno-strict-aliasing   -Wall -c yabm.c
cc -O2 -pipe  -fno-strict-aliasing   -Wall -c bw.c
bw.c:127:16: error: variable has incomplete type 'struct ifaddr'
        struct  ifaddr ifaddr;
                       ^
/usr/include/net/if_var.h:88:24: note: forward declaration of 'struct ifaddr'
TAILQ_HEAD(ifaddrhead, ifaddr); /* instantiation is preserved in the list */
                       ^
/usr/include/sys/queue.h:493:9: note: expanded from macro 'TAILQ_HEAD'
        struct type *tqh_first; /* first element */                     \
               ^
bw.c:147:65: warning: comparison of unsigned expression < 0 is always false 
[-Wtautological-compare]
        if (_kvm_read(kvm, addr, &ifnethead, sizeof(struct ifnethead)) < 0) { 
            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ^ ~
bw.c:326:25: error: array has incomplete element type 'struct ifaddr'
                        struct ifaddr _ifaddr[2];
                                             ^
/usr/include/net/if_var.h:88:24: note: forward declaration of 'struct ifaddr'
TAILQ_HEAD(ifaddrhead, ifaddr); /* instantiation is preserved in the list */
                       ^
/usr/include/sys/queue.h:493:9: note: expanded from macro 'TAILQ_HEAD'
        struct type *tqh_first; /* first element */                     \
               ^
bw.c:353:47: warning: comparison of unsigned expression < 0 is always false 
[-Wtautological-compare]
        if ((tmp = kvm_read(kvm, addr, buf, nbytes)) < 0) {
            ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ^ ~
2 warnings and 2 errors generated.
*** Error code 1

Stop.
make[2]: stopped in /wrkdirs/usr/ports/net-mgmt/yabm/work/yabm-0.2.1/src
*** Error code 1

Stop.
make[1]: stopped in /wrkdirs/usr/ports/net-mgmt/yabm/work/yabm-0.2.1
*** Error code 1

Stop.
make: stopped in /usr/ports/net-mgmt/yabm
===>  Cleaning for yabm-0.2.1_2
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to