You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     webmas...@kibab.com
Last committer: j...@freebsd.org
Ident:          $FreeBSD: head/net/wpa_gui/Makefile 323946 2013-07-30 07:40:14Z 
jgh $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-09-19_01h04m14s/logs/wpa_gui-0.7.3.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-09-19_01h04m14s
Log:

====>> Building net/wpa_gui
build started at Thu Sep 19 06:52:08 UTC 2013
port directory: /usr/ports/net/wpa_gui
building for: FreeBSD head-amd64-default-job-21 10.0-CURRENT FreeBSD 
10.0-CURRENT amd64
maintained by: webmas...@kibab.com
Makefile ident:      $FreeBSD: head/net/wpa_gui/Makefile 323946 2013-07-30 
07:40:14Z jgh $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1000055
UNAME_v=FreeBSD 10.0-CURRENT
UNAME_r=10.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/head-amd64-default/ref
PKG_EXT=txz
tpid=77244
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
NBPARALLEL=24
PKGNG=1
PKGNAME=wpa_gui-0.7.3
PKG_DELETE=/usr/local/sbin/pkg delete -y -f
PKG_ADD=/usr/local/sbin/pkg add
PWD=/root
MASTERNAME=head-amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
SKIPSANITY=0
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-qt-includes=/usr/local/include/qt4  
--with-qt-libraries=/usr/local/lib/qt4  --with-extra-libs=/usr/local/lib  
--with-extra-includes=/usr/local/include
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" MOC="/usr/local/bin/moc-qt4" UIC="/usr/local/bin/uic-qt4" LIBS="" 
 QMAKE="/usr/local/bin/qmake-qt4" 
QMAKESPEC="/usr/local/share/qt4/mkspecs/freebsd-clang" QTDIR="/usr/local" 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" QMAKESPEC="/usr/local/share/qt4/mkspecs/freebsd-clang" 
SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/wpa_gui
DOCSDIR=/usr/local/share/doc/wpa_gui
EXAMPLESDIR=/usr/local/share/examples/wpa_gui
WWWDIR=/usr/local/www/wpa_gui
ETCDIR=/usr/local/etc/wpa_gui
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=yes
---End make.conf---
===>  Cleaning for wpa_gui-0.7.3
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   wpa_gui-0.7.3 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_2.txz
Installing pkg-1.1.4_2... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of wpa_gui-0.7.3
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by wpa_gui-0.7.3 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by wpa_gui-0.7.3 for building
=> SHA256 Checksum OK for wpa_supplicant-0.7.3.tar.gz.
=> SHA256 Checksum OK for wpa-gui-icons.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by wpa_gui-0.7.3 for building
===>  Extracting for wpa_gui-0.7.3
=> SHA256 Checksum OK for wpa_supplicant-0.7.3.tar.gz.
=> SHA256 Checksum OK for wpa-gui-icons.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for wpa_gui-0.7.3
===>  Applying FreeBSD patches for wpa_gui-0.7.3
/bin/mv /wrkdirs/usr/ports/net/wpa_gui/work/icons/hicolor 
/wrkdirs/usr/ports/net/wpa_gui/work/wpa_supplicant-0.7.3/wpa_supplicant/wpa_gui-qt4/icons
===========================================================================
=======================<phase: build-depends  >============================
===>   wpa_gui-0.7.3 depends on file: /usr/local/lib/qt4/libQtGui.so - not found
===>    Verifying install for /usr/local/lib/qt4/libQtGui.so in 
/usr/ports/x11-toolkits/qt4-gui
===>   Installing existing package /packages/All/qt4-gui-4.8.4.txz
Installing qt4-gui-4.8.4...Installing xset-1.2.3_1...Installing 
xproto-7.0.24... done
Installing xextproto-7.2.1... done
Installing libxcb-1.9.1...Installing libXdmcp-1.1.1... done
Installing libXau-1.0.8... done
Installing libxml2-2.8.0_2... done
Installing libpthread-stubs-0.3_3... done
 done
Installing libXext-1.3.2,1...Installing libX11-1.6.1,1...Installing 
kbproto-1.0.6... done
 done
 done
Installing libSM-1.2.1,1...Installing libICE-1.0.8,1... done
 done
Installing libXt-1.1.4,1... done
Installing libXmu-1.1.1,1... done
Installing libXfontcache-1.0.5...Installing fontcacheproto-0.1.3... done
 done
 done
Installing xprop-1.2.2... done
Installing xineramaproto-1.2.1... done
Installing renderproto-0.11.1... done
Installing randrproto-1.4.0... done
Installing libXrender-0.9.8... done
Installing libXrandr-1.4.1... done
Installing libXinerama-1.1.3,1... done
Installing libXi-1.7.2,1...Installing libXfixes-5.0.1...Installing 
fixesproto-5.0... done
 done
Installing inputproto-2.3... done
 done
Installing libXcursor-1.1.14... done
Installing xorg-fonts-truetype-7.7_1...Installing 
mkfontscale-1.1.1...Installing libfontenc-1.1.2... done
Installing freetype2-2.4.12_1... done
 done
Installing mkfontdir-1.0.7... done
Installing fontconfig-2.10.93,1...Installing expat-2.1.0... done
Running fc-cache to build fontconfig cache...
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
/usr/local/lib/X11/fonts/local: caching, new cache contents: 0 fonts, 0 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/var/db/fontconfig: cleaning cache directory
/root/.cache/fontconfig: not cleaning non-existent cache directory
/root/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded
 done
Installing font-util-1.3.0... done
Installing font-misc-meltho-1.0.3... done
Installing font-misc-ethiopic-1.0.3... done
Installing font-bh-ttf-1.0.3... done
Installing encodings-1.0.4,1... done
Installing dejavu-2.34... done
 done
Installing hicolor-icon-theme-0.12... done
Installing python27-2.7.5_3...Installing gettext-0.18.3... done
 done
Installing python2-2_1... done
Installing python-2.7_1,2... done
Installing perl-5.14.4...Removing stale symlinks from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl5
Done.
Cleaning up /etc/make.conf... Done.
Spamming /etc/make.conf... Done.
 done
Installing png-1.5.17... done
Installing xdg-utils-1.0.2_8... done
Installing qt4-corelib-4.8.4_5...Installing pcre-8.33... done
Installing libffi-3.0.13... done
Installing icu-50.1.2... done
Installing glib-2.36.3...No schema files found: doing nothing.
 done
 done
 done
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/lib/X11/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
======================================================================

Qt 4 can be built with optional support for:
 - Common UNIX Printing System (CUPS) (enabled by default)
 - Network Audio System (NAS)
 - Qt style that renders using GTK (QGTKSTYLE)

In order to enable them, you have to add
        QT4_OPTIONS=    CUPS NAS QGTKSTYLE
to your /etc/make.conf and compile devel/qt4-corelib and
x11-toolkits/qt4-gui ports.

Attention! Whenever you change the QT4_OPTIONS both
devel/qt4-corelib and x11-toolkits/qt4-gui ports must be rebuilt!

======================================================================
======================================================================

Qt paint engine makes common use of shared memory. To avoid MIT-SHM
errors (i.e., blank windows), you probably need to raise shared memory
limits in loader.conf(5). The following should be safe values for the
KDE Plasma Desktop:

kern.ipc.shmall=32768
kern.ipc.shmmni=1024
kern.ipc.shmseg=1024

======================================================================
===>   Returning to build of wpa_gui-0.7.3
===>   wpa_gui-0.7.3 depends on file: /usr/local/bin/moc-qt4 - not found
===>    Verifying install for /usr/local/bin/moc-qt4 in /usr/ports/devel/qt4-moc
===>   Installing existing package /packages/All/qt4-moc-4.8.4.txz
Installing qt4-moc-4.8.4... done
===>   Returning to build of wpa_gui-0.7.3
===>   wpa_gui-0.7.3 depends on file: /usr/local/bin/qmake-qt4 - not found
===>    Verifying install for /usr/local/bin/qmake-qt4 in 
/usr/ports/devel/qmake4
===>   Installing existing package /packages/All/qt4-qmake-4.8.4_1.txz
Installing qt4-qmake-4.8.4_1... done
===>   Returning to build of wpa_gui-0.7.3
===>   wpa_gui-0.7.3 depends on file: /usr/local/bin/rcc - not found
===>    Verifying install for /usr/local/bin/rcc in /usr/ports/devel/qt4-rcc
===>   Installing existing package /packages/All/qt4-rcc-4.8.4.txz
Installing qt4-rcc-4.8.4... done
===>   Returning to build of wpa_gui-0.7.3
===>   wpa_gui-0.7.3 depends on file: /usr/local/bin/uic-qt4 - not found
===>    Verifying install for /usr/local/bin/uic-qt4 in /usr/ports/devel/qt4-uic
===>   Installing existing package /packages/All/qt4-uic-4.8.4.txz
Installing qt4-uic-4.8.4... done
===>   Returning to build of wpa_gui-0.7.3
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for wpa_gui-0.7.3
===========================================================================
=======================<phase: build          >============================
===>  Building for wpa_gui-0.7.3
/usr/local/bin/uic-qt4 eventhistory.ui -o .ui/ui_eventhistory.h
/usr/local/bin/uic-qt4 scanresults.ui -o .ui/ui_scanresults.h
/usr/local/bin/uic-qt4 peers.ui -o .ui/ui_peers.h
/usr/local/bin/uic-qt4 wpagui.ui -o .ui/ui_wpagui.h
/usr/local/bin/uic-qt4 userdatarequest.ui -o .ui/ui_userdatarequest.h
/usr/local/bin/uic-qt4 networkconfig.ui -o .ui/ui_networkconfig.h
cc -c -O2 -pipe -fno-strict-aliasing -O2 -Wall -W -DCONFIG_CTRL_IFACE 
-DCONFIG_CTRL_IFACE_UNIX -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4 -I. -I.. -I../../src -I../../src/utils -I.moc -I.ui 
-I/usr/local/include/qt4 -I/usr/local/include -o .obj/os_unix.o 
../../src/utils/os_unix.c
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -Wall -W -pthread -D_THREAD_SAFE 
-DCONFIG_CTRL_IFACE -DCONFIG_CTRL_IFACE_UNIX -DQT_NO_DEBUG -DQT_GUI_LIB 
-DQT_CORE_LIB -DQT_SHARED -I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4 -I. -I.. -I../../src -I../../src/utils -I.moc -I.ui 
-I/usr/local/include/qt4 -I/usr/local/include -o .obj/main.o main.cpp
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -Wall -W -pthread -D_THREAD_SAFE 
-DCONFIG_CTRL_IFACE -DCONFIG_CTRL_IFACE_UNIX -DQT_NO_DEBUG -DQT_GUI_LIB 
-DQT_CORE_LIB -DQT_SHARED -I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4 -I. -I.. -I../../src -I../../src/utils -I.moc -I.ui 
-I/usr/local/include/qt4 -I/usr/local/include -o .obj/wpagui.o wpagui.cpp
wpagui.cpp:246:7: error: use of undeclared identifier 'getopt'
                c = getopt(qApp->argc(), qApp->argv(), "i:p:t");
                    ^
wpagui.cpp:252:24: error: use of undeclared identifier 'optarg'
                        ctrl_iface = strdup(optarg);
                                            ^
wpagui.cpp:256:28: error: use of undeclared identifier 'optarg'
                        ctrl_iface_dir = strdup(optarg);
                                                ^
3 errors generated.
*** Error code 1

Stop.
make[1]: stopped in 
/wrkdirs/usr/ports/net/wpa_gui/work/wpa_supplicant-0.7.3/wpa_supplicant/wpa_gui-qt4
*** Error code 1

Stop.
make: stopped in /usr/ports/net/wpa_gui
===>  Cleaning for wpa_gui-0.7.3
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to