You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     itechb...@gmail.com
Last committer: a...@freebsd.org
Ident:          $FreeBSD: head/devel/edb/Makefile 324744 2013-08-14 22:35:50Z 
ak $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-09-19_01h04m14s/logs/edb-0.9.18_2.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-09-19_01h04m14s
Log:

====>> Building devel/edb
build started at Thu Sep 19 07:08:59 UTC 2013
port directory: /usr/ports/devel/edb
building for: FreeBSD head-amd64-default-job-02 10.0-CURRENT FreeBSD 
10.0-CURRENT amd64
maintained by: itechb...@gmail.com
Makefile ident:      $FreeBSD: head/devel/edb/Makefile 324744 2013-08-14 
22:35:50Z ak $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1000055
UNAME_v=FreeBSD 10.0-CURRENT
UNAME_r=10.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/head-amd64-default/ref
PKG_EXT=txz
tpid=3856
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
NBPARALLEL=24
PKGNG=1
PKGNAME=edb-0.9.18_2
PKG_DELETE=/usr/local/sbin/pkg delete -y -f
PKG_ADD=/usr/local/sbin/pkg add
PWD=/root
MASTERNAME=head-amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
SKIPSANITY=0
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-qt-includes=/usr/local/include/qt4  
--with-qt-libraries=/usr/local/lib/qt4  --with-extra-libs=/usr/local/lib  
--with-extra-includes=/usr/local/include
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" MOC="/usr/local/bin/moc-qt4" UIC="/usr/local/bin/uic-qt4" LIBS="" 
 QMAKE="/usr/local/bin/qmake-qt4" 
QMAKESPEC="/usr/local/share/qt4/mkspecs/freebsd-clang" QTDIR="/usr/local" 
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" QMAKESPEC="/usr/local/share/qt4/mkspecs/freebsd-clang" 
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/edb
DOCSDIR=/usr/local/share/doc/edb
EXAMPLESDIR=/usr/local/share/examples/edb
WWWDIR=/usr/local/www/edb
ETCDIR=/usr/local/etc/edb
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=yes
---End make.conf---
===>  Cleaning for edb-0.9.18_2
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   edb-0.9.18_2 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_2.txz
Installing pkg-1.1.4_2... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of edb-0.9.18_2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by edb-0.9.18_2 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by edb-0.9.18_2 for building
=> SHA256 Checksum OK for debugger-0.9.18.tgz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by edb-0.9.18_2 for building
===>  Extracting for edb-0.9.18_2
=> SHA256 Checksum OK for debugger-0.9.18.tgz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for edb-0.9.18_2
===>  Applying FreeBSD patches for edb-0.9.18_2
===========================================================================
=======================<phase: build-depends  >============================
===>   edb-0.9.18_2 depends on file: /usr/local/lib/qt4/libQtGui.so - not found
===>    Verifying install for /usr/local/lib/qt4/libQtGui.so in 
/usr/ports/x11-toolkits/qt4-gui
===>   Installing existing package /packages/All/qt4-gui-4.8.4.txz
Installing qt4-gui-4.8.4...Installing xset-1.2.3_1...Installing 
xproto-7.0.24... done
Installing xextproto-7.2.1... done
Installing libxcb-1.9.1...Installing libXdmcp-1.1.1... done
Installing libXau-1.0.8... done
Installing libxml2-2.8.0_2... done
Installing libpthread-stubs-0.3_3... done
 done
Installing libXext-1.3.2,1...Installing libX11-1.6.1,1...Installing 
kbproto-1.0.6... done
 done
 done
Installing libSM-1.2.1,1...Installing libICE-1.0.8,1... done
 done
Installing libXt-1.1.4,1... done
Installing libXmu-1.1.1,1... done
Installing libXfontcache-1.0.5...Installing fontcacheproto-0.1.3... done
 done
 done
Installing xprop-1.2.2... done
Installing xineramaproto-1.2.1... done
Installing renderproto-0.11.1... done
Installing randrproto-1.4.0... done
Installing libXrender-0.9.8... done
Installing libXrandr-1.4.1... done
Installing libXinerama-1.1.3,1... done
Installing libXi-1.7.2,1...Installing libXfixes-5.0.1...Installing 
fixesproto-5.0... done
 done
Installing inputproto-2.3... done
 done
Installing libXcursor-1.1.14... done
Installing xorg-fonts-truetype-7.7_1...Installing 
mkfontscale-1.1.1...Installing libfontenc-1.1.2... done
Installing freetype2-2.4.12_1... done
 done
Installing mkfontdir-1.0.7... done
Installing fontconfig-2.10.93,1...Installing expat-2.1.0... done
Running fc-cache to build fontconfig cache...
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
/usr/local/lib/X11/fonts/local: caching, new cache contents: 0 fonts, 0 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/var/db/fontconfig: cleaning cache directory
/root/.cache/fontconfig: not cleaning non-existent cache directory
/root/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded
 done
Installing font-util-1.3.0... done
Installing font-misc-meltho-1.0.3... done
Installing font-misc-ethiopic-1.0.3... done
Installing font-bh-ttf-1.0.3... done
Installing encodings-1.0.4,1... done
Installing dejavu-2.34... done
 done
Installing hicolor-icon-theme-0.12... done
Installing python27-2.7.5_3...Installing gettext-0.18.3... done
 done
Installing python2-2_1... done
Installing python-2.7_1,2... done
Installing perl-5.14.4...Removing stale symlinks from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl5
Done.
Cleaning up /etc/make.conf... Done.
Spamming /etc/make.conf... Done.
 done
Installing png-1.5.17... done
Installing xdg-utils-1.0.2_8... done
Installing qt4-corelib-4.8.4_5...Installing pcre-8.33... done
Installing libffi-3.0.13... done
Installing icu-50.1.2... done
Installing glib-2.36.3...No schema files found: doing nothing.
 done
 done
 done
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/lib/X11/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
======================================================================

Qt 4 can be built with optional support for:
 - Common UNIX Printing System (CUPS) (enabled by default)
 - Network Audio System (NAS)
 - Qt style that renders using GTK (QGTKSTYLE)

In order to enable them, you have to add
        QT4_OPTIONS=    CUPS NAS QGTKSTYLE
to your /etc/make.conf and compile devel/qt4-corelib and
x11-toolkits/qt4-gui ports.

Attention! Whenever you change the QT4_OPTIONS both
devel/qt4-corelib and x11-toolkits/qt4-gui ports must be rebuilt!

======================================================================
======================================================================

Qt paint engine makes common use of shared memory. To avoid MIT-SHM
errors (i.e., blank windows), you probably need to raise shared memory
limits in loader.conf(5). The following should be safe values for the
KDE Plasma Desktop:

kern.ipc.shmall=32768
kern.ipc.shmmni=1024
kern.ipc.shmseg=1024

======================================================================
===>   Returning to build of edb-0.9.18_2
===>   edb-0.9.18_2 depends on file: /usr/local/bin/moc-qt4 - not found
===>    Verifying install for /usr/local/bin/moc-qt4 in /usr/ports/devel/qt4-moc
===>   Installing existing package /packages/All/qt4-moc-4.8.4.txz
Installing qt4-moc-4.8.4... done
===>   Returning to build of edb-0.9.18_2
===>   edb-0.9.18_2 depends on file: /usr/local/lib/qt4/libQtNetwork.so - not 
found
===>    Verifying install for /usr/local/lib/qt4/libQtNetwork.so in 
/usr/ports/net/qt4-network
===>   Installing existing package /packages/All/qt4-network-4.8.4.txz
Installing qt4-network-4.8.4...Installing ca_root_nss-3.15.1_1... done
 done
===>   Returning to build of edb-0.9.18_2
===>   edb-0.9.18_2 depends on file: /usr/local/bin/qmake-qt4 - not found
===>    Verifying install for /usr/local/bin/qmake-qt4 in 
/usr/ports/devel/qmake4
===>   Installing existing package /packages/All/qt4-qmake-4.8.4_1.txz
Installing qt4-qmake-4.8.4_1... done
===>   Returning to build of edb-0.9.18_2
===>   edb-0.9.18_2 depends on file: /usr/local/bin/rcc - not found
===>    Verifying install for /usr/local/bin/rcc in /usr/ports/devel/qt4-rcc
===>   Installing existing package /packages/All/qt4-rcc-4.8.4.txz
Installing qt4-rcc-4.8.4... done
===>   Returning to build of edb-0.9.18_2
===>   edb-0.9.18_2 depends on file: /usr/local/bin/uic-qt4 - not found
===>    Verifying install for /usr/local/bin/uic-qt4 in /usr/ports/devel/qt4-uic
===>   Installing existing package /packages/All/qt4-uic-4.8.4.txz
Installing qt4-uic-4.8.4... done
===>   Returning to build of edb-0.9.18_2
===>   edb-0.9.18_2 depends on file: /usr/local/lib/qt4/libQtXml.so - not found
===>    Verifying install for /usr/local/lib/qt4/libQtXml.so in 
/usr/ports/textproc/qt4-xml
===>   Installing existing package /packages/All/qt4-xml-4.8.4.txz
Installing qt4-xml-4.8.4... done
===>   Returning to build of edb-0.9.18_2
===========================================================================
=======================<phase: lib-depends    >============================
===>   edb-0.9.18_2 depends on shared library: boost_thread - not found
===>    Verifying install for boost_thread in /usr/ports/devel/boost-libs
===>   Installing existing package /packages/All/boost-libs-1.52.0_2.txz
Installing boost-libs-1.52.0_2... done
You have built the Boost library with thread support.

Don't forget to add -pthread to your linker options when
linking your code.
===>   Returning to build of edb-0.9.18_2
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for edb-0.9.18_2
cd /wrkdirs/usr/ports/devel/edb/work/debugger && /usr/bin/env TMPDIR="/tmp" 
MOC="/usr/local/bin/moc-qt4" UIC="/usr/local/bin/uic-qt4" LIBS=""  
QMAKE="/usr/local/bin/qmake-qt4" 
QMAKESPEC="/usr/local/share/qt4/mkspecs/freebsd-clang" QTDIR="/usr/local" 
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh  
/usr/local/bin/qmake-qt4 -recursive PREFIX=/usr/local  
DEFAULT_PLUGIN_PATH="/usr/local/libexec/edb" QMAKE_CC="cc" QMAKE_CXX="c++"  
QMAKE_LINK="c++" QMAKE_LINK_SHLIB="c++"  QMAKE_LINK_C="cc" 
QMAKE_LINK_C_SHLIB="cc"  QMAKE_CFLAGS="-O2 -pipe -fno-strict-aliasing" 
QMAKE_CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  QMAKE_CFLAGS_THREAD=""  
QMAKE_LFLAGS_THREAD="-pthread"
Reading /wrkdirs/usr/ports/devel/edb/work/debugger/src/src.pro
Reading /wrkdirs/usr/ports/devel/edb/work/debugger/plugins/plugins.pro
 Reading 
/wrkdirs/usr/ports/devel/edb/work/debugger/plugins/Analyzer/Analyzer.pro
 Reading 
/wrkdirs/usr/ports/devel/edb/work/debugger/plugins/BinarySearcher/BinarySearcher.pro
 Reading 
/wrkdirs/usr/ports/devel/edb/work/debugger/plugins/Bookmarks/Bookmarks.pro
 Reading 
/wrkdirs/usr/ports/devel/edb/work/debugger/plugins/BreakpointManager/BreakpointManager.pro
 Reading 
/wrkdirs/usr/ports/devel/edb/work/debugger/plugins/CheckVersion/CheckVersion.pro
 Reading 
/wrkdirs/usr/ports/devel/edb/work/debugger/plugins/DebuggerCore/DebuggerCore.pro
 Reading 
/wrkdirs/usr/ports/devel/edb/work/debugger/plugins/DumpState/DumpState.pro
 Reading 
/wrkdirs/usr/ports/devel/edb/work/debugger/plugins/Environment/Environment.pro
 Reading 
/wrkdirs/usr/ports/devel/edb/work/debugger/plugins/FunctionFinder/FunctionFinder.pro
 Reading 
/wrkdirs/usr/ports/devel/edb/work/debugger/plugins/HardwareBreakpoints/HardwareBreakpoints.pro
 Reading 
/wrkdirs/usr/ports/devel/edb/work/debugger/plugins/OpcodeSearcher/OpcodeSearcher.pro
 Reading 
/wrkdirs/usr/ports/devel/edb/work/debugger/plugins/References/References.pro
 Reading /wrkdirs/usr/ports/devel/edb/work/debugger/plugins/ROPTool/ROPTool.pro
 Reading 
/wrkdirs/usr/ports/devel/edb/work/debugger/plugins/SessionManager/SessionManager.pro
 Reading 
/wrkdirs/usr/ports/devel/edb/work/debugger/plugins/StringSearcher/StringSearcher.pro
 Reading 
/wrkdirs/usr/ports/devel/edb/work/debugger/plugins/SymbolViewer/SymbolViewer.pro
 Reading 
/wrkdirs/usr/ports/devel/edb/work/debugger/plugins/ELFBinaryInfo/ELFBinaryInfo.pro
 Reading 
/wrkdirs/usr/ports/devel/edb/work/debugger/plugins/HeapAnalyzer/HeapAnalyzer.pro
===========================================================================
=======================<phase: build          >============================
===>  Building for edb-0.9.18_2
cd src/ && /usr/bin/make -f Makefile all
/usr/local/bin/uic-qt4 binarystring.ui -o .uic/ui_binarystring.h
/usr/local/bin/uic-qt4 debuggerui.ui -o .uic/ui_debuggerui.h
/usr/local/bin/uic-qt4 dialog_arguments.ui -o .uic/ui_dialog_arguments.h
/usr/local/bin/uic-qt4 dialog_attach.ui -o .uic/ui_dialog_attach.h
/usr/local/bin/uic-qt4 dialog_inputbinarystring.ui -o 
.uic/ui_dialog_inputbinarystring.h
/usr/local/bin/uic-qt4 dialog_inputvalue.ui -o .uic/ui_dialog_inputvalue.h
/usr/local/bin/uic-qt4 dialog_memoryregions.ui -o .uic/ui_dialog_memoryregions.h
/usr/local/bin/uic-qt4 dialog_options.ui -o .uic/ui_dialog_options.h
/usr/local/bin/uic-qt4 dialog_plugins.ui -o .uic/ui_dialog_plugins.h
/usr/local/bin/uic-qt4 dialog_threads.ui -o .uic/ui_dialog_threads.h
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/ArchProcessor.o arch/x86_64/ArchProcessor.cpp
In file included from arch/x86_64/ArchProcessor.cpp:33:
/usr/local/include/boost/math/special_functions/fpclassify.hpp:98:29: warning: 
unused parameter 't' [-Wunused-parameter]
inline bool is_nan_helper(T t, const boost::true_type&)
                            ^
1 warning generated.
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/BinaryInfo.o BinaryInfo.cpp
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/BinaryString.o BinaryString.cpp
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/ByteShiftArray.o ByteShiftArray.cpp
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/CommentServer.o CommentServer.cpp
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/Configuration.o Configuration.cpp
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/DataViewInfo.o DataViewInfo.cpp
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/DebugEvent.o os/unix/freebsd/DebugEvent.cpp
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/Debugger.o Debugger.cpp
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/DebuggerMain.o DebuggerMain.cpp
DebuggerMain.cpp:185:31: warning: private field 'ui_' is not used 
[-Wunused-private-field]
        DebuggerMain *const          ui_;
                                     ^
1 warning generated.
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/DebuggerOS.o os/unix/freebsd/DebuggerOS.cpp
os/unix/freebsd/DebuggerOS.cpp:56:29: warning: unused variable 'region' 
[-Wunused-variable]
        Q_FOREACH(const MemRegion &region, r) {
                                   ^
/usr/local/include/qt4/QtCore/qglobal.h:2383:10: note: expanded from macro 
'Q_FOREACH'
    for (variable = *_container_.i;; __extension__ ({--_container_.brk; 
break;}))
         ^
os/unix/freebsd/DebuggerOS.cpp:71:20: warning: unused variable 'pid' 
[-Wunused-variable]
                const edb::pid_t pid = debugger_core->pid();
                                 ^
os/unix/freebsd/DebuggerOS.cpp:85:20: warning: unused variable 'pid' 
[-Wunused-variable]
                const edb::pid_t pid = debugger_core->pid();
                                 ^
os/unix/freebsd/DebuggerOS.cpp:100:20: warning: unused variable 'pid' 
[-Wunused-variable]
                const edb::pid_t pid = debugger_core->pid();
                                 ^
os/unix/freebsd/DebuggerOS.cpp:109:47: warning: unused parameter 'pid' 
[-Wunused-parameter]
edb::pid_t edb::v1::get_parent_pid(edb::pid_t pid) {
                                              ^
5 warnings generated.
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/DebuggerUI.o DebuggerUI.cpp
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/DialogArguments.o DialogArguments.cpp
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/DialogAttach.o os/unix/freebsd/DialogAttach.cpp
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/DialogInputBinaryString.o DialogInputBinaryString.cpp
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/DialogInputValue.o DialogInputValue.cpp
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/DialogMemoryRegions.o DialogMemoryRegions.cpp
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/DialogOptions.o DialogOptions.cpp
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/DialogPlugins.o DialogPlugins.cpp
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/DialogThreads.o DialogThreads.cpp
c++ -c -O2 -pipe -fno-strict-aliasing -O2 -pthread -D_THREAD_SAFE -Wall -W 
-DDEFAULT_PLUGIN_PATH=/usr/local/libexec/edb -DQT_NO_DEBUG -DQT_XML_LIB 
-DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED 
-I/usr/local/share/qt4/mkspecs/freebsd-clang -I. 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/qt4 -Iwidgets -I../include 
-Iqhexview -Iqjson -Ios/unix -I../include/os/unix -Iedisassm -Ios/unix/freebsd 
-I../include/os/unix/freebsd -Iarch/x86_64 -I../include/arch/x86_64 
-I.moc/release-shared -I.uic -I/usr/local/include/qt4 -I/usr/local/include -o 
.obj/release-shared/Instruction.o edisassm/Instruction.cpp
In file included from edisassm/Instruction.cpp:20:
edisassm/Instruction32.h:293:2: error: reference to non-static member function 
must be called; did you mean to call it with no arguments?
        UNUSED(size);
        ^~~~~~~~~~~~
                    ()
edisassm/edisassm_util.h:27:25: note: expanded from macro 'UNUSED'
#define UNUSED(x) (void)(x)
                        ^~~
1 error generated.
*** Error code 1

Stop.
make[2]: stopped in /wrkdirs/usr/ports/devel/edb/work/debugger/src
*** Error code 1

Stop.
make[1]: stopped in /wrkdirs/usr/ports/devel/edb/work/debugger
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/edb
===>  Cleaning for edb-0.9.18_2
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to