You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     k...@freebsd.org
Last committer: t...@freebsd.org
Ident:          $FreeBSD: head/mail/libmapi/Makefile 360588 2014-07-04 
09:40:59Z tijl $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/91amd64-default/2014-07-10_07h07m39s/logs/libmapi-2.1_2.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/91amd64-default/2014-07-10_07h07m39s
Log:

====>> Building mail/libmapi
build started at Thu Jul 10 11:53:59 UTC 2014
port directory: /usr/ports/mail/libmapi
building for: FreeBSD 91amd64-default-job-04 9.1-RELEASE-p13 FreeBSD 
9.1-RELEASE-p13 amd64
maintained by: k...@freebsd.org
Makefile ident:      $FreeBSD: head/mail/libmapi/Makefile 360588 2014-07-04 
09:40:59Z tijl $
Poudriere version: 3.1-pre
Host OSVERSION: 1100022
Jail OSVERSION: 901000

---Begin Environment---
OSVERSION=901000
UNAME_v=FreeBSD 9.1-RELEASE-p13
UNAME_r=9.1-RELEASE-p13
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/build/91amd64-default/ref
PKG_EXT=txz
tpid=35139
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=libmapi-2.1_2
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
OLDPWD=/usr/local/poudriere/data/build/91amd64-default/ref/poudriere/rdeps
PWD=/usr/local/poudriere/data/build/91amd64-default/ref/poudriere/pool
MASTERNAME=91amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for libmapi-2.1_2:
     BOOST=on: libmapi C++ library (needs boost)
     DOXYGEN=off: Build documentation with Doxygen
     SAMBA40=off: Build agains samba 4.0 instead of 4.1
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-samba=/usr/local --disable-pymapi --prefix=/usr/local 
${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
ac_cv_path_DOXYGEN=""  PYTHON_CONFIG=/usr/local/bin/python2.7-config 
XDG_DATA_HOME=/wrkdirs/usr/ports/mail/libmapi/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/mail/libmapi/work  
HOME=/wrkdirs/usr/ports/mail/libmapi/work TMPDIR="/tmp" ac_cv_path_DOXYGEN="" 
XDG_DATA_HOME=/wrkdirs/usr/ports/mail/libmapi/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/mail/libmapi/work  
HOME=/wrkdirs/usr/ports/mail/libmapi/work TMPDIR="/tmp" 
PYTHON="/usr/local/bin/python2.7" MAKE=gmake PKG_CONFIG=pkgconf SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh CONFIG_SITE=/usr/ports/Templates/config.site 
lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/mail/libmapi/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/mail/libmapi/work  
HOME=/wrkdirs/usr/ports/mail/libmapi/work TMPDIR="/tmp" 
XDG_DATA_HOME=/wrkdirs/usr/ports/mail/libmapi/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/mail/libmapi/work  
HOME=/wrkdirs/usr/ports/mail/libmapi/work TMPDIR="/tmp" NO_PIE=yes 
SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS="-I/usr/local/include"  LDFLAGS=" -L/usr/local/lib" LIBS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--PLIST_SUB--
BOOST=""
NO_BOOST="@comment
"
DOXYGEN="@comment
"
NO_DOXYGEN=""
SAMBA40="@comment
"
NO_SAMBA40=""
SAMBA=samba41
PYTHON_INCLUDEDIR=include/python2.7
PYTHON_LIBDIR=lib/python2.7
PYTHON_PLATFORM=freebsd9
PYTHON_SITELIBDIR=lib/python2.7/site-packages
PYTHON_VERSION=python2.7
OSREL=9.1
PREFIX=%D
LOCALBASE=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
PORTDATA=""
LIB32DIR=lib
DOCSDIR="share/doc/libmapi"
EXAMPLESDIR="share/examples/libmapi"
DATADIR="share/libmapi"
WWWDIR="www/libmapi"
ETCDIR="etc/libmapi"
--End PLIST_SUB--

--SUB_LIST--
BOOST=""
NO_BOOST="@comment
"
DOXYGEN="@comment
"
NO_DOXYGEN=""
SAMBA40="@comment
"
NO_SAMBA40=""
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/libmapi
DOCSDIR=/usr/local/share/doc/libmapi
EXAMPLESDIR=/usr/local/share/examples/libmapi
WWWDIR=/usr/local/www/libmapi
ETCDIR=/usr/local/etc/libmapi
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
# clean-restricted ran via poudriere.conf NO_RESTRICTED
#NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for libmapi-2.1_2
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   libmapi-2.1_2 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.2.7_4.txz
Installing pkg-1.2.7_4... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of libmapi-2.1_2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by libmapi-2.1_2 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by libmapi-2.1_2 for building
=> SHA256 Checksum OK for openchange-2.1-QUADRANT.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by libmapi-2.1_2 for building
===>  Extracting for libmapi-2.1_2
=> SHA256 Checksum OK for openchange-2.1-QUADRANT.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for libmapi-2.1_2
===>  Applying FreeBSD patches for libmapi-2.1_2
===========================================================================
=======================<phase: build-depends  >============================
===>   libmapi-2.1_2 depends on package: samba41>=4.1.0 - not found
===>    Verifying install for samba41>=4.1.0 in /usr/ports/net/samba41
===>   Installing existing package /packages/All/samba41-4.1.9.txz
Installing samba41-4.1.9...Installing avahi-app-0.6.31_2...Installing 
dbus-glib-0.100.2_1...Installing dbus-1.8.6...Installing expat-2.1.0_1... done
Installing gnome_subr-1.0... done
Installing libICE-1.0.8_2,1...Installing xproto-7.0.25... done
 done
Installing libSM-1.2.2_2,1... done
Installing libX11-1.6.2_2,1...Installing kbproto-1.0.6... done
Installing libXau-1.0.8_2... done
Installing libXdmcp-1.1.1_2... done
Installing libxcb-1.10_2...Installing libpthread-stubs-0.3_5... done
Installing libxml2-2.9.1_1...Installing libiconv-1.14_3... done
 done
 done
 done
===> Creating users and/or groups.
Creating group 'messagebus' with gid '556'.
Creating user 'messagebus' with uid '556'.
 done
Installing gettext-0.18.3.1_1...Installing indexinfo-0.2... done
 done
Installing glib-2.36.3_3...Installing libffi-3.0.13_1... done
Installing pcre-8.34_1... done
Installing perl5-5.16.3_11... done
Installing python27-2.7.6_4... done
No schema files found: doing nothing.
 done
 done
Installing gdbm-1.11_2... done
Installing gobject-introspection-1.36.0_2...Installing gnomehier-3.0... done
Installing python2-2_2... done
 done
Installing libdaemon-0.14_1... done
===> Creating users and/or groups.
Creating group 'avahi' with gid '558'.
Creating user 'avahi' with uid '558'.
 done
Installing cups-client-1.7.3...===> Creating users and/or groups.
Creating group 'cups' with gid '193'.
Creating user 'cups' with uid '193'.
 done
<snip>
checking python library directory... ${prefix}/lib/python2.7/site-packages
checking for TALLOC... yes
checking for SAMBA... yes
checking for SAMBASERVER... yes
checking for TDB... yes
checking for LDB... yes
checking samba/version.h usability... yes
checking samba/version.h presence... yes
checking for samba/version.h... yes
configure: WARNING: The Samba4 version installed on your system doesn't meet 
OpenChange requirements (4.1.7 or 4.1.7-GIT-).
checking for DCE/RPC server modules directory... 
/usr/local/lib/shared-modules/dcerpc_server
checking for dlopen in -ldl... no
checking for dlopen... (cached) yes
checking for pthread_mutex_init in -lpthread... yes
checking whether we are using the GNU C++ compiler... yes
checking whether c++ accepts -g... yes
checking dependency style of c++... none
checking C++ compiler availability... yes
checking whether we are using the GNU C++ compiler... (cached) yes
checking whether c++ accepts -g... (cached) yes
checking dependency style of c++... (cached) none
checking for SAMR... yes
checking for ICAL... yes
checking for ICAL_0_46... yes
checking for poptFreeContext in -lpopt... yes
checking for magic_open in -lmagic... yes
checking for gzopen in -lz... yes
checking for mq_open in -lrt... yes
checking for doxygen... (cached) no
configure: WARNING: doxygen
checking for SUBUNIT... no
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating config.mk
config.status: creating libmapi.pc
config.status: creating libmapiadmin.pc
config.status: creating libocpf.pc
config.status: creating mapiproxy/libmapiproxy.pc
config.status: creating mapiproxy/libmapiserver.pc
config.status: creating mapiproxy/libmapistore.pc
config.status: creating libmapi++.pc
config.status: creating Doxyfile
config.status: creating libmapi++/Doxyfile
config.status: creating libocpf/Doxyfile
config.status: creating libmapiadmin/Doxyfile
config.status: creating libmapi/Doxyfile
config.status: creating mapiproxy/Doxyfile
config.status: creating utils/mapitest/Doxyfile
config.status: creating mapiproxy/libmapistore/Doxyfile
config.status: creating config.h
config.status: executing depfiles commands
configure: WARNING: unrecognized options: --disable-pymapi


===============================================================
OpenChange Configuration (Please review)

           * OpenChange Libraries:
             - libmapi (C library):     yes
                      Thread support:   yes (pthread)
             - libmapi++ (C++ library): yes
             - libmapiadmin:            yes
             - libocpf:                 yes

           * OpenChange Server:
             - mapiproxy:               yes

           * OpenChange mapistore backends:
             - backends dependencies goes here

           * OpenChange Tools:
             - openchangeclient:        yes
             - mapiprofile:             yes
             - openchangepfadmin:       yes
             - exchange2mbox:           yes
             - exchange2ical:           yes
             - mapitest:                yes
             - openchangemapidump:      yes
             - schemaIDGUID:            yes

           * subunit format (mapitest): no

           * OpenChange Documentation:  no

           * Coverage Tests:            no

           * OpenChange Bindings:
             - Qt4:                     no

           * Installation prefix:       /usr/local

===============================================================


===========================================================================
=======================<phase: build          >============================
===>  Building for libmapi-2.1_2
Creating the gen_ndr directory
mkdir -p gen_ndr
libmapi/conf/mparse.pl --parser=mapicodes --outputdir=libmapi/ 
libmapi/conf/mapi-codes
Parsing libmapi/conf/mapi-codes
Generating libmapi/mapicode.c
Generating mapicodes_enum.h
Generating exchange.h
Compiling exchange.idl
exchange.idl:1441: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:1507: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:1533: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:1547: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:1803: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2231: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2241: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2326: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2342: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2446: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2452: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2495: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2968: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:3536: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:3598: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:3673: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:4181: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:4182: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:4624: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:4179: warning: [out] argument `size' not a pointer
exchange.idl:4180: warning: [out] argument `offset' not a pointer
Generating gen_ndr/ndr_exchange.h
Compiling exchange.idl
exchange.idl:1441: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:1507: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:1533: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:1547: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:1803: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2231: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2241: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2326: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2342: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2446: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2452: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2495: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2968: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:3536: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:3598: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:3673: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:4181: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:4182: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:4624: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:4179: warning: [out] argument `size' not a pointer
exchange.idl:4180: warning: [out] argument `offset' not a pointer
Generating property.h
Compiling property.idl
Generating gen_ndr/ndr_property.h
Compiling property.idl
usage: mktemp [-d] [-q] [-t prefix] [-u] template ...
       mktemp [-d] [-q] [-u] -t prefix 
./script/mkversion.sh: cannot create : No such file or directory
./script/mkversion.sh: cannot create : No such file or directory
./script/mkversion.sh: cannot create : No such file or directory
./script/mkversion.sh: cannot create : No such file or directory
./script/mkversion.sh: cannot create : No such file or directory
./script/mkversion.sh: cannot create : No such file or directory
./script/mkversion.sh: cannot create : No such file or directory
./script/mkversion.sh: cannot create : No such file or directory
./script/mkversion.sh: cannot create : No such file or directory
./script/mkversion.sh: cannot create : No such file or directory
./script/mkversion.sh: cannot create : No such file or directory
mv: rename  to libmapi/version.h: No such file or directory
./script/mkversion.sh: 'libmapi/version.h' created for OpenChange libmapi("2.1 
(Quadrant)")
Generating gen_ndr/ndr_exchange_c.h
Compiling exchange.idl
exchange.idl:1441: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:1507: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:1533: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:1547: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:1803: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2231: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2241: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2326: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2342: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2446: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2452: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2495: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:2968: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:3536: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:3598: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:3673: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:4181: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:4182: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:4624: warning: subcontext() is deprecated. Use represent_as() or 
transmit_as() instead
exchange.idl:4179: warning: [out] argument `size' not a pointer
exchange.idl:4180: warning: [out] argument `offset' not a pointer
exchange.idl:4179: error: EcDoRpc: [out] argument 'size' is not a pointer or 
array, skip client functions
Compiling libmapi/emsmdb.c with -fPIC
In file included from libmapi/emsmdb.c:23:
./libmapi/libmapi.h:58:29: error: libmapi/version.h: No such file or directory
gmake: *** [libmapi/emsmdb.po] Error 1
*** [do-build] Error code 1

Stop in /usr/ports/mail/libmapi.
===>  Cleaning for libmapi-2.1_2
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to