You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     ni...@freebsd.org
Last committer: ni...@freebsd.org
Ident:          $FreeBSD: head/devel/py-virtualenvwrapper/Makefile 378207 
2015-01-31 13:32:06Z nivit $
Log URL:        
http://beefy8.nyi.freebsd.org/data/head-mips64-default/p393537_s286292/logs/py27-virtualenvwrapper-4.3.2.log
Build URL:      
http://beefy8.nyi.freebsd.org/build.html?mastername=head-mips64-default&build=p393537_s286292
Log:

====>> Building devel/py-virtualenvwrapper
build started at Thu Aug 13 00:03:25 UTC 2015
port directory: /usr/ports/devel/py-virtualenvwrapper
building for: FreeBSD head-mips64-default-job-21 11.0-CURRENT FreeBSD 
11.0-CURRENT r286292 mips
maintained by: ni...@freebsd.org
Makefile ident:      $FreeBSD: head/devel/py-virtualenvwrapper/Makefile 378207 
2015-01-31 13:32:06Z nivit $
Poudriere version: 3.1.7
Host OSVERSION: 1100076
Jail OSVERSION: 1100077




!!! Jail is newer than host. (Jail: 1100077, Host: 1100076) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
UNAME_p=mips64
UNAME_m=mips
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1100077
UNAME_v=FreeBSD 11.0-CURRENT r286292
UNAME_r=11.0-CURRENT
LC_COLLATE=C
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=screen
MASTERMNT=/usr/local/poudriere/data/.m/head-mips64-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=py27-virtualenvwrapper-4.3.2
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/head-mips64-default/ref/.p/pool
MASTERNAME=head-mips64-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.7
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for 
py27-virtualenvwrapper-4.3.2:
     DOCS=on: Build and/or install documentation
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PYTHON="/usr/local/bin/python2.7" 
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/py-virtualenvwrapper/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/py-virtualenvwrapper/work  
HOME=/wrkdirs/usr/ports/devel/py-virtualenvwrapper/work TMPDIR="/tmp" 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/py-virtualenvwrapper/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/py-virtualenvwrapper/work  
HOME=/wrkdirs/usr/ports/devel/py-virtualenvwrapper/work TMPDIR="/tmp" 
NO_PIE=yes SHELL=/bin/sh NO_LINT=YES LDSHARED="/nxb-bin/usr/bin/cc -shared" 
PYTHONDONTWRITEBYTECODE= PYTHONOPTIMIZE= PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 
-pipe -G0  -fno-strict-aliasing"  CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS=""  
LDFLAGS="" LIBS=""  CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -G0 
-fno-strict-aliasing "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PYTHON_INCLUDEDIR=include/python2.7
PYTHON_LIBDIR=lib/python2.7
PYTHON_PLATFORM=freebsd11
PYTHON_SITELIBDIR=lib/python2.7/site-packages
PYTHON_VERSION=python2.7
PYTHON_VER=2.7
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/py27-virtualenvwrapper"
EXAMPLESDIR="share/examples/virtualenvwrapper"
DATADIR="share/virtualenvwrapper"
WWWDIR="www/virtualenvwrapper"
ETCDIR="etc/virtualenvwrapper"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/virtualenvwrapper
DOCSDIR=/usr/local/share/doc/py27-virtualenvwrapper
EXAMPLESDIR=/usr/local/share/examples/virtualenvwrapper
WWWDIR=/usr/local/www/virtualenvwrapper
ETCDIR=/usr/local/etc/virtualenvwrapper
--End SUB_LIST--

---Begin make.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
MACHINE=mips
MACHINE_ARCH=mips64
ARCH=${MACHINE_ARCH}
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
MASTER_SITE_FREEBSD=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License MIT accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   py27-virtualenvwrapper-4.3.2 depends on file: /usr/local/sbin/pkg - not 
found
===>   Installing existing package /packages/All/pkg-1.5.5.txz
[head-mips64-default-job-21] Installing pkg-1.5.5...
[head-mips64-default-job-21] Extracting pkg-1.5.5: .......... done
Message for pkg-1.5.5:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   py27-virtualenvwrapper-4.3.2 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of py27-virtualenvwrapper-4.3.2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License MIT accepted by the user
===> Fetching all distfiles required by py27-virtualenvwrapper-4.3.2 for 
building
===========================================================================
=======================<phase: checksum       >============================
===>  License MIT accepted by the user
===> Fetching all distfiles required by py27-virtualenvwrapper-4.3.2 for 
building
=> SHA256 Checksum OK for virtualenvwrapper-4.3.2.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License MIT accepted by the user
===> Fetching all distfiles required by py27-virtualenvwrapper-4.3.2 for 
building
===>  Extracting for py27-virtualenvwrapper-4.3.2
=> SHA256 Checksum OK for virtualenvwrapper-4.3.2.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for py27-virtualenvwrapper-4.3.2
===========================================================================
=======================<phase: build-depends  >============================
===>   py27-virtualenvwrapper-4.3.2 depends on file: py27-pbr>=0.5.19 - not 
found
===>   Installing existing package /packages/All/py27-pbr-1.3.0.txz
[head-mips64-default-job-21] Installing py27-pbr-1.3.0...
[head-mips64-default-job-21] `-- Installing py27-pip-7.0.3...
[head-mips64-default-job-21] |   `-- Installing py27-setuptools27-17.0...
[head-mips64-default-job-21] |   | `-- Installing python27-2.7.10...
[head-mips64-default-job-21] |   |   `-- Installing gettext-runtime-0.19.4...
[head-mips64-default-job-21] |   |   | `-- Installing indexinfo-0.2.3...
[head-mips64-default-job-21] |   |   | `-- Extracting indexinfo-0.2.3: .... done
[head-mips64-default-job-21] |   |   `-- Extracting gettext-runtime-0.19.4: 
.......... done
[head-mips64-default-job-21] |   |   `-- Installing libffi-3.2.1...
[head-mips64-default-job-21] |   |   `-- Extracting libffi-3.2.1: .......... 
done
[head-mips64-default-job-21] |   |   `-- Installing readline-6.3.8...
[head-mips64-default-job-21] |   |   `-- Extracting readline-6.3.8: .......... 
done
[head-mips64-default-job-21] |   | `-- Extracting python27-2.7.10: .......... 
done
[head-mips64-default-job-21] |   `-- Extracting py27-setuptools27-17.0: 
.......... done
[head-mips64-default-job-21] `-- Extracting py27-pip-7.0.3: .......... done
[head-mips64-default-job-21] Extracting py27-pbr-1.3.0: .......... done
Message for python27-2.7.10:
=====================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

=====================================================================
===>   py27-virtualenvwrapper-4.3.2 depends on package: py27-pbr>=0.5.19 - found
===>   Returning to build of py27-virtualenvwrapper-4.3.2
===>   py27-virtualenvwrapper-4.3.2 depends on executable: sphinx-build - not 
found
===>   Installing existing package /packages/All/py27-sphinx-1.3.1_1.txz
[head-mips64-default-job-21] Installing py27-sphinx-1.3.1_1...
[head-mips64-default-job-21] `-- Installing py27-Babel-2.0...
[head-mips64-default-job-21] |   `-- Installing py27-pytz-2015.4,1...
[head-mips64-default-job-21] |   `-- Extracting py27-pytz-2015.4,1: .......... 
done
[head-mips64-default-job-21] `-- Extracting py27-Babel-2.0: .......... done
[head-mips64-default-job-21] `-- Installing py27-Jinja2-2.7.3...
[head-mips64-default-job-21] |   `-- Installing py27-MarkupSafe-0.23...
[head-mips64-default-job-21] |   `-- Extracting py27-MarkupSafe-0.23: 
.......... done
[head-mips64-default-job-21] `-- Extracting py27-Jinja2-2.7.3: .......... done
[head-mips64-default-job-21] `-- Installing py27-alabaster-0.7.6...
[head-mips64-default-job-21] `-- Extracting py27-alabaster-0.7.6: .......... 
done
[head-mips64-default-job-21] `-- Installing py27-docutils-0.12...
[head-mips64-default-job-21] `-- Extracting py27-docutils-0.12: .......... done
[head-mips64-default-job-21] `-- Installing py27-pygments-2.0.2...
[head-mips64-default-job-21] `-- Extracting py27-pygments-2.0.2: .......... done
[head-mips64-default-job-21] `-- Installing py27-six-1.9.0...
[head-mips64-default-job-21] `-- Extracting py27-six-1.9.0: .......... done
[head-mips64-default-job-21] `-- Installing py27-snowballstemmer-1.2.0...
[head-mips64-default-job-21] `-- Extracting py27-snowballstemmer-1.2.0: 
.......... done
[head-mips64-default-job-21] `-- Installing py27-sphinx_rtd_theme-0.1.8...
[head-mips64-default-job-21] `-- Extracting py27-sphinx_rtd_theme-0.1.8: 
.......... done
[head-mips64-default-job-21] Extracting py27-sphinx-1.3.1_1: .......... done
===>   py27-virtualenvwrapper-4.3.2 depends on executable: sphinx-build - found
===>   Returning to build of py27-virtualenvwrapper-4.3.2
===>   py27-virtualenvwrapper-4.3.2 depends on file: 
py27-sphinxcontrib-bitbucket>=1.0 - not found
===>   Installing existing package 
/packages/All/py27-sphinxcontrib-bitbucket-1.0_1.txz
[head-mips64-default-job-21] Installing py27-sphinxcontrib-bitbucket-1.0_1...
[head-mips64-default-job-21] Extracting py27-sphinxcontrib-bitbucket-1.0_1: 
.......... done
===>   py27-virtualenvwrapper-4.3.2 depends on package: 
py27-sphinxcontrib-bitbucket>=1.0 - found
===>   Returning to build of py27-virtualenvwrapper-4.3.2
===>   py27-virtualenvwrapper-4.3.2 depends on package: py27-setuptools27>0 - 
found
===>   py27-virtualenvwrapper-4.3.2 depends on file: /usr/local/bin/python2.7 - 
found
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for py27-virtualenvwrapper-4.3.2
running config
===========================================================================
=======================<phase: build          >============================
===>  Building for py27-virtualenvwrapper-4.3.2
running build_sphinx
creating 
/wrkdirs/usr/ports/devel/py-virtualenvwrapper/work/virtualenvwrapper-4.3.2/build
creating 
/wrkdirs/usr/ports/devel/py-virtualenvwrapper/work/virtualenvwrapper-4.3.2/build/sphinx
creating 
/wrkdirs/usr/ports/devel/py-virtualenvwrapper/work/virtualenvwrapper-4.3.2/build/sphinx/doctrees
creating 
/wrkdirs/usr/ports/devel/py-virtualenvwrapper/work/virtualenvwrapper-4.3.2/build/sphinx/html
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "setup.py", line 7, in <module>
    pbr=True,
  File "/usr/local/lib/python2.7/distutils/core.py", line 151, in setup
    dist.run_commands()
  File "/usr/local/lib/python2.7/distutils/dist.py", line 953, in run_commands
    self.run_command(cmd)
  File "/usr/local/lib/python2.7/distutils/dist.py", line 972, in run_command
    cmd_obj.run()
  File "/usr/local/lib/python2.7/site-packages/pbr/builddoc.py", line 189, in 
run
    self._sphinx_run()
  File "/usr/local/lib/python2.7/site-packages/pbr/builddoc.py", line 133, in 
_sphinx_run
    sphinx_config.init_values()
TypeError: init_values() takes exactly 2 arguments (1 given)
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/py-virtualenvwrapper
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to