You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     s...@freebsd.org
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/security/openvpn-auth-ldap/Makefile 327769 
2013-09-20 22:55:24Z bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/83amd64-default/2013-10-16_01h02m18s/logs/openvpn-auth-ldap-2.0.3_3.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/83amd64-default/2013-10-16_01h02m18s
Log:

====>> Building security/openvpn-auth-ldap
build started at Wed Oct 16 07:49:25 UTC 2013
port directory: /usr/ports/security/openvpn-auth-ldap
building for: FreeBSD 83amd64-default-job-02 8.3-RELEASE FreeBSD 8.3-RELEASE 
amd64
maintained by: s...@freebsd.org
Makefile ident:      $FreeBSD: head/security/openvpn-auth-ldap/Makefile 327769 
2013-09-20 22:55:24Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=803000
UNAME_v=FreeBSD 8.3-RELEASE
UNAME_r=8.3-RELEASE
FTP_PASSIVE_MODE=YES
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/83amd64-default/ref
PKG_EXT=txz
tpid=42981
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=openvpn-auth-ldap-2.0.3_3
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=83amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-openldap=/usr/local  --with-openvpn=`cd /usr/ports/security/openvpn; 
make -V WRKSRC` --prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-DLDAP_DEPRECATED -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  
CXX="c++" CXXFLAGS="-O2 -pipe -DLDAP_DEPRECATED -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/openvpn-auth-ldap
DOCSDIR=/usr/local/share/doc/openvpn-auth-ldap
EXAMPLESDIR=/usr/local/share/examples/openvpn-auth-ldap
WWWDIR=/usr/local/www/openvpn-auth-ldap
ETCDIR=/usr/local/etc/openvpn-auth-ldap
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for openvpn-auth-ldap-2.0.3_3
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   openvpn-auth-ldap-2.0.3_3 depends on file: /usr/local/sbin/pkg - not 
found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of openvpn-auth-ldap-2.0.3_3
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by openvpn-auth-ldap-2.0.3_3 for building
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by openvpn-2.3.2 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by openvpn-auth-ldap-2.0.3_3 for building
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by openvpn-2.3.2 for building
=> SHA256 Checksum OK for auth-ldap-2.0.3.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by openvpn-auth-ldap-2.0.3_3 for building
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by openvpn-2.3.2 for building
===>  Extracting for openvpn-auth-ldap-2.0.3_3
=> SHA256 Checksum OK for auth-ldap-2.0.3.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for openvpn-auth-ldap-2.0.3_3
===========================================================================
=======================<phase: build-depends  >============================
===>   openvpn-auth-ldap-2.0.3_3 depends on executable: re2c - not found
===>    Verifying install for re2c in /usr/ports/devel/re2c
===>   Installing existing package /packages/All/re2c-0.13.6.txz
Installing re2c-0.13.6... done
===>   Returning to build of openvpn-auth-ldap-2.0.3_3
===>   openvpn-auth-ldap-2.0.3_3 depends on file: /nonexistent - not found
===>    Verifying extract for /nonexistent in /usr/ports/security/openvpn
===>  License GPLv2 accepted by the user
===>   openvpn-2.3.2 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by openvpn-2.3.2 for building
===>  Extracting for openvpn-2.3.2
=> SHA256 Checksum OK for openvpn-2.3.2.tar.xz.
===>   Returning to build of openvpn-auth-ldap-2.0.3_3
===========================================================================
=======================<phase: lib-depends    >============================
===>   openvpn-auth-ldap-2.0.3_3 depends on shared library: ldap-2.4.8 - not 
found
===>    Verifying install for ldap-2.4.8 in /usr/ports/net/openldap24-client
===>   Installing existing package /packages/All/openldap-client-2.4.36.txz
Installing openldap-client-2.4.36... done
************************************************************

The OpenLDAP client package has been successfully installed.

Edit
  /usr/local/etc/openldap/ldap.conf
to change the system-wide client defaults.

Try `man ldap.conf' and visit the OpenLDAP FAQ-O-Matic at
  http://www.OpenLDAP.org/faq/index.cgi?file=3
for more information.

************************************************************
===>   Returning to build of openvpn-auth-ldap-2.0.3_3
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for openvpn-auth-ldap-2.0.3_3
configure: loading site script /usr/ports/Templates/config.site
checking build system type... amd64-portbld-freebsd8.3
checking host system type... amd64-portbld-freebsd8.3
checking target system type... amd64-portbld-freebsd8.3
checking for gcc... cc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking for gcc... gcc
checking whether we are using the GNU Objective C compiler... yes
checking whether gcc accepts -x objective-c... yes
checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel
checking whether ln -s works... yes
checking whether make sets $(MAKE)... yes
checking for re2c... /usr/local/bin/re2c
checking for doxygen... no
checking for dot... no
checking how to run the C preprocessor... cpp
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking for ANSI C header files... (cached) yes
checking for the pthreads library -lpthread... yes
checking for joinable pthread attribute... PTHREAD_CREATE_JOINABLE
checking if more special flags are required for pthreads... -D_THREAD_SAFE
checking for BSD pf(4) support... yes
checking for strlcpy... (cached) yes
checking for openldap... yes
checking for check unit test library... no
configure: WARNING: Check library not found. Unit tests will not be built or 
run.
checking for openvpn-plugin.h... no
configure: error: Could not locate a working openvpn source tree.
See `config.log' for more details.
===>  Script "configure" failed unexpectedly.
Please report the problem to s...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/security/openvpn-auth-ldap/work/auth-ldap-2.0.3/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop in /usr/ports/security/openvpn-auth-ldap.
===>  Cleaning for openvpn-2.3.2
===>  Cleaning for openvpn-auth-ldap-2.0.3_3
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to