You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     mar...@onohara.to
Last committer: pgollu...@freebsd.org
Ident:          $FreeBSD: head/textproc/rubygem-opml/Makefile 391169 2015-07-02 
16:01:06Z pgollucci $
Log URL:        
http://beefy8.nyi.freebsd.org/data/head-armv6-default/p395445_s287222/logs/rubygem-opml-1.0.0.log
Build URL:      
http://beefy8.nyi.freebsd.org/build.html?mastername=head-armv6-default&build=p395445_s287222
Log:

====>> Building textproc/rubygem-opml
build started at Mon Aug 31 08:33:10 UTC 2015
port directory: /usr/ports/textproc/rubygem-opml
building for: FreeBSD head-armv6-default-job-18 11.0-CURRENT FreeBSD 
11.0-CURRENT r287222 arm
maintained by: mar...@onohara.to
Makefile ident:      $FreeBSD: head/textproc/rubygem-opml/Makefile 391169 
2015-07-02 16:01:06Z pgollucci $
Poudriere version: 3.1.7
Host OSVERSION: 1100077
Jail OSVERSION: 1100079




!!! Jail is newer than host. (Jail: 1100079, Host: 1100077) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=armv6
UNAME_m=arm
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1100079
UNAME_v=FreeBSD 11.0-CURRENT r287222
UNAME_r=11.0-CURRENT
LC_COLLATE=C
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=screen
MASTERMNT=/usr/local/poudriere/data/.m/head-armv6-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=rubygem-opml-1.0.0
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/head-armv6-default/ref/.p/pool
MASTERNAME=head-armv6-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.7
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/textproc/rubygem-opml/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/textproc/rubygem-opml/work  
HOME=/wrkdirs/usr/ports/textproc/rubygem-opml/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/textproc/rubygem-opml/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/textproc/rubygem-opml/work  
HOME=/wrkdirs/usr/ports/textproc/rubygem-opml/work TMPDIR="/tmp" NO_PIE=yes 
SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe 
-mfloat-abi=softfp  -fno-strict-aliasing"  CPP="/nxb-bin/usr/bin/cpp" 
CPPFLAGS=""  LDFLAGS="" LIBS=""  CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe 
-mfloat-abi=softfp -fno-strict-aliasing "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
RUBY_LIBDIR="lib/ruby/2.1"
RUBY_ARCHLIBDIR="lib/ruby/2.1/armv6-freebsd11"
RUBY_SITELIBDIR="lib/ruby/site_ruby/2.1"
RUBY_SITEARCHLIBDIR="lib/ruby/site_ruby/2.1/armv6-freebsd11"
RUBY_VENDORLIBDIR="lib/ruby/vendor_ruby/2.1"
RUBY_VENDORARCHLIBDIR="lib/ruby/vendor_ruby/2.1/armv6-freebsd11"
RUBY_MODDOCDIR="share/doc/ruby21/opml"
RUBY_MODEXAMPLESDIR="share/examples/ruby21/opml"
RUBY_DOCDIR="share/doc/ruby21"
RUBY_EXAMPLESDIR="share/examples/ruby21"
RUBY_RIDIR="share/ri/2.1/system"
RUBY_SITERIDIR="share/ri/2.1/site"
RUBY_ELISPDIR="lib/ruby/elisp"
RUBY_VERSION="2.1.6"
RUBY_VER="2.1"
RUBY_SHLIBVER="21"
RUBY_ARCH="armv6-freebsd11"
RUBY_SUFFIX="21"
RUBY_NAME="ruby21"
RUBY_DEFAULT_SUFFIX="21"
RUBY20="@comment
"
RUBY21=""
RUBY22="@comment
"
PORTVERSION="1.0.0"
REV=""
GEMS_BASE_DIR="lib/ruby/gems/2.1"
GEMS_DIR="lib/ruby/gems/2.1/gems"
DOC_DIR="lib/ruby/gems/2.1/doc"
CACHE_DIR="lib/ruby/gems/2.1/cache"
SPEC_DIR="lib/ruby/gems/2.1/specifications"
EXT_DIR="lib/ruby/gems/2.1/extensions"
PORT="opml-1.0.0"
GEM_NAME="opml-1.0.0"
GEM_LIB_DIR="lib/ruby/gems/2.1/gems/opml-1.0.0"
GEM_DOC_DIR="lib/ruby/gems/2.1/doc/opml-1.0.0"
GEM_SPEC="lib/ruby/gems/2.1/specifications/opml-1.0.0.gemspec"
GEM_CACHE="lib/ruby/gems/2.1/cache/opml-1.0.0.gem"
EXTRACT_SUFX=".gem"
RUBY_RD_HTML_FILES="@comment
"
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/opml"
EXAMPLESDIR="share/examples/opml"
DATADIR="share/opml"
WWWDIR="www/opml"
ETCDIR="etc/opml"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/opml
DOCSDIR=/usr/local/share/doc/opml
EXAMPLESDIR=/usr/local/share/examples/opml
WWWDIR=/usr/local/www/opml
ETCDIR=/usr/local/etc/opml
--End SUB_LIST--

---Begin make.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
<snip>
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
MACHINE=arm
MACHINE_ARCH=armv6
ARCH=${MACHINE_ARCH}
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   rubygem-opml-1.0.0 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.5.6.txz
[head-armv6-default-job-18] Installing pkg-1.5.6...
[head-armv6-default-job-18] Extracting pkg-1.5.6: .......... done
Message for pkg-1.5.6:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   rubygem-opml-1.0.0 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of rubygem-opml-1.0.0
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by rubygem-opml-1.0.0 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by rubygem-opml-1.0.0 for building
=> SHA256 Checksum OK for rubygem/opml-1.0.0.gem.
===========================================================================
=======================<phase: extract-depends>============================
===>   rubygem-opml-1.0.0 depends on file: /usr/local/bin/gem21 - not found
===>   Installing existing package /packages/All/ruby21-gems-2.4.8.txz
[head-armv6-default-job-18] Installing ruby21-gems-2.4.8...
[head-armv6-default-job-18] `-- Installing ruby-2.1.6,1...
[head-armv6-default-job-18] |   `-- Installing libedit-3.1.20150325_1...
[head-armv6-default-job-18] |   `-- Extracting libedit-3.1.20150325_1: 
.......... done
[head-armv6-default-job-18] |   `-- Installing libffi-3.2.1...
[head-armv6-default-job-18] |   | `-- Installing indexinfo-0.2.3...
[head-armv6-default-job-18] |   | `-- Extracting indexinfo-0.2.3: .... done
[head-armv6-default-job-18] |   `-- Extracting libffi-3.2.1: .......... done
[head-armv6-default-job-18] |   `-- Installing libyaml-0.1.6_2...
[head-armv6-default-job-18] |   `-- Extracting libyaml-0.1.6_2: ......... done
[head-armv6-default-job-18] `-- Extracting ruby-2.1.6,1: .......... done
[head-armv6-default-job-18] Extracting ruby21-gems-2.4.8: .......... done
Message for ruby-2.1.6,1:
====
Some of the standard commands are provided as separate ports for ease
of upgrading:

        devel/ruby-gems:        gem - RubyGems package manager
        devel/rubygem-rake:     rake - Ruby Make

And some of the standard libraries are provided as separate ports
since they require extra dependencies:

        databases/ruby-gdbm:    GDBM module

Install them as occasion demands.
====
===>   rubygem-opml-1.0.0 depends on file: /usr/local/bin/gem21 - found
===>   Returning to build of rubygem-opml-1.0.0
===>   rubygem-opml-1.0.0 depends on file: /usr/local/bin/ruby21 - found
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by rubygem-opml-1.0.0 for building
===>  Extracting for rubygem-opml-1.0.0
=> SHA256 Checksum OK for rubygem/opml-1.0.0.gem.
Unpacked gem: '/wrkdirs/usr/ports/textproc/rubygem-opml/work/opml-1.0.0'
===========================================================================
=======================<phase: patch-depends  >============================
===>   rubygem-opml-1.0.0 depends on file: /usr/local/bin/ruby21 - found
===========================================================================
=======================<phase: patch          >============================
===>  Patching for rubygem-opml-1.0.0
===========================================================================
=======================<phase: build-depends  >============================
===>   rubygem-opml-1.0.0 depends on file: /usr/local/bin/gem21 - found
===>   rubygem-opml-1.0.0 depends on file: /usr/local/bin/ruby21 - found
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for rubygem-opml-1.0.0
===========================================================================
=======================<phase: build          >============================
===>  Building for rubygem-opml-1.0.0
  Successfully built RubyGem
  Name: opml
  Version: 1.0.0
  File: opml-1.0.0.gem
===========================================================================
=======================<phase: run-depends    >============================
===>   rubygem-opml-1.0.0 depends on file: /usr/local/bin/gem21 - found
===>   rubygem-opml-1.0.0 depends on file: /usr/local/bin/ruby21 - found
===========================================================================
=======================<phase: stage          >============================
===>  Staging for rubygem-opml-1.0.0
===>   Generating temporary packing list
(cd /wrkdirs/usr/ports/textproc/rubygem-opml/work/opml-1.0.0; /usr/bin/env 
LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 LC_CTYPE=UTF-8 RB_USER_INSTALL=yes 
/usr/local/bin/gem21 install -l --no-update-sources --install-dir 
/wrkdirs/usr/ports/textproc/rubygem-opml/work/stage/usr/local/lib/ruby/gems/2.1 
--ignore-dependencies 
--bindir=/wrkdirs/usr/ports/textproc/rubygem-opml/work/stage/usr/local/bin 
--rdoc --ri opml-1.0.0.gem -- --build-args )
/usr/local/lib/ruby/2.1/rdoc/generator/ri.rb:4:in `<top (required)>': cannot 
load such file --         _tmp = true (LoadError)
        from 
/usr/local/lib/ruby/site_ruby/2.1/rubygems/core_ext/kernel_require.rb:54:in 
`require'
        from 
/usr/local/lib/ruby/site_ruby/2.1/rubygems/core_ext/kernel_require.rb:54:in 
`require'
        from /usr/local/lib/ruby/2.1/rdoc/rdoc.rb:567:in `<top (required)>'
        from 
/usr/local/lib/ruby/site_ruby/2.1/rubygems/core_ext/kernel_require.rb:54:in 
`require'
        from 
/usr/local/lib/ruby/site_ruby/2.1/rubygems/core_ext/kernel_require.rb:54:in 
`require'
        from /usr/local/lib/ruby/2.1/rdoc/rubygems_hook.rb:73:in `load_rdoc'
        from /usr/local/lib/ruby/2.1/rdoc/rubygems_hook.rb:238:in `setup'
        from /usr/local/lib/ruby/2.1/rdoc/rubygems_hook.rb:151:in `generate'
        from /usr/local/lib/ruby/2.1/rdoc/rubygems_hook.rb:56:in `block in 
generation_hook'
        from /usr/local/lib/ruby/2.1/rdoc/rubygems_hook.rb:55:in `each'
        from /usr/local/lib/ruby/2.1/rdoc/rubygems_hook.rb:55:in 
`generation_hook'
        from 
/usr/local/lib/ruby/site_ruby/2.1/rubygems/commands/install_command.rb:286:in 
`call'
        from 
/usr/local/lib/ruby/site_ruby/2.1/rubygems/commands/install_command.rb:286:in 
`block in install_gem_without_dependencies'
        from 
/usr/local/lib/ruby/site_ruby/2.1/rubygems/commands/install_command.rb:285:in 
`each'
        from 
/usr/local/lib/ruby/site_ruby/2.1/rubygems/commands/install_command.rb:285:in 
`install_gem_without_dependencies'
        from 
/usr/local/lib/ruby/site_ruby/2.1/rubygems/commands/install_command.rb:235:in 
`install_gem'
        from 
/usr/local/lib/ruby/site_ruby/2.1/rubygems/commands/install_command.rb:299:in 
`block in install_gems'
        from 
/usr/local/lib/ruby/site_ruby/2.1/rubygems/commands/install_command.rb:295:in 
`each'
        from 
/usr/local/lib/ruby/site_ruby/2.1/rubygems/commands/install_command.rb:295:in 
`install_gems'
        from 
/usr/local/lib/ruby/site_ruby/2.1/rubygems/commands/install_command.rb:202:in 
`execute'
        from /usr/local/lib/ruby/site_ruby/2.1/rubygems/command.rb:307:in 
`invoke_with_build_args'
        from 
/usr/local/lib/ruby/site_ruby/2.1/rubygems/command_manager.rb:168:in 
`process_args'
        from 
/usr/local/lib/ruby/site_ruby/2.1/rubygems/command_manager.rb:138:in `run'
        from /usr/local/lib/ruby/site_ruby/2.1/rubygems/gem_runner.rb:54:in 
`run'
        from /usr/local/bin/gem21:21:in `<main>'
Successfully installed opml-1.0.0
*** Error code 1

Stop.
make: stopped in /usr/ports/textproc/rubygem-opml
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to