You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     oli...@freebsd.org
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/games/ember/Makefile 327730 2013-09-20 17:36:33Z 
bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/83amd64-default/2013-10-16_01h02m18s/logs/ember-0.7.0_1.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/83amd64-default/2013-10-16_01h02m18s
Log:

====>> Building games/ember
build started at Wed Oct 16 11:43:25 UTC 2013
port directory: /usr/ports/games/ember
building for: FreeBSD 83amd64-default-job-01 8.3-RELEASE FreeBSD 8.3-RELEASE 
amd64
maintained by: oli...@freebsd.org
Makefile ident:      $FreeBSD: head/games/ember/Makefile 327730 2013-09-20 
17:36:33Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=803000
UNAME_v=FreeBSD 8.3-RELEASE
UNAME_r=8.3-RELEASE
FTP_PASSIVE_MODE=YES
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/83amd64-default/ref
PKG_EXT=txz
tpid=40540
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=ember-0.7.0_1
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=83amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-png-prefix=/usr/local --enable-binreloc  --program-transform-name= 
--disable-cppunit --disable-debug  --with-toluaxx=/usr/local/bin/tolua++-5.1 
--prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
LUA_LIBS="-L/usr/local/lib/lua51 -llua"  
LUA_CFLAGS="-I/usr/local/include/lua51"  TOLUAXX="/usr/local/bin/tolua++-5.1" 
TMPDIR="/tmp" TMPDIR="/tmp" SDL_CONFIG=/usr/local/bin/sdl-config 
PKG_CONFIG=pkgconf SHELL=/bin/sh CONFIG_SHELL=/bin/sh 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SDL_CONFIG=/usr/local/bin/sdl-config SHELL=/bin/sh 
NO_LINT=YES LUA_VER="5.1" LUA_VER_SH="1" LUA_VER_STR="51" 
LUA_PREFIX="/usr/local" LUA_SUBDIR="lua51" LUA_BINDIR="/usr/local/bin/lua51" 
LUA_INCDIR="/usr/local/include/lua51" LUA_LIBDIR="/usr/local/lib/lua51" 
LUA_MODLIBDIR="/usr/local/lib/lua/5.1" 
LUA_MODSHAREDIR="/usr/local/share/lua/5.1" PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS="-DBR_NO_MACROS"  LDFLAGS=""  
CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/ember
DOCSDIR=/usr/local/share/doc/ember
EXAMPLESDIR=/usr/local/share/examples/ember
WWWDIR=/usr/local/www/ember
ETCDIR=/usr/local/etc/ember
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for ember-0.7.0_1
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   ember-0.7.0_1 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of ember-0.7.0_1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by ember-0.7.0_1 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by ember-0.7.0_1 for building
=> SHA256 Checksum OK for ember-0.7.0.tar.bz2.
=> SHA256 Checksum OK for ember-media-0.7.0.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by ember-0.7.0_1 for building
===>  Extracting for ember-0.7.0_1
=> SHA256 Checksum OK for ember-0.7.0.tar.bz2.
=> SHA256 Checksum OK for ember-media-0.7.0.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for ember-0.7.0_1
===>  Applying FreeBSD patches for ember-0.7.0_1
===========================================================================
=======================<phase: build-depends  >============================
===>   ember-0.7.0_1 depends on file: /usr/local/lib/libOgreMain.so.1.8.1 - not 
found
===>    Verifying install for /usr/local/lib/libOgreMain.so.1.8.1 in 
/usr/ports/graphics/ogre3d
===>   Installing existing package /packages/All/ogre3d-1.8.1.txz
Installing ogre3d-1.8.1...Installing xproto-7.0.24... done
Installing xf86vidmodeproto-2.3.1... done
Installing xextproto-7.2.1... done
Installing renderproto-0.11.1... done
Installing randrproto-1.4.0... done
Installing printproto-1.0.5... done
Installing libxcb-1.9.1...Installing libXdmcp-1.1.1... done
Installing libXau-1.0.8... done
Installing libxml2-2.8.0_2...Installing pkgconf-0.9.3... done
Installing libiconv-1.14_1... done
 done
Installing libpthread-stubs-0.3_3... done
 done
Installing libXxf86vm-1.1.3...Installing libXext-1.3.2,1...Installing 
libX11-1.6.2,1...Installing kbproto-1.0.6... done
 done
 done
 done
Installing libXrender-0.9.8... done
Installing libXrandr-1.4.2... done
Installing libXpm-3.5.11...Installing libSM-1.2.2,1...Installing 
libICE-1.0.8,1... done
 done
Installing libXt-1.1.4,1... done
 done
Installing libXp-1.0.2,1... done
Installing libXfixes-5.0.1...Installing fixesproto-5.0... done
 done
Installing libXdamage-1.1.4...Installing damageproto-1.2.1... done
 done
Installing dri2proto-2.8... done
Installing libXmu-1.1.2,1... done
Installing libXaw-1.0.12,2... done
Installing expat-2.1.0... done
Installing freetype2-2.5.0.1... done
Installing pciids-20131010... done
Installing libdrm-2.4.17_1...Installing libpciaccess-0.13.2... done
 done
Installing libGLU-9.0.0...Installing libGL-7.6.1_4... done
 done
Installing freeimage-3.15.4_2... done
Installing aalib-1.4.r5_6... done
Installing zziplib-0.13.62... done
Installing sdl-1.2.15_2,2... done
 done
------------------------------------------------------------------------------
 Your SDL library has been built with libvgl support, which means that you
 can run almost any SDL application straight on your console (VESA 2.0
 compatible videocard is required).

 To do this you have to load the vesa kernel module or enable it in your
 kernel, and set environment variable "SDL_VIDEODRIVER=vgl".
------------------------------------------------------------------------------
===>   Returning to build of ember-0.7.0_1
===>   ember-0.7.0_1 depends on file: /usr/local/bin/sdl-config - found
===>   ember-0.7.0_1 depends on executable: pkgconf - found
===>   ember-0.7.0_1 depends on file: /usr/local/lib/lua51/libtolua++.so - not 
found
===>    Verifying install for /usr/local/lib/lua51/libtolua++.so in 
/usr/ports/lang/tolua++
===>   Installing existing package /packages/All/tolua++-1.0.93.txz
Installing tolua++-1.0.93...Installing lua-5.1.5_6... done
 done
===>   Returning to build of ember-0.7.0_1
===========================================================================
=======================<phase: lib-depends    >============================
===>   ember-0.7.0_1 depends on shared library: sigc-2.0 - not found
===>    Verifying install for sigc-2.0 in /usr/ports/devel/libsigc++20
===>   Installing existing package /packages/All/libsigc++-2.3.1.txz
Installing libsigc++-2.3.1... done
===>   Returning to build of ember-0.7.0_1
===>   ember-0.7.0_1 depends on shared library: eris-1.3 - not found
===>    Verifying install for eris-1.3 in /usr/ports/devel/eris
===>   Installing existing package /packages/All/eris-1.3.21.txz
Installing eris-1.3.21...Installing skstream-0.3.9... done
Installing wfmath-1.0.1...Installing mpfr-3.1.2...Installing gmp-5.1.3... done
 done
Installing mpc-0.9... done
Installing gcc-ecj-4.5... done
Installing gcc-4.6.3...Installing gettext-0.18.3.1... done
Installing binutils-2.23.2... done
 done
 done
Installing mercator-0.3.2... done
Installing Atlas-devel-0.6.2... done
 done
===>   Returning to build of ember-0.7.0_1
===>   ember-0.7.0_1 depends on shared library: varconf-1.0.8 - not found
===>    Verifying install for varconf-1.0.8 in /usr/ports/devel/varconf
<snip>
===>    Verifying install for openal.1 in /usr/ports/audio/openal-soft
===>   Installing existing package /packages/All/openal-soft-1.15.1_2.txz
Installing openal-soft-1.15.1_2... done
===>   Returning to build of ember-0.7.0_1
===>   ember-0.7.0_1 depends on shared library: alut.1 - not found
===>    Verifying install for alut.1 in /usr/ports/audio/freealut
===>   Installing existing package /packages/All/freealut-1.1.0_2.txz
Installing freealut-1.1.0_2... done
===>   Returning to build of ember-0.7.0_1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for ember-0.7.0_1
configure: WARNING: unrecognized options: --with-png-prefix
configure: loading site script /usr/ports/Templates/config.site
checking build system type... amd64-portbld-freebsd8.3
checking host system type... amd64-portbld-freebsd8.3
checking target system type... amd64-portbld-freebsd8.3
checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... (cached) /bin/mkdir -p
checking for gawk... (cached) /usr/bin/awk
checking whether make sets $(MAKE)... yes
checking how to create a ustar tar archive... (cached) /usr/bin/tar
checking how to print strings... printf
checking for style of include used by make... GNU
checking for gcc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking dependency style of cc... gcc3
checking for a sed that does not truncate output... (cached) /usr/bin/sed
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking for fgrep... (cached) /usr/bin/fgrep
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... (cached) 262144
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... no
checking how to convert amd64-portbld-freebsd8.3 file names to 
amd64-portbld-freebsd8.3 format... func_convert_file_noop
checking how to convert amd64-portbld-freebsd8.3 file names to toolchain 
format... func_convert_file_noop
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... (cached) pass_all
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for ar... ar
checking for archiver @FILE support... no
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for sysroot... no
checking for mt... mt
checking if mt is a manifest tool... no
checking how to run the C preprocessor... cpp
checking for ANSI C header files... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking for dlfcn.h... (cached) yes
checking for objdir... .libs
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC -DPIC
checking if cc PIC flag -fPIC -DPIC works... yes
checking if cc static flag -static works... yes
checking if cc supports -c -o file.o... yes
checking if cc supports -c -o file.o... (cached) yes
checking whether the cc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... freebsd8.3 ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking whether we are using the GNU C++ compiler... yes
checking whether c++ accepts -g... yes
checking dependency style of c++... gcc3
checking how to run the C++ preprocessor... c++ -E
checking for ld used by c++... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking whether the c++ linker (/usr/bin/ld) supports shared libraries... yes
checking for c++ option to produce PIC... -fPIC -DPIC
checking if c++ PIC flag -fPIC -DPIC works... yes
checking if c++ static flag -static works... yes
checking if c++ supports -c -o file.o... yes
checking if c++ supports -c -o file.o... (cached) yes
checking whether the c++ linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... freebsd8.3 ld.so
checking how to hardcode library paths into programs... immediate
checking for gcc... (cached) cc
checking whether we are using the GNU C compiler... (cached) yes
checking whether cc accepts -g... (cached) yes
checking for cc option to accept ISO C89... (cached) none needed
checking dependency style of cc... (cached) gcc3
checking for gcc... gcc
checking whether we are using the GNU Objective C compiler... yes
checking whether gcc accepts -g... yes
checking dependency style of gcc... gcc3
checking for xmllint... /usr/local/bin/xmllint
checking for ANSI C header files... (cached) yes
checking for stdlib.h... (cached) yes
checking for math.h... (cached) yes
checking for signal.h... (cached) yes
checking for an ANSI C-conforming const... yes
checking for inline... inline
checking whether struct tm is in sys/time.h or time.h... time.h
checking for sighandler_t... no
checking for error_at_line... no
checking for stdlib.h... (cached) yes
checking for GNU libc compatible malloc... (cached) yes
checking for vprintf... (cached) yes
checking for _doprnt... no
checking for memset... (cached) yes
checking for select... (cached) yes


                **************************************
                * Checking for SDL Libraries
                **************************************

        
checking for sdl-config... /usr/local/bin/sdl-config
checking for SDL - version >= 1.2.0... yes
checking for glViewport in -L/usr/local/lib -lGL... yes


                **************************************
                * Checking for C Libraries
                **************************************

        
checking whether binary relocation support should be enabled... yes
checking for pthread_getspecific in -lpthread... yes
checking whether binary relocation should use threads... yes
checking for main in -ltinyxml... no


                **************************************
                * Checking for C++ Libraries
                **************************************

        
checking ext/hash_set usability... yes
checking ext/hash_set presence... yes
checking for ext/hash_set... yes
checking pkg-config is at least version 0.9.0... yes
checking for OPENAL... yes
checking for FREEALUT... yes
checking for SIG... yes
checking for boostlib >= 1.35.0... yes
checking whether the Boost::Thread library is available... yes
cc
cc42
checking for main in -lboost_thread-cc42... no
checking for main in -lboost_thread-cc42-mt... no
checking for main in -lboost_thread-cc42-mt-s... no
checking for main in -lboost_thread-cc42-s... no
checking for main in -lboost_thread-cc... no
checking for main in -lboost_thread-cc-mt... no
checking for main in -lboost_thread-cc-mt-s... no
checking for main in -lboost_thread-cc-s... no
checking for main in -lboost_thread... yes
checking for /usr/local/lib/libboost_thread.so... yes
checking if /usr/local/lib/libboost_thread.so require extra libs.... 
-lboost_thread -lboost_system -lboost_system 
checking for WF... yes
checking for OGRE... yes
checking for CEGUI... yes
checking for X11... yes
checking for CEGUIOGRE... yes
checking for LUA... yes
configure: Lua version => 5.1, make sure that CEGUI also has been compiled for 
this version
checking for main in -lCEGUItoluapp... no
checking for main in -ltolua++... no
checking for main in -ltolua++5.1... no
configure: error: Couldn't find tolua++. Make sure that tolua++ 
(http://www.codenix.com/~tolua/) is installed and CEGUI is compiled with Lua 
scripting support.
===>  Script "configure" failed unexpectedly.
Please report the problem to oli...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/games/ember/work/ember-0.7.0/config.log" including the
output of the failure of your make command. Also, it might be a good idea to
provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop in /usr/ports/games/ember.
===>  Cleaning for ember-0.7.0_1
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to