You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     madpi...@freebsd.org
Last committer: madpi...@freebsd.org
Ident:          $FreeBSD: head/audio/p5-xmms2/Makefile 328665 2013-09-29 
10:41:24Z madpilot $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/91i386-default/2013-10-16_14h14m28s/logs/p5-xmms2-0.8_1.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/91i386-default/2013-10-16_14h14m28s
Log:

====>> Building audio/p5-xmms2
build started at Wed Oct 16 22:10:39 UTC 2013
port directory: /usr/ports/audio/p5-xmms2
building for: FreeBSD 91i386-default-job-13 9.1-RELEASE FreeBSD 9.1-RELEASE i386
maintained by: madpi...@freebsd.org
Makefile ident:      $FreeBSD: head/audio/p5-xmms2/Makefile 328665 2013-09-29 
10:41:24Z madpilot $
Poudriere version: 3.1-pre

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=901000
UNAME_v=FreeBSD 9.1-RELEASE
UNAME_r=9.1-RELEASE
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/91i386-default/ref
PKG_EXT=txz
tpid=36459
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=p5-xmms2-0.8_1
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=91i386-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" PYTHON="/usr/local/bin/python2.7" 
PKG_CONFIG=pkgconf SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/xmms2
DOCSDIR=/usr/local/share/doc/xmms2
EXAMPLESDIR=/usr/local/share/examples/xmms2
WWWDIR=/usr/local/www/xmms2
ETCDIR=/usr/local/etc/xmms2
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for p5-xmms2-0.8_1
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   p5-xmms2-0.8_1 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of p5-xmms2-0.8_1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by p5-xmms2-0.8_1 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by p5-xmms2-0.8_1 for building
=> SHA256 Checksum OK for xmms2-0.8DrO_o.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by p5-xmms2-0.8_1 for building
===>  Extracting for p5-xmms2-0.8_1
=> SHA256 Checksum OK for xmms2-0.8DrO_o.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for p5-xmms2-0.8_1
===>  Applying FreeBSD patches for p5-xmms2-0.8_1
===========================================================================
=======================<phase: build-depends  >============================
===>   p5-xmms2-0.8_1 depends on file: /usr/local/bin/python2.7 - not found
===>    Verifying install for /usr/local/bin/python2.7 in 
/usr/ports/lang/python27
===>   Installing existing package /packages/All/python27-2.7.5_3.txz
Installing python27-2.7.5_3...Installing gettext-0.18.3.1...Installing 
libiconv-1.14_1... done
 done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of p5-xmms2-0.8_1
===>   p5-xmms2-0.8_1 depends on executable: python - not found
===>    Verifying install for python in /usr/ports/lang/python
===>   Installing existing package /packages/All/python-2.7_1,2.txz
Installing python-2.7_1,2...Installing python2-2_1... done
 done
===>   Returning to build of p5-xmms2-0.8_1
===>   p5-xmms2-0.8_1 depends on executable: pkgconf - not found
===>    Verifying install for pkgconf in /usr/ports/devel/pkgconf
===>   Installing existing package /packages/All/pkgconf-0.9.3.txz
Installing pkgconf-0.9.3... done
===>   Returning to build of p5-xmms2-0.8_1
===>   p5-xmms2-0.8_1 depends on file: /usr/local/bin/perl5.14.4 - not found
===>    Verifying install for /usr/local/bin/perl5.14.4 in 
/usr/ports/lang/perl5.14
===>   Installing existing package /packages/All/perl-5.14.4_2.txz
Installing perl-5.14.4_2...Removing stale symlinks from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl5
Done.
Removing /usr/local/etc/perl5_version... Done.
Creating /usr/local/etc/perl5_version... Done.
 done
===>   Returning to build of p5-xmms2-0.8_1
===========================================================================
=======================<phase: lib-depends    >============================
===>   p5-xmms2-0.8_1 depends on shared library: libxmmsclient.so - not found
===>    Verifying for libxmmsclient.so in /usr/ports/audio/xmms2
===>   Installing existing package /packages/All/xmms2-0.8_4.txz
Installing xmms2-0.8_4...Installing ca_root_nss-3.15.1_1... done
Installing curl-7.32.0... done
Installing faad2-2.7_4,1... done
Installing flac-1.3.0_1...Installing libogg-1.3.1,4... done
 done
Installing glib-2.36.3...Installing pcre-8.33... done
Installing libffi-3.0.13... done
No schema files found: doing nothing.
 done
Installing libmad-0.15.1b_2... done
Installing libvorbis-1.3.3_1,3... done
Installing mDNSResponder-379.38.1... done
Installing sqlite3-3.8.0.2... done
 done
===>   Returning to build of p5-xmms2-0.8_1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for p5-xmms2-0.8_1
cd /wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o && /usr/bin/env 
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444" ./waf  configure  --conf-prefix=/usr/local 
--prefix=/usr/local  --mandir=/usr/local/man --without-xmms2d 
--with-optionals="perl"
Setting top to                           : 
/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o 
Setting out to                           : 
/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/_build_ 
Platform code for posix                  : ok 
Checking for program gcc,cc              : cc 
Checking for program ar                  : /usr/bin/ar 
Checking for program g++,c++             : c++ 
git commit id                            : Unknown 
uncommited changed                       : no 
Checking for compiler flags -Wall        : yes 
Checking for compiler flags -Wempty-body : no 
Checking for compiler flags -Wformat=2   : yes 
Checking for compiler flags -Wformat-nonliteral : yes 
Checking for compiler flags -Wformat-security   : yes 
Checking for compiler flags -Wignored-qualifiers : no 
Checking for compiler flags -Wmissing-prototypes : yes 
Checking for compiler flags -Wstrict-prototypes  : yes 
Checking for compiler flags -Wtype-limits        : no 
Checking for compiler flags -Wwrite-strings      : yes 
Checking for compiler flags -Wformat-extra-args  : yes 
Checking for compiler flags -Wformat-zero-length : yes 
Checking for compiler flags -fdiagnostics-show-option : yes 
Checking for compiler flags -fdiagnostics-show-option : yes 
Checking for compiler flags -Werror=implicit-function-declaration : yes 
Checking for program pkg-config                                   : 
/usr/local/bin/pkg-config 
Checking for 'glib-2.0'                                           : yes 
Checking for program perl                                         : 
/usr/bin/perl 
Checking for perl version                                         : 5.7.3 
Checking for function nanosleep                                   : yes 
Checking for function modf                                        : yes 
Checking for function semtimedop                                  : not found 
Compiling visualization without shm support!

 
Optional configuration:
======================= 
Enabled:  perl 
Disabled:  et, launcher, mdns, medialib-updater, nycli, pixmaps, python, ruby, 
tests, vistest, xmmsclient++, xmmsclient++-glib, xmmsclient-cf, 
xmmsclient-ecore 
Plugins configuration:
====================== 
Output:   
XForm/Other:   
Disabled:  airplay, alsa, ao, apefile, asf, asx, avcodec, cdda, coreaudio, cue, 
curl, daap, diskwrite, equalizer, faad, file, flac, flv, gme, gvfs, html, ices, 
icymetaint, id3v2, jack, karaoke, m3u, mac, mad, mms, modplug, mp4, mpg123, 
musepack, nms, normalize, null, nulstripper, ofa, oss, pls, pulse, replaygain, 
rss, samba, sc68, sid, sndfile, speex, sun, tremor, tta, vocoder, vorbis, wave, 
waveout, wavpack, xml, xspf 
'configure' finished successfully (1.267s)
===========================================================================
=======================<phase: build          >============================
===>  Building for p5-xmms2-0.8_1
cd /wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o && /usr/bin/env 
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444" ./waf  build
Waf: Entering directory 
`/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/_build_'
[ 1/36] xsubpp: src/clients/lib/perl/XMMSClientCollection.xs -> 
_build_/src/clients/lib/perl/XMMSClientCollection.c
[ 2/36] xsubpp: src/clients/lib/perl/XMMSClient.xs -> 
_build_/src/clients/lib/perl/XMMSClient.c
[ 3/36] xsubpp: src/clients/lib/perl/XMMSClientResult.xs -> 
_build_/src/clients/lib/perl/XMMSClientResult.c
[ 4/36] xsubpp: src/clients/lib/perl/XMMSClientPlaylist.xs -> 
_build_/src/clients/lib/perl/XMMSClientPlaylist.c
[ 5/36] perldoc: src/clients/lib/perl/XMMSClient.xs -> 
_build_/src/clients/lib/perl/Audio/XMMSClient.pod
[ 6/36] perldoc: src/clients/lib/perl/XMMSClientPlaylist.xs -> 
_build_/src/clients/lib/perl/Audio/XMMSClient/Playlist.pod
[ 7/36] perldoc: src/clients/lib/perl/XMMSClientCollection.xs -> 
_build_/src/clients/lib/perl/Audio/XMMSClient/Collection.pod
[ 8/36] perldoc: src/clients/lib/perl/XMMSClientResult.xs -> 
_build_/src/clients/lib/perl/Audio/XMMSClient/Result.pod
[ 9/36] c: _build_/src/clients/lib/perl/XMMSClient.c -> 
_build_/src/clients/lib/perl/XMMSClient.c.1.o
[10/36] c: _build_/src/clients/lib/perl/XMMSClientResult.c -> 
_build_/src/clients/lib/perl/XMMSClientResult.c.1.o
./src/clients/lib/perl/XMMSClientResult.xs: In function 'sv_from_value_uint':
./src/clients/lib/perl/XMMSClientResult.xs:22: warning: 'xmmsv_get_uint' is 
deprecated (declared at 
/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/src/include/xmmsc/xmmsv_deprecated.h:50)
 [-Wdeprecated-declarations]
./src/clients/lib/perl/XMMSClientResult.c: In function 
'XS_Audio__XMMSClient__Result_get_type':
./src/clients/lib/perl/XMMSClientResult.c:378: warning: 
'XMMSV_TYPE_UINT32_IS_DEPRECATED' is deprecated (declared at 
/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/src/include/xmmsc/xmmsv_deprecated.h:37)
 [-Wdeprecated-declarations]
./src/clients/lib/perl/XMMSClientResult.c: In function 
'XS_Audio__XMMSClient__Result_get_error':
./src/clients/lib/perl/XMMSClientResult.c:437: warning: 'xmmsv_get_error_old' 
is deprecated (declared at 
/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/src/include/xmmsc/xmmsv_deprecated.h:48)
 [-Wdeprecated-declarations]
./src/clients/lib/perl/XMMSClientResult.c: At top level:
./src/clients/lib/perl/XMMSClientResult.xs:18: warning: 'sv_from_value_uint' 
defined but not used
./src/clients/lib/perl/XMMSClient.xs:13: warning: no previous prototype for 
'perl_xmmsclient_xmmsc_io_need_out_callback_set_cb' [-Wmissing-prototypes]
./src/clients/lib/perl/XMMSClient.c: In function 
'XS_Audio__XMMSClient_plugin_list':
./src/clients/lib/perl/XMMSClient.c:256: warning: assignment discards 
qualifiers from pointer target type
./src/clients/lib/perl/XMMSClient.c:273: warning: 'xmmsc_plugin_list' is 
deprecated (declared at 
/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/src/include/xmmsclient/xmmsclient.h:173)
 [-Wdeprecated-declarations]
./src/clients/lib/perl/XMMSClient.c: In function 
'XS_Audio__XMMSClient_medialib_add_entry_args':
./src/clients/lib/perl/XMMSClient.c:476: warning: 
'xmmsc_medialib_add_entry_args' is deprecated (declared at 
/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/src/include/xmmsclient/xmmsclient.h:224)
 [-Wdeprecated-declarations]
./src/clients/lib/perl/XMMSClient.c: In function 
'XS_Audio__XMMSClient_medialib_path_import':
./src/clients/lib/perl/XMMSClient.c:558: warning: 'xmmsc_medialib_path_import' 
is deprecated (declared at 
/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/src/include/xmmsclient/xmmsclient.h:228)
 [-Wdeprecated-declarations]
./src/clients/lib/perl/XMMSClient.c: In function 
'XS_Audio__XMMSClient_medialib_path_import_encoded':
./src/clients/lib/perl/XMMSClient.c:582: warning: 
'xmmsc_medialib_path_import_encoded' is deprecated (declared at 
/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/src/include/xmmsclient/xmmsclient.h:229)
 [-Wdeprecated-declarations]
./src/clients/lib/perl/XMMSClient.c: In function 
'XS_Audio__XMMSClient_playback_seek_ms_abs':
./src/clients/lib/perl/XMMSClient.c:1613: warning: 'xmmsc_playback_seek_ms_abs' 
is deprecated (declared at 
/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/src/include/xmmsclient/xmmsclient.h:129)
 [-Wdeprecated-declarations]
./src/clients/lib/perl/XMMSClient.c: In function 
'XS_Audio__XMMSClient_playback_seek_ms_rel':
./src/clients/lib/perl/XMMSClient.c:1637: warning: 'xmmsc_playback_seek_ms_rel' 
is deprecated (declared at 
/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/src/include/xmmsclient/xmmsclient.h:130)
 [-Wdeprecated-declarations]
./src/clients/lib/perl/XMMSClient.c: In function 
'XS_Audio__XMMSClient_playback_seek_samples_abs':
./src/clients/lib/perl/XMMSClient.c:1661: warning: 
'xmmsc_playback_seek_samples_abs' is deprecated (declared at 
/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/src/include/xmmsclient/xmmsclient.h:132)
 [-Wdeprecated-declarations]
./src/clients/lib/perl/XMMSClient.c: In function 
'XS_Audio__XMMSClient_playback_seek_samples_rel':
./src/clients/lib/perl/XMMSClient.c:1685: warning: 
'xmmsc_playback_seek_samples_rel' is deprecated (declared at 
/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/src/include/xmmsclient/xmmsclient.h:133)
 [-Wdeprecated-declarations]
Waf: Leaving directory 
`/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/_build_'
Build failed
Traceback (most recent call last):
  File 
"/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/.waf-1.6.7-b271784c448ab906d5606267fb7f92c0/waflib/Runner.py",
 line 161, in start
    st=tsk.runnable_status()
  File 
"/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/.waf-1.6.7-b271784c448ab906d5606267fb7f92c0/waflib/Task.py",
 line 282, in runnable_status
    new_sig=self.signature()
  File 
"/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/.waf-1.6.7-b271784c448ab906d5606267fb7f92c0/waflib/Task.py",
 line 271, in signature
    self.sig_implicit_deps()
  File 
"/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/.waf-1.6.7-b271784c448ab906d5606267fb7f92c0/waflib/Task.py",
 line 369, in sig_implicit_deps
    (nodes,names)=self.scan()
  File 
"/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/.waf-1.6.7-b271784c448ab906d5606267fb7f92c0/waflib/Tools/c_preproc.py",
 line 600, in scan
    tmp.start(task.inputs[0],task.env)
  File 
"/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/.waf-1.6.7-b271784c448ab906d5606267fb7f92c0/waflib/Tools/c_preproc.py",
 line 520, in start
    self.addlines(node)
  File 
"/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/.waf-1.6.7-b271784c448ab906d5606267fb7f92c0/waflib/Tools/c_preproc.py",
 line 507, in addlines
    raise PreprocError("could not read the file %s"%filepath)
PreprocError: could not read the file 
/wrkdirs/usr/ports/audio/p5-xmms2/work/xmms2-0.8DrO_o/_build_/src/clients/lib/perl/XMMSClientCollection.c

*** [do-build] Error code 1

Stop in /usr/ports/audio/p5-xmms2.
===>  Cleaning for p5-xmms2-0.8_1
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to