You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     jn...@csie.nctu.edu.tw
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/www/trafficserver/Makefile 327776 2013-09-20 
23:36:50Z bapt $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/91i386-default/2013-10-16_14h14m28s/logs/trafficserver-3.2.4.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/91i386-default/2013-10-16_14h14m28s
Log:

====>> Building www/trafficserver
build started at Wed Oct 16 23:01:46 UTC 2013
port directory: /usr/ports/www/trafficserver
building for: FreeBSD 91i386-default-job-12 9.1-RELEASE FreeBSD 9.1-RELEASE i386
maintained by: jn...@csie.nctu.edu.tw
Makefile ident:      $FreeBSD: head/www/trafficserver/Makefile 327776 
2013-09-20 23:36:50Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=901000
UNAME_v=FreeBSD 9.1-RELEASE
UNAME_r=9.1-RELEASE
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/91i386-default/ref
PKG_EXT=txz
tpid=56452
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=trafficserver-3.2.4
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=91i386-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-expat=/usr/local  --with-pcre=/usr/local --prefix=/usr/local 
${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh 
AUTOMAKE=/usr/local/bin/automake-1.14  
AUTOMAKE_DIR=/usr/local/share/automake-1.14  AUTOMAKE_VERSION=1.14  
AUTOMAKE_APIVER=1.14  ACLOCAL=/usr/local/bin/aclocal-1.14  
ACLOCAL_DIR=/usr/local/share/aclocal-1.14 AUTOCONF=/usr/local/bin/autoconf-2.69 
 AUTOCONF_DIR=/usr/local/share/autoconf-2.69  
AUTOHEADER=/usr/local/bin/autoheader-2.69  
AUTOIFNAMES=/usr/local/bin/ifnames-2.69  AUTOM4TE=/usr/local/bin/autom4te-2.69  
AUTORECONF=/usr/local/bin/autoreconf-2.69  
AUTOSCAN=/usr/local/bin/autoscan-2.69  
AUTOUPDATE=/usr/local/bin/autoupdate-2.69  AUTOCONF_VERSION=2.69 
LIBTOOL=/usr/local/bin/libtool  LIBTOOLIZE=/usr/local/bin/libtoolize  
LIBTOOL_LIBEXECDIR=/usr/local/libexec/libtool  
LIBTOOL_SHAREDIR=/usr/local/share/libtool  
LIBTOOL_M4=/usr/local/share/aclocal/libtool.m4  
LTMAIN=/usr/local/share/libtool/config/ltmain.sh 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" OPENSSLLIB=/usr/lib OPENSSLINC=/usr/include  OPENSSLBASE=/usr 
OPENSSLDIR=/etc/ssl TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES 
AUTOMAKE=/usr/local/bin/automake-1.14  
AUTOMAKE_DIR=/usr/local/share/automake-1.14  AUTOMAKE_VERSION=1.14  
AUTOMAKE_APIVER=1.14  ACLOCAL=/usr/local/bin/aclocal-1.14  
ACLOCAL_DIR=/usr/local/share/aclocal-1.14 AUTOCONF=/usr/local/bin/autoconf-2.69 
 AUTOCONF_DIR=/usr/local/share/autoconf-2.69  
AUTOHEADER=/usr/local/bin/autoheader-2.69  
AUTOIFNAMES=/usr/local/bin/ifnames-2.69  AUTOM4TE=/usr/local/bin/autom4te-2.69  
AUTORECONF=/usr/local/bin/autoreconf-2.69  
AUTOSCAN=/usr/local/bin/autoscan-2.69  
AUTOUPDATE=/usr/local/bin/autoupdate-2.69  AUTOCONF_VERSION=2.69 
LIBTOOL=/usr/local/bin/libtool  LIBTOOLIZE=/usr/local/bin/libtoolize  
LIBTOOL_LIBEXECDIR=/usr/local/libexec/libtool  
LIBTOOL_SHAREDIR=/usr/local/share/libtool  
LIBTOOL_M4=/usr/local/share/aclocal/libtool.m4  
LTMAIN=/usr/local/share/libtool/config/ltmain.sh PREFIX=/usr/local  
LOCALBASE=/usr/l
 ocal  LI
 BDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=" -L/usr/local/lib -Wl,-rpath=/usr/lib:/usr/local/lib"  
CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/trafficserver
DOCSDIR=/usr/local/share/doc/trafficserver
EXAMPLESDIR=/usr/local/share/examples/trafficserver
WWWDIR=/usr/local/www/trafficserver
ETCDIR=/usr/local/etc/trafficserver
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for trafficserver-3.2.4
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   trafficserver-3.2.4 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of trafficserver-3.2.4
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License AL2 accepted by the user
===> Fetching all distfiles required by trafficserver-3.2.4 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License AL2 accepted by the user
===> Fetching all distfiles required by trafficserver-3.2.4 for building
=> SHA256 Checksum OK for trafficserver-3.2.4.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License AL2 accepted by the user
===> Fetching all distfiles required by trafficserver-3.2.4 for building
===>  Extracting for trafficserver-3.2.4
=> SHA256 Checksum OK for trafficserver-3.2.4.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for trafficserver-3.2.4
===>  Applying FreeBSD patches for trafficserver-3.2.4
===========================================================================
=======================<phase: build-depends  >============================
===>   trafficserver-3.2.4 depends on file: /usr/local/bin/automake-1.14 - not 
found
===>    Verifying install for /usr/local/bin/automake-1.14 in 
/usr/ports/devel/automake
===>   Installing existing package /packages/All/automake-1.14.txz
Installing automake-1.14...Installing autoconf-wrapper-20130530... done
Installing autoconf-2.69...Installing m4-1.4.17,1... done
Installing perl-5.14.4_2...Removing stale symlinks from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl5
Done.
Removing /usr/local/etc/perl5_version... Done.
Creating /usr/local/etc/perl5_version... Done.
 done
 done
Installing automake-wrapper-20130530... done
 done
===>   Returning to build of trafficserver-3.2.4
===>   trafficserver-3.2.4 depends on file: /usr/local/bin/autoconf-2.69 - found
===>   trafficserver-3.2.4 depends on package: libtool>=2.4 - not found
===>    Verifying install for libtool>=2.4 in /usr/ports/devel/libtool
===>   Installing existing package /packages/All/libtool-2.4.2_2.txz
Installing libtool-2.4.2_2... done
===>   Returning to build of trafficserver-3.2.4
===========================================================================
=======================<phase: lib-depends    >============================
===>   trafficserver-3.2.4 depends on shared library: libiconv.so.3 - not found
===>    Verifying for libiconv.so.3 in /usr/ports/converters/libiconv
===>   Installing existing package /packages/All/libiconv-1.14_1.txz
Installing libiconv-1.14_1... done
===>   Returning to build of trafficserver-3.2.4
===>   trafficserver-3.2.4 depends on shared library: execinfo - not found
===>    Verifying install for execinfo in /usr/ports/devel/libexecinfo
===>   Installing existing package /packages/All/libexecinfo-1.1_3.txz
Installing libexecinfo-1.1_3... done
===>   Returning to build of trafficserver-3.2.4
===>   trafficserver-3.2.4 depends on shared library: expat - not found
===>    Verifying install for expat in /usr/ports/textproc/expat2
===>   Installing existing package /packages/All/expat-2.1.0.txz
Installing expat-2.1.0... done
===>   Returning to build of trafficserver-3.2.4
===>   trafficserver-3.2.4 depends on shared library: pcre - not found
===>    Verifying install for pcre in /usr/ports/devel/pcre
===>   Installing existing package /packages/All/pcre-8.33.txz
Installing pcre-8.33... done
===>   Returning to build of trafficserver-3.2.4
===>   trafficserver-3.2.4 depends on shared library: tcl86 - not found
===>    Verifying install for tcl86 in /usr/ports/lang/tcl86
===>   Installing existing package /packages/All/tcl86-8.6.1.txz
Installing tcl86-8.6.1... done
===>   Returning to build of trafficserver-3.2.4
===>   trafficserver-3.2.4 depends on shared library: sqlite3.8 - not found
===>    Verifying install for sqlite3.8 in /usr/ports/databases/sqlite3
===>   Installing existing package /packages/All/sqlite3-3.8.0.2.txz
Installing sqlite3-3.8.0.2... done
===>   Returning to build of trafficserver-3.2.4
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for trafficserver-3.2.4
configure.ac:496: installing 'build/aux/ar-lib'
configure.ac:477: installing 'build/aux/compile'
parallel-tests: installing 'build/aux/test-driver'
automake-1.14: warnings are treated as errors
mgmt/Makefile.am:70: warning: source file '$(top_srcdir)/proxy/Error.cc' is in 
a subdirectory,
mgmt/Makefile.am:70: but option 'subdir-objects' is disabled
automake-1.14: warning: possible forward-incompatibility.
automake-1.14: At least a source file is in a subdirectory, but the 
'subdir-objects'
automake-1.14: automake option hasn't been enabled.  For now, the corresponding 
output
automake-1.14: object file(s) will be placed in the top-level directory.  
However,
automake-1.14: this behaviour will change in future Automake versions: they will
automake-1.14: unconditionally cause object files to be placed in the same 
subdirectory
automake-1.14: of the corresponding sources.
automake-1.14: You are advised to start using 'subdir-objects' option 
throughout your
automake-1.14: project, to avoid future incompatibilities.
mgmt/api/remote/Makefile.am:38: warning: source file '../CfgContextImpl.cc' is 
in a subdirectory,
mgmt/api/remote/Makefile.am:38: but option 'subdir-objects' is disabled
mgmt/api/remote/Makefile.am:38: warning: source file '../CfgContextManager.cc' 
is in a subdirectory,
mgmt/api/remote/Makefile.am:38: but option 'subdir-objects' is disabled
mgmt/api/remote/Makefile.am:38: warning: source file '../CfgContextUtils.cc' is 
in a subdirectory,
mgmt/api/remote/Makefile.am:38: but option 'subdir-objects' is disabled
mgmt/api/remote/Makefile.am:38: warning: source file '../CoreAPIShared.cc' is 
in a subdirectory,
mgmt/api/remote/Makefile.am:38: but option 'subdir-objects' is disabled
mgmt/api/remote/Makefile.am:38: warning: source file '../EventCallback.cc' is 
in a subdirectory,
mgmt/api/remote/Makefile.am:38: but option 'subdir-objects' is disabled
mgmt/api/remote/Makefile.am:38: warning: source file '../GenericParser.cc' is 
in a subdirectory,
mgmt/api/remote/Makefile.am:38: but option 'subdir-objects' is disabled
mgmt/api/remote/Makefile.am:38: warning: source file '../INKMgmtAPI.cc' is in a 
subdirectory,
mgmt/api/remote/Makefile.am:38: but option 'subdir-objects' is disabled
mgmt/utils/Makefile.am:42: warning: source file 
'$(top_srcdir)/lib/ts/MatcherUtils.cc' is in a subdirectory,
mgmt/utils/Makefile.am:42: but option 'subdir-objects' is disabled
mgmt/utils/Makefile.am:42: warning: source file 
'$(top_srcdir)/proxy/DiagsConfig.cc' is in a subdirectory,
mgmt/utils/Makefile.am:42: but option 'subdir-objects' is disabled
autoreconf-2.69: automake failed with exit status: 1
*** [pre-configure] Error code 1

Stop in /usr/ports/www/trafficserver.
===>  Cleaning for trafficserver-3.2.4
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to