You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     numise...@yahoo.com
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/databases/ruby-oci8/Makefile 327717 2013-09-20 
16:13:47Z bapt $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/91i386-default/2013-10-16_14h14m28s/logs/ruby19-oci8-1.0.0.r1.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/91i386-default/2013-10-16_14h14m28s
Log:

====>> Building databases/ruby-oci8
build started at Thu Oct 17 00:02:22 UTC 2013
port directory: /usr/ports/databases/ruby-oci8
building for: FreeBSD 91i386-default-job-20 9.1-RELEASE FreeBSD 9.1-RELEASE i386
maintained by: numise...@yahoo.com
Makefile ident:      $FreeBSD: head/databases/ruby-oci8/Makefile 327717 
2013-09-20 16:13:47Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=901000
UNAME_v=FreeBSD 9.1-RELEASE
UNAME_r=9.1-RELEASE
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/91i386-default/ref
PKG_EXT=txz
tpid=67524
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=ruby19-oci8-1.0.0.r1
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=91i386-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-instant-client="/usr/local/oracle8-client/lib" 
--with-opt-dir="/usr/local"
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local 
 LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/oci8
DOCSDIR=/usr/local/share/doc/oci8
EXAMPLESDIR=/usr/local/share/examples/oci8
WWWDIR=/usr/local/www/oci8
ETCDIR=/usr/local/etc/oci8
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for ruby19-oci8-1.0.0.r1
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   ruby19-oci8-1.0.0.r1 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of ruby19-oci8-1.0.0.r1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by ruby19-oci8-1.0.0.r1 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by ruby19-oci8-1.0.0.r1 for building
=> SHA256 Checksum OK for ruby/ruby-oci8-1.0.0-rc1.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===>   ruby19-oci8-1.0.0.r1 depends on file: /usr/local/bin/ruby19 - not found
===>    Verifying install for /usr/local/bin/ruby19 in /usr/ports/lang/ruby19
===>   Installing existing package /packages/All/ruby-1.9.3.448,1.txz
Installing ruby-1.9.3.448,1...Installing libyaml-0.1.4_2... done
Installing libffi-3.0.13... done
Installing libexecinfo-1.1_3... done
 done
====
Some of the standard commands are provided as separate ports for ease
of upgrading:

        devel/ruby-gems:        gem - RubyGems package manager
        devel/rubygem-rake:     rake - Ruby Make

And some of the standard libraries are provided as separate ports
since they require extra dependencies:

        converters/ruby-iconv:  iconv module
        databases/ruby-gdbm:    GDBM module
        x11-toolkits/ruby-tk:   Tcl/Tk modules
        japanese/ruby-tk:       Tcl/Tk modules for Japanized Tcl/Tk
        lang/ruby-mode.el:      Emacs lisp modules

Install them as occasion demands.
====
===>   Returning to build of ruby19-oci8-1.0.0.r1
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by ruby19-oci8-1.0.0.r1 for building
===>  Extracting for ruby19-oci8-1.0.0.r1
=> SHA256 Checksum OK for ruby/ruby-oci8-1.0.0-rc1.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===>   ruby19-oci8-1.0.0.r1 depends on file: /usr/local/bin/ruby19 - found
===========================================================================
=======================<phase: patch          >============================
===>  Patching for ruby19-oci8-1.0.0.r1
===>  Applying FreeBSD patches for ruby19-oci8-1.0.0.r1
===========================================================================
=======================<phase: build-depends  >============================
===>   ruby19-oci8-1.0.0.r1 depends on file: 
/usr/local/oracle8-client/lib/libclntsh.a - not found
===>    Verifying install for /usr/local/oracle8-client/lib/libclntsh.a in 
/usr/ports/databases/oracle8-client
===>   Installing existing package /packages/All/oracle8-client-0.2.0_1.txz
Installing oracle8-client-0.2.0_1... done
===>   Returning to build of ruby19-oci8-1.0.0.r1
===>   ruby19-oci8-1.0.0.r1 depends on file: /usr/local/bin/ruby19 - found
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for ruby19-oci8-1.0.0.r1
===>  Running extconf.rb in ext/oci8 to configure
checking for cc... ok
checking for gcc... yes
checking for LP64... no
checking for ruby header... 
/wrkdirs/usr/ports/databases/ruby-oci8/work/ruby-oci8-1.0.0-rc1/ext/oci8/oraconf.rb:301:
 Use RbConfig instead of obsolete and deprecated Config.
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
        --with-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=/usr/local/bin/ruby19
        --with-instant-client
/wrkdirs/usr/ports/databases/ruby-oci8/work/ruby-oci8-1.0.0-rc1/ext/oci8/oraconf.rb:130:in
 `rescue in get': undefined method `to_str' for #<RuntimeError:0x28a490fc> 
(NoMethodError)
        from 
/wrkdirs/usr/ports/databases/ruby-oci8/work/ruby-oci8-1.0.0-rc1/ext/oci8/oraconf.rb:143:in
 `get'
        from extconf.rb:6:in `<main>'
ng
*** [ruby-extconf-configure] Error code 1

Stop in /usr/ports/databases/ruby-oci8.
===>  Cleaning for ruby19-oci8-1.0.0.r1
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to