You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     b...@freebsd.org
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/net-mgmt/rubygem-visage-app/Makefile 327757 
2013-09-20 22:24:43Z bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/91amd64-default/2013-10-16_16h05m32s/logs/rubygem-visage-app-2.1.0.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/91amd64-default/2013-10-16_16h05m32s
Log:

====>> Building net-mgmt/rubygem-visage-app
build started at Thu Oct 17 01:34:28 UTC 2013
port directory: /usr/ports/net-mgmt/rubygem-visage-app
building for: FreeBSD 91amd64-default-job-02 9.1-RELEASE FreeBSD 9.1-RELEASE 
amd64
maintained by: b...@freebsd.org
Makefile ident:      $FreeBSD: head/net-mgmt/rubygem-visage-app/Makefile 327757 
2013-09-20 22:24:43Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=901000
UNAME_v=FreeBSD 9.1-RELEASE
UNAME_r=9.1-RELEASE
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/91amd64-default/ref
PKG_EXT=txz
tpid=84455
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=rubygem-visage-app-2.1.0
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=91amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local 
 LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/visage-app
DOCSDIR=/usr/local/share/doc/visage-app
EXAMPLESDIR=/usr/local/share/examples/visage-app
WWWDIR=/usr/local/www/visage-app
ETCDIR=/usr/local/etc/visage-app
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for rubygem-visage-app-2.1.0
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   rubygem-visage-app-2.1.0 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of rubygem-visage-app-2.1.0
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by rubygem-visage-app-2.1.0 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by rubygem-visage-app-2.1.0 for building
=> SHA256 Checksum OK for rubygem/visage-app-2.1.0.gem.
===========================================================================
=======================<phase: extract-depends>============================
===>   rubygem-visage-app-2.1.0 depends on file: /usr/local/bin/gem19 - not 
found
===>    Verifying install for /usr/local/bin/gem19 in /usr/ports/devel/ruby-gems
===>   Installing existing package /packages/All/ruby19-gems-1.8.25.txz
Installing ruby19-gems-1.8.25...Installing libyaml-0.1.4_2... done
Installing ruby-1.9.3.448,1...Installing libffi-3.0.13... done
Installing libexecinfo-1.1_3... done
 done
 done
====
Some of the standard commands are provided as separate ports for ease
of upgrading:

        devel/ruby-gems:        gem - RubyGems package manager
        devel/rubygem-rake:     rake - Ruby Make

And some of the standard libraries are provided as separate ports
since they require extra dependencies:

        converters/ruby-iconv:  iconv module
        databases/ruby-gdbm:    GDBM module
        x11-toolkits/ruby-tk:   Tcl/Tk modules
        japanese/ruby-tk:       Tcl/Tk modules for Japanized Tcl/Tk
        lang/ruby-mode.el:      Emacs lisp modules

Install them as occasion demands.
====
===>   Returning to build of rubygem-visage-app-2.1.0
===>   rubygem-visage-app-2.1.0 depends on file: /usr/local/bin/ruby19 - found
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by rubygem-visage-app-2.1.0 for building
===>  Extracting for rubygem-visage-app-2.1.0
=> SHA256 Checksum OK for rubygem/visage-app-2.1.0.gem.
Unpacked gem: 
'/wrkdirs/usr/ports/net-mgmt/rubygem-visage-app/work/visage-app-2.1.0'
===========================================================================
=======================<phase: patch-depends  >============================
===>   rubygem-visage-app-2.1.0 depends on file: /usr/local/bin/ruby19 - found
===========================================================================
=======================<phase: patch          >============================
===>  Patching for rubygem-visage-app-2.1.0
===>  Applying FreeBSD patches for rubygem-visage-app-2.1.0
===========================================================================
=======================<phase: build-depends  >============================
===>   rubygem-visage-app-2.1.0 depends on file: /usr/local/bin/gem19 - found
===>   rubygem-visage-app-2.1.0 depends on file: /usr/local/bin/ruby19 - found
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for rubygem-visage-app-2.1.0
===========================================================================
=======================<phase: build          >============================
===>  Building for rubygem-visage-app-2.1.0
  Successfully built RubyGem
  Name: visage-app
  Version: 2.1.0
  File: visage-app-2.1.0.gem
===========================================================================
=======================<phase: run-depends    >============================
===>   rubygem-visage-app-2.1.0 depends on package: rubygem-tilt>=1.3.3 - not 
found
===>    Verifying install for rubygem-tilt>=1.3.3 in 
/usr/ports/devel/rubygem-tilt
===>   Installing existing package /packages/All/rubygem-tilt-1.4.1.txz
Installing rubygem-tilt-1.4.1... done
===>   Returning to build of rubygem-visage-app-2.1.0
===>   rubygem-visage-app-2.1.0 depends on package: rubygem-haml>=3.1.4 - not 
found
===>    Verifying install for rubygem-haml>=3.1.4 in /usr/ports/www/rubygem-haml
===>   Installing existing package /packages/All/rubygem-haml-3.1.7.txz
Installing rubygem-haml-3.1.7... done
===>   Returning to build of rubygem-visage-app-2.1.0
===>   rubygem-visage-app-2.1.0 depends on package: rubygem-sinatra>=1.3.2 - 
not found
===>    Verifying install for rubygem-sinatra>=1.3.2 in 
/usr/ports/www/rubygem-sinatra
===>   Installing existing package /packages/All/rubygem-sinatra-1.4.3.txz
Installing rubygem-sinatra-1.4.3...Installing 
rubygem-rack-protection-1.5.0...Installing rubygem-rack-1.4.5,3... done
 done
 done

                **** NOTE ****

        Sinatra optionally integrates with haml/sass or Builder
        for templating and mongrel or thin as an HTTP server.
        To use them, install the respective ports separately:

                www/rubygem-haml
                devel/rubygem-builder
                www/rubygem-mongrel
                www/rubygem-thin
===>   Returning to build of rubygem-visage-app-2.1.0
===>   rubygem-visage-app-2.1.0 depends on package: rubygem-errand>=0.7.3 - not 
found
===>    Verifying install for rubygem-errand>=0.7.3 in 
/usr/ports/devel/rubygem-errand
===>   Installing existing package /packages/All/rubygem-errand-0.7.3.txz
Installing rubygem-errand-0.7.3...Installing xproto-7.0.24... done
Installing xcb-util-renderutil-0.3.8...Installing 
xcb-util-0.3.9_1,1...Installing libxcb-1.9.1...Installing libXdmcp-1.1.1... done
Installing libXau-1.0.8... done
Installing libxml2-2.8.0_2...Installing pkgconf-0.9.3... done
Installing libiconv-1.14_1... done
 done
Installing libpthread-stubs-0.3_3... done
 done
 done
 done
Installing renderproto-0.11.1... done
Installing pixman-0.30.2... done
Installing libXrender-0.9.8...Installing libX11-1.6.2,1...Installing 
kbproto-1.0.6... done
 done
 done
Installing pango-1.34.1_1...Installing xorg-fonts-truetype-7.7_1...Installing 
mkfontscale-1.1.1...Installing libfontenc-1.1.2... done
Installing freetype2-2.5.0.1... done
 done
Installing mkfontdir-1.0.7... done
Installing fontconfig-2.10.95,1...Installing expat-2.1.0... done
Running fc-cache to build fontconfig cache...
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
/usr/local/lib/X11/fonts/local: caching, new cache contents: 0 fonts, 0 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/var/db/fontconfig: cleaning cache directory
/root/.cache/fontconfig: not cleaning non-existent cache directory
/root/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded
 done
Installing font-util-1.3.0... done
Installing font-misc-meltho-1.0.3... done
Installing font-misc-ethiopic-1.0.3... done
Installing font-bh-ttf-1.0.3... done
Installing encodings-1.0.4,1... done
Installing dejavu-2.34... done
 done
Installing libXft-2.3.1... done
Installing harfbuzz-0.9.19...Installing python27-2.7.5_3...Installing 
gettext-0.18.3.1... done
 done
Installing python2-2_1... done
Installing python-2.7_1,2... done
Installing perl-5.14.4_2...Removing stale symlinks from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl5
Done.
Removing /usr/local/etc/perl5_version... Done.
Creating /usr/local/etc/perl5_version... Done.
 done
Installing png-1.5.17... done
Installing graphite2-1.2.3... done
Installing cairo-1.10.2_6,2...Installing pcre-8.33... done
Installing glib-2.36.3...No schema files found: doing nothing.
 done
 done
Installing icu-50.1.2... done
 done
Installing gnomehier-3.0... done
 done
Installing rrdtool-1.4.7_2... done
 done
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/lib/X11/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of rubygem-visage-app-2.1.0
===>   rubygem-visage-app-2.1.0 depends on package: rubygem-yajl-ruby>=1.1.0 - 
not found
===>    Verifying install for rubygem-yajl-ruby>=1.1.0 in 
/usr/ports/devel/rubygem-yajl-ruby
===>   Installing existing package /packages/All/rubygem-yajl-ruby-1.1.0.txz
Installing rubygem-yajl-ruby-1.1.0... done
===>   Returning to build of rubygem-visage-app-2.1.0
===>   rubygem-visage-app-2.1.0 depends on file: /usr/local/bin/gem19 - found
===>   rubygem-visage-app-2.1.0 depends on file: /usr/local/bin/ruby19 - found
===========================================================================
=======================<phase: install-mtree  >============================
===========================================================================
=======================<phase: install        >============================
===>  Installing for rubygem-visage-app-2.1.0
===>   Generating temporary packing list
===>  Checking if net-mgmt/rubygem-visage-app already installed
ERROR:  While executing gem ... (Gem::DependencyError)
    Unable to resolve dependencies: visage-app requires tilt (= 1.3.3), sinatra 
(= 1.3.2)
*** [do-install] Error code 1

Stop in /usr/ports/net-mgmt/rubygem-visage-app.
===>  Cleaning for rubygem-visage-app-2.1.0
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to