You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     emulat...@freebsd.org
Last committer: x...@freebsd.org
Ident:          $FreeBSD: head/net/linux-c6-openldap/Makefile 372445 2014-11-11 
13:06:39Z xmj $
Log URL:        
http://beefy4.nyi.freebsd.org/data/head-amd64-default/p398968_s289099/logs/linux-c6-openldap-2.4.39.log
Build URL:      
http://beefy4.nyi.freebsd.org/build.html?mastername=head-amd64-default&build=p398968_s289099
Log:

====>> Building net/linux-c6-openldap
build started at Sat Oct 10 03:11:54 UTC 2015
port directory: /usr/ports/net/linux-c6-openldap
building for: FreeBSD head-amd64-default-job-21 11.0-CURRENT FreeBSD 
11.0-CURRENT r289099 amd64
maintained by: emulat...@freebsd.org
Makefile ident:      $FreeBSD: head/net/linux-c6-openldap/Makefile 372445 
2014-11-11 13:06:39Z xmj $
Poudriere version: 3.1.8
Host OSVERSION: 1100079
Jail OSVERSION: 1100080




!!! Jail is newer than host. (Jail: 1100080, Host: 1100079) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
OSVERSION=1100080
UNAME_v=FreeBSD 11.0-CURRENT r289099
UNAME_r=11.0-CURRENT
LC_COLLATE=C
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/head-amd64-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=linux-c6-openldap-2.4.39
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/head-amd64-default/ref/.p/pool
MASTERNAME=head-amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.8
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/net/linux-c6-openldap/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/net/linux-c6-openldap/work  
HOME=/wrkdirs/usr/ports/net/linux-c6-openldap/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/net/linux-c6-openldap/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/net/linux-c6-openldap/work  
HOME=/wrkdirs/usr/ports/net/linux-c6-openldap/work TMPDIR="/tmp" NO_PIE=yes 
SHELL=/bin/sh NO_LINT=YES PREFIX=/compat/linux  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe  -fstack-protector 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=" -fstack-protector" 
LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector -fno-strict-aliasing " 
 MANPREFIX="/compat/linux" BSD_INSTALL_PROGRAM="install   -m 555"  
BSD_INSTALL_LIB="install   -m 444"  BSD_INSTALL_SCRIPT="install  -m 555"  
BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/compat/linux
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="usr/share/doc/openldap-2.4.39"
EXAMPLESDIR="share/examples/openldap"
DATADIR="share/openldap"
WWWDIR="www/openldap"
ETCDIR="/etc"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/compat/linux
LOCALBASE=/usr/local
DATADIR=/compat/linux/share/openldap
DOCSDIR=usr/share/doc/openldap-2.4.39
EXAMPLESDIR=/compat/linux/share/examples/openldap
WWWDIR=/compat/linux/www/openldap
ETCDIR=/etc
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   linux-c6-openldap-2.4.39 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.6.1.txz
[head-amd64-default-job-21] Installing pkg-1.6.1...
[head-amd64-default-job-21] Extracting pkg-1.6.1: .......... done
Message from pkg-1.6.1:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   linux-c6-openldap-2.4.39 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of linux-c6-openldap-2.4.39
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by linux-c6-openldap-2.4.39 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by linux-c6-openldap-2.4.39 for building
=> SHA256 Checksum OK for rpm/i686/centos/6.6/openldap-2.4.39-8.el6.i686.rpm.
=> SHA256 Checksum OK for rpm/i686/centos/6.6/openldap-2.4.39-8.el6.src.rpm.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by linux-c6-openldap-2.4.39 for building
===>  Extracting for linux-c6-openldap-2.4.39
=> SHA256 Checksum OK for rpm/i686/centos/6.6/openldap-2.4.39-8.el6.i686.rpm.
=> SHA256 Checksum OK for rpm/i686/centos/6.6/openldap-2.4.39-8.el6.src.rpm.
/bin/rm -f -rf /wrkdirs/usr/ports/net/linux-c6-openldap/work/etc
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for linux-c6-openldap-2.4.39
===========================================================================
=======================<phase: build-depends  >============================
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for linux-c6-openldap-2.4.39
===========================================================================
=======================<phase: build          >============================
===========================================================================
=======================<phase: run-depends    >============================
===>   linux-c6-openldap-2.4.39 depends on file: /compat/linux/bin/sh - not 
found
===>   Installing existing package /packages/All/linux_base-c6-6.6_6.txz
[head-amd64-default-job-21] Installing linux_base-c6-6.6_6...
[head-amd64-default-job-21] Extracting linux_base-c6-6.6_6: .......... done
grep: /etc/fstab: No such file or directory

+++ Some programs may need linprocfs, please add it to /etc/fstab! +++

Running linux ldconfig...
Message from linux_base-c6-6.6_6:
This software is based in part on the work of the FreeType Team.
See <URL:http://www.freetype.org/>.

Installation of the Linux base system is finished. The Linux kernel
mode, which must be enabled for Linux binaries to run, is now
enabled. Linux mode can be enabled permanently with the linux_enable
variable of rc.conf(5).

----------------------
You should enable Linux mode with the linux_enable variable of rc.conf(5).
Depending on the version of FreeBSD you are using you may have to increase
the emulated linux version via compat.linux.osrelease=2.6.18 in
sysctl.conf(5). Check via "sysctl compat.linux.osrelease" that it shows a
lower version number before setting it.
----------------------

If you want to use shared memory in Linux applications, you need to set up
a link from /dev/shm to a suitable place, e.g. by adding the following line
to /etc/devfs.conf (takes effect on each boot):
        link /tmp shm

To make use of NIS you have to adjust yp.conf and nsswitch.conf in
/compat/linux/etc/ accordingly. For example:

Set your yp-server and yp-domainname in yp.conf:
        domainname      my.yp.domainname
        ypserver        my.yp.server

Let your lists for hosts, passwd and group be resolved via nsswitch.conf:
        passwd: files nis
        shadow: files nis
        group:  files nis
        hosts:  files dns nis

WARNING: doing work which needs to chroot into the linux base may not work.
In such cases (e.g. cross-development) you are better suited with a linux_dist
port.
===>   linux-c6-openldap-2.4.39 depends on file: /compat/linux/bin/sh - found
===>   Returning to build of linux-c6-openldap-2.4.39
===========================================================================
=======================<phase: stage          >============================
===>  Staging for linux-c6-openldap-2.4.39
===>   Generating temporary packing list
cd /wrkdirs/usr/ports/net/linux-c6-openldap/work && /usr/bin/find * ! -path 
"stage*" -type d -exec /bin/mkdir -p 
"/wrkdirs/usr/ports/net/linux-c6-openldap/work/stage/compat/linux/{}" \;
cd /wrkdirs/usr/ports/net/linux-c6-openldap/work && /usr/bin/find * ! -path 
"stage/*" ! -type d | /usr/bin/cpio -pm -R root:wheel 
/wrkdirs/usr/ports/net/linux-c6-openldap/work/stage/compat/linux
1662 blocks
/bin/mkdir -p 
/wrkdirs/usr/ports/net/linux-c6-openldap/work/stage/compat/linux/etc
/bin/ln -sf /usr/local/etc/openldap 
/wrkdirs/usr/ports/net/linux-c6-openldap/work/stage/compat/linux/etc/openldap
====> Compressing man pages (compress-man)
===========================================================================
=======================<phase: package        >============================
===>  Building package for linux-c6-openldap-2.4.39
pkg-static: Unable to access file 
/wrkdirs/usr/ports/net/linux-c6-openldap/work/stage/etc: No such file or 
directory
*** Error code 1

Stop.
make: stopped in /usr/ports/net/linux-c6-openldap
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to