You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     din...@freebsd.org
Last committer: din...@freebsd.org
Ident:          $FreeBSD: head/net-im/licq-jabber/Makefile 327804 2013-09-21 
11:06:03Z dinoex $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/91amd64-default/2013-10-16_16h05m32s/logs/licq-jabber-1.8.0.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/91amd64-default/2013-10-16_16h05m32s
Log:

====>> Building net-im/licq-jabber
build started at Thu Oct 17 03:28:13 UTC 2013
port directory: /usr/ports/net-im/licq-jabber
building for: FreeBSD 91amd64-default-job-23 9.1-RELEASE FreeBSD 9.1-RELEASE 
amd64
maintained by: din...@freebsd.org
Makefile ident:      $FreeBSD: head/net-im/licq-jabber/Makefile 327804 
2013-09-21 11:06:03Z dinoex $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=901000
UNAME_v=FreeBSD 9.1-RELEASE
UNAME_r=9.1-RELEASE
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/91amd64-default/ref
PKG_EXT=txz
tpid=31112
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=licq-jabber-1.8.0
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=91amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/jabber
DOCSDIR=/usr/local/share/doc/licq-jabber
EXAMPLESDIR=/usr/local/share/examples/jabber
WWWDIR=/usr/local/www/jabber
ETCDIR=/usr/local/etc/jabber
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for licq-jabber-1.8.0
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   licq-jabber-1.8.0 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of licq-jabber-1.8.0
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by licq-jabber-1.8.0 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by licq-jabber-1.8.0 for building
=> SHA256 Checksum OK for licq-1.8.0.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by licq-jabber-1.8.0 for building
===>  Extracting for licq-jabber-1.8.0
=> SHA256 Checksum OK for licq-1.8.0.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for licq-jabber-1.8.0
===========================================================================
=======================<phase: build-depends  >============================
===>   licq-jabber-1.8.0 depends on file: /usr/local/bin/cmake - not found
===>    Verifying install for /usr/local/bin/cmake in /usr/ports/devel/cmake
===>   Installing existing package /packages/All/cmake-2.8.11.2.txz
Installing cmake-2.8.11.2...Installing cmake-modules-2.8.11.2_1... done
 done
===>   Returning to build of licq-jabber-1.8.0
===>   licq-jabber-1.8.0 depends on executable: licq - not found
===>    Verifying install for licq in /usr/ports/net-im/licq
===>   Installing existing package /packages/All/licq-base-1.8.0_1.txz
Installing licq-base-1.8.0_1...Installing icu-50.1.2... done
Installing boost-libs-1.52.0_2... done
Installing libiconv-1.14_1... done
 done
You have built the Boost library with thread support.

Don't forget to add -pthread to your linker options when
linking your code.
In order to actually use licq, at least one plugin port needs to be installed.
Currently they include: licq-qt-gui, licq-kde-gui and several others.
Check the net category to find them.
===>   Returning to build of licq-jabber-1.8.0
===========================================================================
=======================<phase: lib-depends    >============================
===>   licq-jabber-1.8.0 depends on shared library: gloox - not found
===>    Verifying install for gloox in /usr/ports/net-im/gloox
===>   Installing existing package /packages/All/gloox-1.0_3.txz
Installing gloox-1.0_3...Installing p11-kit-0.16.3...Installing 
libtasn1-2.14... done
Installing ca_root_nss-3.15.1_1... done
 done
Installing nettle-2.7.1...Installing gmp-5.1.3... done
 done
Installing libgpg-error-1.12...Installing gettext-0.18.3.1... done
 done
Installing gnutls-2.12.23_1... done
Installing libidn-1.28_1... done
 done
===>   Returning to build of licq-jabber-1.8.0
===>   licq-jabber-1.8.0 depends on shared library: boost_regex - found
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for licq-jabber-1.8.0
===>  Performing in-source build
/bin/mkdir -p 
/wrkdirs/usr/ports/net-im/licq-jabber/work/licq-1.8.0/plugins/jabber
-- The C compiler identification is GNU 4.2.1
-- The CXX compiler identification is GNU 4.2.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Found Licq headers: /usr/local/include
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Found Threads: TRUE  
-- Boost version: 1.52.0
-- Found the following Boost libraries:
--   regex
-- Checking to see if CXX compiler accepts flag -Wall
-- Checking to see if CXX compiler accepts flag -Wall - yes
-- Checking to see if CXX compiler accepts flag -Wextra
-- Checking to see if CXX compiler accepts flag -Wextra - yes
-- Creating 
/wrkdirs/usr/ports/net-im/licq-jabber/work/licq-1.8.0/plugins/jabber/pluginversion.h
CMake Error at 
/usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:108 
(message):
  Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE)
Call Stack (most recent call first):
  /usr/local/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:315 
(_FPHSA_FAILURE_MESSAGE)
  /usr/local/share/cmake/Modules/FindPkgConfig.cmake:102 
(find_package_handle_standard_args)
  CMakeLists.txt:17 (find_package)


-- Configuring incomplete, errors occurred!
*** [do-configure] Error code 1

Stop in /usr/ports/net-im/licq-jabber.
===>  Cleaning for licq-jabber-1.8.0
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to