You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     mar...@arp242.net
Last committer: anto...@freebsd.org
Ident:          $FreeBSD: head/games/nlarn/Makefile 356174 2014-06-01 21:11:50Z 
antoine $
Log URL:        
http://beefy4.nyi.freebsd.org/data/head-amd64-default/p399324_s289348/logs/nlarn-0.7.2.log
Build URL:      
http://beefy4.nyi.freebsd.org/build.html?mastername=head-amd64-default&build=p399324_s289348
Log:

====>> Building games/nlarn
build started at Fri Oct 16 12:20:10 UTC 2015
port directory: /usr/ports/games/nlarn
building for: FreeBSD head-amd64-default-job-21 11.0-CURRENT FreeBSD 
11.0-CURRENT r289348 amd64
maintained by: mar...@arp242.net
Makefile ident:      $FreeBSD: head/games/nlarn/Makefile 356174 2014-06-01 
21:11:50Z antoine $
Poudriere version: 3.1.9
Host OSVERSION: 1100079
Jail OSVERSION: 1100080




!!! Jail is newer than host. (Jail: 1100080, Host: 1100079) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
OSVERSION=1100080
UNAME_v=FreeBSD 11.0-CURRENT r289348
UNAME_r=11.0-CURRENT
LC_COLLATE=C
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/head-amd64-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=nlarn-0.7.2
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/head-amd64-default/ref/.p/pool
MASTERNAME=head-amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.9
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake PKG_CONFIG=pkgconf XDG_DATA_HOME=/wrkdirs/usr/ports/games/nlarn/work 
 XDG_CONFIG_HOME=/wrkdirs/usr/ports/games/nlarn/work  
HOME=/wrkdirs/usr/ports/games/nlarn/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
LUA_MODLIBDIR=/usr/local/lib/lua/5.1  LUA_MODSHAREDIR=/usr/local/share/lua/5.1  
LUA_VER=5.1  LUA_INCDIR=/usr/local/include/lua51  LUA_LIBDIR=/usr/local/lib 
XDG_DATA_HOME=/wrkdirs/usr/ports/games/nlarn/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/games/nlarn/work  
HOME=/wrkdirs/usr/ports/games/nlarn/work TMPDIR="/tmp" NO_PIE=yes SHELL=/bin/sh 
NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" 
CFLAGS="-O2 -pipe  -fstack-protector -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=" -fstack-protector" LIBS=""  CXX="c++" CXXFLAGS="-O2 
-pipe -fstack-protector -fno-strict-aliasing "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
LUA_MODLIBDIR=lib/lua/5.1
LUA_MODSHAREDIR=share/lua/5.1
LUA_VER=5.1
LUA_INCDIR=include/lua51
LUA_LIBDIR=lib
LUA_VER_STR=51
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
GTK2_VERSION="2.10.0"
GTK3_VERSION="3.0.0"
DOCSDIR="share/doc/nlarn"
EXAMPLESDIR="share/examples/nlarn"
DATADIR="share/nlarn"
WWWDIR="www/nlarn"
ETCDIR="etc/nlarn"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/nlarn
DOCSDIR=/usr/local/share/doc/nlarn
EXAMPLESDIR=/usr/local/share/examples/nlarn
WWWDIR=/usr/local/www/nlarn
ETCDIR=/usr/local/etc/nlarn
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License GPLv3 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   nlarn-0.7.2 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.6.1.txz
[head-amd64-default-job-21] Installing pkg-1.6.1...
[head-amd64-default-job-21] Extracting pkg-1.6.1: .......... done
Message from pkg-1.6.1:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   nlarn-0.7.2 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of nlarn-0.7.2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv3 accepted by the user
===> Fetching all distfiles required by nlarn-0.7.2 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv3 accepted by the user
===> Fetching all distfiles required by nlarn-0.7.2 for building
=> SHA256 Checksum OK for nlarn-0.7.2.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv3 accepted by the user
===> Fetching all distfiles required by nlarn-0.7.2 for building
===>  Extracting for nlarn-0.7.2
=> SHA256 Checksum OK for nlarn-0.7.2.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for nlarn-0.7.2
===>  Applying FreeBSD patches for nlarn-0.7.2
===========================================================================
=======================<phase: build-depends  >============================
===>   nlarn-0.7.2 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.1_2.txz
[head-amd64-default-job-21] Installing gmake-4.1_2...
[head-amd64-default-job-21] `-- Installing indexinfo-0.2.3...
[head-amd64-default-job-21] `-- Extracting indexinfo-0.2.3: .... done
[head-amd64-default-job-21] `-- Installing gettext-runtime-0.19.6...
[head-amd64-default-job-21] `-- Extracting gettext-runtime-0.19.6: .......... 
done
[head-amd64-default-job-21] Extracting gmake-4.1_2: .......... done
===>   nlarn-0.7.2 depends on executable: gmake - found
===>   Returning to build of nlarn-0.7.2
===>   nlarn-0.7.2 depends on executable: pkgconf - not found
===>   Installing existing package /packages/All/pkgconf-0.9.12.txz
[head-amd64-default-job-21] Installing pkgconf-0.9.12...
[head-amd64-default-job-21] Extracting pkgconf-0.9.12: ....... done
===>   nlarn-0.7.2 depends on executable: pkgconf - found
===>   Returning to build of nlarn-0.7.2
===========================================================================
=======================<phase: lib-depends    >============================
===>   nlarn-0.7.2 depends on shared library: liblua-5.1.so - not found
===>   Installing existing package /packages/All/lua51-5.1.5_9.txz
[head-amd64-default-job-21] Installing lua51-5.1.5_9...
[head-amd64-default-job-21] `-- Installing libedit-3.1.20150325_1...
[head-amd64-default-job-21] `-- Extracting libedit-3.1.20150325_1: .......... 
done
[head-amd64-default-job-21] Extracting lua51-5.1.5_9: .......... done
===>   nlarn-0.7.2 depends on shared library: liblua-5.1.so - found 
(/usr/local/lib/liblua-5.1.so)
===>   Returning to build of nlarn-0.7.2
===>   nlarn-0.7.2 depends on shared library: libglib-2.0.so - not found
===>   Installing existing package /packages/All/glib-2.44.1_1.txz
[head-amd64-default-job-21] Installing glib-2.44.1_1...
[head-amd64-default-job-21] `-- Installing libiconv-1.14_9...
[head-amd64-default-job-21] `-- Extracting libiconv-1.14_9: .......... done
[head-amd64-default-job-21] `-- Installing python27-2.7.10...
[head-amd64-default-job-21] |   `-- Installing libffi-3.2.1...
[head-amd64-default-job-21] |   `-- Extracting libffi-3.2.1: .......... done
[head-amd64-default-job-21] |   `-- Installing readline-6.3.8...
[head-amd64-default-job-21] |   `-- Extracting readline-6.3.8: .......... done
[head-amd64-default-job-21] `-- Extracting python27-2.7.10: .......... done
[head-amd64-default-job-21] `-- Installing pcre-8.37_4...
[head-amd64-default-job-21] `-- Extracting pcre-8.37_4: .......... done
[head-amd64-default-job-21] `-- Installing perl5-5.20.3_8...
[head-amd64-default-job-21] `-- Extracting perl5-5.20.3_8: .......... done
[head-amd64-default-job-21] Extracting glib-2.44.1_1: .......... done
No schema files found: doing nothing.
Message from python27-2.7.10:
=====================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

=====================================================================
Message from perl5-5.20.3_8:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   nlarn-0.7.2 depends on shared library: libglib-2.0.so - found 
(/usr/local/lib/libglib-2.0.so)
===>   Returning to build of nlarn-0.7.2
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for nlarn-0.7.2
===========================================================================
=======================<phase: build          >============================
===>  Building for nlarn-0.7.2
gmake[1]: Entering directory '/wrkdirs/usr/ports/games/nlarn/work/nlarn-0.7.2'
cc -O2 -pipe  -fstack-protector -fno-strict-aliasing -MMD -MP -std=c99 -Wall 
-Wextra -Werror -Iinc -I/usr/local/include/glib-2.0 
-I/usr/local/lib/glib-2.0/include -I/usr/local/include   
-I/usr/local/include/lua51   -DG_DISABLE_DEPRECATED -DDEBUG -DLUA_USE_APICHECK 
-g -o src/utils.o -c src/utils.c
cc -O2 -pipe  -fstack-protector -fno-strict-aliasing -MMD -MP -std=c99 -Wall 
-Wextra -Werror -Iinc -I/usr/local/include/glib-2.0 
-I/usr/local/lib/glib-2.0/include -I/usr/local/include   
-I/usr/local/include/lua51   -DG_DISABLE_DEPRECATED -DDEBUG -DLUA_USE_APICHECK 
-g -o src/wrap_utils.o -c src/wrap_utils.c
cc -O2 -pipe  -fstack-protector -fno-strict-aliasing -MMD -MP -std=c99 -Wall 
-Wextra -Werror -Iinc -I/usr/local/include/glib-2.0 
-I/usr/local/lib/glib-2.0/include -I/usr/local/include   
-I/usr/local/include/lua51   -DG_DISABLE_DEPRECATED -DDEBUG -DLUA_USE_APICHECK 
-g -o src/buildings.o -c src/buildings.c
cc -O2 -pipe  -fstack-protector -fno-strict-aliasing -MMD -MP -std=c99 -Wall 
-Wextra -Werror -Iinc -I/usr/local/include/glib-2.0 
-I/usr/local/lib/glib-2.0/include -I/usr/local/include   
-I/usr/local/include/lua51   -DG_DISABLE_DEPRECATED -DDEBUG -DLUA_USE_APICHECK 
-g -o src/map.o -c src/map.c
cc -O2 -pipe  -fstack-protector -fno-strict-aliasing -MMD -MP -std=c99 -Wall 
-Wextra -Werror -Iinc -I/usr/local/include/glib-2.0 
-I/usr/local/lib/glib-2.0/include -I/usr/local/include   
-I/usr/local/include/lua51   -DG_DISABLE_DEPRECATED -DDEBUG -DLUA_USE_APICHECK 
-g -o src/fov.o -c src/fov.c
cc -O2 -pipe  -fstack-protector -fno-strict-aliasing -MMD -MP -std=c99 -Wall 
-Wextra -Werror -Iinc -I/usr/local/include/glib-2.0 
-I/usr/local/lib/glib-2.0/include -I/usr/local/include   
-I/usr/local/include/lua51   -DG_DISABLE_DEPRECATED -DDEBUG -DLUA_USE_APICHECK 
-g -o src/monsters.o -c src/monsters.c
src/monsters.c:2723:13: error: variable 'npos' is used uninitialized whenever 
'if' condition is false [-Werror,-Wsometimes-uninitialized]
        if (path && !g_queue_is_empty(path->path))
            ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
src/monsters.c:2739:12: note: uninitialized use occurs here
    return npos;
           ^~~~
src/monsters.c:2723:9: note: remove the 'if' if its condition is always true
        if (path && !g_queue_is_empty(path->path))
        ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
src/monsters.c:2723:13: error: variable 'npos' is used uninitialized whenever 
'&&' condition is false [-Werror,-Wsometimes-uninitialized]
        if (path && !g_queue_is_empty(path->path))
            ^~~~
src/monsters.c:2739:12: note: uninitialized use occurs here
    return npos;
           ^~~~
src/monsters.c:2723:13: note: remove the '&&' if its condition is always true
        if (path && !g_queue_is_empty(path->path))
            ^~~~~~~
src/monsters.c:2702:5: note: variable 'npos' is declared here
    position npos;
    ^
2 errors generated.
Makefile:179: recipe for target 'src/monsters.o' failed
gmake[1]: *** [src/monsters.o] Error 1
gmake[1]: Leaving directory '/wrkdirs/usr/ports/games/nlarn/work/nlarn-0.7.2'
*** Error code 1

Stop.
make: stopped in /usr/ports/games/nlarn
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to