You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     l...@freebsd.org
Last committer: m...@freebsd.org
Ident:          $FreeBSD: head/devel/subversion-static/Makefile 394508 
2015-08-17 14:20:40Z mat $
Log URL:        
http://beefy3.nyi.freebsd.org/data/head-i386-default/p399527_s289435/logs/subversion-static-1.9.2.log
Build URL:      
http://beefy3.nyi.freebsd.org/build.html?mastername=head-i386-default&build=p399527_s289435
Log:

====>> Building devel/subversion-static
build started at Sun Oct 18 07:42:27 UTC 2015
port directory: /usr/ports/devel/subversion-static
building for: FreeBSD head-i386-default-job-12 11.0-CURRENT FreeBSD 
11.0-CURRENT r289435 i386
maintained by: l...@freebsd.org
Makefile ident:      $FreeBSD: head/devel/subversion-static/Makefile 394508 
2015-08-17 14:20:40Z mat $
Poudriere version: 3.1.9
Host OSVERSION: 1100079
Jail OSVERSION: 1100081




!!! Jail is newer than host. (Jail: 1100081, Host: 1100079) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
OSVERSION=1100081
UNAME_v=FreeBSD 11.0-CURRENT r289435
UNAME_r=11.0-CURRENT
LC_COLLATE=C
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/head-i386-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=subversion-static-1.9.2
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/head-i386-default/ref/.p/pool
MASTERNAME=head-i386-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.9
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--without-swig  --with-sqlite=/usr/local  
--with-expat=/usr/local/include:/usr/local/lib:expat --with-serf 
--enable-all-static PKG_CONFIG="/usr/local/bin/pkg-config --static" 
--with-apr=/usr/local/bin/apr-1-config 
--with-apr-util=/usr/local/bin/apu-1-config --without-gnome-keyring  
--without-kwallet  --with-apxs=no --without-berkeley-db --prefix=/usr/local 
${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PKG_CONFIG=pkgconf 
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/subversion-static/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/subversion-static/work  
HOME=/wrkdirs/usr/ports/devel/subversion-static/work TMPDIR="/tmp" 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh CONFIG_SITE=/usr/ports/Templates/config.site 
lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/subversion-static/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/subversion-static/work  
HOME=/wrkdirs/usr/ports/devel/subversion-static/work TMPDIR="/tmp" NO_PIE=yes 
SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe  -fstack-protector 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=" -fstack-protector" 
LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector -fno-strict-aliasing " 
 MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 555"  
BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
TOOLS="@comment
"
SVNSERVE_WRAPPER="@comment
"
BDB="@comment
"
NLS="@comment
"
FREEBSD_TEMPLATE=""
NO_FREEBSD_TEMPLATE="@comment
"
P4_STYLE_MARKERS=""
NO_P4_STYLE_MARKERS="@comment
"
SERF=""
NO_SERF="@comment
"
STATIC=""
NO_STATIC="@comment
"
NO_SVNSERVE_WRAPPER=""
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS="@comment
"
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/subversion"
EXAMPLESDIR="share/examples/subversion"
DATADIR="share/subversion"
WWWDIR="www/subversion"
ETCDIR="etc/subversion"
--End PLIST_SUB--

--SUB_LIST--
FREEBSD_TEMPLATE=""
NO_FREEBSD_TEMPLATE="@comment
"
P4_STYLE_MARKERS=""
NO_P4_STYLE_MARKERS="@comment
"
SERF=""
NO_SERF="@comment
"
STATIC=""
NO_STATIC="@comment
"
SVNSERVE_BIN_EXT=""
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/subversion
DOCSDIR=/usr/local/share/doc/subversion
EXAMPLESDIR=/usr/local/share/examples/subversion
WWWDIR=/usr/local/www/subversion
ETCDIR=/usr/local/etc/subversion
--End SUB_LIST--

---Begin make.conf---
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================

You can have the repository created for you by defining
WITH_REPOSITORY_CREATION.

Make sure that:
* all your svn users are members of a common group
* this group is the group id of the db/ and locks/
  subdirectories of your repository
* the above subdirectories are writable by this group

Static binaries will be built.
Many useful scripts will be installed into /usr/local/share/subversion
===>  License APACHE20 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   subversion-static-1.9.2 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.6.1.txz
[head-i386-default-job-12] Installing pkg-1.6.1...
[head-i386-default-job-12] Extracting pkg-1.6.1: .......... done
Message from pkg-1.6.1:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   subversion-static-1.9.2 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of subversion-static-1.9.2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================

You can have the repository created for you by defining
WITH_REPOSITORY_CREATION.

Make sure that:
* all your svn users are members of a common group
* this group is the group id of the db/ and locks/
  subdirectories of your repository
* the above subdirectories are writable by this group

Static binaries will be built.
Many useful scripts will be installed into /usr/local/share/subversion
===>  License APACHE20 accepted by the user
===> Fetching all distfiles required by subversion-static-1.9.2 for building
===========================================================================
=======================<phase: checksum       >============================

You can have the repository created for you by defining
WITH_REPOSITORY_CREATION.

Make sure that:
* all your svn users are members of a common group
* this group is the group id of the db/ and locks/
  subdirectories of your repository
* the above subdirectories are writable by this group

Static binaries will be built.
Many useful scripts will be installed into /usr/local/share/subversion
===>  License APACHE20 accepted by the user
===> Fetching all distfiles required by subversion-static-1.9.2 for building
=> SHA256 Checksum OK for subversion19/subversion-1.9.2.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================

You can have the repository created for you by defining
WITH_REPOSITORY_CREATION.

Make sure that:
* all your svn users are members of a common group
* this group is the group id of the db/ and locks/
  subdirectories of your repository
* the above subdirectories are writable by this group

Static binaries will be built.
Many useful scripts will be installed into /usr/local/share/subversion
===>  License APACHE20 accepted by the user
===> Fetching all distfiles required by subversion-static-1.9.2 for building
===>  Extracting for subversion-static-1.9.2
=> SHA256 Checksum OK for subversion19/subversion-1.9.2.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for subversion-static-1.9.2
===>  Applying extra patch 
/usr/ports/devel/subversion-static/../subversion/files/extra-patch-fbsd-template
===>  Applying FreeBSD patches for subversion-static-1.9.2
===========================================================================
=======================<phase: build-depends  >============================
===>   subversion-static-1.9.2 depends on executable: pkgconf - not found
===>   Installing existing package /packages/All/pkgconf-0.9.12.txz
[head-i386-default-job-12] Installing pkgconf-0.9.12...
[head-i386-default-job-12] Extracting pkgconf-0.9.12: ....... done
===>   subversion-static-1.9.2 depends on executable: pkgconf - found
===>   Returning to build of subversion-static-1.9.2
===>   subversion-static-1.9.2 depends on file: /usr/local/lib/libapr-1.a - not 
found
===>   Installing existing package /packages/All/apr-1.5.2.1.5.4.txz
[head-i386-default-job-12] Installing apr-1.5.2.1.5.4...
[head-i386-default-job-12] `-- Installing expat-2.1.0_3...
[head-i386-default-job-12] `-- Extracting expat-2.1.0_3: .......... done
[head-i386-default-job-12] `-- Installing gdbm-1.11_2...
[head-i386-default-job-12] |   `-- Installing indexinfo-0.2.3...
[head-i386-default-job-12] |   `-- Extracting indexinfo-0.2.3: .... done
[head-i386-default-job-12] |   `-- Installing gettext-runtime-0.19.6...
[head-i386-default-job-12] |   `-- Extracting gettext-runtime-0.19.6: 
.......... done
[head-i386-default-job-12] `-- Extracting gdbm-1.11_2: .......... done
[head-i386-default-job-12] `-- Installing db5-5.3.28_2...
[head-i386-default-job-12] `-- Extracting db5-5.3.28_2: .......... done
[head-i386-default-job-12] Extracting apr-1.5.2.1.5.4: .......... done
===>   subversion-static-1.9.2 depends on file: /usr/local/lib/libapr-1.a - 
found
===>   Returning to build of subversion-static-1.9.2
===>   subversion-static-1.9.2 depends on file: /usr/local/lib/libsqlite3.a - 
not found
===>   Installing existing package /packages/All/sqlite3-3.8.11.1_1.txz
[head-i386-default-job-12] Installing sqlite3-3.8.11.1_1...
[head-i386-default-job-12] `-- Installing readline-6.3.8...
[head-i386-default-job-12] `-- Extracting readline-6.3.8: .......... done
[head-i386-default-job-12] Extracting sqlite3-3.8.11.1_1: .......... done
===>   subversion-static-1.9.2 depends on file: /usr/local/lib/libsqlite3.a - 
found
===>   Returning to build of subversion-static-1.9.2
===>   subversion-static-1.9.2 depends on file: /usr/local/lib/libexpat.a - 
found
===>   subversion-static-1.9.2 depends on file: /usr/local/lib/libserf-1.a - 
not found
===>   Installing existing package /packages/All/serf-1.3.8.txz
[head-i386-default-job-12] Installing serf-1.3.8...
[head-i386-default-job-12] Extracting serf-1.3.8: .......... done
===>   subversion-static-1.9.2 depends on file: /usr/local/lib/libserf-1.a - 
found
===>   Returning to build of subversion-static-1.9.2
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for subversion-static-1.9.2
grep: /usr/local/lib/libsqlite3.la: No such file or directory
configure: loading site script /usr/ports/Templates/config.site
configure: Configuring Subversion 1.9.2
configure: creating config.nice
checking for gcc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking if cc accepts -std=c90... yes
checking if cc accepts -w... yes
checking if cc accepts -Werror=unknown-warning-option... yes
checking whether we are using the GNU C++ compiler... yes
checking whether c++ accepts -g... yes
checking if c++ accepts -std=c++98... yes
checking if c++ accepts -w... yes
checking if c++ accepts -Werror=unknown-warning-option... yes
checking how to run the C preprocessor... cpp
checking for a sed that does not truncate output... (cached) /usr/bin/sed
checking build system type... i386-portbld-freebsd11.0
checking host system type... i386-portbld-freebsd11.0
checking target system type... i386-portbld-freebsd11.0
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking whether ln -s works... yes
checking for a BSD-compatible install... /usr/bin/install -c
configure: Apache Portable Runtime (APR) library configuration
checking for APR... yes
checking APR version... 1.5.2
configure: Apache Portable Runtime Utility (APRUTIL) library configuration
checking for APR-util... yes
checking APRUTIL version... 1.5.4
checking for pkg-config... /usr/local/bin/pkg-config --static
checking for ANSI C header files... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
configure: serf library configuration via pkg-config
checking for serf-2 library... no
checking for serf-1 library... yes
checking serf library version... 1.3.8
checking serf version is suitable... yes
checking was serf enabled... yes
configure: looking for apr_memcache as part of apr-util
checking apr_memcache.h usability... yes
checking apr_memcache.h presence... yes
checking for apr_memcache.h... yes
checking for apr_memcache_create in -laprutil-1... no
checking for Apache module support via DSO through APXS... no
configure: checking sqlite library
checking sqlite3.h usability... yes
checking sqlite3.h presence... yes
checking for sqlite3.h... yes
checking sqlite library version (via header)... okay
checking for sqlite3_close in -lsqlite3... no
configure: WARNING: no suitable sqlite found in /usr/local

An appropriate version of sqlite could not be found.  We recommmend
3.7.15.1, but require at least 3.7.12.
Please either install a newer sqlite on this system

or

get the sqlite 3.7.15.1 amalgamation from:
    http://www.sqlite.org/sqlite-amalgamation-3071501.zip
unpack the archive using unzip and rename the resulting
directory to:
/wrkdirs/usr/ports/devel/subversion-static/work/subversion-1.9.2/sqlite-amalgamation

configure: error: Subversion requires SQLite
===>  Script "configure" failed unexpectedly.
Please report the problem to l...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/devel/subversion-static/work/subversion-1.9.2/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/subversion-static
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to