You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     mikael.uran...@gmail.com
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/misc/raspberrypi-userland/Makefile 399696 
2015-10-19 16:35:28Z brd $
Log URL:        
http://beefy2.nyi.freebsd.org/data/93amd64-default/399796/logs/raspberrypi-userland-20150501.log
Build URL:      
http://beefy2.nyi.freebsd.org/build.html?mastername=93amd64-default&build=399796
Log:

====>> Building misc/raspberrypi-userland
build started at Wed Oct 21 05:19:58 UTC 2015
port directory: /usr/ports/misc/raspberrypi-userland
building for: FreeBSD 93amd64-default-job-03 9.3-RELEASE-p28 FreeBSD 
9.3-RELEASE-p28 amd64
maintained by: mikael.uran...@gmail.com
Makefile ident:      $FreeBSD: head/misc/raspberrypi-userland/Makefile 399696 
2015-10-19 16:35:28Z brd $
Poudriere version: 3.1.9
Host OSVERSION: 1100079
Jail OSVERSION: 903000

---Begin Environment---
SHELL=/bin/csh
OSVERSION=903000
UNAME_v=FreeBSD 9.3-RELEASE-p28
UNAME_r=9.3-RELEASE-p28
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/93amd64-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=raspberrypi-userland-20150501
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/93amd64-default/ref/.p/pool
MASTERNAME=93amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.9
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for 
raspberrypi-userland-20150501:
     EXAMPLES=on: Install test applications source code (hello_pi)
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/misc/raspberrypi-userland/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/misc/raspberrypi-userland/work  
HOME=/wrkdirs/usr/ports/misc/raspberrypi-userland/work TMPDIR="/tmp" 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/misc/raspberrypi-userland/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/misc/raspberrypi-userland/work  
HOME=/wrkdirs/usr/ports/misc/raspberrypi-userland/work TMPDIR="/tmp" NO_PIE=yes 
SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fstack-protector 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=" -fstack-protector" 
LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 555"  
BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
CMAKE_BUILD_TYPE="release"
OSREL=9.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/raspberrypi-userland"
EXAMPLESDIR="share/examples/raspberrypi-userland"
DATADIR="share/raspberrypi-userland"
WWWDIR="www/raspberrypi-userland"
ETCDIR="etc/raspberrypi-userland"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/raspberrypi-userland
DOCSDIR=/usr/local/share/doc/raspberrypi-userland
EXAMPLESDIR=/usr/local/share/examples/raspberrypi-userland
WWWDIR=/usr/local/www/raspberrypi-userland
ETCDIR=/usr/local/etc/raspberrypi-userland
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License BSD3CLAUSE accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   raspberrypi-userland-20150501 depends on file: /usr/local/sbin/pkg - not 
found
===>   Installing existing package /packages/All/pkg-1.6.1.txz
[93amd64-default-job-03] Installing pkg-1.6.1...
[93amd64-default-job-03] Extracting pkg-1.6.1: .......... done
Message from pkg-1.6.1:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   raspberrypi-userland-20150501 depends on file: /usr/local/sbin/pkg - 
found
===>   Returning to build of raspberrypi-userland-20150501
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License BSD3CLAUSE accepted by the user
=> gonzoua-userland-20150501-11ffc75_GH0.tar.gz doesn't seem to exist in 
/portdistfiles/.
=> Attempting to fetch 
https://codeload.github.com/gonzoua/userland/tar.gz/11ffc75?dummy=/gonzoua-userland-20150501-11ffc75_GH0.tar.gz
fetch: 
https://codeload.github.com/gonzoua/userland/tar.gz/11ffc75?dummy=/gonzoua-userland-20150501-11ffc75_GH0.tar.gz:
 size unknown
fetch: 
https://codeload.github.com/gonzoua/userland/tar.gz/11ffc75?dummy=/gonzoua-userland-20150501-11ffc75_GH0.tar.gz:
 size of remote file is not known
gonzoua-userland-20150501-11ffc75_GH0.tar.gz            -1  B    0  Bps
===> Fetching all distfiles required by raspberrypi-userland-20150501 for 
building
===========================================================================
=======================<phase: checksum       >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by raspberrypi-userland-20150501 for 
building
=> SHA256 Checksum OK for gonzoua-userland-20150501-11ffc75_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by raspberrypi-userland-20150501 for 
building
===>  Extracting for raspberrypi-userland-20150501
=> SHA256 Checksum OK for gonzoua-userland-20150501-11ffc75_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for raspberrypi-userland-20150501
===>  Applying FreeBSD patches for raspberrypi-userland-20150501
===========================================================================
=======================<phase: build-depends  >============================
===>   raspberrypi-userland-20150501 depends on file: /usr/local/bin/cmake - 
not found
===>   Installing existing package /packages/All/cmake-3.3.1.txz
[93amd64-default-job-03] Installing cmake-3.3.1...
[93amd64-default-job-03] `-- Installing expat-2.1.0_3...
[93amd64-default-job-03] `-- Extracting expat-2.1.0_3: .......... done
[93amd64-default-job-03] `-- Installing cmake-modules-3.3.1...
[93amd64-default-job-03] `-- Extracting cmake-modules-3.3.1: .......... done
[93amd64-default-job-03] `-- Installing curl-7.45.0...
[93amd64-default-job-03] |   `-- Installing ca_root_nss-3.20...
[93amd64-default-job-03] |   `-- Extracting ca_root_nss-3.20: ....... done
[93amd64-default-job-03] `-- Extracting curl-7.45.0: .......... done
[93amd64-default-job-03] `-- Installing libarchive-3.1.2_4,1...
[93amd64-default-job-03] |   `-- Installing libiconv-1.14_9...
[93amd64-default-job-03] |   `-- Extracting libiconv-1.14_9: .......... done
[93amd64-default-job-03] |   `-- Installing lzo2-2.09...
[93amd64-default-job-03] |   `-- Extracting lzo2-2.09: .......... done
[93amd64-default-job-03] `-- Extracting libarchive-3.1.2_4,1: .......... done
[93amd64-default-job-03] `-- Installing jsoncpp-0.6.0.r2_2...
[93amd64-default-job-03] `-- Extracting jsoncpp-0.6.0.r2_2: .......... done
[93amd64-default-job-03] Extracting cmake-3.3.1: .......... done
Message from ca_root_nss-3.20:
********************************* WARNING *********************************

FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.

*********************************** NOTE **********************************

This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem

***************************************************************************
===>   raspberrypi-userland-20150501 depends on file: /usr/local/bin/cmake - 
found
===>   Returning to build of raspberrypi-userland-20150501
===========================================================================
=======================<phase: lib-depends    >============================
===>   raspberrypi-userland-20150501 depends on shared library: libfreetype.so 
- not found
===>   Installing existing package /packages/All/freetype2-2.6_1.txz
[93amd64-default-job-03] Installing freetype2-2.6_1...
[93amd64-default-job-03] Extracting freetype2-2.6_1: .......... done
===>   raspberrypi-userland-20150501 depends on shared library: libfreetype.so 
- found (/usr/local/lib/libfreetype.so)
===>   Returning to build of raspberrypi-userland-20150501
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for raspberrypi-userland-20150501
===>  Performing in-source build
/bin/mkdir -p /wrkdirs/usr/ports/misc/raspberrypi-userland/work/userland-11ffc75
-- The C compiler identification is GNU 4.2.1
-- The CXX compiler identification is GNU 4.2.1
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- broken
CMake Error at /usr/local/share/cmake/Modules/CMakeTestCCompiler.cmake:61 
(message):
  The C compiler "/usr/bin/cc" is not able to compile a simple test program.

  It fails with the following output:

   Change Dir: 
/wrkdirs/usr/ports/misc/raspberrypi-userland/work/userland-11ffc75/CMakeFiles/CMakeTmp

  

  Run Build Command:"/usr/bin/make" "cmTC_71af7/fast"

  /usr/bin/make -f CMakeFiles/cmTC_71af7.dir/build.make
  CMakeFiles/cmTC_71af7.dir/build

  Building C object CMakeFiles/cmTC_71af7.dir/testCCompiler.c.o

  /usr/bin/cc -DVCOS_DEFAULT_STACK_SIZE=16384 -O2 -pipe -fstack-protector
  -fno-strict-aliasing -U_FORTIFY_SOURCE -U_FORTIFY_SOURCE -mcpu=arm1176jzf-s
  -mfpu=vfp -o CMakeFiles/cmTC_71af7.dir/testCCompiler.c.o -c
  
/wrkdirs/usr/ports/misc/raspberrypi-userland/work/userland-11ffc75/CMakeFiles/CMakeTmp/testCCompiler.c


  `-mcpu=' is deprecated.  Use `-mtune=' or '-march=' instead.

  cc1: error: unrecognized command line option "-mfpu=vfp"

  
  
/wrkdirs/usr/ports/misc/raspberrypi-userland/work/userland-11ffc75/CMakeFiles/CMakeTmp/testCCompiler.c:1:
  error: bad value (arm1176jzf-s) for -mtune= switch

  *** [CMakeFiles/cmTC_71af7.dir/testCCompiler.c.o] Error code 1

  

  Stop in
  
/wrkdirs/usr/ports/misc/raspberrypi-userland/work/userland-11ffc75/CMakeFiles/CMakeTmp.


  *** [cmTC_71af7/fast] Error code 1

  

  Stop in
  
/wrkdirs/usr/ports/misc/raspberrypi-userland/work/userland-11ffc75/CMakeFiles/CMakeTmp.


  

  

  CMake will not be able to correctly generate this project.
Call Stack (most recent call first):
  CMakeLists.txt:3 (project)


-- Configuring incomplete, errors occurred!
See also 
"/wrkdirs/usr/ports/misc/raspberrypi-userland/work/userland-11ffc75/CMakeFiles/CMakeOutput.log".
See also 
"/wrkdirs/usr/ports/misc/raspberrypi-userland/work/userland-11ffc75/CMakeFiles/CMakeError.log".
*** [do-configure] Error code 1

Stop in /usr/ports/misc/raspberrypi-userland.
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to