You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     tobias.rehb...@web.de
Last committer: jbe...@freebsd.org
Ident:          $FreeBSD: head/games/stonesoup/Makefile 394379 2015-08-16 
02:50:50Z jbeich $
Log URL:        
http://beefy8.nyi.freebsd.org/data/head-armv6-default/p399861_s289632/logs/stonesoup-0.16.2.log
Build URL:      
http://beefy8.nyi.freebsd.org/build.html?mastername=head-armv6-default&build=p399861_s289632
Log:

====>> Building games/stonesoup
build started at Thu Oct 22 19:48:34 UTC 2015
port directory: /usr/ports/games/stonesoup
building for: FreeBSD head-armv6-default-job-02 11.0-CURRENT FreeBSD 
11.0-CURRENT r289632 arm
maintained by: tobias.rehb...@web.de
Makefile ident:      $FreeBSD: head/games/stonesoup/Makefile 394379 2015-08-16 
02:50:50Z jbeich $
Poudriere version: 3.1.9
Host OSVERSION: 1100079
Jail OSVERSION: 1100082




!!! Jail is newer than host. (Jail: 1100082, Host: 1100079) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=armv6
UNAME_m=arm
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1100082
UNAME_v=FreeBSD 11.0-CURRENT r289632
UNAME_r=11.0-CURRENT
LC_COLLATE=C
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=screen
MASTERMNT=/usr/local/poudriere/data/.m/head-armv6-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=stonesoup-0.16.2
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/head-armv6-default/ref/.p/pool
MASTERNAME=head-armv6-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.9
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for stonesoup-0.16.2:
     DOCS=on: Build and/or install documentation
     EXAMPLES=on: Build and/or install examples
     LUA_BINDINGS=off: Bindings for LUA user scripts
     SOUND=off: Sound support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake ac_cv_path_PERL=/usr/local/bin/perl 
ac_cv_path_PERL_PATH=/usr/local/bin/perl PKG_CONFIG=pkgconf 
XDG_DATA_HOME=/wrkdirs/usr/ports/games/stonesoup/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/games/stonesoup/work  
HOME=/wrkdirs/usr/ports/games/stonesoup/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
LUA_MODLIBDIR=/usr/local/lib/lua/5.1  LUA_MODSHAREDIR=/usr/local/share/lua/5.1  
LUA_VER=5.1  LUA_INCDIR=/usr/local/include/lua51  LUA_LIBDIR=/usr/local/lib 
XDG_DATA_HOME=/wrkdirs/usr/ports/games/stonesoup/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/games/stonesoup/work  
HOME=/wrkdirs/usr/ports/games/stonesoup/work TMPDIR="/tmp" NO_PIE=yes 
SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe 
-mfloat-abi=softfp  -fno-strict-aliasing"  CPP="/nxb-bin/usr/bin/cpp" 
CPPFLAGS=""  LDFLAGS=" -Wl,-rpath=/usr/lib:/usr/local/lib" LIBS=""  
CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -mfloat-abi=softfp 
-fno-strict-aliasing "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
SAVEDIR="\~/.stonesoup"
SDL="@comment
"
LUA_MODLIBDIR=lib/lua/5.1
LUA_MODSHAREDIR=share/lua/5.1
LUA_VER=5.1
LUA_INCDIR=include/lua51
LUA_LIBDIR=lib
LUA_VER_STR=51
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
PERL_VERSION=5.20.3
PERL_VER=5.20
PERL5_MAN1=lib/perl5/site_perl/man/man1
PERL5_MAN3=lib/perl5/site_perl/man/man3
SITE_PERL=lib/perl5/site_perl
SITE_ARCH=lib/perl5/site_perl/mach/5.20
DOCSDIR="share/doc/stonesoup"
EXAMPLESDIR="share/examples/stonesoup"
DATADIR="share/stonesoup"
WWWDIR="www/stonesoup"
ETCDIR="etc/stonesoup"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/stonesoup
DOCSDIR=/usr/local/share/doc/stonesoup
EXAMPLESDIR=/usr/local/share/examples/stonesoup
WWWDIR=/usr/local/www/stonesoup
ETCDIR=/usr/local/etc/stonesoup
--End SUB_LIST--

---Begin make.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
<snip>
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
MACHINE=arm
MACHINE_ARCH=armv6
ARCH=${MACHINE_ARCH}
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License GPLv2 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   stonesoup-0.16.2 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.6.1.txz
[head-armv6-default-job-02] Installing pkg-1.6.1...
[head-armv6-default-job-02] Extracting pkg-1.6.1: .......... done
Message from pkg-1.6.1:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   stonesoup-0.16.2 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of stonesoup-0.16.2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by stonesoup-0.16.2 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by stonesoup-0.16.2 for building
=> SHA256 Checksum OK for stone_soup-0.16.2-nodeps.tar.xz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by stonesoup-0.16.2 for building
===>  Extracting for stonesoup-0.16.2
=> SHA256 Checksum OK for stone_soup-0.16.2-nodeps.tar.xz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for stonesoup-0.16.2
===>  Applying FreeBSD patches for stonesoup-0.16.2
===========================================================================
=======================<phase: build-depends  >============================
===>   stonesoup-0.16.2 depends on executable: bison - not found
===>   Installing existing package /packages/All/bison-2.7.1,1.txz
[head-armv6-default-job-02] Installing bison-2.7.1,1...
[head-armv6-default-job-02] `-- Installing indexinfo-0.2.3...
[head-armv6-default-job-02] `-- Extracting indexinfo-0.2.3: .... done
[head-armv6-default-job-02] `-- Installing gettext-runtime-0.19.6...
[head-armv6-default-job-02] `-- Extracting gettext-runtime-0.19.6: .......... 
done
[head-armv6-default-job-02] `-- Installing m4-1.4.17_1,1...
[head-armv6-default-job-02] `-- Extracting m4-1.4.17_1,1: .......... done
[head-armv6-default-job-02] Extracting bison-2.7.1,1: .......... done
===>   stonesoup-0.16.2 depends on executable: bison - found
===>   Returning to build of stonesoup-0.16.2
===>   stonesoup-0.16.2 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.1_2.txz
[head-armv6-default-job-02] Installing gmake-4.1_2...
[head-armv6-default-job-02] Extracting gmake-4.1_2: .......... done
===>   stonesoup-0.16.2 depends on executable: gmake - found
===>   Returning to build of stonesoup-0.16.2
===>   stonesoup-0.16.2 depends on executable: pkgconf - not found
===>   Installing existing package /packages/All/pkgconf-0.9.12_1.txz
[head-armv6-default-job-02] Installing pkgconf-0.9.12_1...
[head-armv6-default-job-02] Extracting pkgconf-0.9.12_1: ....... done
===>   stonesoup-0.16.2 depends on executable: pkgconf - found
===>   Returning to build of stonesoup-0.16.2
===>   stonesoup-0.16.2 depends on package: perl5>=5.20<5.21 - not found
===>   Installing existing package /packages/All/perl5-5.20.3_8.txz
[head-armv6-default-job-02] Installing perl5-5.20.3_8...
[head-armv6-default-job-02] Extracting perl5-5.20.3_8: .......... done
Message from perl5-5.20.3_8:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   stonesoup-0.16.2 depends on package: perl5>=5.20<5.21 - found
===>   Returning to build of stonesoup-0.16.2
===========================================================================
=======================<phase: lib-depends    >============================
===>   stonesoup-0.16.2 depends on shared library: liblua-5.1.so - not found
===>   Installing existing package /packages/All/lua51-5.1.5_9.txz
[head-armv6-default-job-02] Installing lua51-5.1.5_9...
[head-armv6-default-job-02] `-- Installing libedit-3.1.20150325_1...
[head-armv6-default-job-02] `-- Extracting libedit-3.1.20150325_1: .......... 
done
[head-armv6-default-job-02] Extracting lua51-5.1.5_9: .......... done
===>   stonesoup-0.16.2 depends on shared library: liblua-5.1.so - found 
(/usr/local/lib/liblua-5.1.so)
===>   Returning to build of stonesoup-0.16.2
===>   stonesoup-0.16.2 depends on shared library: libsqlite3.so - not found
===>   Installing existing package /packages/All/sqlite3-3.9.1.txz
[head-armv6-default-job-02] Installing sqlite3-3.9.1...
[head-armv6-default-job-02] `-- Installing readline-6.3.8...
[head-armv6-default-job-02] `-- Extracting readline-6.3.8: .......... done
[head-armv6-default-job-02] Extracting sqlite3-3.9.1: .......... done
===>   stonesoup-0.16.2 depends on shared library: libsqlite3.so - found 
(/usr/local/lib/libsqlite3.so)
===>   Returning to build of stonesoup-0.16.2
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for stonesoup-0.16.2
===========================================================================
=======================<phase: build          >============================
===>  Building for stonesoup-0.16.2
gmake[1]: Entering directory 
'/wrkdirs/usr/ports/games/stonesoup/work/stone_soup-0.16.2/source'
  * If you experience any problems building Crawl, please take a second look
  * at INSTALL.txt: the solution to your problem just might be in there!
    * rebuilding crawl: new build flags or prefix
TRACK_CFLAGS = /nxb-bin/usr/bin/cc /nxb-bin/usr/bin/c++ -O2 -pipe 
-mfloat-abi=softfp -fno-strict-aliasing -Wall -Wformat-security -Wundef 
-Wno-parentheses -Wwrite-strings -Wshadow -pedantic -Iutil -I. -isystem 
/usr/local/include/lua51 -isystem /usr/local/include -Irltiles -isystem 
/usr/include/ncursesw -DWIZARD -DASSERTS -DSAVE_DIR_PATH=\"~/.stonesoup\" 
-DDATA_DIR_PATH=\"/usr/local/share/stonesoup/\" #EOL
OLD_CFLAGS   =  #EOL
util/art-data.pl
    Generating art-data.h
    Generating art-enum.h
    Generating dc-unrand.txt
    Generating tiledef-unrand.cc
    GEN config.h
    GEN mon-mst.h
gmake -C rltiles all ARCH=armv6 TILES=
gmake[2]: Entering directory 
'/wrkdirs/usr/ports/games/stonesoup/work/stone_soup-0.16.2/source/rltiles'
    * rebuilding tilegen: new build flags or prefix
    HOSTCXX tool/tile_colour.o
    HOSTCXX tool/tile.o
    HOSTCXX tool/tile_page.o
    HOSTCXX tool/tile_list_processor.o
    HOSTCXX tool/main.o
    HOSTLINK tool/tilegen.elf
    GEN tiledef-main.h
    GEN tiledef-dngn.h
    GEN tiledef-floor.h
    GEN tiledef-wall.h
    GEN tiledef-feat.h
    GEN tiledef-player.h
    GEN tiledef-gui.h
    GEN tiledef-icons.h
gmake[2]: Leaving directory 
'/wrkdirs/usr/ports/games/stonesoup/work/stone_soup-0.16.2/source/rltiles'
    CXX ability.o
In file included from ability.cc:6:
./AppHdr.h:179:6: error: Missing platform #define or unsupported compiler.
    #error Missing platform #define or unsupported compiler.
     ^
In file included from ability.cc:42:
./menu.h:557:52: error: use of undeclared identifier 'get_number_of_cols'
                                       int width = get_number_of_cols()-1);
                                                   ^
In file included from ability.cc:43:
In file included from ./message.h:49:
./cio.h:212:18: error: use of undeclared identifier 'is_cursor_enabled'
        : cstate(is_cursor_enabled()), smartcstate(is_smart_cursor_enabled())
                 ^
./cio.h:212:52: error: use of undeclared identifier 'is_smart_cursor_enabled'
        : cstate(is_cursor_enabled()), smartcstate(is_smart_cursor_enabled())
                                                   ^
./cio.h:214:9: error: use of undeclared identifier 'enable_smart_cursor'
        enable_smart_cursor(false);
        ^
./cio.h:215:9: error: use of undeclared identifier 'set_cursor_enabled'
        set_cursor_enabled(cursor_enabled);
        ^
./cio.h:219:9: error: use of undeclared identifier 'set_cursor_enabled'
        set_cursor_enabled(cstate);
        ^
./cio.h:220:9: error: use of undeclared identifier 'enable_smart_cursor'
        enable_smart_cursor(smartcstate);
        ^
./cio.h:232:32: error: use of undeclared identifier 'get_number_of_cols'
                int wrap_col = get_number_of_cols());
                               ^
ability.cc:1390:5: error: use of undeclared identifier 'clrscr'
    clrscr();
    ^
ability.cc:1395:5: error: use of undeclared identifier 'clrscr'
    clrscr();
    ^
11 errors generated.
Makefile:1540: recipe for target 'ability.o' failed
gmake[1]: *** [ability.o] Error 1
gmake[1]: Leaving directory 
'/wrkdirs/usr/ports/games/stonesoup/work/stone_soup-0.16.2/source'
*** Error code 1

Stop.
make: stopped in /usr/ports/games/stonesoup
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to