You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     amd...@freebsd.org
Last committer: w...@freebsd.org
Ident:          $FreeBSD: head/converters/osm2pgsql/Makefile 389704 2015-06-15 
13:03:11Z wen $
Log URL:        
http://beefy8.nyi.freebsd.org/data/head-armv6-default/p399861_s289632/logs/osm2pgsql-0.87.2_1.log
Build URL:      
http://beefy8.nyi.freebsd.org/build.html?mastername=head-armv6-default&build=p399861_s289632
Log:

====>> Building converters/osm2pgsql
build started at Thu Oct 22 23:10:54 UTC 2015
port directory: /usr/ports/converters/osm2pgsql
building for: FreeBSD head-armv6-default-job-17 11.0-CURRENT FreeBSD 
11.0-CURRENT r289632 arm
maintained by: amd...@freebsd.org
Makefile ident:      $FreeBSD: head/converters/osm2pgsql/Makefile 389704 
2015-06-15 13:03:11Z wen $
Poudriere version: 3.1.9
Host OSVERSION: 1100079
Jail OSVERSION: 1100082




!!! Jail is newer than host. (Jail: 1100082, Host: 1100079) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=armv6
UNAME_m=arm
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1100082
UNAME_v=FreeBSD 11.0-CURRENT r289632
UNAME_r=11.0-CURRENT
LC_COLLATE=C
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=screen
MASTERMNT=/usr/local/poudriere/data/.m/head-armv6-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=osm2pgsql-0.87.2_1
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/head-armv6-default/ref/.p/pool
MASTERNAME=head-armv6-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.9
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for osm2pgsql-0.87.2_1:
     DOCS=on: Build and/or install documentation
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
LUA="lua52"  LUA_INCLUDE="-I/usr/local/include/lua52"  
LUA_LIB="-L/usr/local/lib -llua-5.2"  --without-lockfree --prefix=/usr/local 
${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake XDG_DATA_HOME=/wrkdirs/usr/ports/converters/osm2pgsql/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/converters/osm2pgsql/work  
HOME=/wrkdirs/usr/ports/converters/osm2pgsql/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh CONFIG_SITE=/usr/ports/Templates/config.site 
lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
LUA_MODLIBDIR=/usr/local/lib/lua/5.2  LUA_MODSHAREDIR=/usr/local/share/lua/5.2  
LUA_VER=5.2  LUA_INCDIR=/usr/local/include/lua52  LUA_LIBDIR=/usr/local/lib 
XDG_DATA_HOME=/wrkdirs/usr/ports/converters/osm2pgsql/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/converters/osm2pgsql/work  
HOME=/wrkdirs/usr/ports/converters/osm2pgsql/work TMPDIR="/tmp" NO_PIE=yes 
SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe 
-mfloat-abi=softfp  -fno-strict-aliasing"  CPP="/nxb-bin/usr/bin/cpp" 
CPPFLAGS="-I/usr/local/include"  LDFLAGS=" -L/usr/local/lib" LIBS=""  
CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -mfloat-abi=softfp 
-fno-strict-aliasing "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
LUA_MODLIBDIR=lib/lua/5.2
LUA_MODSHAREDIR=share/lua/5.2
LUA_VER=5.2
LUA_INCDIR=include/lua52
LUA_LIBDIR=lib
LUA_VER_STR=52
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
GTK2_VERSION="2.10.0"
GTK3_VERSION="3.0.0"
DOCSDIR="share/doc/osm2pgsql"
EXAMPLESDIR="share/examples/osm2pgsql"
DATADIR="share/osm2pgsql"
WWWDIR="www/osm2pgsql"
ETCDIR="etc/osm2pgsql"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/osm2pgsql
DOCSDIR=/usr/local/share/doc/osm2pgsql
EXAMPLESDIR=/usr/local/share/examples/osm2pgsql
WWWDIR=/usr/local/www/osm2pgsql
ETCDIR=/usr/local/etc/osm2pgsql
--End SUB_LIST--

---Begin make.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
<snip>

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   osm2pgsql-0.87.2_1 depends on executable: autoconf-2.69 - found
===>   Returning to build of osm2pgsql-0.87.2_1
===>   osm2pgsql-0.87.2_1 depends on executable: autoheader-2.69 - found
===>   osm2pgsql-0.87.2_1 depends on executable: autoreconf-2.69 - found
===>   osm2pgsql-0.87.2_1 depends on executable: aclocal-1.15 - not found
===>   Installing existing package /packages/All/automake-1.15_1.txz
[head-armv6-default-job-17] Installing automake-1.15_1...
[head-armv6-default-job-17] `-- Installing automake-wrapper-20131203...
[head-armv6-default-job-17] `-- Extracting automake-wrapper-20131203: ... done
[head-armv6-default-job-17] Extracting automake-1.15_1: .......... done
===>   osm2pgsql-0.87.2_1 depends on executable: aclocal-1.15 - found
===>   Returning to build of osm2pgsql-0.87.2_1
===>   osm2pgsql-0.87.2_1 depends on executable: automake-1.15 - found
===>   osm2pgsql-0.87.2_1 depends on executable: libtoolize - not found
===>   Installing existing package /packages/All/libtool-2.4.6.txz
[head-armv6-default-job-17] Installing libtool-2.4.6...
[head-armv6-default-job-17] Extracting libtool-2.4.6: .......... done
===>   osm2pgsql-0.87.2_1 depends on executable: libtoolize - found
===>   Returning to build of osm2pgsql-0.87.2_1
===>   osm2pgsql-0.87.2_1 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.1_2.txz
[head-armv6-default-job-17] Installing gmake-4.1_2...
[head-armv6-default-job-17] `-- Installing gettext-runtime-0.19.6...
[head-armv6-default-job-17] `-- Extracting gettext-runtime-0.19.6: .......... 
done
[head-armv6-default-job-17] Extracting gmake-4.1_2: .......... done
===>   osm2pgsql-0.87.2_1 depends on executable: gmake - found
===>   Returning to build of osm2pgsql-0.87.2_1
===========================================================================
=======================<phase: lib-depends    >============================
===>   osm2pgsql-0.87.2_1 depends on shared library: libproj.so - not found
===>   Installing existing package /packages/All/proj-4.9.1.txz
[head-armv6-default-job-17] Installing proj-4.9.1...
[head-armv6-default-job-17] Extracting proj-4.9.1: .......... done
===>   osm2pgsql-0.87.2_1 depends on shared library: libproj.so - found 
(/usr/local/lib/libproj.so)
===>   Returning to build of osm2pgsql-0.87.2_1
===>   osm2pgsql-0.87.2_1 depends on shared library: libgeos.so - not found
===>   Installing existing package /packages/All/geos-3.5.0.txz
[head-armv6-default-job-17] Installing geos-3.5.0...
[head-armv6-default-job-17] Extracting geos-3.5.0: .......... done
===>   osm2pgsql-0.87.2_1 depends on shared library: libgeos.so - found 
(/usr/local/lib/libgeos.so)
===>   Returning to build of osm2pgsql-0.87.2_1
===>   osm2pgsql-0.87.2_1 depends on shared library: libprotobuf-c.so - not 
found
===>   Installing existing package /packages/All/protobuf-c-1.1.1.txz
[head-armv6-default-job-17] Installing protobuf-c-1.1.1...
[head-armv6-default-job-17] `-- Installing protobuf-2.6.1...
[head-armv6-default-job-17] `-- Extracting protobuf-2.6.1: .......... done
[head-armv6-default-job-17] Extracting protobuf-c-1.1.1: .......... done
===>   osm2pgsql-0.87.2_1 depends on shared library: libprotobuf-c.so - found 
(/usr/local/lib/libprotobuf-c.so)
===>   Returning to build of osm2pgsql-0.87.2_1
===>   osm2pgsql-0.87.2_1 depends on shared library: libboost_thread.so - not 
found
===>   Installing existing package /packages/All/boost-libs-1.55.0_9.txz
[head-armv6-default-job-17] Installing boost-libs-1.55.0_9...
[head-armv6-default-job-17] `-- Installing icu-55.1...
[head-armv6-default-job-17] `-- Extracting icu-55.1: .......... done
[head-armv6-default-job-17] Extracting boost-libs-1.55.0_9: .......... done
Message from boost-libs-1.55.0_9:
You have built the Boost library with thread support.

Don't forget to add -pthread to your linker options when
linking your code.
===>   osm2pgsql-0.87.2_1 depends on shared library: libboost_thread.so - found 
(/usr/local/lib/libboost_thread.so)
===>   Returning to build of osm2pgsql-0.87.2_1
===>   osm2pgsql-0.87.2_1 depends on shared library: liblua-5.2.so - not found
===>   Installing existing package /packages/All/lua52-5.2.4.txz
[head-armv6-default-job-17] Installing lua52-5.2.4...
[head-armv6-default-job-17] `-- Installing libedit-3.1.20150325_1...
[head-armv6-default-job-17] `-- Extracting libedit-3.1.20150325_1: .......... 
done
[head-armv6-default-job-17] Extracting lua52-5.2.4: .......... done
===>   osm2pgsql-0.87.2_1 depends on shared library: liblua-5.2.so - found 
(/usr/local/lib/liblua-5.2.so)
===>   Returning to build of osm2pgsql-0.87.2_1
===>   osm2pgsql-0.87.2_1 depends on shared library: libpq.so.5 - not found
===>   Installing existing package /packages/All/postgresql93-client-9.3.10.txz
[head-armv6-default-job-17] Installing postgresql93-client-9.3.10...
[head-armv6-default-job-17] `-- Installing readline-6.3.8...
[head-armv6-default-job-17] `-- Extracting readline-6.3.8: .......... done
[head-armv6-default-job-17] Extracting postgresql93-client-9.3.10: .......... 
done
Message from postgresql93-client-9.3.10:
The PostgreSQL port has a collection of "side orders":

postgresql-docs
  For all of the html documentation

p5-Pg
  A perl5 API for client access to PostgreSQL databases.

postgresql-tcltk 
  If you want tcl/tk client support.

postgresql-jdbc
  For Java JDBC support.

postgresql-odbc
  For client access from unix applications using ODBC as access
  method. Not needed to access unix PostgreSQL servers from Win32
  using ODBC. See below.

ruby-postgres, py-PyGreSQL
  For client access to PostgreSQL databases using the ruby & python
  languages.

postgresql-plperl, postgresql-pltcl & postgresql-plruby
  For using perl5, tcl & ruby as procedural languages.

postgresql-contrib
  Lots of contributed utilities, postgresql functions and
  datatypes. There you find pg_standby, pgcrypto and many other cool
  things.

etc...
===>   osm2pgsql-0.87.2_1 depends on shared library: libpq.so.5 - found 
(/usr/local/lib/libpq.so.5)
===>   Returning to build of osm2pgsql-0.87.2_1
===>   osm2pgsql-0.87.2_1 depends on shared library: libxml2.so - not found
===>   Installing existing package /packages/All/libxml2-2.9.2_3.txz
[head-armv6-default-job-17] Installing libxml2-2.9.2_3...
[head-armv6-default-job-17] Extracting libxml2-2.9.2_3: .......... done
===>   osm2pgsql-0.87.2_1 depends on shared library: libxml2.so - found 
(/usr/local/lib/libxml2.so)
===>   Returning to build of osm2pgsql-0.87.2_1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for osm2pgsql-0.87.2_1
libtoolize: putting auxiliary files in '.'.
libtoolize: copying file './ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIRS, 'm4'.
libtoolize: copying file 'm4/libtool.m4'
libtoolize: copying file 'm4/ltoptions.m4'
libtoolize: copying file 'm4/ltsugar.m4'
libtoolize: copying file 'm4/ltversion.m4'
libtoolize: copying file 'm4/lt~obsolete.m4'
configure.ac:25: installing './compile'
configure.ac:44: installing './config.guess'
configure.ac:44: installing './config.sub'
configure.ac:13: installing './install-sh'
configure.ac:13: installing './missing'
Makefile.am: installing './depcomp'
parallel-tests: installing './test-driver'
configure: loading site script /usr/ports/Templates/config.site
checking whether to enable maintainer-specific portions of Makefiles... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... (cached) /bin/mkdir -p
checking for gawk... (cached) /usr/bin/awk
checking whether gmake sets $(MAKE)... yes
checking whether gmake supports nested variables... yes
checking for style of include used by gmake... GNU
checking for gcc... /nxb-bin/usr/bin/cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether /nxb-bin/usr/bin/cc accepts -g... yes
checking for /nxb-bin/usr/bin/cc option to accept ISO C89... none needed
checking whether /nxb-bin/usr/bin/cc understands -c and -o together... yes
checking dependency style of /nxb-bin/usr/bin/cc... gcc3
checking how to run the C preprocessor... /nxb-bin/usr/bin/cpp
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking for ANSI C header files... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking for minix/config.h... (cached) no
checking whether it is safe to define __EXTENSIONS__... yes
checking for sys/wait.h that is POSIX.1 compatible... (cached) yes
checking for stdlib.h... (cached) yes
checking for unistd.h... (cached) yes
checking for sys/param.h... (cached) yes
checking for getpagesize... (cached) yes
checking for working mmap... (cached) yes
checking whether we are using the GNU C++ compiler... yes
checking whether /nxb-bin/usr/bin/c++ accepts -g... yes
checking dependency style of /nxb-bin/usr/bin/c++... gcc3
checking for /nxb-bin/usr/bin/c++... no
configure: error: Could not find a c++ compiler
===>  Script "configure" failed unexpectedly.
Please report the problem to amd...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/converters/osm2pgsql/work/osm2pgsql-0.87.2/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/converters/osm2pgsql
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to