You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     f...@freebsd.org
Last committer: f...@freebsd.org
Ident:          $FreeBSD: head/devel/libiqxmlrpc/Makefile 378038 2015-01-28 
02:03:49Z fjoe $
Log URL:        
http://beefy8.nyi.freebsd.org/data/head-armv6-default/p399861_s289632/logs/libiqxmlrpc-0.12.12.log
Build URL:      
http://beefy8.nyi.freebsd.org/build.html?mastername=head-armv6-default&build=p399861_s289632
Log:

====>> Building devel/libiqxmlrpc
build started at Fri Oct 23 03:10:21 UTC 2015
port directory: /usr/ports/devel/libiqxmlrpc
building for: FreeBSD head-armv6-default-job-17 11.0-CURRENT FreeBSD 
11.0-CURRENT r289632 arm
maintained by: f...@freebsd.org
Makefile ident:      $FreeBSD: head/devel/libiqxmlrpc/Makefile 378038 
2015-01-28 02:03:49Z fjoe $
Poudriere version: 3.1.9
Host OSVERSION: 1100079
Jail OSVERSION: 1100082




!!! Jail is newer than host. (Jail: 1100082, Host: 1100079) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=armv6
UNAME_m=arm
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1100082
UNAME_v=FreeBSD 11.0-CURRENT r289632
UNAME_r=11.0-CURRENT
LC_COLLATE=C
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=screen
MASTERMNT=/usr/local/poudriere/data/.m/head-armv6-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=libiqxmlrpc-0.12.12
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/head-armv6-default/ref/.p/pool
MASTERNAME=head-armv6-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.9
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for libiqxmlrpc-0.12.12:
     DOCS=on: Build and/or install documentation
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/libiqxmlrpc/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/libiqxmlrpc/work  
HOME=/wrkdirs/usr/ports/devel/libiqxmlrpc/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
OPENSSLBASE=/usr OPENSSLDIR=/etc/ssl OPENSSLINC=/usr/include 
OPENSSLLIB=/usr/lib XDG_DATA_HOME=/wrkdirs/usr/ports/devel/libiqxmlrpc/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/libiqxmlrpc/work  
HOME=/wrkdirs/usr/ports/devel/libiqxmlrpc/work TMPDIR="/tmp" NO_PIE=yes 
SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe 
-mfloat-abi=softfp  -fno-strict-aliasing"  CPP="/nxb-bin/usr/bin/cpp" 
CPPFLAGS=""  LDFLAGS=" -L/usr/local/lib " LIBS=""  CXX="/nxb-bin/usr/bin/c++" 
CXXFLAGS="-O2 -pipe -mfloat-abi=softfp -fno-strict-aliasing "  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 555"  
BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
CMAKE_BUILD_TYPE="release"
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
GTK2_VERSION="2.10.0"
GTK3_VERSION="3.0.0"
DOCSDIR="share/doc/libiqxmlrpc"
EXAMPLESDIR="share/examples/libiqxmlrpc"
DATADIR="share/libiqxmlrpc"
WWWDIR="www/libiqxmlrpc"
ETCDIR="etc/libiqxmlrpc"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/libiqxmlrpc
DOCSDIR=/usr/local/share/doc/libiqxmlrpc
EXAMPLESDIR=/usr/local/share/examples/libiqxmlrpc
WWWDIR=/usr/local/www/libiqxmlrpc
ETCDIR=/usr/local/etc/libiqxmlrpc
--End SUB_LIST--

---Begin make.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
<snip>
[head-armv6-default-job-17] |   |   `-- Extracting ghostscript9-base-9.06_11: 
.......... done
[head-armv6-default-job-17] |   |   `-- Installing poppler-0.34.0...
[head-armv6-default-job-17] |   |   | `-- Installing openjpeg15-1.5.2_1...
[head-armv6-default-job-17] |   |   | `-- Extracting openjpeg15-1.5.2_1: 
.......... done
[head-armv6-default-job-17] |   |   | `-- Installing poppler-data-0.4.7...
[head-armv6-default-job-17] |   |   | `-- Extracting poppler-data-0.4.7: 
.......... done
[head-armv6-default-job-17] |   |   `-- Extracting poppler-0.34.0: .......... 
done
[head-armv6-default-job-17] |   |   `-- Installing tex-ptexenc-1.3.3_2...
[head-armv6-default-job-17] |   |   `-- Extracting tex-ptexenc-1.3.3_2: 
.......... done
[head-armv6-default-job-17] |   |   `-- Installing zziplib-0.13.62_2...
[head-armv6-default-job-17] |   |   `-- Extracting zziplib-0.13.62_2: 
.......... done
[head-armv6-default-job-17] |   |   `-- Installing tex-web2c-20150521_1...
[head-armv6-default-job-17] |   |   | `-- Installing mpfr-3.1.2_2...
[head-armv6-default-job-17] |   |   | `-- Extracting mpfr-3.1.2_2: .......... 
done
[head-armv6-default-job-17] |   |   `-- Extracting tex-web2c-20150521_1: 
.......... done
[head-armv6-default-job-17] |   | `-- Extracting texlive-base-20150521_6: 
.......... done
[head-armv6-default-job-17] |   `-- Extracting texlive-texmf-20150523_3: 
.......... done
[head-armv6-default-job-17] `-- Extracting tex-dvipsk-5.995_1: .......... done
[head-armv6-default-job-17] `-- Installing graphviz-2.38.0_9...
[head-armv6-default-job-17] |   `-- Installing pango-1.36.8_2...
[head-armv6-default-job-17] |   | `-- Installing encodings-1.0.4_3,1...
[head-armv6-default-job-17] |   |   `-- Installing font-util-1.3.1...
[head-armv6-default-job-17] |   |   `-- Extracting font-util-1.3.1: .......... 
done
[head-armv6-default-job-17] |   | `-- Extracting encodings-1.0.4_3,1: 
.......... done
[head-armv6-default-job-17] |   | `-- Installing libXft-2.3.2_1...
[head-armv6-default-job-17] |   | `-- Extracting libXft-2.3.2_1: ......... done
[head-armv6-default-job-17] |   | `-- Installing xorg-fonts-truetype-7.7_1...
[head-armv6-default-job-17] |   |   `-- Installing font-misc-meltho-1.0.3_3...
[head-armv6-default-job-17] |   |   | `-- Installing mkfontdir-1.0.7...
[head-armv6-default-job-17] |   |   |   `-- Installing mkfontscale-1.1.2...
[head-armv6-default-job-17] |   |   |   | `-- Installing libfontenc-1.1.3...
[head-armv6-default-job-17] |   |   |   | `-- Extracting libfontenc-1.1.3: 
...... done
[head-armv6-default-job-17] |   |   |   `-- Extracting mkfontscale-1.1.2: .. 
done
[head-armv6-default-job-17] |   |   | `-- Extracting mkfontdir-1.0.7: .. done
[head-armv6-default-job-17] |   |   `-- Extracting font-misc-meltho-1.0.3_3: 
.......... done
[head-armv6-default-job-17] |   |   `-- Installing font-bh-ttf-1.0.3_3...
[head-armv6-default-job-17] |   |   `-- Extracting font-bh-ttf-1.0.3_3: 
.......... done
[head-armv6-default-job-17] |   |   `-- Installing font-misc-ethiopic-1.0.3_3...
[head-armv6-default-job-17] |   |   `-- Extracting font-misc-ethiopic-1.0.3_3: 
.. done
[head-armv6-default-job-17] |   |   `-- Installing dejavu-2.35...
[head-armv6-default-job-17] |   |   `-- Extracting dejavu-2.35: .......... done
[head-armv6-default-job-17] |   `-- Extracting pango-1.36.8_2: .......... done
[head-armv6-default-job-17] |   `-- Installing libltdl-2.4.6...
[head-armv6-default-job-17] |   `-- Extracting libltdl-2.4.6: .......... done
[head-armv6-default-job-17] `-- Extracting graphviz-2.38.0_9: .......... done
[head-armv6-default-job-17] `-- Installing tex-formats-20150521_2...
[head-armv6-default-job-17] |   `-- Installing tex-basic-engines-20150521...
[head-armv6-default-job-17] |   `-- Extracting tex-basic-engines-20150521: 
.......... done
[head-armv6-default-job-17] `-- Extracting tex-formats-20150521_2: .......... 
done
[head-armv6-default-job-17] `-- Installing python2-2_3...
[head-armv6-default-job-17] `-- Extracting python2-2_3: ...... done
[head-armv6-default-job-17] Extracting doxygen-1.8.10_2,2: .......... done
Message from perl5-5.20.3_8:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
Message from python27-2.7.10_1:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
Message from ca_root_nss-3.20:
********************************* WARNING *********************************

FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.

*********************************** NOTE **********************************

This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem

***************************************************************************
Message from trousers-tddl-0.3.10_7:
To run tcsd automatically, add the following line to /etc/rc.conf

tcsd_enable="YES"

You might want to edit /usr/local/etc/tcsd.conf to reflect your setup.

To use TPM, add your_account to '_tss' group like following:

# pw groupadd _tss -m your_account
Message from ghostscript9-base-9.06_11:
Note: in order to use the script "dvipdf", dvips must be installed.
This program is provided by another package print/tex-dvipsk.

FAPIfontmap and FAPIcidfmap in /usr/local/share/ghostscript/9.06/Resource/Init
have to be configured if you want to use FAPI feature.
Message from dejavu-2.35:
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/share/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
===>   libiqxmlrpc-0.12.12 depends on executable: doxygen - found
===>   Returning to build of libiqxmlrpc-0.12.12
===>   libiqxmlrpc-0.12.12 depends on file: /usr/local/bin/cmake - not found
===>   Installing existing package /packages/All/cmake-3.3.1.txz
[head-armv6-default-job-17] Installing cmake-3.3.1...
[head-armv6-default-job-17] `-- Installing cmake-modules-3.3.1...
[head-armv6-default-job-17] `-- Extracting cmake-modules-3.3.1: .......... done
[head-armv6-default-job-17] `-- Installing curl-7.45.0...
[head-armv6-default-job-17] `-- Extracting curl-7.45.0: .......... done
[head-armv6-default-job-17] `-- Installing libarchive-3.1.2_4,1...
[head-armv6-default-job-17] |   `-- Installing lzo2-2.09...
[head-armv6-default-job-17] |   `-- Extracting lzo2-2.09: .......... done
[head-armv6-default-job-17] `-- Extracting libarchive-3.1.2_4,1: .......... done
[head-armv6-default-job-17] `-- Installing jsoncpp-0.6.0.r2_2...
[head-armv6-default-job-17] `-- Extracting jsoncpp-0.6.0.r2_2: .......... done
[head-armv6-default-job-17] Extracting cmake-3.3.1: .......... done
===>   libiqxmlrpc-0.12.12 depends on file: /usr/local/bin/cmake - found
===>   Returning to build of libiqxmlrpc-0.12.12
===========================================================================
=======================<phase: lib-depends    >============================
===>   libiqxmlrpc-0.12.12 depends on shared library: libboost_thread.so - not 
found
===>   Installing existing package /packages/All/boost-libs-1.55.0_9.txz
[head-armv6-default-job-17] Installing boost-libs-1.55.0_9...
[head-armv6-default-job-17] Extracting boost-libs-1.55.0_9: .......... done
Message from boost-libs-1.55.0_9:
You have built the Boost library with thread support.

Don't forget to add -pthread to your linker options when
linking your code.
===>   libiqxmlrpc-0.12.12 depends on shared library: libboost_thread.so - 
found (/usr/local/lib/libboost_thread.so)
===>   Returning to build of libiqxmlrpc-0.12.12
===>   libiqxmlrpc-0.12.12 depends on shared library: libxml2.so - found 
(/usr/local/lib/libxml2.so)
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for libiqxmlrpc-0.12.12
===>  Performing in-source build
/bin/mkdir -p /wrkdirs/usr/ports/devel/libiqxmlrpc/work/libiqxmlrpc-0.12.12
-- The C compiler identification is Clang 3.6.1
-- The CXX compiler identification is Clang 3.6.1
-- Check for working C compiler: /nxb-bin/usr/bin/cc
-- Check for working C compiler: /nxb-bin/usr/bin/cc -- works
-- Detecting C compiler ABI info
CMake Error: Generator: execution of make failed. Make command was: 
"/usr/bin/make" "cmTC_70521/fast"
-- Detecting C compiler ABI info - failed
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Boost version: 1.55.0
-- Found LibXml2: /usr/local/lib/libxml2.so (found version "2.9.2") 
-- Found OpenSSL: /usr/lib/libssl.so;/usr/lib/libcrypto.so (found version 
"1.0.1p") 
-- Boost version: 1.55.0
-- Found the following Boost libraries:
--   date_time
--   thread
--   system
-- Looking for poll
-- Looking for poll - found
iqxmlrpc: Using poll reactor implementation
-- Configuring incomplete, errors occurred!
See also 
"/wrkdirs/usr/ports/devel/libiqxmlrpc/work/libiqxmlrpc-0.12.12/CMakeFiles/CMakeOutput.log".
See also 
"/wrkdirs/usr/ports/devel/libiqxmlrpc/work/libiqxmlrpc-0.12.12/CMakeFiles/CMakeError.log".
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/libiqxmlrpc
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to