You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     m...@freebsd.org
Last committer: m...@freebsd.org
Ident:          $FreeBSD: head/irc/quassel/Makefile 395231 2015-08-25 10:03:08Z 
makc $
Log URL:        
http://beefy8.nyi.freebsd.org/data/head-armv6-default/p399861_s289632/logs/quassel-0.11.1.log
Build URL:      
http://beefy8.nyi.freebsd.org/build.html?mastername=head-armv6-default&build=p399861_s289632
Log:

====>> Building irc/quassel
build started at Sat Oct 24 23:11:21 UTC 2015
port directory: /usr/ports/irc/quassel
building for: FreeBSD head-armv6-default-job-19 11.0-CURRENT FreeBSD 
11.0-CURRENT r289632 arm
maintained by: m...@freebsd.org
Makefile ident:      $FreeBSD: head/irc/quassel/Makefile 395231 2015-08-25 
10:03:08Z makc $
Poudriere version: 3.1.9
Host OSVERSION: 1100079
Jail OSVERSION: 1100082




!!! Jail is newer than host. (Jail: 1100082, Host: 1100079) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=armv6
UNAME_m=arm
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1100082
UNAME_v=FreeBSD 11.0-CURRENT r289632
UNAME_r=11.0-CURRENT
LC_COLLATE=C
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=screen
MASTERMNT=/usr/local/poudriere/data/.m/head-armv6-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=quassel-0.11.1
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/head-armv6-default/ref/.p/pool
MASTERNAME=head-armv6-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.9
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for quassel-0.11.1:
     KDE=off: KDE 4 integration (for clients only)
     NLS=on: Native Language Support
====> Quassel components: you have to choose at least one of them
     MONO=on: Quassel standalone client
     CORE=on: Quassel core (for use with client)
     CLIENT=on: Quassel client (for use with core)
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-qt-includes=/usr/local/include/qt4  
--with-qt-libraries=/usr/local/lib/qt4  
--with-extra-includes=/usr/local/include  --with-extra-libs=/usr/local/lib
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
QTDIR="/usr/local" QMAKE="/usr/local/bin/qmake-qt4"  
MOC="/usr/local/bin/moc-qt4" RCC="/usr/local/bin/rcc" 
UIC="/usr/local/bin/uic-qt4"  
QMAKESPEC="/usr/local/share/qt4/mkspecs/freebsd-$(ccver="$(/nxb-bin/usr/bin/c++ 
--version)"; case "$ccver" in *clang*) echo clang ;; *) echo g++ ;; esac)" 
XDG_DATA_HOME=/wrkdirs/usr/ports/irc/quassel/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/irc/quassel/work  
HOME=/wrkdirs/usr/ports/irc/quassel/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/irc/quassel/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/irc/quassel/work  
HOME=/wrkdirs/usr/ports/irc/quassel/work TMPDIR="/tmp" NO_PIE=yes SHELL=/bin/sh 
NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  
CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe -mfloat-abi=softfp  
-fno-strict-aliasing"  CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS=""  LDFLAGS="" 
LIBS=""  CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -mfloat-abi=softfp 
-fno-strict-aliasing "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
KDE="@comment
"
NO_KDE=""
NLS=""
NO_NLS="@comment
"
MONO=""
NO_MONO="@comment
"
CORE=""
NO_CORE="@comment
"
CLIENT=""
NO_CLIENT="@comment
"
MONO_OR_CLIENT=""
QT_PREFIX="/usr/local"
QT_BINDIR="bin"
QT_INCDIR="include/qt4"
QT_LIBDIR="lib/qt4"
QT_ARCHDIR="lib/qt4/qt4"
QT_PLUGINDIR="lib/qt4/plugins"
QT_LIBEXECDIR="libexec/qt4"
QT_IMPORTDIR="lib/qt4/imports"
QT_QMLDIR="lib/qt4/qt4/qml"
QT_DATADIR="share/qt4"
QT_DOCDIR="share/doc/qt4"
QT_L10NDIR="share/qt4/translations"
QT_ETCDIR="etc/xdg"
QT_EXAMPLEDIR="share/examples/qt4"
QT_TESTDIR="share/qt4/tests"
QT_MKSPECDIR="share/qt4/mkspecs"
CMAKE_BUILD_TYPE="release"
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/quassel"
EXAMPLESDIR="share/examples/quassel"
DATADIR="share/quassel"
WWWDIR="www/quassel"
ETCDIR="etc/quassel"
--End PLIST_SUB--

--SUB_LIST--
KDE="@comment
"
NO_KDE=""
NLS=""
NO_NLS="@comment
"
MONO=""
NO_MONO="@comment
"
CORE=""
NO_CORE="@comment
"
CLIENT=""
NO_CLIENT="@comment
"
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/quassel
DOCSDIR=/usr/local/share/doc/quassel
EXAMPLESDIR=/usr/local/share/examples/quassel
WWWDIR=/usr/local/www/quassel
ETCDIR=/usr/local/etc/quassel
--End SUB_LIST--

---Begin make.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
<snip>
 - databases/qt4-pgsql-plugin           PostgreSQL
 - databases/qt4-sqlite-plugin          SQLite 2
 - databases/qt4-sqlite3-plugin         SQLite 3

======================================================================
Message from qzeitgeist-0.8.0_2:
======================================================================

You'll have to install sysutils/zeitgeist to enable event logging.

======================================================================
Message from phonon-4.8.3:
======================================================================

Please, consider installing backends for Phonon:
- multimedia/phonon-gstreamer   GStreamer backend
- multimedia/phonon-vlc         VLC backend

======================================================================
===>   quassel-0.11.1 depends on file: /usr/local/lib/qt4/libphonon.so - found
===>   Returning to build of quassel-0.11.1
===>   quassel-0.11.1 depends on file: /usr/local/bin/qmake-qt4 - not found
===>   Installing existing package /packages/All/qt4-qmake-4.8.7.txz
[head-armv6-default-job-19] Installing qt4-qmake-4.8.7...
[head-armv6-default-job-19] Extracting qt4-qmake-4.8.7: .......... done
===>   quassel-0.11.1 depends on file: /usr/local/bin/qmake-qt4 - found
===>   Returning to build of quassel-0.11.1
===>   quassel-0.11.1 depends on file: /usr/local/bin/rcc - not found
===>   Installing existing package /packages/All/qt4-rcc-4.8.7.txz
[head-armv6-default-job-19] Installing qt4-rcc-4.8.7...
[head-armv6-default-job-19] Extracting qt4-rcc-4.8.7: .... done
===>   quassel-0.11.1 depends on file: /usr/local/bin/rcc - found
===>   Returning to build of quassel-0.11.1
===>   quassel-0.11.1 depends on file: /usr/local/lib/qt4/libQtScript.so - found
===>   quassel-0.11.1 depends on file: /usr/local/lib/qt4/libQtSql.so - found
===>   quassel-0.11.1 depends on file: /usr/local/bin/uic-qt4 - not found
===>   Installing existing package /packages/All/qt4-uic-4.8.7.txz
[head-armv6-default-job-19] Installing qt4-uic-4.8.7...
[head-armv6-default-job-19] Extracting qt4-uic-4.8.7: .... done
===>   quassel-0.11.1 depends on file: /usr/local/bin/uic-qt4 - found
===>   Returning to build of quassel-0.11.1
===>   quassel-0.11.1 depends on file: /usr/local/lib/qt4/libQtWebKit.so - not 
found
===>   Installing existing package /packages/All/qt4-webkit-4.8.7.txz
[head-armv6-default-job-19] Installing qt4-webkit-4.8.7...
[head-armv6-default-job-19] `-- Installing gstreamer-plugins-0.10.36_6,3...
[head-armv6-default-job-19] |   `-- Installing orc-0.4.24_1...
[head-armv6-default-job-19] |   `-- Extracting orc-0.4.24_1: .......... done
[head-armv6-default-job-19] |   `-- Installing gstreamer-0.10.36_4...
[head-armv6-default-job-19] |   | `-- Installing gobject-introspection-1.44.0...
[head-armv6-default-job-19] |   |   `-- Installing python2-2_3...
[head-armv6-default-job-19] |   |   `-- Extracting python2-2_3: ...... done
[head-armv6-default-job-19] |   | `-- Extracting gobject-introspection-1.44.0: 
.......... done
[head-armv6-default-job-19] |   `-- Extracting gstreamer-0.10.36_4: .......... 
done
[head-armv6-default-job-19] `-- Extracting gstreamer-plugins-0.10.36_6,3: 
.......... done
[head-armv6-default-job-19] Extracting qt4-webkit-4.8.7: .......... done
===>   quassel-0.11.1 depends on file: /usr/local/lib/qt4/libQtWebKit.so - found
===>   Returning to build of quassel-0.11.1
===>   quassel-0.11.1 depends on file: /usr/local/lib/qt4/libQtXml.so - found
===>   quassel-0.11.1 depends on file: /usr/local/lib/qt4/libQtXmlPatterns.so - 
found
===========================================================================
=======================<phase: lib-depends    >============================
===>   quassel-0.11.1 depends on shared library: libqca.so - not found
===>   Installing existing package /packages/All/qca-2.1.0_3.txz
[head-armv6-default-job-19] Installing qca-2.1.0_3...
[head-armv6-default-job-19] `-- Installing gnupg-2.1.8...
[head-armv6-default-job-19] |   `-- Installing gnutls-3.3.17.1...
[head-armv6-default-job-19] |   | `-- Installing nettle-2.7.1...
[head-armv6-default-job-19] |   |   `-- Installing gmp-5.1.3_2...
[head-armv6-default-job-19] |   |   `-- Extracting gmp-5.1.3_2: .......... done
[head-armv6-default-job-19] |   | `-- Extracting nettle-2.7.1: .......... done
[head-armv6-default-job-19] |   | `-- Installing libtasn1-4.7...
[head-armv6-default-job-19] |   | `-- Extracting libtasn1-4.7: .......... done
[head-armv6-default-job-19] |   | `-- Installing libidn-1.31...
[head-armv6-default-job-19] |   | `-- Extracting libidn-1.31: .......... done
[head-armv6-default-job-19] |   | `-- Installing p11-kit-0.23.1_1...
[head-armv6-default-job-19] |   | `-- Extracting p11-kit-0.23.1_1: .......... 
done
[head-armv6-default-job-19] |   | `-- Installing trousers-tddl-0.3.10_7...
===> Creating users and/or groups.
Creating group '_tss' with gid '601'.
Creating user '_tss' with uid '601'.
[head-armv6-default-job-19] |   | `-- Extracting trousers-tddl-0.3.10_7: 
.......... done
[head-armv6-default-job-19] |   `-- Extracting gnutls-3.3.17.1: .......... done
[head-armv6-default-job-19] |   `-- Installing libassuan-2.2.1...
[head-armv6-default-job-19] |   | `-- Installing libgpg-error-1.20...
[head-armv6-default-job-19] |   | `-- Extracting libgpg-error-1.20: .......... 
done
[head-armv6-default-job-19] |   `-- Extracting libassuan-2.2.1: .......... done
[head-armv6-default-job-19] |   `-- Installing npth-1.2...
[head-armv6-default-job-19] |   `-- Extracting npth-1.2: .......... done
[head-armv6-default-job-19] |   `-- Installing libgcrypt-1.6.3...
[head-armv6-default-job-19] |   `-- Extracting libgcrypt-1.6.3: .......... done
[head-armv6-default-job-19] |   `-- Installing libksba-1.3.3...
[head-armv6-default-job-19] |   `-- Extracting libksba-1.3.3: .......... done
[head-armv6-default-job-19] |   `-- Installing pinentry-0.9.5...
[head-armv6-default-job-19] |   | `-- Installing pinentry-tty-0.9.5...
[head-armv6-default-job-19] |   | `-- Extracting pinentry-tty-0.9.5: . done
[head-armv6-default-job-19] |   `-- Extracting pinentry-0.9.5: .. done
[head-armv6-default-job-19] `-- Extracting gnupg-2.1.8: .......... done
[head-armv6-default-job-19] Extracting qca-2.1.0_3: .......... done
Message from trousers-tddl-0.3.10_7:
To run tcsd automatically, add the following line to /etc/rc.conf

tcsd_enable="YES"

You might want to edit /usr/local/etc/tcsd.conf to reflect your setup.

To use TPM, add your_account to '_tss' group like following:

# pw groupadd _tss -m your_account
Message from gnupg-2.1.8:
###############################################################################
                                A T T E N T I O N

In order to use gpg-agent, you need to install a pinentry dialog.

The following ports of pinentry dialogs are available:

security/pinentry-curses        (ncurses based dialog)
security/pinentry-gtk2          (GTK 2.x based dialog)
security/pinentry-qt4           (QT4 based dialog)
security/pinentry-tty           (console based dialog)

###############################################################################
===>   quassel-0.11.1 depends on shared library: libqca.so - found 
(/usr/local/lib/libqca.so)
===>   Returning to build of quassel-0.11.1
===>   quassel-0.11.1 depends on shared library: libdbusmenu-qt.so - not found
===>   Installing existing package 
/packages/All/libdbusmenu-qt-0.9.3.151020150604.txz
[head-armv6-default-job-19] Installing libdbusmenu-qt-0.9.3.151020150604...
[head-armv6-default-job-19] Extracting libdbusmenu-qt-0.9.3.151020150604: 
.......... done
===>   quassel-0.11.1 depends on shared library: libdbusmenu-qt.so - found 
(/usr/local/lib/libdbusmenu-qt.so)
===>   Returning to build of quassel-0.11.1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for quassel-0.11.1
===>  Performing out-of-source build
/bin/mkdir -p /wrkdirs/usr/ports/irc/quassel/work/.build
-- The C compiler identification is Clang 3.6.1
-- The CXX compiler identification is Clang 3.6.1
-- Check for working C compiler: /nxb-bin/usr/bin/cc
-- Check for working C compiler: /nxb-bin/usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
CMake Error: Generator: execution of make failed. Make command was: 
"/usr/bin/make" "cmTC_2b4ff/fast"
-- Detecting C compile features - failed
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++
CMake Error: Generator: execution of make failed. Make command was: 
"/usr/bin/make" "cmTC_34269/fast"
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++ -- broken
CMake Error at /usr/local/share/cmake/Modules/CMakeTestCXXCompiler.cmake:54 
(message):
  The C++ compiler "/nxb-bin/usr/bin/c++" is not able to compile a simple
  test program.

  It fails with the following output:

   Change Dir: /wrkdirs/usr/ports/irc/quassel/work/.build/CMakeFiles/CMakeTmp

  

  Run Build Command:"/usr/bin/make" "cmTC_34269/fast"

  /nxb-bin/usr/bin/make -f CMakeFiles/cmTC_34269.dir/build.make
  CMakeFiles/cmTC_34269.dir/build

  Building CXX object CMakeFiles/cmTC_34269.dir/testCXXCompiler.cxx.o

  /nxb-bin/usr/bin/c++ -O2 -pipe -mfloat-abi=softfp -fno-strict-aliasing -o
  CMakeFiles/cmTC_34269.dir/testCXXCompiler.cxx.o -c
  
/wrkdirs/usr/ports/irc/quassel/work/.build/CMakeFiles/CMakeTmp/testCXXCompiler.cxx


  Linking CXX executable cmTC_34269

  /usr/local/bin/cmake -E cmake_link_script
  CMakeFiles/cmTC_34269.dir/link.txt --verbose=1

  /nxb-bin/usr/bin/c++ -O2 -pipe -mfloat-abi=softfp -fno-strict-aliasing
  CMakeFiles/cmTC_34269.dir/testCXXCompiler.cxx.o -o cmTC_34269

  Process terminated due to timeout

  

  Generator: execution of make failed.  Make command was: "/usr/bin/make"
  "cmTC_34269/fast"

  

  

  CMake will not be able to correctly generate this project.
Call Stack (most recent call first):
  CMakeLists.txt:10 (project)


-- Configuring incomplete, errors occurred!
See also 
"/wrkdirs/usr/ports/irc/quassel/work/.build/CMakeFiles/CMakeOutput.log".
See also "/wrkdirs/usr/ports/irc/quassel/work/.build/CMakeFiles/CMakeError.log".
*** Error code 1

Stop.
make: stopped in /usr/ports/irc/quassel
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to