You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     po...@freebsd.org
Last committer: da...@freebsd.org
Ident:          $FreeBSD: head/audio/libgme/Makefile 383870 2015-04-12 
14:15:14Z danfe $
Log URL:        
http://beefy7.nyi.freebsd.org/data/head-mips-default/p400328_s290048/logs/libgme-0.6.0.log
Build URL:      
http://beefy7.nyi.freebsd.org/build.html?mastername=head-mips-default&build=p400328_s290048
Log:

====>> Building audio/libgme
build started at Thu Oct 29 02:17:24 UTC 2015
port directory: /usr/ports/audio/libgme
building for: FreeBSD head-mips-default-job-11 11.0-CURRENT FreeBSD 
11.0-CURRENT r290048 mips
maintained by: po...@freebsd.org
Makefile ident:      $FreeBSD: head/audio/libgme/Makefile 383870 2015-04-12 
14:15:14Z danfe $
Poudriere version: 3.1.9
Host OSVERSION: 1100079
Jail OSVERSION: 1100083




!!! Jail is newer than host. (Jail: 1100083, Host: 1100079) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=mips
UNAME_m=mips
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1100083
UNAME_v=FreeBSD 11.0-CURRENT r290048
UNAME_r=11.0-CURRENT
LC_COLLATE=C
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=screen
MASTERMNT=/usr/local/poudriere/data/.m/head-mips-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=libgme-0.6.0
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/head-mips-default/ref/.p/pool
MASTERNAME=head-mips-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.9
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for libgme-0.6.0:
     DOCS=on: Build and/or install documentation
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/audio/libgme/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/audio/libgme/work  
HOME=/wrkdirs/usr/ports/audio/libgme/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/audio/libgme/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/audio/libgme/work  
HOME=/wrkdirs/usr/ports/audio/libgme/work TMPDIR="/tmp" NO_PIE=yes 
SHELL=/bin/sh NO_LINT=YES DESTDIR=/wrkdirs/usr/ports/audio/libgme/work/stage 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  
CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe -G0  -fno-strict-aliasing"  
CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS=""  LDFLAGS="" LIBS=""  
CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -G0 -fno-strict-aliasing "  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 555"  
BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
CMAKE_BUILD_TYPE="release"
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/libgme"
EXAMPLESDIR="share/examples/libgme"
DATADIR="share/libgme"
WWWDIR="www/libgme"
ETCDIR="etc/libgme"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/libgme
DOCSDIR=/usr/local/share/doc/libgme
EXAMPLESDIR=/usr/local/share/examples/libgme
WWWDIR=/usr/local/www/libgme
ETCDIR=/usr/local/etc/libgme
--End SUB_LIST--

---Begin make.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
<snip>
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
MACHINE=mips
MACHINE_ARCH=mips
ARCH=${MACHINE_ARCH}
.sinclude "/etc/make.nxb.conf"
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
---Begin make.nxb.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
=======================<phase: check-sanity   >============================
===>  License LGPL21 LGPL3 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   libgme-0.6.0 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.6.1_1.txz
[head-mips-default-job-11] Installing pkg-1.6.1_1...
[head-mips-default-job-11] Extracting pkg-1.6.1_1: .......... done
Message from pkg-1.6.1_1:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   libgme-0.6.0 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of libgme-0.6.0
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License LGPL21 LGPL3 accepted by the user
===> Fetching all distfiles required by libgme-0.6.0 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License LGPL21 LGPL3 accepted by the user
===> Fetching all distfiles required by libgme-0.6.0 for building
=> SHA256 Checksum OK for game-music-emu-0.6.0.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License LGPL21 LGPL3 accepted by the user
===> Fetching all distfiles required by libgme-0.6.0 for building
===>  Extracting for libgme-0.6.0
=> SHA256 Checksum OK for game-music-emu-0.6.0.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for libgme-0.6.0
===>   Converting DOS text files to UNIX text files
===========================================================================
=======================<phase: build-depends  >============================
===>   libgme-0.6.0 depends on file: /usr/local/bin/cmake - not found
===>   Installing existing package /packages/All/cmake-3.3.1.txz
[head-mips-default-job-11] Installing cmake-3.3.1...
[head-mips-default-job-11] `-- Installing expat-2.1.0_3...
[head-mips-default-job-11] `-- Extracting expat-2.1.0_3: .......... done
[head-mips-default-job-11] `-- Installing cmake-modules-3.3.1...
[head-mips-default-job-11] `-- Extracting cmake-modules-3.3.1: .......... done
[head-mips-default-job-11] `-- Installing curl-7.45.0...
[head-mips-default-job-11] |   `-- Installing ca_root_nss-3.20...
[head-mips-default-job-11] |   `-- Extracting ca_root_nss-3.20: ....... done
[head-mips-default-job-11] `-- Extracting curl-7.45.0: .......... done
[head-mips-default-job-11] `-- Installing libarchive-3.1.2_4,1...
[head-mips-default-job-11] |   `-- Installing lzo2-2.09...
[head-mips-default-job-11] |   `-- Extracting lzo2-2.09: .......... done
[head-mips-default-job-11] `-- Extracting libarchive-3.1.2_4,1: .......... done
[head-mips-default-job-11] `-- Installing jsoncpp-0.6.0.r2_2...
[head-mips-default-job-11] `-- Extracting jsoncpp-0.6.0.r2_2: .......... done
[head-mips-default-job-11] Extracting cmake-3.3.1: .......... done
Message from ca_root_nss-3.20:
********************************* WARNING *********************************

FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.

*********************************** NOTE **********************************

This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem

***************************************************************************
===>   libgme-0.6.0 depends on file: /usr/local/bin/cmake - found
===>   Returning to build of libgme-0.6.0
===>   libgme-0.6.0 depends on executable: ninja - not found
===>   Installing existing package /packages/All/ninja-1.6.0,2.txz
[head-mips-default-job-11] Installing ninja-1.6.0,2...
[head-mips-default-job-11] Extracting ninja-1.6.0,2: ....... done
===>   libgme-0.6.0 depends on executable: ninja - found
===>   Returning to build of libgme-0.6.0
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for libgme-0.6.0
===>  Performing in-source build
/bin/mkdir -p /wrkdirs/usr/ports/audio/libgme/work/game-music-emu-0.6.0
-- The C compiler identification is GNU 4.2.1
-- The CXX compiler identification is GNU 4.2.1
-- Check for working C compiler using: Ninja
-- Check for working C compiler using: Ninja -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler using: Ninja
-- Check for working CXX compiler using: Ninja -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Performing Test __LIBGME_TEST_VISIBILITY
-- Performing Test __LIBGME_TEST_VISIBILITY - Success
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Found Threads: TRUE  
SDL library not found, disabling player demo build
-- Configuring done
-- Generating done
CMake Warning:
  Manually-specified variables were not used by the project:

    CMAKE_COLOR_MAKEFILE
    CMAKE_CXX_FLAGS_DEBUG
    CMAKE_C_FLAGS_DEBUG
    CMAKE_MODULE_LINKER_FLAGS
    CMAKE_VERBOSE_MAKEFILE


-- Build files have been written to: 
/wrkdirs/usr/ports/audio/libgme/work/game-music-emu-0.6.0
===========================================================================
=======================<phase: build          >============================
===>  Building for libgme-0.6.0
[1/48] Building CXX object gme/CMakeFiles/gme.dir/Blip_Buffer.cpp.o
[2/48] Building CXX object gme/CMakeFiles/gme.dir/Classic_Emu.cpp.o
[3/48] Building CXX object gme/CMakeFiles/gme.dir/Data_Reader.cpp.o
[4/48] Building CXX object gme/CMakeFiles/gme.dir/Dual_Resampler.cpp.o
[5/48] Building CXX object gme/CMakeFiles/gme.dir/Effects_Buffer.cpp.o
[6/48] Building CXX object gme/CMakeFiles/gme.dir/Fir_Resampler.cpp.o
[7/48] Building CXX object gme/CMakeFiles/gme.dir/Gme_File.cpp.o
[8/48] Building CXX object gme/CMakeFiles/gme.dir/gme.cpp.o
[9/48] Building CXX object gme/CMakeFiles/gme.dir/M3u_Playlist.cpp.o
[10/48] Building CXX object gme/CMakeFiles/gme.dir/Multi_Buffer.cpp.o
[11/48] Building CXX object gme/CMakeFiles/gme.dir/Music_Emu.cpp.o
[12/48] Building CXX object gme/CMakeFiles/gme.dir/Ym2612_Emu.cpp.o
[13/48] Building CXX object gme/CMakeFiles/gme.dir/Ay_Apu.cpp.o
[14/48] Building CXX object gme/CMakeFiles/gme.dir/Sms_Apu.cpp.o
[15/48] Building CXX object gme/CMakeFiles/gme.dir/Gb_Oscs.cpp.o
[16/48] Building CXX object gme/CMakeFiles/gme.dir/Ay_Cpu.cpp.o
FAILED: /nxb-bin/usr/bin/c++   -DBLARGG_BUILD_DLL -DLIBGME_VISIBILITY 
-Dgme_EXPORTS -O2 -pipe -G0 -fno-strict-aliasing -fvisibility=hidden 
-fvisibility-inlines-hidden -O2 -pipe -G0 -fno-strict-aliasing -fPIC -Igme -MMD 
-MT gme/CMakeFiles/gme.dir/Ay_Cpu.cpp.o -MF 
gme/CMakeFiles/gme.dir/Ay_Cpu.cpp.o.d -o gme/CMakeFiles/gme.dir/Ay_Cpu.cpp.o -c 
gme/Ay_Cpu.cpp
gme/Ay_Cpu.cpp:104:3: error: #error "Byte order of CPU must be known"
gme/Ay_Cpu.cpp: In member function 'bool Ay_Cpu::run(cpu_time_t)':
gme/Ay_Cpu.cpp:420: error: 'R8' was not declared in this scope
ninja: build stopped: subcommand failed.
*** Error code 1

Stop.
make: stopped in /usr/ports/audio/libgme
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to