You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     gn...@freebsd.org
Last committer: k...@freebsd.org
Ident:          $FreeBSD: head/devel/appstream-glib/Makefile 402209 2015-11-22 
00:52:13Z kwm $
Log URL:        
http://beefy1.nyi.freebsd.org/data/93i386-default/402209/logs/appstream-glib-0.5.4.log
Build URL:      
http://beefy1.nyi.freebsd.org/build.html?mastername=93i386-default&build=402209
Log:

====>> Building devel/appstream-glib
build started at Sun Nov 22 17:46:46 UTC 2015
port directory: /usr/ports/devel/appstream-glib
building for: FreeBSD 93i386-default-job-22 9.3-RELEASE-p30 FreeBSD 
9.3-RELEASE-p30 i386
maintained by: gn...@freebsd.org
Makefile ident:      $FreeBSD: head/devel/appstream-glib/Makefile 402209 
2015-11-22 00:52:13Z kwm $
Poudriere version: 3.1.9
Host OSVERSION: 1100085
Jail OSVERSION: 903000

---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
OSVERSION=903000
UNAME_v=FreeBSD 9.3-RELEASE-p30
UNAME_r=9.3-RELEASE-p30
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/93i386-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=appstream-glib-0.5.4
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/93i386-default/ref/.p/pool
MASTERNAME=93i386-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.9
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for appstream-glib-0.5.4:
     MANPAGES=on: Build and/or install manual pages
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-xml-catalog=/usr/local/share/xml/catalog  --disable-rpm  
--disable-ostree --enable-man --prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
GPERF=/usr/bin/gperf MAKE=gmake CMAKE_PREFIX_PATH="/usr/local" 
PKG_CONFIG=pkgconf XDG_DATA_HOME=/wrkdirs/usr/ports/devel/appstream-glib/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/appstream-glib/work  
HOME=/wrkdirs/usr/ports/devel/appstream-glib/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh CONFIG_SITE=/usr/ports/Templates/config.site 
lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
GPERF=/usr/bin/gperf XDG_DATA_HOME=/wrkdirs/usr/ports/devel/appstream-glib/work 
 XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/appstream-glib/work  
HOME=/wrkdirs/usr/ports/devel/appstream-glib/work TMPDIR="/tmp" NO_PIE=yes 
SHELL=/bin/sh NO_LINT=YES GI_SCANNER_DISABLE_CACHE=1 
XDG_CACHE_HOME=/wrkdirs/usr/ports/devel/appstream-glib/work PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -isystem 
/usr/local/include -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS="-I/usr/local/include -isystem /usr/local/include"  LDFLAGS=" 
-L/usr/local/lib -L/usr/local/lib" LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe 
-isystem /usr/local/include -fno-strict-aliasing -isystem /usr/local/include"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 555"  
BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
MANPAGES=""
NO_MANPAGES="@comment
"
OSREL=9.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
GTK2_VERSION="2.10.0"
GTK3_VERSION="3.0.0"
DOCSDIR="share/doc/appstream-glib"
EXAMPLESDIR="share/examples/appstream-glib"
DATADIR="share/appstream-glib"
WWWDIR="www/appstream-glib"
ETCDIR="etc/appstream-glib"
--End PLIST_SUB--

--SUB_LIST--
MANPAGES=""
NO_MANPAGES="@comment
"
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/appstream-glib
DOCSDIR=/usr/local/share/doc/appstream-glib
EXAMPLESDIR=/usr/local/share/examples/appstream-glib
WWWDIR=/usr/local/www/appstream-glib
ETCDIR=/usr/local/etc/appstream-glib
--End SUB_LIST--

---Begin make.conf---
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License LGPL21 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   appstream-glib-0.5.4 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.6.1_2.txz
[93i386-default-job-22] Installing pkg-1.6.1_2...
[93i386-default-job-22] Extracting pkg-1.6.1_2: .......... done
Message from pkg-1.6.1_2:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   appstream-glib-0.5.4 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of appstream-glib-0.5.4
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License LGPL21 accepted by the user
=> appstream-glib-0.5.4.tar.xz doesn't seem to exist in /portdistfiles/gnome3.
=> Attempting to fetch 
http://people.freedesktop.org/~hughsient/appstream-glib/releases/appstream-glib-0.5.4.tar.xz
appstream-glib-0.5.4.tar.xz                           1810 kB    0  Bps
===> Fetching all distfiles required by appstream-glib-0.5.4 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License LGPL21 accepted by the user
===> Fetching all distfiles required by appstream-glib-0.5.4 for building
=> SHA256 Checksum OK for gnome3/appstream-glib-0.5.4.tar.xz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License LGPL21 accepted by the user
===> Fetching all distfiles required by appstream-glib-0.5.4 for building
===>  Extracting for appstream-glib-0.5.4
=> SHA256 Checksum OK for gnome3/appstream-glib-0.5.4.tar.xz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for appstream-glib-0.5.4
/usr/bin/sed -i.bak -e 's|-Wtype-limits||g'  
/wrkdirs/usr/ports/devel/appstream-glib/work/appstream-glib-0.5.4/configure
===========================================================================
=======================<phase: build-depends  >============================
===>   appstream-glib-0.5.4 depends on executable: gtkdoc-check - not found
===>   Installing existing package /packages/All/gtk-doc-1.24.txz
[93i386-default-job-22] Installing gtk-doc-1.24...
[93i386-default-job-22] `-- Installing libxml2-2.9.3...
[93i386-default-job-22] |   `-- Installing libiconv-1.14_9...
[93i386-default-job-22] |   `-- Extracting libiconv-1.14_9: .......... done
[93i386-default-job-22] `-- Extracting libxml2-2.9.3: .......... done
[93i386-default-job-22] `-- Installing python27-2.7.10_1...
[93i386-default-job-22] |   `-- Installing libffi-3.2.1...
[93i386-default-job-22] |   | `-- Installing indexinfo-0.2.4...
[93i386-default-job-22] |   | `-- Extracting indexinfo-0.2.4: .... done
[93i386-default-job-22] |   `-- Extracting libffi-3.2.1: .......... done
[93i386-default-job-22] |   `-- Installing gettext-runtime-0.19.6...
[93i386-default-job-22] |   `-- Extracting gettext-runtime-0.19.6: .......... 
done
[93i386-default-job-22] `-- Extracting python27-2.7.10_1: .......... done
[93i386-default-job-22] `-- Installing rarian-0.8.1_4...
[93i386-default-job-22] |   `-- Installing bash-4.3.42...
[93i386-default-job-22] |   `-- Extracting bash-4.3.42: .......... done
[93i386-default-job-22] |   `-- Installing docbook-xsl-1.76.1_2...
[93i386-default-job-22] |   | `-- Installing docbook-1.5...
[93i386-default-job-22] |   |   `-- Installing sdocbook-xml-1.1_1,2...
[93i386-default-job-22] |   |   | `-- Installing xmlcatmgr-2.2_2...
[93i386-default-job-22] |   |   | `-- Extracting xmlcatmgr-2.2_2: .......... 
done
 + Creating /usr/local/share/sgml/catalog
 + Registering CATALOG catalog.ports (SGML)
 + Creating /usr/local/share/sgml/catalog.ports
 + Creating /usr/local/share/xml/catalog
 + Registering nextCatalog catalog.ports (XML)
 + Creating /usr/local/share/xml/catalog.ports
[93i386-default-job-22] |   |   `-- Extracting sdocbook-xml-1.1_1,2: .......... 
done
[93i386-default-job-22] |   |   `-- Installing docbook-sgml-4.5_1...
[93i386-default-job-22] |   |   | `-- Installing iso8879-1986_3...
[93i386-default-job-22] |   |   | `-- Extracting iso8879-1986_3: .......... done
[93i386-default-job-22] |   |   `-- Extracting docbook-sgml-4.5_1: .......... 
done
[93i386-default-job-22] |   |   `-- Installing docbook-xml-5.0_3...
[93i386-default-job-22] |   |   | `-- Installing xmlcharent-0.3_2...
[93i386-default-job-22] |   |   | `-- Extracting xmlcharent-0.3_2: .......... 
done
[93i386-default-job-22] |   |   `-- Extracting docbook-xml-5.0_3: .......... 
done
[93i386-default-job-22] |   `-- Extracting docbook-xsl-1.76.1_2: .......... done
[93i386-default-job-22] |   `-- Installing libxslt-1.1.28_8...
[93i386-default-job-22] |   | `-- Installing libgcrypt-1.6.4_1...
[93i386-default-job-22] |   |   `-- Installing libgpg-error-1.20_1...
[93i386-default-job-22] |   |   `-- Extracting libgpg-error-1.20_1: .......... 
done
[93i386-default-job-22] |   | `-- Extracting libgcrypt-1.6.4_1: .......... done
[93i386-default-job-22] |   `-- Extracting libxslt-1.1.28_8: .......... done
[93i386-default-job-22] |   `-- Installing getopt-1.1.6...
[93i386-default-job-22] |   `-- Extracting getopt-1.1.6: .......... done
[93i386-default-job-22] `-- Extracting rarian-0.8.1_4: .......... done
[93i386-default-job-22] `-- Installing perl5-5.20.3_8...
[93i386-default-job-22] `-- Extracting perl5-5.20.3_8: .......... done
[93i386-default-job-22] `-- Installing jade-1.2.1_10...
[93i386-default-job-22] `-- Extracting jade-1.2.1_10: .......... done
[93i386-default-job-22] Extracting gtk-doc-1.24: .......... done
<snip>
[93i386-default-job-22] |   `-- Extracting pango-1.36.8_2: .......... done
[93i386-default-job-22] |   `-- Installing libXcursor-1.1.14_3...
[93i386-default-job-22] |   `-- Extracting libXcursor-1.1.14_3: .......... done
[93i386-default-job-22] |   `-- Installing libXcomposite-0.4.4_3,1...
[93i386-default-job-22] |   | `-- Installing compositeproto-0.4.2...
[93i386-default-job-22] |   | `-- Extracting compositeproto-0.4.2: .... done
[93i386-default-job-22] |   `-- Extracting libXcomposite-0.4.4_3,1: .......... 
done
[93i386-default-job-22] |   `-- Installing shared-mime-info-1.4...
[93i386-default-job-22] |   `-- Extracting shared-mime-info-1.4: .......... done
[93i386-default-job-22] `-- Extracting gtk-update-icon-cache-2.24.28: .... done
[93i386-default-job-22] `-- Installing libepoxy-1.2...
[93i386-default-job-22] |   `-- Installing libglesv2-10.6.9...
[93i386-default-job-22] |   `-- Extracting libglesv2-10.6.9: .......... done
[93i386-default-job-22] `-- Extracting libepoxy-1.2: .......... done
[93i386-default-job-22] `-- Installing at-spi2-atk-2.16.0...
[93i386-default-job-22] |   `-- Installing at-spi2-core-2.16.0...
[93i386-default-job-22] |   | `-- Installing libXtst-1.2.2_3...
[93i386-default-job-22] |   |   `-- Installing recordproto-1.14.2...
[93i386-default-job-22] |   |   `-- Extracting recordproto-1.14.2: .... done
[93i386-default-job-22] |   | `-- Extracting libXtst-1.2.2_3: .......... done
[93i386-default-job-22] |   `-- Extracting at-spi2-core-2.16.0: .......... done
[93i386-default-job-22] `-- Extracting at-spi2-atk-2.16.0: .......... done
[93i386-default-job-22] `-- Installing adwaita-icon-theme-3.16.2.1...
[93i386-default-job-22] `-- Extracting adwaita-icon-theme-3.16.2.1: .......... 
done
[93i386-default-job-22] Extracting gtk3-3.16.6: .......... done
Message from gcc-4.8.5:
To ensure binaries built with this toolchain find appropriate versions
of the necessary run-time libraries, you may want to link using

  -Wl,-rpath=/usr/local/lib/gcc48

For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
transparently.
Message from dejavu-2.35:
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/share/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
===>   appstream-glib-0.5.4 depends on shared library: libgtk-3.so - found 
(/usr/local/lib/libgtk-3.so)
===>   Returning to build of appstream-glib-0.5.4
===>   appstream-glib-0.5.4 depends on shared library: libpango-1.0.so - found 
(/usr/local/lib/libpango-1.0.so)
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for appstream-glib-0.5.4
configure: loading site script /usr/ports/Templates/config.site
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... (cached) /bin/mkdir -p
checking for gawk... (cached) /usr/bin/awk
checking whether gmake sets $(MAKE)... yes
checking whether gmake supports nested variables... yes
checking whether UID '0' is supported by ustar format... yes
checking whether GID '0' is supported by ustar format... yes
checking how to create a ustar tar archive... (cached) /usr/bin/tar
checking for style of include used by gmake... GNU
checking for gcc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking whether cc understands -c and -o together... yes
checking dependency style of cc... gcc3
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... no
checking pkg-config is at least version 0.9.0... yes
checking for gobject-introspection... yes
checking whether gmake supports nested variables... (cached) yes
checking for linguas... ca cs da de en_GB es fi fr gl hu it ko pl pt_BR ru sk 
sl sr sr@latin sv tr uk zh_TW 
checking for gcc... (cached) cc
checking whether we are using the GNU C compiler... (cached) yes
checking whether cc accepts -g... (cached) yes
checking for cc option to accept ISO C89... (cached) none needed
checking whether cc understands -c and -o together... (cached) yes
checking dependency style of cc... (cached) gcc3
checking whether we are using the GNU C++ compiler... yes
checking whether c++ accepts -g... yes
checking dependency style of c++... gcc3
checking how to run the C preprocessor... cpp
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking for ANSI C header files... (cached) yes
checking build system type... i386-portbld-freebsd9.3
checking host system type... i386-portbld-freebsd9.3
checking how to print strings... printf
checking for a sed that does not truncate output... (cached) /usr/bin/sed
checking for fgrep... (cached) /usr/bin/fgrep
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... (cached) 262144
checking how to convert i386-portbld-freebsd9.3 file names to 
i386-portbld-freebsd9.3 format... func_convert_file_noop
checking how to convert i386-portbld-freebsd9.3 file names to toolchain 
format... func_convert_file_noop
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for dlltool... no
checking how to associate runtime and link libraries... printf %s\n
checking for ar... ar
checking for archiver @FILE support... no
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for sysroot... no
checking for a working dd... /bin/dd
checking how to truncate binary pipes... /bin/dd bs=4096 count=1
checking for mt... mt
checking if mt is a manifest tool... no
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking for dlfcn.h... (cached) yes
checking for objdir... .libs
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC -DPIC
checking if cc PIC flag -fPIC -DPIC works... yes
checking if cc static flag -static works... yes
checking if cc supports -c -o file.o... yes
checking if cc supports -c -o file.o... (cached) yes
checking whether the cc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... freebsd9.3 ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
checking how to run the C++ preprocessor... c++ -E
checking for ld used by c++... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking whether the c++ linker (/usr/bin/ld) supports shared libraries... yes
checking for c++ option to produce PIC... -fPIC -DPIC
checking if c++ PIC flag -fPIC -DPIC works... yes
checking if c++ static flag -static works... yes
checking if c++ supports -c -o file.o... yes
checking if c++ supports -c -o file.o... (cached) yes
checking whether the c++ linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... freebsd9.3 ld.so
checking how to hardcode library paths into programs... immediate
checking whether NLS is requested... yes
checking for intltool >= 0.40.0... 0.51.0 found
checking for intltool-update... /usr/local/bin/intltool-update
checking for intltool-merge... /usr/local/bin/intltool-merge
checking for intltool-extract... /usr/local/bin/intltool-extract
checking for xgettext... /usr/local/bin/xgettext
checking for msgmerge... /usr/local/bin/msgmerge
checking for msgfmt... /usr/local/bin/msgfmt
checking for gmsgfmt... /usr/local/bin/msgfmt
checking for perl... /usr/local/bin/perl
checking for perl >= 5.8.1... 5.20.3
checking for XML::Parser... ok
checking for gtk-doc... yes
checking for gtkdoc-check... gtkdoc-check.test
checking for gtkdoc-check... /usr/local/bin/gtkdoc-check
checking for gtkdoc-rebase... /usr/local/bin/gtkdoc-rebase
checking for gtkdoc-mkpdf... /usr/local/bin/gtkdoc-mkpdf
checking whether to build gtk-doc documentation... no
checking for GTKDOC_DEPS... yes
checking whether C compiler accepts -fPIE... yes
checking whether the linker accepts -fPIE -pie... yes
checking for gperf... /usr/bin/gperf
checking for GLIB... no
configure: error: Package requirements (glib-2.0 >= 2.45.8 gio-2.0 gobject-2.0 
gthread-2.0 gio-unix-2.0 gmodule-2.0) were not met:

Package dependency requirement 'glib-2.0 >= 2.45.8' could not be satisfied.
Package 'glib-2.0' has version '2.44.1', required version is '>= 2.45.8'

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GLIB_CFLAGS
and GLIB_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
===>  Script "configure" failed unexpectedly.
Please report the problem to gn...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/devel/appstream-glib/work/appstream-glib-0.5.4/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** [do-configure] Error code 1

Stop in /usr/ports/devel/appstream-glib.
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to