You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     kuriy...@freebsd.org
Last committer: m...@freebsd.org
Ident:          $FreeBSD: head/textproc/p5-Groonga-API/Makefile 384688 
2015-04-24 21:46:37Z mat $
Log URL:        
http://beefy2.nyi.freebsd.org/data/93amd64-default/402209/logs/p5-Groonga-API-0.03.20150303.log
Build URL:      
http://beefy2.nyi.freebsd.org/build.html?mastername=93amd64-default&build=402209
Log:

====>> Building textproc/p5-Groonga-API
build started at Sun Nov 22 21:38:54 UTC 2015
port directory: /usr/ports/textproc/p5-Groonga-API
building for: FreeBSD 93amd64-default-job-05 9.3-RELEASE-p30 FreeBSD 
9.3-RELEASE-p30 amd64
maintained by: kuriy...@freebsd.org
Makefile ident:      $FreeBSD: head/textproc/p5-Groonga-API/Makefile 384688 
2015-04-24 21:46:37Z mat $
Poudriere version: 3.1.9
Host OSVERSION: 1100085
Jail OSVERSION: 903000

---Begin Environment---
SHELL=/bin/csh
OSVERSION=903000
UNAME_v=FreeBSD 9.3-RELEASE-p30
UNAME_r=9.3-RELEASE-p30
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/93amd64-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=p5-Groonga-API-0.03.20150303
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/93amd64-default/ref/.p/pool
MASTERNAME=93amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.9
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
INSTALLDIRS="site" CC="cc" CCFLAGS="-O2 -pipe -fstack-protector 
-fno-strict-aliasing" PREFIX="/usr/local"  INSTALLPRIVLIB="/usr/local/lib" 
INSTALLARCHLIB="/usr/local/lib"
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
ac_cv_path_PERL=/usr/local/bin/perl ac_cv_path_PERL_PATH=/usr/local/bin/perl 
XDG_DATA_HOME=/wrkdirs/usr/ports/textproc/p5-Groonga-API/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/textproc/p5-Groonga-API/work  
HOME=/wrkdirs/usr/ports/textproc/p5-Groonga-API/work TMPDIR="/tmp" 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh PERL_EXTUTILS_AUTOINSTALL="--skipdeps" 
PERL_MM_USE_DEFAULT="YES"
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/textproc/p5-Groonga-API/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/textproc/p5-Groonga-API/work  
HOME=/wrkdirs/usr/ports/textproc/p5-Groonga-API/work TMPDIR="/tmp" NO_PIE=yes 
SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fstack-protector 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=" -fstack-protector" 
LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 555"  
BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=9.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
PERL_VERSION=5.20.3
PERL_VER=5.20
PERL5_MAN1=lib/perl5/site_perl/man/man1
PERL5_MAN3=lib/perl5/site_perl/man/man3
SITE_PERL=lib/perl5/site_perl
SITE_ARCH=lib/perl5/site_perl/mach/5.20
DOCSDIR="share/doc/Groonga-API"
EXAMPLESDIR="share/examples/Groonga-API"
DATADIR="share/Groonga-API"
WWWDIR="www/Groonga-API"
ETCDIR="etc/Groonga-API"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/Groonga-API
DOCSDIR=/usr/local/share/doc/Groonga-API
EXAMPLESDIR=/usr/local/share/examples/Groonga-API
WWWDIR=/usr/local/www/Groonga-API
ETCDIR=/usr/local/etc/Groonga-API
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License ART10 GPLv1 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   p5-Groonga-API-0.03.20150303 depends on file: /usr/local/sbin/pkg - not 
found
===>   Installing existing package /packages/All/pkg-1.6.1_2.txz
[93amd64-default-job-05] Installing pkg-1.6.1_2...
[93amd64-default-job-05] Extracting pkg-1.6.1_2: .......... done
Message from pkg-1.6.1_2:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   p5-Groonga-API-0.03.20150303 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of p5-Groonga-API-0.03.20150303
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License ART10 GPLv1 accepted by the user
===> Fetching all distfiles required by p5-Groonga-API-0.03.20150303 for 
building
===========================================================================
=======================<phase: checksum       >============================
===>  License ART10 GPLv1 accepted by the user
===> Fetching all distfiles required by p5-Groonga-API-0.03.20150303 for 
building
=> SHA256 Checksum OK for charsbar-groonga-api-0.03.20150303-314060b_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License ART10 GPLv1 accepted by the user
===> Fetching all distfiles required by p5-Groonga-API-0.03.20150303 for 
building
===>  Extracting for p5-Groonga-API-0.03.20150303
=> SHA256 Checksum OK for charsbar-groonga-api-0.03.20150303-314060b_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for p5-Groonga-API-0.03.20150303
===>  Applying FreeBSD patches for p5-Groonga-API-0.03.20150303
===========================================================================
=======================<phase: build-depends  >============================
===>   p5-Groonga-API-0.03.20150303 depends on package: p5-JSON-XS>0 - not found
===>   Installing existing package /packages/All/p5-JSON-XS-3.01_2.txz
[93amd64-default-job-05] Installing p5-JSON-XS-3.01_2...
[93amd64-default-job-05] `-- Installing p5-common-sense-3.73_1...
[93amd64-default-job-05] |   `-- Installing perl5-5.20.3_8...
[93amd64-default-job-05] |   `-- Extracting perl5-5.20.3_8: .......... done
[93amd64-default-job-05] `-- Extracting p5-common-sense-3.73_1: ........ done
[93amd64-default-job-05] `-- Installing p5-Types-Serialiser-1.0_1...
[93amd64-default-job-05] `-- Extracting p5-Types-Serialiser-1.0_1: ......... 
done
[93amd64-default-job-05] Extracting p5-JSON-XS-3.01_2: .......... done
Message from perl5-5.20.3_8:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   p5-Groonga-API-0.03.20150303 depends on package: p5-JSON-XS>0 - found
===>   Returning to build of p5-Groonga-API-0.03.20150303
===>   p5-Groonga-API-0.03.20150303 depends on package: p5-Path-Extended>0 - 
not found
===>   Installing existing package /packages/All/p5-Path-Extended-0.23.txz
[93amd64-default-job-05] Installing p5-Path-Extended-0.23...
[93amd64-default-job-05] `-- Installing p5-File-Find-Rule-0.33_1...
[93amd64-default-job-05] |   `-- Installing p5-Text-Glob-0.09_1...
[93amd64-default-job-05] |   `-- Extracting p5-Text-Glob-0.09_1: ... done
[93amd64-default-job-05] |   `-- Installing p5-Number-Compare-0.03_1...
[93amd64-default-job-05] |   `-- Extracting p5-Number-Compare-0.03_1: ....... 
done
[93amd64-default-job-05] `-- Extracting p5-File-Find-Rule-0.33_1: ......... done
[93amd64-default-job-05] `-- Installing p5-File-Copy-Recursive-0.38_1...
[93amd64-default-job-05] `-- Extracting p5-File-Copy-Recursive-0.38_1: ... done
[93amd64-default-job-05] `-- Installing p5-Log-Dump-0.14_1...
[93amd64-default-job-05] |   `-- Installing p5-Data-Dump-1.23_1...
[93amd64-default-job-05] |   `-- Extracting p5-Data-Dump-1.23_1: .......... done
[93amd64-default-job-05] |   `-- Installing p5-Sub-Install-0.928_1...
[93amd64-default-job-05] |   `-- Extracting p5-Sub-Install-0.928_1: ....... done
[93amd64-default-job-05] `-- Extracting p5-Log-Dump-0.14_1: .......... done
[93amd64-default-job-05] Extracting p5-Path-Extended-0.23: .......... done
===>   p5-Groonga-API-0.03.20150303 depends on package: p5-Path-Extended>0 - 
found
===>   Returning to build of p5-Groonga-API-0.03.20150303
===>   p5-Groonga-API-0.03.20150303 depends on package: p5-Test-Differences>0 - 
not found
===>   Installing existing package /packages/All/p5-Test-Differences-0.630,1.txz
[93amd64-default-job-05] Installing p5-Test-Differences-0.630,1...
[93amd64-default-job-05] `-- Installing p5-Text-Diff-1.41_1...
[93amd64-default-job-05] |   `-- Installing p5-Algorithm-Diff-1.1903...
[93amd64-default-job-05] |   `-- Extracting p5-Algorithm-Diff-1.1903: ......... 
done
[93amd64-default-job-05] `-- Extracting p5-Text-Diff-1.41_1: .......... done
[93amd64-default-job-05] Extracting p5-Test-Differences-0.630,1: ....... done
===>   p5-Groonga-API-0.03.20150303 depends on package: p5-Test-Differences>0 - 
found
===>   Returning to build of p5-Groonga-API-0.03.20150303
===>   p5-Groonga-API-0.03.20150303 depends on package: 
p5-Test-UseAllModules>=0.10 - not found
===>   Installing existing package 
/packages/All/p5-Test-UseAllModules-0.17_1.txz
[93amd64-default-job-05] Installing p5-Test-UseAllModules-0.17_1...
[93amd64-default-job-05] Extracting p5-Test-UseAllModules-0.17_1: ....... done
===>   p5-Groonga-API-0.03.20150303 depends on package: 
p5-Test-UseAllModules>=0.10 - found
===>   Returning to build of p5-Groonga-API-0.03.20150303
===>   p5-Groonga-API-0.03.20150303 depends on package: perl5>=5.20<5.21 - found
===>   p5-Groonga-API-0.03.20150303 depends on package: perl5>=5.20<5.21 - found
===========================================================================
=======================<phase: lib-depends    >============================
===>   p5-Groonga-API-0.03.20150303 depends on shared library: libgroonga.so - 
not found
===>   Installing existing package /packages/All/groonga-5.0.9.txz
[93amd64-default-job-05] Installing groonga-5.0.9...
[93amd64-default-job-05] `-- Installing libzmq2-2.2.0_3...
[93amd64-default-job-05] `-- Extracting libzmq2-2.2.0_3: .......... done
[93amd64-default-job-05] `-- Installing msgpack-1.1.0...
[93amd64-default-job-05] `-- Extracting msgpack-1.1.0: .......... done
[93amd64-default-job-05] `-- Installing libevent2-2.0.22_1...
[93amd64-default-job-05] `-- Extracting libevent2-2.0.22_1: .......... done
[93amd64-default-job-05] `-- Installing ja-mecab-0.996_2...
[93amd64-default-job-05] |   `-- Installing libiconv-1.14_9...
[93amd64-default-job-05] |   `-- Extracting libiconv-1.14_9: .......... done
[93amd64-default-job-05] `-- Extracting ja-mecab-0.996_2: .......... done
[93amd64-default-job-05] `-- Installing pcre-8.37_4...
[93amd64-default-job-05] `-- Extracting pcre-8.37_4: .......... done
[93amd64-default-job-05] Extracting groonga-5.0.9: .......... done
Message from ja-mecab-0.996_2:
========================================================
                     **** NOTE ****
  ipadic was split into japanese/mecab-ipadic port.
========================================================
===>   p5-Groonga-API-0.03.20150303 depends on shared library: libgroonga.so - 
found (/usr/local/lib/libgroonga.so)
===>   Returning to build of p5-Groonga-API-0.03.20150303
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for p5-Groonga-API-0.03.20150303
UNKNOWN TYPE: grn_user_data (grn_ctx.user_data) at inc/GroongaAPIUtil/APIs.pm 
line 290.
UNKNOWN TYPE: struct _grn_ctx_impl * (grn_ctx.impl) at 
inc/GroongaAPIUtil/APIs.pm line 290.
UNKNOWN TYPE: void ** (grn_ctx.trace) at inc/GroongaAPIUtil/APIs.pm line 290.
UNKNOWN TYPE: grn_section *
UNKNOWN TYPE: grn_obj_header *
UNKNOWN TYPE: grn_obj_header (grn_obj.header) at inc/GroongaAPIUtil/APIs.pm 
line 290.
UNKNOWN TYPE: grn_expr_var *
UNKNOWN TYPE: uint32_t (grn_posting.sid) at inc/GroongaAPIUtil/APIs.pm line 290.
UNKNOWN TYPE: uint32_t (grn_posting.pos) at inc/GroongaAPIUtil/APIs.pm line 290.
UNKNOWN TYPE: uint32_t (grn_posting.tf) at inc/GroongaAPIUtil/APIs.pm line 290.
UNKNOWN TYPE: uint32_t (grn_posting.weight) at inc/GroongaAPIUtil/APIs.pm line 
290.
UNKNOWN TYPE: uint32_t (grn_posting.rest) at inc/GroongaAPIUtil/APIs.pm line 
290.
UNKNOWN TYPE: grn_table_group_result *
UNKNOWN TYPE: int * (grn_search_optarg.weight_vector) at 
inc/GroongaAPIUtil/APIs.pm line 290.
UNKNOWN TYPE: grn_index_datum *
UNKNOWN TYPE: grn_geo_point *
UNKNOWN TYPE: grn_snip_mapping *
UNKNOWN TYPE: grn_query_logger *
UNKNOWN TYPE: grn_str *
UNKNOWN TYPE: grn_table_scan_hit *
UNKNOWN TYPE: grn_obj_format *
Found groonga.h: /usr/local/include/groonga/groonga.h
INC: -I/usr/local/include/groonga
LIBS: -L/usr/local/lib -lgroonga
Found 413 APIs
Supported 356 APIs
Checking if your kit is complete...
Looks good
Generating a Unix-style Makefile
Writing Makefile for Groonga::API
Writing MYMETA.yml and MYMETA.json
===========================================================================
=======================<phase: build          >============================
===>  Building for p5-Groonga-API-0.03.20150303
cp lib/Groonga/API/Test.pm blib/lib/Groonga/API/Test.pm
cp lib/Groonga/API/Constants.pm blib/lib/Groonga/API/Constants.pm
cp lib/Groonga/API.pm blib/lib/Groonga/API.pm
cp lib/Groonga/API/Exports.pm blib/lib/Groonga/API/Exports.pm
cp lib/Ploonga.pm blib/lib/Ploonga.pm
Running Mkbootstrap for Groonga::API ()
chmod 644 API.bs
/usr/local/bin/perl5.20.3 /usr/local/lib/perl5/5.20/ExtUtils/xsubpp  -typemap 
/usr/local/lib/perl5/5.20/ExtUtils/typemap -typemap typemap  API.xs > API.xsc 
&& mv API.xsc API.c
cc -c  -I/usr/local/include/groonga  -O2 -pipe -fstack-protector 
-fno-strict-aliasing -O2 -pipe -fstack-protector -fno-strict-aliasing    
-DVERSION=\"0.03\"  -DXS_VERSION=\"0.03\" -DPIC -fPIC 
"-I/usr/local/lib/perl5/5.20/mach/CORE"   API.c
API.c: In function 'XS_Groonga__API_windows_base_dir':
API.c:16530: warning: assignment makes pointer from integer without a cast
API.c: In function 'boot_Groonga__API':
API.c:20843: error: expected expression before ';' token
*** [API.o] Error code 1

Stop in /wrkdirs/usr/ports/textproc/p5-Groonga-API/work/groonga-api-314060b.
*** [do-build] Error code 1

Stop in /usr/ports/textproc/p5-Groonga-API.
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to