You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     r...@freebsd.org
Last committer: r...@freebsd.org
Ident:          $FreeBSD: head/devel/gnome-builder/Makefile 398549 2015-10-03 
17:52:07Z rm $
Log URL:        
http://beefy2.nyi.freebsd.org/data/93amd64-default/402209/logs/gnome-builder-3.16.2.log
Build URL:      
http://beefy2.nyi.freebsd.org/build.html?mastername=93amd64-default&build=402209
Log:

====>> Building devel/gnome-builder
build started at Mon Nov 23 02:22:07 UTC 2015
port directory: /usr/ports/devel/gnome-builder
building for: FreeBSD 93amd64-default-job-06 9.3-RELEASE-p30 FreeBSD 
9.3-RELEASE-p30 amd64
maintained by: r...@freebsd.org
Makefile ident:      $FreeBSD: head/devel/gnome-builder/Makefile 398549 
2015-10-03 17:52:07Z rm $
Poudriere version: 3.1.9
Host OSVERSION: 1100085
Jail OSVERSION: 903000

---Begin Environment---
SHELL=/bin/csh
OSVERSION=903000
UNAME_v=FreeBSD 9.3-RELEASE-p30
UNAME_r=9.3-RELEASE-p30
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/93amd64-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=gnome-builder-3.16.2
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/93amd64-default/ref/.p/pool
MASTERNAME=93amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.9
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--disable-debug --prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake PKG_CONFIG=pkgconf 
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/gnome-builder/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/gnome-builder/work  
HOME=/wrkdirs/usr/ports/devel/gnome-builder/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh CONFIG_SITE=/usr/ports/Templates/config.site 
lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/gnome-builder/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/gnome-builder/work  
HOME=/wrkdirs/usr/ports/devel/gnome-builder/work TMPDIR="/tmp" NO_PIE=yes 
SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fstack-protector 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS="-I/usr/local/include"  LDFLAGS=" 
-L/usr/local/lib -fstack-protector" LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe 
-fstack-protector -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=9.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
GTK2_VERSION="2.10.0"
GTK3_VERSION="3.0.0"
DOCSDIR="share/doc/gnome-builder"
EXAMPLESDIR="share/examples/gnome-builder"
DATADIR="share/gnome-builder"
WWWDIR="www/gnome-builder"
ETCDIR="etc/gnome-builder"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/gnome-builder
DOCSDIR=/usr/local/share/doc/gnome-builder
EXAMPLESDIR=/usr/local/share/examples/gnome-builder
WWWDIR=/usr/local/www/gnome-builder
ETCDIR=/usr/local/etc/gnome-builder
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License GPLv3 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   gnome-builder-3.16.2 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.6.1_2.txz
[93amd64-default-job-06] Installing pkg-1.6.1_2...
[93amd64-default-job-06] Extracting pkg-1.6.1_2: .......... done
Message from pkg-1.6.1_2:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   gnome-builder-3.16.2 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of gnome-builder-3.16.2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv3 accepted by the user
===> Fetching all distfiles required by gnome-builder-3.16.2 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv3 accepted by the user
===> Fetching all distfiles required by gnome-builder-3.16.2 for building
=> SHA256 Checksum OK for gnome3/gnome-builder-3.16.2.tar.xz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv3 accepted by the user
===> Fetching all distfiles required by gnome-builder-3.16.2 for building
===>  Extracting for gnome-builder-3.16.2
=> SHA256 Checksum OK for gnome3/gnome-builder-3.16.2.tar.xz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for gnome-builder-3.16.2
===>  Applying FreeBSD patches for gnome-builder-3.16.2
===========================================================================
=======================<phase: build-depends  >============================
===>   gnome-builder-3.16.2 depends on executable: intltool-update - not found
===>   Installing existing package /packages/All/intltool-0.51.0.txz
[93amd64-default-job-06] Installing intltool-0.51.0...
[93amd64-default-job-06] `-- Installing libiconv-1.14_9...
[93amd64-default-job-06] `-- Extracting libiconv-1.14_9: .......... done
[93amd64-default-job-06] `-- Installing p5-XML-Parser-2.44...
[93amd64-default-job-06] |   `-- Installing expat-2.1.0_3...
[93amd64-default-job-06] |   `-- Extracting expat-2.1.0_3: .......... done
[93amd64-default-job-06] |   `-- Installing perl5-5.20.3_8...
[93amd64-default-job-06] |   `-- Extracting perl5-5.20.3_8: .......... done
[93amd64-default-job-06] `-- Extracting p5-XML-Parser-2.44: .......... done
[93amd64-default-job-06] Extracting intltool-0.51.0: .......... done
Message from perl5-5.20.3_8:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   gnome-builder-3.16.2 depends on executable: intltool-update - found
===>   Returning to build of gnome-builder-3.16.2
===>   gnome-builder-3.16.2 depends on executable: llvm-config35 - not found
===>   Installing existing package /packages/All/llvm35-3.5.2_1.txz
[93amd64-default-job-06] Installing llvm35-3.5.2_1...
[93amd64-default-job-06] `-- Installing libedit-3.1.20150325_1...
[93amd64-default-job-06] `-- Extracting libedit-3.1.20150325_1: .......... done
[93amd64-default-job-06] `-- Installing python27-2.7.10_1...
[93amd64-default-job-06] |   `-- Installing libffi-3.2.1...
[93amd64-default-job-06] |   | `-- Installing indexinfo-0.2.4...
[93amd64-default-job-06] |   | `-- Extracting indexinfo-0.2.4: .... done
[93amd64-default-job-06] |   `-- Extracting libffi-3.2.1: .......... done
[93amd64-default-job-06] |   `-- Installing gettext-runtime-0.19.6...
[93amd64-default-job-06] |   `-- Extracting gettext-runtime-0.19.6: .......... 
done
[93amd64-default-job-06] `-- Extracting python27-2.7.10_1: .......... done
[93amd64-default-job-06] `-- Installing libexecinfo-1.1_3...
[93amd64-default-job-06] `-- Extracting libexecinfo-1.1_3: ..... done
[93amd64-default-job-06] `-- Installing gcc-4.8.5...
[93amd64-default-job-06] |   `-- Installing mpc-1.0.3...
[93amd64-default-job-06] |   | `-- Installing gmp-5.1.3_2...
[93amd64-default-job-06] |   | `-- Extracting gmp-5.1.3_2: .......... done
[93amd64-default-job-06] |   | `-- Installing mpfr-3.1.2_2...
[93amd64-default-job-06] |   | `-- Extracting mpfr-3.1.2_2: .......... done
[93amd64-default-job-06] |   `-- Extracting mpc-1.0.3: ...... done
[93amd64-default-job-06] |   `-- Installing gcc-ecj-4.5...
[93amd64-default-job-06] |   `-- Extracting gcc-ecj-4.5: . done
[93amd64-default-job-06] |   `-- Installing binutils-2.25.1...
[93amd64-default-job-06] |   `-- Extracting binutils-2.25.1: .......... done
[93amd64-default-job-06] `-- Extracting gcc-4.8.5: .......... done
[93amd64-default-job-06] Extracting llvm35-3.5.2_1: .......... done
Message from python27-2.7.10_1:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
Message from gcc-4.8.5:
To ensure binaries built with this toolchain find appropriate versions
of the necessary run-time libraries, you may want to link using

<snip>
checking libintl.h presence... yes
checking for libintl.h... yes
checking for ngettext in libc... no
checking for bindtextdomain in -lintl... yes
checking for ngettext in -lintl... yes
checking for dgettext in -lintl... yes
checking for bind_textdomain_codeset... yes
checking for msgfmt... (cached) /usr/local/bin/msgfmt
checking for dcgettext... yes
checking if msgfmt accepts -c... yes
checking for gmsgfmt... (cached) /usr/local/bin/msgfmt
checking for xgettext... (cached) /usr/local/bin/xgettext
checking build system type... amd64-portbld-freebsd9.3
checking host system type... amd64-portbld-freebsd9.3
checking how to print strings... printf
checking for a sed that does not truncate output... (cached) /usr/bin/sed
checking for fgrep... (cached) /usr/bin/fgrep
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for BSD- or MS-compatible name lister (nm)... /usr/bin/nm -B
checking the name lister (/usr/bin/nm -B) interface... BSD nm
checking whether ln -s works... yes
checking the maximum length of command line arguments... (cached) 262144
checking whether the shell understands some XSI constructs... yes
checking whether the shell understands "+="... no
checking how to convert amd64-portbld-freebsd9.3 file names to 
amd64-portbld-freebsd9.3 format... func_convert_file_noop
checking how to convert amd64-portbld-freebsd9.3 file names to toolchain 
format... func_convert_file_noop
checking for /usr/bin/ld option to reload object files... -r
checking for objdump... objdump
checking how to recognize dependent libraries... pass_all
checking for dlltool... dlltool
checking how to associate runtime and link libraries... printf %s\n
checking for ar... ar
checking for archiver @FILE support... no
checking for strip... strip
checking for ranlib... ranlib
checking for gawk... (cached) /usr/bin/awk
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for sysroot... no
checking for mt... mt
checking if mt is a manifest tool... no
checking for dlfcn.h... (cached) yes
checking for objdir... .libs
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC -DPIC
checking if cc PIC flag -fPIC -DPIC works... yes
checking if cc static flag -static works... yes
checking if cc supports -c -o file.o... yes
checking if cc supports -c -o file.o... (cached) yes
checking whether the cc linker (/usr/bin/ld) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... freebsd9.3 ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking for appstream-util... no
checking pkg-config is at least version 0.16... yes
checking for llvm-config-3.5... no
checking for llvm-config35... llvm-config35
checking clang-c/Index.h usability... yes
checking clang-c/Index.h presence... yes
checking for clang-c/Index.h... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... (cached) /bin/mkdir -p
checking whether gmake sets $(MAKE)... yes
checking for style of include used by gmake... GNU
checking whether gmake supports nested variables... yes
checking whether UID '0' is supported by ustar format... yes
checking whether GID '0' is supported by ustar format... yes
checking how to create a ustar tar archive... (cached) /usr/bin/tar
checking dependency style of cc... gcc3
checking whether to enable maintainer-specific portions of Makefiles... yes
checking for BUILDER... yes
checking for LIBIDE... yes
checking for python3-config... /usr/local/bin/python3-config
checking for gobject-introspection... yes
checking for gmake... gmake
checking whether gmake supports nested variables... (cached) yes
checking for gcc... (cached) cc
checking whether we are using the GNU C compiler... (cached) yes
checking whether cc accepts -g... (cached) yes
checking for cc option to accept ISO C89... (cached) none needed
checking whether cc understands -c and -o together... (cached) yes
checking whether we are using the GNU C++ compiler... yes
checking whether c++ accepts -g... yes
checking how to run the C++ preprocessor... c++ -E
checking for ld used by c++... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking whether the c++ linker (/usr/bin/ld) supports shared libraries... yes
checking for c++ option to produce PIC... -fPIC -DPIC
checking if c++ PIC flag -fPIC -DPIC works... yes
checking if c++ static flag -static works... yes
checking if c++ supports -c -o file.o... yes
checking if c++ supports -c -o file.o... (cached) yes
checking whether the c++ linker (/usr/bin/ld) supports shared libraries... yes
checking dynamic linker characteristics... freebsd9.3 ld.so
checking how to hardcode library paths into programs... immediate
checking dependency style of c++... gcc3
checking for library containing strerror... none required
checking for ANSI C header files... (cached) yes
checking for an ANSI C-conforming const... yes
checking what warning flags to pass to the C++ compiler... -Wall -Wno-unused
checking what language compliance flags to pass to the C++ compiler... 
checking for gtk-doc... no
configure: WARNING:
  You will not be able to create source packages with 'make dist'
  because gtk-doc is not found.
checking for gtkdoc-check... no
checking for gtkdoc-check... no
checking for gtkdoc-rebase... no
checking for gtkdoc-mkpdf... no
checking whether to build gtk-doc documentation... no
checking for GTKDOC_DEPS... yes
checking that generated files are newer than configure... done
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/util/gb-version.h
config.status: creating data/icons/Makefile
config.status: creating data/libide-1.0.pc
config.status: creating data/gsettings/org.gnome.builder.editor.gschema.xml
config.status: creating 
data/gsettings/org.gnome.builder.editor.language.gschema.xml
config.status: creating 
data/gsettings/org.gnome.builder.experimental.gschema.xml
config.status: creating 
data/gsettings/org.gnome.builder.project-tree.gschema.xml
config.status: creating po/Makefile.in
config.status: creating config.h
config.status: executing default-1 commands
config.status: executing libtool commands
config.status: executing depfiles commands
config.status: executing po/stamp-it commands

gnome-builder configured with the following options:

Build Options

  prefix ............................... : /usr/local
  libdir ............................... : ${exec_prefix}/lib

Developer Build Options

  Debug Build .......................... : no
  Trace Build .......................... : no
  Maintainer Flags ..................... : no

Run "make" to build gnome-builder.

===========================================================================
=======================<phase: build          >============================
===>  Building for gnome-builder-3.16.2
gmake  all-recursive
gmake[1]: Entering directory 
'/wrkdirs/usr/ports/devel/gnome-builder/work/gnome-builder-3.16.2'
Making all in .
gmake[2]: Entering directory 
'/wrkdirs/usr/ports/devel/gnome-builder/work/gnome-builder-3.16.2'
  CC       libide/autotools/libide_1_0_la-ide-autotools-build-system.lo
In file included from ./libide/ide-build-system.h:24,
                 from libide/autotools/ide-autotools-build-system.h:22,
                 from libide/autotools/ide-autotools-build-system.c:22:
./libide/ide-object.h:28: error: redefinition of typedef 'IdeObject'
./libide/ide-types.h:83: error: previous declaration of 'IdeObject' was here
In file included from libide/autotools/ide-autotools-build-system.h:22,
                 from libide/autotools/ide-autotools-build-system.c:22:
./libide/ide-build-system.h:31: error: redefinition of typedef 'IdeBuildSystem'
./libide/ide-types.h:42: error: previous declaration of 'IdeBuildSystem' was 
here
In file included from libide/autotools/ide-autotools-builder.h:22,
                 from libide/autotools/ide-autotools-build-system.c:23:
./libide/ide-builder.h:28: error: redefinition of typedef 'IdeBuilder'
./libide/ide-types.h:38: error: previous declaration of 'IdeBuilder' was here
In file included from libide/autotools/ide-autotools-build-system.c:24:
./libide/ide-context.h:31: error: redefinition of typedef 'IdeContext'
./libide/ide-types.h:44: error: previous declaration of 'IdeContext' was here
In file included from libide/autotools/ide-autotools-build-system.c:25:
./libide/ide-device.h:28: error: redefinition of typedef 'IdeDevice'
./libide/ide-types.h:51: error: previous declaration of 'IdeDevice' was here
In file included from libide/autotools/ide-autotools-build-system.c:26:
./libide/ide-device-manager.h:29: error: redefinition of typedef 
'IdeDeviceManager'
./libide/ide-types.h:53: error: previous declaration of 'IdeDeviceManager' was 
here
In file included from libide/autotools/ide-autotools-build-system.c:27:
./libide/ide-file.h:28: error: redefinition of typedef 'IdeFile'
./libide/ide-types.h:71: error: previous declaration of 'IdeFile' was here
In file included from ./libide/ide-internal.h:25,
                 from libide/autotools/ide-autotools-build-system.c:28:
./libide/ide-back-forward-item.h:28: error: redefinition of typedef 
'IdeBackForwardItem'
./libide/ide-types.h:28: error: previous declaration of 'IdeBackForwardItem' 
was here
In file included from ./libide/ide-internal.h:26,
                 from libide/autotools/ide-autotools-build-system.c:28:
./libide/ide-back-forward-list.h:28: error: redefinition of typedef 
'IdeBackForwardList'
./libide/ide-types.h:30: error: previous declaration of 'IdeBackForwardList' 
was here
Makefile:4234: recipe for target 
'libide/autotools/libide_1_0_la-ide-autotools-build-system.lo' failed
gmake[2]: *** [libide/autotools/libide_1_0_la-ide-autotools-build-system.lo] 
Error 1
gmake[2]: Leaving directory 
'/wrkdirs/usr/ports/devel/gnome-builder/work/gnome-builder-3.16.2'
Makefile:5786: recipe for target 'all-recursive' failed
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory 
'/wrkdirs/usr/ports/devel/gnome-builder/work/gnome-builder-3.16.2'
Makefile:2028: recipe for target 'all' failed
gmake: *** [all] Error 2
*** [do-build] Error code 1

Stop in /usr/ports/devel/gnome-builder.
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to