You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     jessefrgsm...@yahoo.ca
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/games/atanks/Makefile 327730 2013-09-20 
17:36:33Z bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/10amd64-default/2013-10-17_07h20m58s/logs/atanks-5.1.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/10amd64-default/2013-10-17_07h20m58s
Log:

====>> Building games/atanks
build started at Thu Oct 17 15:06:23 UTC 2013
port directory: /usr/ports/games/atanks
building for: FreeBSD 10amd64-default-job-12 10.0-BETA1 FreeBSD 10.0-BETA1 
r256420 amd64
maintained by: jessefrgsm...@yahoo.ca
Makefile ident:      $FreeBSD: head/games/atanks/Makefile 327730 2013-09-20 
17:36:33Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1000500
UNAME_v=FreeBSD 10.0-BETA1 r256420
UNAME_r=10.0-BETA1
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/10amd64-default/ref
PKG_EXT=txz
tpid=46516
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=atanks-5.1
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=10amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" MAKE=gmake TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/atanks
DOCSDIR=/usr/local/share/doc/atanks
EXAMPLESDIR=/usr/local/share/examples/atanks
WWWDIR=/usr/local/www/atanks
ETCDIR=/usr/local/etc/atanks
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for atanks-5.1
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   atanks-5.1 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of atanks-5.1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by atanks-5.1 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by atanks-5.1 for building
=> SHA256 Checksum OK for atanks-5.1.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by atanks-5.1 for building
===>  Extracting for atanks-5.1
=> SHA256 Checksum OK for atanks-5.1.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for atanks-5.1
===>  Applying FreeBSD patches for atanks-5.1
===>   Applying FreeBSD patch /usr/ports/games/atanks/files/patch-Makefile
Hmm...  Looks like a unified diff to me...
The text leading up to this was:
--------------------------
|--- Makefile.orig      2010-06-10 10:03:35.000000000 -0300
|+++ Makefile   2010-06-10 11:00:00.000000000 -0300
--------------------------
Patching file Makefile using Plan A...
Hunk #1 succeeded at 16.
done
/usr/bin/sed -i.bak  -e 's}^INSTALL[    ]*=.*}INSTALL=install };'  -e 's/-m 
*755/-m555 -s/;'  -e 's/-m *644/-m444/;'  
/wrkdirs/usr/ports/games/atanks/work/atanks-5.1/Makefile
/usr/bin/sed -i.bak  -e 's/int Filter_File( struct dirent/int Filter_File( 
const struct dirent/'  
/wrkdirs/usr/ports/games/atanks/work/atanks-5.1/src/files.cpp
===========================================================================
=======================<phase: build-depends  >============================
===>   atanks-5.1 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1...Installing gettext-0.18.3.1... done
 done
===>   Returning to build of atanks-5.1
===========================================================================
=======================<phase: lib-depends    >============================
===>   atanks-5.1 depends on shared library: alleg - not found
===>    Verifying install for alleg in /usr/ports/devel/allegro
===>   Installing existing package /packages/All/allegro-4.4.2_1.txz
Installing allegro-4.4.2_1...Installing xproto-7.0.24... done
Installing xf86vidmodeproto-2.3.1... done
Installing xf86dgaproto-2.1... done
Installing xextproto-7.2.1... done
Installing renderproto-0.11.1... done
Installing libxcb-1.9.1...Installing libXdmcp-1.1.1... done
Installing libXau-1.0.8... done
Installing libxml2-2.8.0_2... done
Installing libpthread-stubs-0.3_3... done
 done
Installing libXxf86vm-1.1.3...Installing libXext-1.3.2,1...Installing 
libX11-1.6.2,1...Installing kbproto-1.0.6... done
 done
 done
 done
Installing libXxf86dga-1.1.4... done
Installing libXrender-0.9.8... done
Installing libXpm-3.5.11...Installing libSM-1.2.2,1...Installing 
libICE-1.0.8,1... done
 done
Installing libXt-1.1.4,1... done
 done
Installing libXfixes-5.0.1...Installing fixesproto-5.0... done
 done
Installing libXdamage-1.1.4...Installing damageproto-1.2.1... done
 done
Installing libXcursor-1.1.14... done
Installing dri2proto-2.8... done
Installing expat-2.1.0... done
Installing pciids-20131010... done
Installing png-1.5.17... done
Installing libdrm-2.4.17_1...Installing libpciaccess-0.13.2... done
 done
Installing libGLU-9.0.0...Installing libGL-7.6.1_4... done
 done
Installing portaudio-18.1_3... done
Installing libvorbis-1.3.3_1,3...Installing libogg-1.3.1,4... done
 done
Installing libsndfile-1.0.25_3...Installing flac-1.3.0_1... done
 done
Installing libsamplerate-0.1.8_3... done
Installing jackit-0.121.3_2...Installing celt-0.11.3_1... done
 done
Installing alsa-lib-1.0.27.2... done
 done
===>   Returning to build of atanks-5.1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for atanks-5.1
===========================================================================
=======================<phase: build          >============================
===>  Building for atanks-5.1
gmake[1]: Entering directory `/wrkdirs/usr/ports/games/atanks/work/atanks-5.1'
FLAGS=-DMACOSX gmake -C src -f Makefile.bsd
gmake[2]: Entering directory 
`/wrkdirs/usr/ports/games/atanks/work/atanks-5.1/src'
g++ -c atanks.cpp -o atanks.o -DMACOSX 
-DDATA_DIR=\"/usr/local/share/games/atanks\" -DNEW_GAMELOOP -Wno-write-strings 
-DTHREADS   -O2 -pipe -fno-strict-aliasing -g -Wall -Iinclude 
-I/usr/local/include 
gmake[2]: g++: Command not found
gmake[2]: *** [atanks.o] Error 127
gmake[2]: Leaving directory 
`/wrkdirs/usr/ports/games/atanks/work/atanks-5.1/src'
gmake[1]: *** [all] Error 2
gmake[1]: Leaving directory `/wrkdirs/usr/ports/games/atanks/work/atanks-5.1'
*** Error code 1

Stop.
make: stopped in /usr/ports/games/atanks
===>  Cleaning for atanks-5.1
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to