You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     jo...@stromnet.se
Last committer: t...@freebsd.org
Ident:          $FreeBSD: head/comms/telldus-core/Makefile 384038 2015-04-15 
08:20:27Z tijl $
Log URL:        
http://beefy8.nyi.freebsd.org/data/head-armv6-default/p402431_s291353/logs/telldus-core-2.1.2_1.log
Build URL:      
http://beefy8.nyi.freebsd.org/build.html?mastername=head-armv6-default&build=p402431_s291353
Log:

====>> Building comms/telldus-core
build started at Sat Nov 28 04:40:07 UTC 2015
port directory: /usr/ports/comms/telldus-core
building for: FreeBSD head-armv6-default-job-24 11.0-CURRENT FreeBSD 
11.0-CURRENT r291353 arm
maintained by: jo...@stromnet.se
Makefile ident:      $FreeBSD: head/comms/telldus-core/Makefile 384038 
2015-04-15 08:20:27Z tijl $
Poudriere version: 3.1.10
Host OSVERSION: 1100085
Jail OSVERSION: 1100090




!!! Jail is newer than host. (Jail: 1100090, Host: 1100085) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=armv6
UNAME_m=arm
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1100090
UNAME_v=FreeBSD 11.0-CURRENT r291353
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=screen
QEMU_EMULATING=1
MASTERMNT=/usr/local/poudriere/data/.m/head-armv6-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=telldus-core-2.1.2_1
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/head-armv6-default/ref/.p/pool
MASTERNAME=head-armv6-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.10
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/comms/telldus-core/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/comms/telldus-core/work  
HOME=/wrkdirs/usr/ports/comms/telldus-core/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/comms/telldus-core/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/comms/telldus-core/work  
HOME=/wrkdirs/usr/ports/comms/telldus-core/work TMPDIR="/tmp" NO_PIE=yes 
SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe 
-mfloat-abi=softfp  -fno-strict-aliasing"  CPP="/nxb-bin/usr/bin/cpp" 
CPPFLAGS=""  LDFLAGS="" LIBS=""  CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe 
-mfloat-abi=softfp -fno-strict-aliasing "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
CMAKE_BUILD_TYPE="release"
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/telldus-core"
EXAMPLESDIR="share/examples/telldus-core"
DATADIR="share/telldus-core"
WWWDIR="www/telldus-core"
ETCDIR="etc/telldus-core"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/telldus-core
DOCSDIR=/usr/local/share/doc/telldus-core
EXAMPLESDIR=/usr/local/share/examples/telldus-core
WWWDIR=/usr/local/www/telldus-core
ETCDIR=/usr/local/etc/telldus-core
--End SUB_LIST--

---Begin make.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
<snip>
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
=======================<phase: check-sanity   >============================
===>  License LGPL21 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   telldus-core-2.1.2_1 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.6.2.txz
[head-armv6-default-job-24] Installing pkg-1.6.2...
[head-armv6-default-job-24] Extracting pkg-1.6.2: .......... done
Message from pkg-1.6.2:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   telldus-core-2.1.2_1 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of telldus-core-2.1.2_1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License LGPL21 accepted by the user
===> Fetching all distfiles required by telldus-core-2.1.2_1 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License LGPL21 accepted by the user
===> Fetching all distfiles required by telldus-core-2.1.2_1 for building
=> SHA256 Checksum OK for telldus-core-2.1.2.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License LGPL21 accepted by the user
===> Fetching all distfiles required by telldus-core-2.1.2_1 for building
===>  Extracting for telldus-core-2.1.2_1
=> SHA256 Checksum OK for telldus-core-2.1.2.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for telldus-core-2.1.2_1
===>  Applying FreeBSD patches for telldus-core-2.1.2_1
===========================================================================
=======================<phase: build-depends  >============================
===>   telldus-core-2.1.2_1 depends on executable: help2man - not found
===>   Installing existing package /packages/All/help2man-1.43.3_1.txz
[head-armv6-default-job-24] Installing help2man-1.43.3_1...
[head-armv6-default-job-24] `-- Installing indexinfo-0.2.4...
[head-armv6-default-job-24] `-- Extracting indexinfo-0.2.4: .... done
[head-armv6-default-job-24] `-- Installing p5-Locale-gettext-1.06...
[head-armv6-default-job-24] |   `-- Installing gettext-runtime-0.19.6...
[head-armv6-default-job-24] |   `-- Extracting gettext-runtime-0.19.6: 
.......... done
[head-armv6-default-job-24] |   `-- Installing perl5-5.20.3_8...
[head-armv6-default-job-24] |   `-- Extracting perl5-5.20.3_8: .......... done
[head-armv6-default-job-24] `-- Extracting p5-Locale-gettext-1.06: .... done
[head-armv6-default-job-24] Extracting help2man-1.43.3_1: .......... done
Message from perl5-5.20.3_8:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   telldus-core-2.1.2_1 depends on executable: help2man - found
===>   Returning to build of telldus-core-2.1.2_1
===>   telldus-core-2.1.2_1 depends on file: /usr/local/bin/cmake - not found
===>   Installing existing package /packages/All/cmake-3.3.1.txz
[head-armv6-default-job-24] Installing cmake-3.3.1...
[head-armv6-default-job-24] `-- Installing expat-2.1.0_3...
[head-armv6-default-job-24] `-- Extracting expat-2.1.0_3: .......... done
[head-armv6-default-job-24] `-- Installing cmake-modules-3.3.1...
[head-armv6-default-job-24] `-- Extracting cmake-modules-3.3.1: .......... done
[head-armv6-default-job-24] `-- Installing curl-7.45.0...
[head-armv6-default-job-24] |   `-- Installing ca_root_nss-3.20.1...
[head-armv6-default-job-24] |   `-- Extracting ca_root_nss-3.20.1: ....... done
[head-armv6-default-job-24] `-- Extracting curl-7.45.0: .......... done
[head-armv6-default-job-24] `-- Installing libarchive-3.1.2_4,1...
[head-armv6-default-job-24] |   `-- Installing lzo2-2.09...
[head-armv6-default-job-24] |   `-- Extracting lzo2-2.09: .......... done
[head-armv6-default-job-24] `-- Extracting libarchive-3.1.2_4,1: .......... done
[head-armv6-default-job-24] `-- Installing jsoncpp-0.6.0.r2_2...
[head-armv6-default-job-24] `-- Extracting jsoncpp-0.6.0.r2_2: .......... done
[head-armv6-default-job-24] Extracting cmake-3.3.1: .......... done
Message from ca_root_nss-3.20.1:
********************************* WARNING *********************************

FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.

*********************************** NOTE **********************************

This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem

***************************************************************************
===>   telldus-core-2.1.2_1 depends on file: /usr/local/bin/cmake - found
===>   Returning to build of telldus-core-2.1.2_1
===========================================================================
=======================<phase: lib-depends    >============================
===>   telldus-core-2.1.2_1 depends on shared library: libftdi.so - not found
===>   Installing existing package /packages/All/libftdi-0.20_4.txz
[head-armv6-default-job-24] Installing libftdi-0.20_4...
[head-armv6-default-job-24] `-- Installing boost-libs-1.55.0_9...
[head-armv6-default-job-24] |   `-- Installing icu-55.1...
[head-armv6-default-job-24] |   `-- Extracting icu-55.1: .......... done
[head-armv6-default-job-24] `-- Extracting boost-libs-1.55.0_9: .......... done
[head-armv6-default-job-24] `-- Installing python27-2.7.10_1...
[head-armv6-default-job-24] |   `-- Installing libffi-3.2.1...
[head-armv6-default-job-24] |   `-- Extracting libffi-3.2.1: .......... done
[head-armv6-default-job-24] |   `-- Installing readline-6.3.8...
[head-armv6-default-job-24] |   `-- Extracting readline-6.3.8: .......... done
[head-armv6-default-job-24] `-- Extracting python27-2.7.10_1: .......... done
[head-armv6-default-job-24] Extracting libftdi-0.20_4: .......... done
Message from boost-libs-1.55.0_9:
You have built the Boost library with thread support.

Don't forget to add -pthread to your linker options when
linking your code.
Message from python27-2.7.10_1:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
===>   telldus-core-2.1.2_1 depends on shared library: libftdi.so - found 
(/usr/local/lib/libftdi.so)
===>   Returning to build of telldus-core-2.1.2_1
===>   telldus-core-2.1.2_1 depends on shared library: libconfuse.so - not found
===>   Installing existing package /packages/All/libconfuse-2.7_1.txz
[head-armv6-default-job-24] Installing libconfuse-2.7_1...
[head-armv6-default-job-24] Extracting libconfuse-2.7_1: ......... done
===>   telldus-core-2.1.2_1 depends on shared library: libconfuse.so - found 
(/usr/local/lib/libconfuse.so)
===>   Returning to build of telldus-core-2.1.2_1
===>   telldus-core-2.1.2_1 depends on shared library: libargp.so - not found
===>   Installing existing package /packages/All/argp-standalone-1.3_2.txz
[head-armv6-default-job-24] Installing argp-standalone-1.3_2...
[head-armv6-default-job-24] Extracting argp-standalone-1.3_2: ..... done
===>   telldus-core-2.1.2_1 depends on shared library: libargp.so - found 
(/usr/local/lib/libargp.so)
===>   Returning to build of telldus-core-2.1.2_1
===>   telldus-core-2.1.2_1 depends on shared library: libiconv.so - not found
===>   Installing existing package /packages/All/libiconv-1.14_9.txz
[head-armv6-default-job-24] Installing libiconv-1.14_9...
[head-armv6-default-job-24] Extracting libiconv-1.14_9: .......... done
===>   telldus-core-2.1.2_1 depends on shared library: libiconv.so - found 
(/usr/local/lib/libiconv.so)
===>   Returning to build of telldus-core-2.1.2_1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for telldus-core-2.1.2_1
===>  Performing in-source build
/bin/mkdir -p /wrkdirs/usr/ports/comms/telldus-core/work/telldus-core-2.1.2
-- The C compiler identification is Clang 3.7.0
-- The CXX compiler identification is Clang 3.7.0
-- Check for working C compiler: /nxb-bin/usr/bin/cc
-- Check for working C compiler: /nxb-bin/usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
CMake Error: Generator: execution of make failed. Make command was: 
"/usr/bin/make" "cmTC_76b3c/fast"
-- Detecting C compile features - failed
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Found Threads: TRUE  
-- Could NOT find PkgConfig (missing:  PKG_CONFIG_EXECUTABLE) 
-- checking for one of the modules 'libftdi'
-- Configuring incomplete, errors occurred!
See also 
"/wrkdirs/usr/ports/comms/telldus-core/work/telldus-core-2.1.2/CMakeFiles/CMakeOutput.log".
See also 
"/wrkdirs/usr/ports/comms/telldus-core/work/telldus-core-2.1.2/CMakeFiles/CMakeError.log".
*** Error code 1

Stop.
make: stopped in /usr/ports/comms/telldus-core
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to