You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     crest_maintai...@rlwinm.de
Last committer: din...@freebsd.org
Ident:          $FreeBSD: head/security/fastd-devel/Makefile 401293 2015-11-11 
18:42:24Z dinoex $
Log URL:        
http://beefy1.nyi.freebsd.org/data/93i386-default/402563/logs/fastd-devel-18.a.20151111.log
Build URL:      
http://beefy1.nyi.freebsd.org/build.html?mastername=93i386-default&build=402563
Log:

====>> Building security/fastd-devel
build started at Sun Nov 29 04:24:14 UTC 2015
port directory: /usr/ports/security/fastd-devel
building for: FreeBSD 93i386-default-job-14 9.3-RELEASE-p30 FreeBSD 
9.3-RELEASE-p30 i386
maintained by: crest_maintai...@rlwinm.de
Makefile ident:      $FreeBSD: head/security/fastd-devel/Makefile 401293 
2015-11-11 18:42:24Z dinoex $
Poudriere version: 3.1.10
Host OSVERSION: 1100085
Jail OSVERSION: 903000

---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
OSVERSION=903000
UNAME_v=FreeBSD 9.3-RELEASE-p30
UNAME_r=9.3-RELEASE-p30
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/93i386-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=fastd-devel-18.a.20151111
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/93i386-default/ref/.p/pool
MASTERNAME=93i386-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.10
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PKG_CONFIG_PATH=/usr/local/lib/pkgconfig/ PKG_CONFIG=pkgconf 
XDG_DATA_HOME=/wrkdirs/usr/ports/security/fastd-devel/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/security/fastd-devel/work  
HOME=/wrkdirs/usr/ports/security/fastd-devel/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/security/fastd-devel/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/security/fastd-devel/work  
HOME=/wrkdirs/usr/ports/security/fastd-devel/work TMPDIR="/tmp" NO_PIE=yes 
SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS="" LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe 
-fno-strict-aliasing"  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
CMAKE_BUILD_TYPE="release"
OSREL=9.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/fastd"
EXAMPLESDIR="share/examples/fastd"
DATADIR="share/fastd"
WWWDIR="www/fastd"
ETCDIR="etc/fastd"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/fastd
DOCSDIR=/usr/local/share/doc/fastd
EXAMPLESDIR=/usr/local/share/examples/fastd
WWWDIR=/usr/local/www/fastd
ETCDIR=/usr/local/etc/fastd
--End SUB_LIST--

---Begin make.conf---
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License BSD2CLAUSE accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   fastd-devel-18.a.20151111 depends on file: /usr/local/sbin/pkg - not 
found
===>   Installing existing package /packages/All/pkg-1.6.2.txz
[93i386-default-job-14] Installing pkg-1.6.2...
[93i386-default-job-14] Extracting pkg-1.6.2: .......... done
Message from pkg-1.6.2:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   fastd-devel-18.a.20151111 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of fastd-devel-18.a.20151111
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License BSD2CLAUSE accepted by the user
===> Fetching all distfiles required by fastd-devel-18.a.20151111 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License BSD2CLAUSE accepted by the user
===> Fetching all distfiles required by fastd-devel-18.a.20151111 for building
=> SHA256 Checksum OK for 999b87b80302dbc14e23ef3dff187b91dae7fab5.tar.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License BSD2CLAUSE accepted by the user
===> Fetching all distfiles required by fastd-devel-18.a.20151111 for building
===>  Extracting for fastd-devel-18.a.20151111
=> SHA256 Checksum OK for 999b87b80302dbc14e23ef3dff187b91dae7fab5.tar.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for fastd-devel-18.a.20151111
===>  Applying FreeBSD patches for fastd-devel-18.a.20151111
===========================================================================
=======================<phase: build-depends  >============================
===>   fastd-devel-18.a.20151111 depends on executable: bison - not found
===>   Installing existing package /packages/All/bison-2.7.1,1.txz
[93i386-default-job-14] Installing bison-2.7.1,1...
[93i386-default-job-14] `-- Installing indexinfo-0.2.4...
[93i386-default-job-14] `-- Extracting indexinfo-0.2.4: .... done
[93i386-default-job-14] `-- Installing gettext-runtime-0.19.6...
[93i386-default-job-14] |   `-- Installing libiconv-1.14_9...
[93i386-default-job-14] |   `-- Extracting libiconv-1.14_9: .......... done
[93i386-default-job-14] `-- Extracting gettext-runtime-0.19.6: .......... done
[93i386-default-job-14] `-- Installing m4-1.4.17_1,1...
[93i386-default-job-14] `-- Extracting m4-1.4.17_1,1: .......... done
[93i386-default-job-14] Extracting bison-2.7.1,1: .......... done
===>   fastd-devel-18.a.20151111 depends on executable: bison - found
===>   Returning to build of fastd-devel-18.a.20151111
===>   fastd-devel-18.a.20151111 depends on file: /usr/local/bin/cmake - not 
found
===>   Installing existing package /packages/All/cmake-3.3.1.txz
[93i386-default-job-14] Installing cmake-3.3.1...
[93i386-default-job-14] `-- Installing expat-2.1.0_3...
[93i386-default-job-14] `-- Extracting expat-2.1.0_3: .......... done
[93i386-default-job-14] `-- Installing cmake-modules-3.3.1...
[93i386-default-job-14] `-- Extracting cmake-modules-3.3.1: .......... done
[93i386-default-job-14] `-- Installing curl-7.45.0...
[93i386-default-job-14] |   `-- Installing ca_root_nss-3.20.1...
[93i386-default-job-14] |   `-- Extracting ca_root_nss-3.20.1: ....... done
[93i386-default-job-14] `-- Extracting curl-7.45.0: .......... done
[93i386-default-job-14] `-- Installing libarchive-3.1.2_4,1...
[93i386-default-job-14] |   `-- Installing lzo2-2.09...
[93i386-default-job-14] |   `-- Extracting lzo2-2.09: .......... done
[93i386-default-job-14] `-- Extracting libarchive-3.1.2_4,1: .......... done
[93i386-default-job-14] `-- Installing jsoncpp-0.6.0.r2_2...
[93i386-default-job-14] `-- Extracting jsoncpp-0.6.0.r2_2: .......... done
[93i386-default-job-14] Extracting cmake-3.3.1: .......... done
Message from ca_root_nss-3.20.1:
********************************* WARNING *********************************

FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.

*********************************** NOTE **********************************

This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem

***************************************************************************
===>   fastd-devel-18.a.20151111 depends on file: /usr/local/bin/cmake - found
===>   Returning to build of fastd-devel-18.a.20151111
===>   fastd-devel-18.a.20151111 depends on executable: pkgconf - not found
===>   Installing existing package /packages/All/pkgconf-0.9.12_1.txz
[93i386-default-job-14] Installing pkgconf-0.9.12_1...
[93i386-default-job-14] Extracting pkgconf-0.9.12_1: ....... done
===>   fastd-devel-18.a.20151111 depends on executable: pkgconf - found
===>   Returning to build of fastd-devel-18.a.20151111
===========================================================================
=======================<phase: lib-depends    >============================
===>   fastd-devel-18.a.20151111 depends on shared library: libjson-c.so - not 
found
===>   Installing existing package /packages/All/json-c-0.12_2.txz
[93i386-default-job-14] Installing json-c-0.12_2...
[93i386-default-job-14] Extracting json-c-0.12_2: .......... done
===>   fastd-devel-18.a.20151111 depends on shared library: libjson-c.so - 
found (/usr/local/lib/libjson-c.so)
===>   Returning to build of fastd-devel-18.a.20151111
===>   fastd-devel-18.a.20151111 depends on shared library: libsodium.so - not 
found
===>   Installing existing package /packages/All/libsodium-1.0.3.txz
[93i386-default-job-14] Installing libsodium-1.0.3...
[93i386-default-job-14] Extracting libsodium-1.0.3: .......... done
===>   fastd-devel-18.a.20151111 depends on shared library: libsodium.so - 
found (/usr/local/lib/libsodium.so)
===>   Returning to build of fastd-devel-18.a.20151111
===>   fastd-devel-18.a.20151111 depends on shared library: libuecc.so - not 
found
===>   Installing existing package /packages/All/libuecc-6.txz
[93i386-default-job-14] Installing libuecc-6...
[93i386-default-job-14] Extracting libuecc-6: ......... done
===>   fastd-devel-18.a.20151111 depends on shared library: libuecc.so - found 
(/usr/local/lib/libuecc.so)
===>   Returning to build of fastd-devel-18.a.20151111
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for fastd-devel-18.a.20151111
===>  Performing out-of-source build
/bin/mkdir -p /wrkdirs/usr/ports/security/fastd-devel/work/.build
-- The C compiler identification is GNU 4.2.1
-- The ASM compiler identification is GNU
-- Found assembler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Performing Test ARCH_X86
-- Performing Test ARCH_X86 - Success
-- Performing Test ARCH_X86_64
-- Performing Test ARCH_X86_64 - Failed
-- Found BISON: /usr/local/bin/bison (found suitable version "2.7.12-4996", 
minimum required is "2.5") 
-- checking for module 'libuecc>=6'
--   found libuecc, version 6
-- Found LIBUECC: /usr/local/lib/libuecc.so  
-- checking for module 'libsodium'
--   found libsodium, version 1.0.3
-- Found libsodium: /usr/local/lib/libsodium.so  
-- checking for module 'json-c'
--   found json-c, version 0.12
-- Found JSON_C: /usr/local/lib/libjson-c.so  
-- Performing Test HAVE_PCLMUL
-- Performing Test HAVE_PCLMUL - Failed
-- Performing Test HAVE_AI_ADDRCONFIG
-- Performing Test HAVE_AI_ADDRCONFIG - Success
-- Checking prototype get_current_dir_name for HAVE_GET_CURRENT_DIR_NAME - False
-- Looking for clock_gettime
-- Looking for clock_gettime - found
-- Performing Test HAVE_ENDIAN_H
-- Performing Test HAVE_ENDIAN_H - Failed
-- Performing Test HAVE_SYS_ENDIAN_H
-- Performing Test HAVE_SYS_ENDIAN_H - Success
-- Looking for be32toh
-- Looking for be32toh - found
-- Could NOT find Doxygen (missing:  DOXYGEN_EXECUTABLE) 
CMake Error at src/crypto/mac/ghash/pclmulqdq/CMakeLists.txt:9 (message):
  WITH_MAC_GHASH_PCLMULQDQ enabled, but there is no compiler support for
  -mpclmul


-- Configuring incomplete, errors occurred!
See also 
"/wrkdirs/usr/ports/security/fastd-devel/work/.build/CMakeFiles/CMakeOutput.log".
See also 
"/wrkdirs/usr/ports/security/fastd-devel/work/.build/CMakeFiles/CMakeError.log".
*** [do-configure] Error code 1

Stop in /usr/ports/security/fastd-devel.
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to