You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     po...@freebsd.org
Last committer: m...@freebsd.org
Ident:          $FreeBSD: head/games/asteroid/Makefile 385523 2015-05-06 
16:04:20Z mat $
Log URL:        
http://beefy8.nyi.freebsd.org/data/head-armv6-default/p402431_s291353/logs/asteroid-1.2.1_3.log
Build URL:      
http://beefy8.nyi.freebsd.org/build.html?mastername=head-armv6-default&build=p402431_s291353
Log:

====>> Building games/asteroid
build started at Sun Nov 29 18:28:09 UTC 2015
port directory: /usr/ports/games/asteroid
building for: FreeBSD head-armv6-default-job-24 11.0-CURRENT FreeBSD 
11.0-CURRENT r291353 arm
maintained by: po...@freebsd.org
Makefile ident:      $FreeBSD: head/games/asteroid/Makefile 385523 2015-05-06 
16:04:20Z mat $
Poudriere version: 3.1.10
Host OSVERSION: 1100085
Jail OSVERSION: 1100090




!!! Jail is newer than host. (Jail: 1100090, Host: 1100085) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=armv6
UNAME_m=arm
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1100090
UNAME_v=FreeBSD 11.0-CURRENT r291353
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=screen
QEMU_EMULATING=1
MASTERMNT=/usr/local/poudriere/data/.m/head-armv6-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=asteroid-1.2.1_3
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/head-armv6-default/ref/.p/pool
MASTERNAME=head-armv6-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.10
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for asteroid-1.2.1_3:
     DOCS=on: Build and/or install documentation
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
SDL_CONFIG=/usr/local/bin/sdl-config 
XDG_DATA_HOME=/wrkdirs/usr/ports/games/asteroid/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/games/asteroid/work  
HOME=/wrkdirs/usr/ports/games/asteroid/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
SDL_CONFIG=/usr/local/bin/sdl-config 
XDG_DATA_HOME=/wrkdirs/usr/ports/games/asteroid/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/games/asteroid/work  
HOME=/wrkdirs/usr/ports/games/asteroid/work TMPDIR="/tmp" NO_PIE=yes 
SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe 
-mfloat-abi=softfp  -fno-strict-aliasing"  CPP="/nxb-bin/usr/bin/cpp" 
CPPFLAGS=""  LDFLAGS=" -lm" LIBS=""  CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 
-pipe -mfloat-abi=softfp -fno-strict-aliasing "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
CMAKE_BUILD_TYPE="release"
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
GTK2_VERSION="2.10.0"
GTK3_VERSION="3.0.0"
DOCSDIR="share/doc/asteroid"
EXAMPLESDIR="share/examples/asteroid"
DATADIR="share/asteroid"
WWWDIR="www/asteroid"
ETCDIR="etc/asteroid"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/asteroid
DOCSDIR=/usr/local/share/doc/asteroid
EXAMPLESDIR=/usr/local/share/examples/asteroid
WWWDIR=/usr/local/www/asteroid
ETCDIR=/usr/local/etc/asteroid
--End SUB_LIST--

---Begin make.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
<snip>
[head-armv6-default-job-24] |   |   `-- Extracting mkfontdir-1.0.7: .. done
[head-armv6-default-job-24] |   | `-- Extracting font-misc-meltho-1.0.3_3: 
.......... done
[head-armv6-default-job-24] |   | `-- Installing font-bh-ttf-1.0.3_3...
[head-armv6-default-job-24] |   | `-- Extracting font-bh-ttf-1.0.3_3: 
.......... done
[head-armv6-default-job-24] |   | `-- Installing font-misc-ethiopic-1.0.3_3...
[head-armv6-default-job-24] |   | `-- Extracting font-misc-ethiopic-1.0.3_3: .. 
done
[head-armv6-default-job-24] |   | `-- Installing dejavu-2.35...
[head-armv6-default-job-24] |   | `-- Extracting dejavu-2.35: .......... done
[head-armv6-default-job-24] `-- Extracting pango-1.36.8_2: .......... done
[head-armv6-default-job-24] `-- Installing libXcursor-1.1.14_3...
[head-armv6-default-job-24] `-- Extracting libXcursor-1.1.14_3: .......... done
[head-armv6-default-job-24] `-- Installing libXinerama-1.1.3_3,1...
[head-armv6-default-job-24] |   `-- Installing xineramaproto-1.2.1...
[head-armv6-default-job-24] |   `-- Extracting xineramaproto-1.2.1: .. done
[head-armv6-default-job-24] `-- Extracting libXinerama-1.1.3_3,1: .......... 
done
[head-armv6-default-job-24] `-- Installing libXcomposite-0.4.4_3,1...
[head-armv6-default-job-24] |   `-- Installing compositeproto-0.4.2...
[head-armv6-default-job-24] |   `-- Extracting compositeproto-0.4.2: .... done
[head-armv6-default-job-24] `-- Extracting libXcomposite-0.4.4_3,1: .......... 
done
[head-armv6-default-job-24] `-- Installing libXi-1.7.5,1...
[head-armv6-default-job-24] |   `-- Installing inputproto-2.3.1...
[head-armv6-default-job-24] |   `-- Extracting inputproto-2.3.1: ..... done
[head-armv6-default-job-24] `-- Extracting libXi-1.7.5,1: .......... done
[head-armv6-default-job-24] `-- Installing atk-2.16.0...
[head-armv6-default-job-24] `-- Extracting atk-2.16.0: .......... done
[head-armv6-default-job-24] `-- Installing gdk-pixbuf2-2.32.1...
[head-armv6-default-job-24] |   `-- Installing jasper-1.900.1_15...
[head-armv6-default-job-24] |   | `-- Installing jpeg-turbo-1.4.2...
[head-armv6-default-job-24] |   | `-- Extracting jpeg-turbo-1.4.2: .......... 
done
[head-armv6-default-job-24] |   `-- Extracting jasper-1.900.1_15: .......... 
done
[head-armv6-default-job-24] |   `-- Installing tiff-4.0.6...
[head-armv6-default-job-24] |   | `-- Installing jbigkit-2.1_1...
[head-armv6-default-job-24] |   | `-- Extracting jbigkit-2.1_1: .......... done
[head-armv6-default-job-24] |   `-- Extracting tiff-4.0.6: .......... done
[head-armv6-default-job-24] `-- Extracting gdk-pixbuf2-2.32.1: .......... done
[head-armv6-default-job-24] `-- Installing shared-mime-info-1.4...
[head-armv6-default-job-24] `-- Extracting shared-mime-info-1.4: .......... done
[head-armv6-default-job-24] Extracting gtk-update-icon-cache-2.24.28: .... done
Message from python27-2.7.10_1:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
Message from perl5-5.20.3_8:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
Message from dejavu-2.35:
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/share/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
===>   asteroid-1.2.1_3 depends on executable: gtk-update-icon-cache - found
===>   Returning to build of asteroid-1.2.1_3
===========================================================================
=======================<phase: lib-depends    >============================
===>   asteroid-1.2.1_3 depends on shared library: libSDL.so - found 
(/usr/local/lib/libSDL.so)
===>   asteroid-1.2.1_3 depends on shared library: libSDL_mixer.so - not found
===>   Installing existing package /packages/All/sdl_mixer-1.2.12_10.txz
[head-armv6-default-job-24] Installing sdl_mixer-1.2.12_10...
[head-armv6-default-job-24] `-- Installing flac-1.3.1_1...
[head-armv6-default-job-24] |   `-- Installing libogg-1.3.2_1,4...
[head-armv6-default-job-24] |   `-- Extracting libogg-1.3.2_1,4: .......... done
[head-armv6-default-job-24] `-- Extracting flac-1.3.1_1: .......... done
[head-armv6-default-job-24] `-- Installing libmikmod-3.3.6_2...
[head-armv6-default-job-24] `-- Extracting libmikmod-3.3.6_2: .......... done
[head-armv6-default-job-24] `-- Installing smpeg-0.4.4_14...
[head-armv6-default-job-24] `-- Extracting smpeg-0.4.4_14: .......... done
[head-armv6-default-job-24] `-- Installing libvorbis-1.3.5,3...
[head-armv6-default-job-24] `-- Extracting libvorbis-1.3.5,3: .......... done
[head-armv6-default-job-24] `-- Installing timidity-0.2i_1...
[head-armv6-default-job-24] `-- Extracting timidity-0.2i_1: .......... done
[head-armv6-default-job-24] Extracting sdl_mixer-1.2.12_10: ......... done
===>   asteroid-1.2.1_3 depends on shared library: libSDL_mixer.so - found 
(/usr/local/lib/libSDL_mixer.so)
===>   Returning to build of asteroid-1.2.1_3
===>   asteroid-1.2.1_3 depends on shared library: libglut.so - not found
===>   Installing existing package /packages/All/freeglut-2.8.1_4.txz
[head-armv6-default-job-24] Installing freeglut-2.8.1_4...
[head-armv6-default-job-24] Extracting freeglut-2.8.1_4: .......... done
Message from freeglut-2.8.1_4:
Since FreeBSD has new USB stack, freeglut normally doesn't build on FreeBSD 8
(yet). To workaround this a small patch adds one include file and comments out
content of one function (only leaves return NULL).

This might cause side effects.  Joysticks do not work, and there might be ports
that do not compile or applications that crash because of this.

Do not hesitate to contact x...@freebsd.org if there are any issues and side
effects because of this.
===>   asteroid-1.2.1_3 depends on shared library: libglut.so - found 
(/usr/local/lib/libglut.so)
===>   Returning to build of asteroid-1.2.1_3
===>   asteroid-1.2.1_3 depends on shared library: libatk-1.0.so - found 
(/usr/local/lib/libatk-1.0.so)
===>   asteroid-1.2.1_3 depends on shared library: libgdk_pixbuf-2.0.so - found 
(/usr/local/lib/libgdk_pixbuf-2.0.so)
===>   asteroid-1.2.1_3 depends on shared library: libglib-2.0.so - found 
(/usr/local/lib/libglib-2.0.so)
===>   asteroid-1.2.1_3 depends on shared library: libgtk-x11-2.0.so - not found
===>   Installing existing package /packages/All/gtk2-2.24.28_1.txz
[head-armv6-default-job-24] Installing gtk2-2.24.28_1...
[head-armv6-default-job-24] `-- Installing cups-client-2.0.3_2...
[head-armv6-default-job-24] |   `-- Installing libgcrypt-1.6.4_2...
[head-armv6-default-job-24] |   | `-- Installing libgpg-error-1.20_1...
[head-armv6-default-job-24] |   | `-- Extracting libgpg-error-1.20_1: 
.......... done
[head-armv6-default-job-24] |   `-- Extracting libgcrypt-1.6.4_2: .......... 
done
[head-armv6-default-job-24] |   `-- Installing gnutls-3.3.17.1...
[head-armv6-default-job-24] |   | `-- Installing nettle-2.7.1...
[head-armv6-default-job-24] |   |   `-- Installing gmp-5.1.3_2...
[head-armv6-default-job-24] |   |   `-- Extracting gmp-5.1.3_2: .......... done
[head-armv6-default-job-24] |   | `-- Extracting nettle-2.7.1: .......... done
[head-armv6-default-job-24] |   | `-- Installing libtasn1-4.7...
[head-armv6-default-job-24] |   | `-- Extracting libtasn1-4.7: .......... done
[head-armv6-default-job-24] |   | `-- Installing libidn-1.31...
[head-armv6-default-job-24] |   | `-- Extracting libidn-1.31: .......... done
[head-armv6-default-job-24] |   | `-- Installing p11-kit-0.23.1_1...
[head-armv6-default-job-24] |   | `-- Extracting p11-kit-0.23.1_1: .......... 
done
[head-armv6-default-job-24] |   | `-- Installing trousers-tddl-0.3.10_7...
===> Creating users and/or groups.
Creating group '_tss' with gid '601'.
Creating user '_tss' with uid '601'.
[head-armv6-default-job-24] |   | `-- Extracting trousers-tddl-0.3.10_7: 
.......... done
[head-armv6-default-job-24] |   `-- Extracting gnutls-3.3.17.1: .......... done
[head-armv6-default-job-24] |   `-- Installing mDNSResponder-576.30.4...
[head-armv6-default-job-24] |   `-- Extracting mDNSResponder-576.30.4: 
.......... done
===> Creating users and/or groups.
Creating group 'cups' with gid '193'.
Creating user 'cups' with uid '193'.
[head-armv6-default-job-24] `-- Extracting cups-client-2.0.3_2: .......... done
[head-armv6-default-job-24] `-- Installing python-2.7_2,2...
[head-armv6-default-job-24] |   `-- Installing python2-2_3...
[head-armv6-default-job-24] |   `-- Extracting python2-2_3: ...... done
[head-armv6-default-job-24] `-- Extracting python-2.7_2,2: ..... done
[head-armv6-default-job-24] Extracting gtk2-2.24.28_1: .......... done
Message from trousers-tddl-0.3.10_7:
To run tcsd automatically, add the following line to /etc/rc.conf

tcsd_enable="YES"

You might want to edit /usr/local/etc/tcsd.conf to reflect your setup.

To use TPM, add your_account to '_tss' group like following:

# pw groupadd _tss -m your_account
===>   asteroid-1.2.1_3 depends on shared library: libgtk-x11-2.0.so - found 
(/usr/local/lib/libgtk-x11-2.0.so)
===>   Returning to build of asteroid-1.2.1_3
===>   asteroid-1.2.1_3 depends on shared library: libpango-1.0.so - found 
(/usr/local/lib/libpango-1.0.so)
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for asteroid-1.2.1_3
===>  Performing in-source build
/bin/mkdir -p /wrkdirs/usr/ports/games/asteroid/work/asteroid-ffeb0fd
-- The C compiler identification is Clang 3.7.0
-- The CXX compiler identification is Clang 3.7.0
-- Check for working C compiler: /nxb-bin/usr/bin/cc
-- Check for working C compiler: /nxb-bin/usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found OpenGL: /usr/local/lib/libGL.so  
-- Found GLUT: /usr/local/lib/libglut.so  
-- Found GTK2_GTK: /usr/local/lib/libgtk-x11-2.0.so  
-- Looking for include file pthread.h
CMake Error: Generator: execution of make failed. Make command was: 
"/usr/bin/make" "cmTC_fbb42/fast"
-- Looking for include file pthread.h - not found
-- Could NOT find Threads (missing:  Threads_FOUND) 
-- Found SDL: /usr/local/lib/libSDLmain.a;/usr/local/lib/libSDL.so  
-- Found SDL_mixer: /usr/local/lib/libSDL_mixer.so (found version "1.2.12") 
-- Configuring incomplete, errors occurred!
See also 
"/wrkdirs/usr/ports/games/asteroid/work/asteroid-ffeb0fd/CMakeFiles/CMakeOutput.log".
See also 
"/wrkdirs/usr/ports/games/asteroid/work/asteroid-ffeb0fd/CMakeFiles/CMakeError.log".
*** Error code 1

Stop.
make: stopped in /usr/ports/games/asteroid
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to