You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     b...@freebsd.org
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/benchmarks/fio/Makefile 401947 2015-11-19 
13:19:54Z bapt $
Log URL:        
http://beefy1.nyi.freebsd.org/data/93i386-default/403015/logs/fio-2.2.11.log
Build URL:      
http://beefy1.nyi.freebsd.org/build.html?mastername=93i386-default&build=403015
Log:

====>> Building benchmarks/fio
build started at Sun Dec  6 03:46:22 UTC 2015
port directory: /usr/ports/benchmarks/fio
building for: FreeBSD 93i386-default-job-19 9.3-RELEASE-p30 FreeBSD 
9.3-RELEASE-p30 i386
maintained by: b...@freebsd.org
Makefile ident:      $FreeBSD: head/benchmarks/fio/Makefile 401947 2015-11-19 
13:19:54Z bapt $
Poudriere version: 3.1.10
Host OSVERSION: 1100085
Jail OSVERSION: 903000

---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
OSVERSION=903000
UNAME_v=FreeBSD 9.3-RELEASE-p30
UNAME_r=9.3-RELEASE-p30
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/93i386-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=fio-2.2.11
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/93i386-default/ref/.p/pool
MASTERNAME=93i386-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.10
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for fio-2.2.11:
     EXAMPLES=on: Build and/or install examples
     GNUPLOT=off: Support for plotting graphs
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake XDG_DATA_HOME=/wrkdirs/usr/ports/benchmarks/fio/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/benchmarks/fio/work  
HOME=/wrkdirs/usr/ports/benchmarks/fio/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/benchmarks/fio/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/benchmarks/fio/work  
HOME=/wrkdirs/usr/ports/benchmarks/fio/work TMPDIR="/tmp" NO_PIE=yes 
SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS="" LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe 
-fno-strict-aliasing"  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=9.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/fio"
EXAMPLESDIR="share/examples/fio"
DATADIR="share/fio"
WWWDIR="www/fio"
ETCDIR="etc/fio"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/fio
DOCSDIR=/usr/local/share/doc/fio
EXAMPLESDIR=/usr/local/share/examples/fio
WWWDIR=/usr/local/www/fio
ETCDIR=/usr/local/etc/fio
--End SUB_LIST--

---Begin make.conf---
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License GPLv2 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   fio-2.2.11 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.6.2.txz
[93i386-default-job-19] Installing pkg-1.6.2...
[93i386-default-job-19] Extracting pkg-1.6.2: .......... done
Message from pkg-1.6.2:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   fio-2.2.11 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of fio-2.2.11
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by fio-2.2.11 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by fio-2.2.11 for building
=> SHA256 Checksum OK for fio-2.2.11.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv2 accepted by the user
===> Fetching all distfiles required by fio-2.2.11 for building
===>  Extracting for fio-2.2.11
=> SHA256 Checksum OK for fio-2.2.11.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for fio-2.2.11
===========================================================================
=======================<phase: build-depends  >============================
===>   fio-2.2.11 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.1_2.txz
[93i386-default-job-19] Installing gmake-4.1_2...
[93i386-default-job-19] `-- Installing indexinfo-0.2.4...
[93i386-default-job-19] `-- Extracting indexinfo-0.2.4: .... done
[93i386-default-job-19] `-- Installing libiconv-1.14_9...
[93i386-default-job-19] `-- Extracting libiconv-1.14_9: .......... done
[93i386-default-job-19] `-- Installing gettext-runtime-0.19.6...
[93i386-default-job-19] `-- Extracting gettext-runtime-0.19.6: .......... done
[93i386-default-job-19] Extracting gmake-4.1_2: .......... done
===>   fio-2.2.11 depends on executable: gmake - found
===>   Returning to build of fio-2.2.11
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for fio-2.2.11
===========================================================================
=======================<phase: build          >============================
===>  Building for fio-2.2.11
Makefile:20: config-host.mak: No such file or directory
FIO_VERSION = fio-2.2.11
Running configure for you...
Operating system              FreeBSD
CPU                           i386
Big endian                    no
Compiler                      cc
Cross compile                 no

Static build                  no
Wordsize                      32
zlib                          yes
Linux AIO support             no
POSIX AIO support             yes
POSIX AIO support needs -lrt  no
POSIX AIO fsync               yes
Solaris AIO support           no
__sync_fetch_and_add          no
libverbs                      no
rdmacm                        no
Linux fallocate               no
POSIX fadvise                 yes
POSIX fallocate               yes
sched_setaffinity(3 arg)      no
sched_setaffinity(2 arg)      no
clock_gettime                 yes
CLOCK_MONOTONIC               yes
CLOCK_MONOTONIC_RAW           no
CLOCK_MONOTONIC_PRECISE       yes
gettimeofday                  yes
fdatasync                     no
sync_file_range               no
EXT4 move extent              no
Linux splice(2)               no
GUASI                         no
Fusion-io atomic engine       no
libnuma                       no
strsep                        yes
strcasestr                    yes
strlcat                       yes
getopt_long_only()            yes
inet_aton                     yes
socklen_t                     yes
__thread                      yes
RUSAGE_THREAD                 yes
SCHED_IDLE                    no
TCP_NODELAY                   yes
Net engine window_size        yes
TCP_MAXSEG                    yes
RLIMIT_MEMLOCK                yes
pwritev/preadv                yes
IPv6 helpers                  yes
Rados Block Device engine     no
setvbuf                       yes
Gluster API engine            no
s390_z196_facilities          no
HDFS engine                   no
MTD                           no
lex/yacc for arithmetic       yes
getmntent                     no
getmntinfo                    yes
Static Assert                 yes
    CC gettime.o
    CC ioengines.o
    CC init.o
    CC stat.o
    CC log.o
    CC time.o
    CC filesetup.o
    CC eta.o
    CC verify.o
    CC memory.o
    CC io_u.o
   LEX lex.yy.c
lex: can't open lex.yy.c
Makefile:303: recipe for target 'lex.yy.c' failed
gmake: *** [lex.yy.c] Error 1
*** [do-build] Error code 1

Stop in /usr/ports/benchmarks/fio.
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to