You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     p...@freebsd.org
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/textproc/p5-CSS-Croco/Makefile 327773 2013-09-20 
23:17:30Z bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/10amd64-default/2013-10-17_07h20m58s/logs/p5-CSS-Croco-0.09.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/10amd64-default/2013-10-17_07h20m58s
Log:

====>> Building textproc/p5-CSS-Croco
build started at Thu Oct 17 15:45:57 UTC 2013
port directory: /usr/ports/textproc/p5-CSS-Croco
building for: FreeBSD 10amd64-default-job-19 10.0-BETA1 FreeBSD 10.0-BETA1 
r256420 amd64
maintained by: p...@freebsd.org
Makefile ident:      $FreeBSD: head/textproc/p5-CSS-Croco/Makefile 327773 
2013-09-20 23:17:30Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1000500
UNAME_v=FreeBSD 10.0-BETA1 r256420
UNAME_r=10.0-BETA1
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/10amd64-default/ref
PKG_EXT=txz
tpid=67370
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=p5-CSS-Croco-0.09
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=10amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
INSTALLDIRS="site" CC="cc" CCFLAGS="-O2 -pipe -fno-strict-aliasing" 
PREFIX="/usr/local"  INSTALLPRIVLIB="/usr/local/lib" 
INSTALLARCHLIB="/usr/local/lib"
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh 
PERL_EXTUTILS_AUTOINSTALL="--skipdeps" PERL_MM_USE_DEFAULT="YES"
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local 
 LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/CSS-Croco
DOCSDIR=/usr/local/share/doc/CSS-Croco
EXAMPLESDIR=/usr/local/share/examples/CSS-Croco
WWWDIR=/usr/local/www/CSS-Croco
ETCDIR=/usr/local/etc/CSS-Croco
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for p5-CSS-Croco-0.09
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   p5-CSS-Croco-0.09 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of p5-CSS-Croco-0.09
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by p5-CSS-Croco-0.09 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by p5-CSS-Croco-0.09 for building
=> SHA256 Checksum OK for CSS-Croco-0.09.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by p5-CSS-Croco-0.09 for building
===>  Extracting for p5-CSS-Croco-0.09
=> SHA256 Checksum OK for CSS-Croco-0.09.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for p5-CSS-Croco-0.09
===========================================================================
=======================<phase: build-depends  >============================
===>   p5-CSS-Croco-0.09 depends on package: p5-URI>=0 - not found
===>    Verifying install for p5-URI>=0 in /usr/ports/net/p5-URI
===>   Installing existing package /packages/All/p5-URI-1.60.txz
Installing p5-URI-1.60...Installing perl-5.14.4_2...Removing 
/usr/local/etc/perl5_version... Done.
Creating /usr/local/etc/perl5_version... Done.
Removing stale symlinks from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl5
Done.
 done
 done
===>   Returning to build of p5-CSS-Croco-0.09
===>   p5-CSS-Croco-0.09 depends on package: libcroco>=0.6 - not found
===>    Verifying install for libcroco>=0.6 in /usr/ports/textproc/libcroco
===>   Installing existing package /packages/All/libcroco-0.6.8.txz
Installing libcroco-0.6.8...Installing libxml2-2.8.0_2... done
Installing python27-2.7.5_3...Installing gettext-0.18.3.1... done
 done
Installing python2-2_1... done
Installing python-2.7_1,2... done
Installing pcre-8.33... done
Installing libffi-3.0.13... done
Installing glib-2.36.3...No schema files found: doing nothing.
 done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of p5-CSS-Croco-0.09
===>   p5-CSS-Croco-0.09 depends on file: /usr/local/bin/perl5.14.4 - found
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for p5-CSS-Croco-0.09
NA: libcroco-0.6 is not available. Please intall it and try again
Checking if your kit is complete...
Looks good
Writing Makefile for CSS::Croco
Writing MYMETA.yml
===========================================================================
=======================<phase: build          >============================
===>  Building for p5-CSS-Croco-0.09
cp lib/CSS/Croco/Term/URI.pm blib/lib/CSS/Croco/Term/URI.pm
cp lib/CSS/Croco/Term/Number.pm blib/lib/CSS/Croco/Term/Number.pm
cp lib/CSS/Croco/Statement.pm blib/lib/CSS/Croco/Statement.pm
cp lib/CSS/Croco/Term.pm blib/lib/CSS/Croco/Term.pm
cp lib/CSS/Croco/Statement/RuleSet.pm blib/lib/CSS/Croco/Statement/RuleSet.pm
cp lib/CSS/Croco/Selector.pm blib/lib/CSS/Croco/Selector.pm
cp lib/CSS/Croco/Term/Ident.pm blib/lib/CSS/Croco/Term/Ident.pm
cp lib/CSS/Croco/Term/Hash.pm blib/lib/CSS/Croco/Term/Hash.pm
cp lib/CSS/Croco/Statement/Media.pm blib/lib/CSS/Croco/Statement/Media.pm
cp lib/CSS/Croco/Term/String.pm blib/lib/CSS/Croco/Term/String.pm
cp lib/CSS/Croco/StyleSheet.pm blib/lib/CSS/Croco/StyleSheet.pm
cp lib/CSS/Croco.pm blib/lib/CSS/Croco.pm
AutoSplitting blib/lib/CSS/Croco.pm (blib/lib/auto/CSS/Croco)
/usr/local/bin/perl5.14.4 "-Iinc" /usr/local/lib/perl5/5.14/ExtUtils/xsubpp  
-prototypes -typemap /usr/local/lib/perl5/5.14/ExtUtils/typemap -typemap 
typemap  Croco.xs > Croco.xsc && mv Croco.xsc Croco.c
cc -c  -I.  -O2 -pipe -fno-strict-aliasing -O2 -pipe -fno-strict-aliasing    
-DVERSION=\"0.09\"  -DXS_VERSION=\"0.09\" -DPIC -fPIC 
"-I/usr/local/lib/perl5/5.14/mach/CORE"   Croco.c
Croco.xs:7:10: fatal error: 'libcroco/libcroco.h' file not found
#include <libcroco/libcroco.h>
         ^
1 error generated.
*** Error code 1

Stop.
make[1]: stopped in /wrkdirs/usr/ports/textproc/p5-CSS-Croco/work/CSS-Croco-0.09
*** Error code 1

Stop.
make: stopped in /usr/ports/textproc/p5-CSS-Croco
===>  Cleaning for p5-CSS-Croco-0.09
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to