You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     marco.broe...@posteo.eu
Last committer: ko...@freebsd.org
Ident:          $FreeBSD: head/mail/trojita/Makefile 387540 2015-05-27 
04:47:15Z koobs $
Log URL:        
http://beefy8.nyi.freebsd.org/data/head-armv6-default/p403218_s291949/logs/trojita-0.5_1.log
Build URL:      
http://beefy8.nyi.freebsd.org/build.html?mastername=head-armv6-default&build=p403218_s291949
Log:

====>> Building mail/trojita
build started at Thu Dec 10 03:34:49 UTC 2015
port directory: /usr/ports/mail/trojita
building for: FreeBSD head-armv6-default-job-19 11.0-CURRENT FreeBSD 
11.0-CURRENT r291949 arm
maintained by: marco.broe...@posteo.eu
Makefile ident:      $FreeBSD: head/mail/trojita/Makefile 387540 2015-05-27 
04:47:15Z koobs $
Poudriere version: 3.1.10
Host OSVERSION: 1100085
Jail OSVERSION: 1100091




!!! Jail is newer than host. (Jail: 1100091, Host: 1100085) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=armv6
UNAME_m=arm
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1100091
UNAME_v=FreeBSD 11.0-CURRENT r291949
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=screen
QEMU_EMULATING=1
MASTERMNT=/usr/local/poudriere/data/.m/head-armv6-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=trojita-0.5_1
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/head-armv6-default/ref/.p/pool
MASTERNAME=head-armv6-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.10
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-qt-includes=/usr/local/include/qt5  --with-qt-libraries=/usr/local/lib  
--with-extra-includes=/usr/local/include  --with-extra-libs=/usr/local/lib
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
CPATH=/usr/local/include  LIBRARY_PATH=/usr/local/lib 
XDG_DATA_HOME=/wrkdirs/usr/ports/mail/trojita/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/mail/trojita/work  
HOME=/wrkdirs/usr/ports/mail/trojita/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh QTDIR="/usr/local" QMAKE="/usr/local/lib/qt5/bin/qmake"  
MOC="/usr/local/lib/qt5/bin/moc" RCC="/usr/local/lib/qt5/bin/rcc" 
UIC="/usr/local/lib/qt5/bin/uic"  
QMAKESPEC="/usr/local/lib/qt5/mkspecs/freebsd-$(ccver="$(/nxb-bin/usr/bin/c++ 
--version)"; case "$ccver" in *clang*) echo clang ;; *) echo g++ ;; esac)"
--End CONFIGURE_ENV--

--MAKE_ENV--
CPATH=/usr/local/include  LIBRARY_PATH=/usr/local/lib 
XDG_DATA_HOME=/wrkdirs/usr/ports/mail/trojita/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/mail/trojita/work  
HOME=/wrkdirs/usr/ports/mail/trojita/work TMPDIR="/tmp" NO_PIE=yes 
SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe 
-mfloat-abi=softfp  -fno-strict-aliasing"  CPP="/nxb-bin/usr/bin/cpp" 
CPPFLAGS=""  LDFLAGS="" LIBS=""  CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe 
-mfloat-abi=softfp -fno-strict-aliasing "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
QT_PREFIX="/usr/local"
QT_BINDIR="lib/qt5/bin"
QT_INCDIR="include/qt5"
QT_LIBDIR="lib"
QT_ARCHDIR="lib/qt5"
QT_PLUGINDIR="lib/qt5/plugins"
QT_LIBEXECDIR="libexec/qt5"
QT_IMPORTDIR="lib/qt5/imports"
QT_QMLDIR="lib/qt5/qml"
QT_DATADIR="share/qt5"
QT_DOCDIR="share/doc/qt5"
QT_L10NDIR="share/qt5/translations"
QT_ETCDIR="etc/xdg"
QT_EXAMPLEDIR="share/examples/qt5"
QT_TESTDIR="share/qt5/tests"
QT_MKSPECDIR="lib/qt5/mkspecs"
CMAKE_BUILD_TYPE="release"
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
GTK2_VERSION="2.10.0"
GTK3_VERSION="3.0.0"
DOCSDIR="share/doc/trojita"
EXAMPLESDIR="share/examples/trojita"
DATADIR="share/trojita"
WWWDIR="www/trojita"
ETCDIR="etc/trojita"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/trojita
DOCSDIR=/usr/local/share/doc/trojita
EXAMPLESDIR=/usr/local/share/examples/trojita
WWWDIR=/usr/local/www/trojita
ETCDIR=/usr/local/etc/trojita
--End SUB_LIST--

---Begin make.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
<snip>
[head-armv6-default-job-19] |   | `-- Installing gobject-introspection-1.44.0...
[head-armv6-default-job-19] |   |   `-- Installing python2-2_3...
[head-armv6-default-job-19] |   |   `-- Extracting python2-2_3: ...... done
[head-armv6-default-job-19] |   | `-- Extracting gobject-introspection-1.44.0: 
.......... done
[head-armv6-default-job-19] |   `-- Extracting gstreamer-0.10.36_4: .......... 
done
[head-armv6-default-job-19] `-- Extracting gstreamer-plugins-0.10.36_6,3: 
.......... done
[head-armv6-default-job-19] `-- Installing libxslt-1.1.28_8...
[head-armv6-default-job-19] |   `-- Installing libgcrypt-1.6.4_2...
[head-armv6-default-job-19] |   | `-- Installing libgpg-error-1.20_1...
[head-armv6-default-job-19] |   | `-- Extracting libgpg-error-1.20_1: 
.......... done
[head-armv6-default-job-19] |   `-- Extracting libgcrypt-1.6.4_2: .......... 
done
[head-armv6-default-job-19] `-- Extracting libxslt-1.1.28_8: .......... done
[head-armv6-default-job-19] `-- Installing libXcomposite-0.4.4_3,1...
[head-armv6-default-job-19] |   `-- Installing compositeproto-0.4.2...
[head-armv6-default-job-19] |   `-- Extracting compositeproto-0.4.2: .... done
[head-armv6-default-job-19] `-- Extracting libXcomposite-0.4.4_3,1: .......... 
done
[head-armv6-default-job-19] `-- Installing webp-0.4.4_1...
[head-armv6-default-job-19] |   `-- Installing giflib-5.1.1...
[head-armv6-default-job-19] |   `-- Extracting giflib-5.1.1: .......... done
[head-armv6-default-job-19] |   `-- Installing tiff-4.0.6...
[head-armv6-default-job-19] |   | `-- Installing jbigkit-2.1_1...
[head-armv6-default-job-19] |   | `-- Extracting jbigkit-2.1_1: .......... done
[head-armv6-default-job-19] |   `-- Extracting tiff-4.0.6: .......... done
[head-armv6-default-job-19] `-- Extracting webp-0.4.4_1: .......... done
[head-armv6-default-job-19] Extracting qt5-webkit-5.4.1_2: .......... done
===>   trojita-0.5_1 depends on file: /usr/local/lib/libQt5WebKit.so - found
===>   Returning to build of trojita-0.5_1
===>   trojita-0.5_1 depends on file: /usr/local/lib/libQt5Widgets.so - found
===>   trojita-0.5_1 depends on executable: gtk-update-icon-cache - not found
===>   Installing existing package 
/packages/All/gtk-update-icon-cache-2.24.28.txz
[head-armv6-default-job-19] Installing gtk-update-icon-cache-2.24.28...
[head-armv6-default-job-19] `-- Installing pango-1.36.8_2...
[head-armv6-default-job-19] |   `-- Installing libXft-2.3.2_1...
[head-armv6-default-job-19] |   `-- Extracting libXft-2.3.2_1: ......... done
[head-armv6-default-job-19] `-- Extracting pango-1.36.8_2: .......... done
[head-armv6-default-job-19] `-- Installing libXcursor-1.1.14_3...
[head-armv6-default-job-19] `-- Extracting libXcursor-1.1.14_3: .......... done
[head-armv6-default-job-19] `-- Installing libXinerama-1.1.3_3,1...
[head-armv6-default-job-19] |   `-- Installing xineramaproto-1.2.1...
[head-armv6-default-job-19] |   `-- Extracting xineramaproto-1.2.1: .. done
[head-armv6-default-job-19] `-- Extracting libXinerama-1.1.3_3,1: .......... 
done
[head-armv6-default-job-19] `-- Installing atk-2.16.0...
[head-armv6-default-job-19] `-- Extracting atk-2.16.0: .......... done
[head-armv6-default-job-19] `-- Installing libXrandr-1.5.0...
[head-armv6-default-job-19] |   `-- Installing randrproto-1.5.0...
[head-armv6-default-job-19] |   `-- Extracting randrproto-1.5.0: .... done
[head-armv6-default-job-19] `-- Extracting libXrandr-1.5.0: .......... done
[head-armv6-default-job-19] `-- Installing gdk-pixbuf2-2.32.1...
[head-armv6-default-job-19] |   `-- Installing jasper-1.900.1_15...
[head-armv6-default-job-19] |   `-- Extracting jasper-1.900.1_15: .......... 
done
[head-armv6-default-job-19] `-- Extracting gdk-pixbuf2-2.32.1: .......... done
[head-armv6-default-job-19] `-- Installing shared-mime-info-1.4...
[head-armv6-default-job-19] `-- Extracting shared-mime-info-1.4: .......... done
[head-armv6-default-job-19] Extracting gtk-update-icon-cache-2.24.28: .... done
===>   trojita-0.5_1 depends on executable: gtk-update-icon-cache - found
===>   Returning to build of trojita-0.5_1
===========================================================================
=======================<phase: lib-depends    >============================
===>   trojita-0.5_1 depends on shared library: libqt5keychain.so - not found
===>   Installing existing package /packages/All/qtkeychain-qt5-0.5.0.txz
[head-armv6-default-job-19] Installing qtkeychain-qt5-0.5.0...
[head-armv6-default-job-19] Extracting qtkeychain-qt5-0.5.0: .......... done
===>   trojita-0.5_1 depends on shared library: libqt5keychain.so - found 
(/usr/local/lib/libqt5keychain.so)
===>   Returning to build of trojita-0.5_1
===>   trojita-0.5_1 depends on shared library: libatk-1.0.so - found 
(/usr/local/lib/libatk-1.0.so)
===>   trojita-0.5_1 depends on shared library: libgdk_pixbuf-2.0.so - found 
(/usr/local/lib/libgdk_pixbuf-2.0.so)
===>   trojita-0.5_1 depends on shared library: libglib-2.0.so - found 
(/usr/local/lib/libglib-2.0.so)
===>   trojita-0.5_1 depends on shared library: libpango-1.0.so - found 
(/usr/local/lib/libpango-1.0.so)
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for trojita-0.5_1
===>  Performing in-source build
/bin/mkdir -p /wrkdirs/usr/ports/mail/trojita/work/trojita-0.5
-- The C compiler identification is Clang 3.7.0
-- The CXX compiler identification is Clang 3.7.0
-- Check for working C compiler: /nxb-bin/usr/bin/cc
-- Check for working C compiler: /nxb-bin/usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Performing Test _HAS_CXX11_FLAG
-- Performing Test _HAS_CXX11_FLAG - Success
-- Checking C++ support for "alignof"
-- Checking C++ support for "alignof": works
-- Checking C++ support for "auto"
-- Checking C++ support for "auto": works
-- Checking C++ support for "class_override_final"
-- Checking C++ support for "class_override_final": works
-- Checking C++ support for "constexpr"
-- Checking C++ support for "constexpr": works
-- Checking C++ support for "cstdint_header"
-- Checking C++ support for "cstdint_header": works
-- Checking C++ support for "decltype"
-- Checking C++ support for "decltype": works
-- Checking C++ support for "defaulted_functions"
-- Checking C++ support for "defaulted_functions": works
-- Checking C++ support for "deleted_functions"
-- Checking C++ support for "deleted_functions": works
-- Checking C++ support for "func_identifier"
CMake Error: Generator: execution of make failed. Make command was: 
"/usr/bin/make" "cmTC_60cdf/fast"
-- Checking C++ support for "func_identifier": not supported
-- Checking C++ support for "initializer_list"
-- Checking C++ support for "initializer_list": works
-- Checking C++ support for "lambda"
-- Checking C++ support for "lambda": works
-- Checking C++ support for "long_long"
CMake Error: Generator: execution of make failed. Make command was: 
"/usr/bin/make" "cmTC_c1eca/fast"
-- Checking C++ support for "long_long": not supported
-- Checking C++ support for "nullptr"
-- Checking C++ support for "nullptr": works
-- Checking C++ support for "rvalue_references"
-- Checking C++ support for "rvalue_references": works
-- Checking C++ support for "sizeof_member"
-- Checking C++ support for "sizeof_member": works
-- Checking C++ support for "static_assert"
-- Checking C++ support for "static_assert": works
-- Checking C++ support for "variadic_templates"
-- Checking C++ support for "variadic_templates": works
-- Found CXXFeatures: TRUE   
-- Disabling WITH_HARMATTAN because of NOT;WITH_DESKTOP
-- Building the Qt5 version
-- Package Qt5DBus is required because of WITH_DBUS
-- Found lupdate: Qt5::lupdate
-- Found lrelease: Qt5::lrelease
-- Found lconvert: Qt5::lconvert
-- Could NOT find Git (missing:  GIT_EXECUTABLE) 
-- Package Qt5Keychain is required because of WITH_QTKEYCHAIN_PLUGIN
-- Found QtKeychain library (includes at /usr/local/include, lib at qt5keychain)
-- Performing Test COMPILER_HAS_HIDDEN_VISIBILITY
-- Performing Test COMPILER_HAS_HIDDEN_VISIBILITY - Success
-- Performing Test COMPILER_HAS_HIDDEN_INLINE_VISIBILITY
-- Performing Test COMPILER_HAS_HIDDEN_INLINE_VISIBILITY - Success
-- Performing Test COMPILER_HAS_DEPRECATED_ATTR
-- Performing Test COMPILER_HAS_DEPRECATED_ATTR - Success
-- Looking for ragel
-- Package ZLIB is required because of WITH_ZLIB
-- Found ZLIB: /usr/lib/libz.so (found version "1.2.8") 
-- Support for COMPRESS=DEFLATE enabled
-- 

-- The following features have been enabled:

 * WITH_DESKTOP , Build desktop version
 * WITH_QT5 , Build with Qt5 library
 * WITH_DBUS , Build with DBus library
 * WITH_ZLIB , Build with zlib library
 * WITH_SHARED_PLUGINS , Enable shared dynamic plugins
 * WITH_CLEARTEXT_PLUGIN , Build Cleartext password plugin
 * WITH_QTKEYCHAIN_PLUGIN , Build Qtkeychain password plugin

-- The following OPTIONAL packages have been found:

 * Qt5LinguistTools
 * Qt5Test , Qt5 QTest library , <http://qt-project.org>
   Needed for automated tests
 * Qt5LinguistForTrojita

-- The following REQUIRED packages have been found:

 * Qt5Core (required version >= 5.2)
 * Qt5Gui
 * Qt5Network
 * Qt5Sql
 * Qt5WebKit (required version >= 5.4.1)
 * Qt5WebKitWidgets
 * Qt5Widgets
 * Qt5DBus , Qt5 D-Bus support , <http://qt-project.org>
   Needed for IPC anf for some plugins
 * Qt5Keychain , QtKeychain library (Qt5 version) , 
<https://github.com/frankosterfeld/qtkeychain>
   Needed for QtKeychain password plugin
 * ZLIB

-- The following features have been disabled:

 * WITH_HARMATTAN , Build MeeGo Harmattan version
 * WITH_RAGEL , Build with Ragel library
 * WITH_TESTS , Build tests

-- The following OPTIONAL packages have not been found:

 * Git
 * RagelForTrojita

-- Using pregenerated RFC 5322 parser
-- Available languages: 
ar;bs;ca;cs;da;de;el;en_GB;es;et;fi;fr;ga;gl;hu;ia;it;ja;lt;mr;nb;nds;nl;pl;pt;pt_BR;ro;sk;sv;tr;ug;uk;x-test;zh_CN;zh_TW
-- Building shared plugin trojita_plugin_ClearTextPasswordPlugin
-- Building shared plugin trojita_plugin_QtKeychainPasswordPlugin
-- Configuring incomplete, errors occurred!
See also 
"/wrkdirs/usr/ports/mail/trojita/work/trojita-0.5/CMakeFiles/CMakeOutput.log".
*** Error code 1

Stop.
make: stopped in /usr/ports/mail/trojita
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to