You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     jbe...@freebsd.org
Last committer: jbe...@freebsd.org
Ident:          $FreeBSD: head/devel/fb-adb/Makefile 403069 2015-12-05 
15:04:05Z jbeich $
Log URL:        
http://beefy8.nyi.freebsd.org/data/head-armv6-default/p403218_s291949/logs/fb-adb-1.4.4.118.log
Build URL:      
http://beefy8.nyi.freebsd.org/build.html?mastername=head-armv6-default&build=p403218_s291949
Log:

====>> Building devel/fb-adb
build started at Fri Dec 11 01:35:00 UTC 2015
port directory: /usr/ports/devel/fb-adb
building for: FreeBSD head-armv6-default-job-16 11.0-CURRENT FreeBSD 
11.0-CURRENT r291949 arm
maintained by: jbe...@freebsd.org
Makefile ident:      $FreeBSD: head/devel/fb-adb/Makefile 403069 2015-12-05 
15:04:05Z jbeich $
Poudriere version: 3.1.10
Host OSVERSION: 1100085
Jail OSVERSION: 1100091




!!! Jail is newer than host. (Jail: 1100091, Host: 1100085) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=armv6
UNAME_m=arm
ABI_FILE=/usr/lib/crt1.o
OSVERSION=1100091
UNAME_v=FreeBSD 11.0-CURRENT r291949
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=screen
QEMU_EMULATING=1
MASTERMNT=/usr/local/poudriere/data/.m/head-armv6-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=fb-adb-1.4.4.118
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/head-armv6-default/ref/.p/pool
MASTERNAME=head-armv6-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.10
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for fb-adb-1.4.4.118:
     ASSERT=off: Enable debug assertions
     BASH=off: Install JSON parser used by bash-completion
     DEBUG=off: Build with debugging support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--mandir="/usr/local/man" --disable-checking --disable-debuggable-stubs 
--prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PYTHON3="/usr/local/bin/python3.4" HOST_CFLAGS=" -mfloat-abi=softfp 
-fno-strict-aliasing"  STUB_CFLAGS=""  CPPFLAGS="" CFLAGS="-O2 -pipe"  
HOST_LDFLAGS=" -Wl,-rpath=/usr/lib:/usr/local/lib "  STUB_LDFLAGS=""  
LDFLAGS="" LIBS="" MAKE=gmake ac_cv_path_PERL=/usr/local/bin/perl 
ac_cv_path_PERL_PATH=/usr/local/bin/perl PYTHON="/usr/local/bin/python3.4" 
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/fb-adb/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/fb-adb/work  
HOME=/wrkdirs/usr/ports/devel/fb-adb/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh CONFIG_SITE=/dev/null lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/fb-adb/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/fb-adb/work  
HOME=/wrkdirs/usr/ports/devel/fb-adb/work TMPDIR="/tmp" NO_PIE=yes 
SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  
LIBDIR="/usr/lib"  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 -pipe 
-mfloat-abi=softfp  -fno-strict-aliasing"  CPP="/nxb-bin/usr/bin/cpp" 
CPPFLAGS=""  LDFLAGS=" -Wl,-rpath=/usr/lib:/usr/local/lib" LIBS=""  
CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -mfloat-abi=softfp 
-fno-strict-aliasing "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PYTHON_INCLUDEDIR=include/python3.4
PYTHON_LIBDIR=lib/python3.4
PYTHON_PLATFORM=freebsd11
PYTHON_SITELIBDIR=lib/python3.4/site-packages
PYTHON_VERSION=python3.4
PYTHON_VER=3.4
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
PERL_VERSION=5.20.3
PERL_VER=5.20
PERL5_MAN1=lib/perl5/site_perl/man/man1
PERL5_MAN3=lib/perl5/site_perl/man/man3
SITE_PERL=lib/perl5/site_perl
SITE_ARCH=lib/perl5/site_perl/mach/5.20
DOCSDIR="share/doc/fb-adb"
EXAMPLESDIR="share/examples/fb-adb"
DATADIR="share/fb-adb"
WWWDIR="www/fb-adb"
ETCDIR="etc/fb-adb"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/fb-adb
DOCSDIR=/usr/local/share/doc/fb-adb
EXAMPLESDIR=/usr/local/share/examples/fb-adb
WWWDIR=/usr/local/www/fb-adb
ETCDIR=/usr/local/etc/fb-adb
--End SUB_LIST--

---Begin make.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
<snip>
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
MACHINE=arm
MACHINE_ARCH=armv6
ARCH=${MACHINE_ARCH}
.sinclude "/etc/make.nxb.conf"
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
---Begin make.nxb.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
---End make.nxb.conf---
=======================<phase: check-sanity   >============================
===>  License BSD3CLAUSE accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   fb-adb-1.4.4.118 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.6.2.txz
[head-armv6-default-job-16] Installing pkg-1.6.2...
[head-armv6-default-job-16] Extracting pkg-1.6.2: .......... done
Message from pkg-1.6.2:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   fb-adb-1.4.4.118 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of fb-adb-1.4.4.118
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License BSD3CLAUSE accepted by the user
=> facebook-fb-adb-1.4.4-118-gbe2289d_GH0.tar.gz doesn't seem to exist in 
/portdistfiles/.
=> Attempting to fetch 
https://codeload.github.com/facebook/fb-adb/tar.gz/1.4.4-118-gbe2289d?dummy=/facebook-fb-adb-1.4.4-118-gbe2289d_GH0.tar.gz
fetch: 
https://codeload.github.com/facebook/fb-adb/tar.gz/1.4.4-118-gbe2289d?dummy=/facebook-fb-adb-1.4.4-118-gbe2289d_GH0.tar.gz:
 size unknown
fetch: 
https://codeload.github.com/facebook/fb-adb/tar.gz/1.4.4-118-gbe2289d?dummy=/facebook-fb-adb-1.4.4-118-gbe2289d_GH0.tar.gz:
 size of remote file is not known
facebook-fb-adb-1.4.4-118-gbe2289d_GH0.tar.gz            0  B    0  Bps
===> Fetching all distfiles required by fb-adb-1.4.4.118 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by fb-adb-1.4.4.118 for building
=> SHA256 Checksum OK for facebook-fb-adb-1.4.4-118-gbe2289d_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License BSD3CLAUSE accepted by the user
===> Fetching all distfiles required by fb-adb-1.4.4.118 for building
===>  Extracting for fb-adb-1.4.4.118
=> SHA256 Checksum OK for facebook-fb-adb-1.4.4-118-gbe2289d_GH0.tar.gz.
find: /wrkdirs/usr/ports/devel/fb-adb/work/android-ndk-r10e-linux-: No such 
file or directory
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for fb-adb-1.4.4.118
===>  Applying FreeBSD patches for fb-adb-1.4.4.118
===========================================================================
=======================<phase: build-depends  >============================
===>   fb-adb-1.4.4.118 depends on executable: xxd - not found
===>   Installing existing package /packages/All/vim-lite-7.4.960.txz
[head-armv6-default-job-16] Installing vim-lite-7.4.960...
[head-armv6-default-job-16] Extracting vim-lite-7.4.960: .......... done
===>   fb-adb-1.4.4.118 depends on executable: xxd - found
===>   Returning to build of fb-adb-1.4.4.118
===>   fb-adb-1.4.4.118 depends on executable: bash - not found
===>   Installing existing package /packages/All/bash-4.3.42_1.txz
[head-armv6-default-job-16] Installing bash-4.3.42_1...
[head-armv6-default-job-16] `-- Installing indexinfo-0.2.4...
[head-armv6-default-job-16] `-- Extracting indexinfo-0.2.4: .... done
[head-armv6-default-job-16] `-- Installing gettext-runtime-0.19.6...
[head-armv6-default-job-16] `-- Extracting gettext-runtime-0.19.6: .......... 
done
[head-armv6-default-job-16] Extracting bash-4.3.42_1: .......... done
Message from bash-4.3.42_1:
======================================================================

bash requires fdescfs(5) mounted on /dev/fd

If you have not done it yet, please do the following:

        mount -t fdescfs fdesc /dev/fd

To make it permanent, you need the following lines in /etc/fstab:

        fdesc   /dev/fd         fdescfs         rw      0       0

======================================================================
===>   fb-adb-1.4.4.118 depends on executable: bash - found
===>   Returning to build of fb-adb-1.4.4.118
===>   fb-adb-1.4.4.118 depends on executable: autoconf-2.69 - not found
===>   Installing existing package /packages/All/autoconf-2.69.txz
[head-armv6-default-job-16] Installing autoconf-2.69...
[head-armv6-default-job-16] `-- Installing autoconf-wrapper-20131203...
[head-armv6-default-job-16] `-- Extracting autoconf-wrapper-20131203: ........ 
done
[head-armv6-default-job-16] `-- Installing perl5-5.20.3_8...
[head-armv6-default-job-16] `-- Extracting perl5-5.20.3_8: .......... done
[head-armv6-default-job-16] `-- Installing m4-1.4.17_1,1...
[head-armv6-default-job-16] `-- Extracting m4-1.4.17_1,1: .......... done
[head-armv6-default-job-16] Extracting autoconf-2.69: .......... done
Message from perl5-5.20.3_8:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
===>   fb-adb-1.4.4.118 depends on executable: autoconf-2.69 - found
===>   Returning to build of fb-adb-1.4.4.118
===>   fb-adb-1.4.4.118 depends on executable: autoheader-2.69 - found
===>   fb-adb-1.4.4.118 depends on executable: autoreconf-2.69 - found
===>   fb-adb-1.4.4.118 depends on executable: aclocal-1.15 - not found
===>   Installing existing package /packages/All/automake-1.15_1.txz
[head-armv6-default-job-16] Installing automake-1.15_1...
[head-armv6-default-job-16] `-- Installing automake-wrapper-20131203...
[head-armv6-default-job-16] `-- Extracting automake-wrapper-20131203: ... done
[head-armv6-default-job-16] Extracting automake-1.15_1: .......... done
===>   fb-adb-1.4.4.118 depends on executable: aclocal-1.15 - found
===>   Returning to build of fb-adb-1.4.4.118
===>   fb-adb-1.4.4.118 depends on executable: automake-1.15 - found
===>   fb-adb-1.4.4.118 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.1_2.txz
[head-armv6-default-job-16] Installing gmake-4.1_2...
[head-armv6-default-job-16] Extracting gmake-4.1_2: .......... done
===>   fb-adb-1.4.4.118 depends on executable: gmake - found
===>   Returning to build of fb-adb-1.4.4.118
===>   fb-adb-1.4.4.118 depends on file: /usr/local/bin/python3.4 - not found
===>   Installing existing package /packages/All/python34-3.4.3_2.txz
[head-armv6-default-job-16] Installing python34-3.4.3_2...
[head-armv6-default-job-16] `-- Installing libffi-3.2.1...
[head-armv6-default-job-16] `-- Extracting libffi-3.2.1: .......... done
[head-armv6-default-job-16] `-- Installing readline-6.3.8...
[head-armv6-default-job-16] `-- Extracting readline-6.3.8: .......... done
[head-armv6-default-job-16] Extracting python34-3.4.3_2: .......... done
Message from python34-3.4.3_2:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

py34-gdbm       databases/py34-gdbm
py34-sqlite3    databases/py34-sqlite3
py34-tkinter    x11-toolkits/py34-tkinter

===========================================================================
===>   fb-adb-1.4.4.118 depends on file: /usr/local/bin/python3.4 - found
===>   Returning to build of fb-adb-1.4.4.118
===>   fb-adb-1.4.4.118 depends on executable: python3 - not found
===>   Installing existing package /packages/All/python3-3_3.txz
[head-armv6-default-job-16] Installing python3-3_3...
[head-armv6-default-job-16] Extracting python3-3_3: ...... done
===>   fb-adb-1.4.4.118 depends on executable: python3 - found
===>   Returning to build of fb-adb-1.4.4.118
===>   fb-adb-1.4.4.118 depends on package: perl5>=5.20<5.21 - found
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for fb-adb-1.4.4.118
checking build system type... armv6-portbld-freebsd11.0
checking host system type... armv6-portbld-freebsd11.0
configure: error: Android NDK location not given
===>  Script "configure" failed unexpectedly.
Please report the problem to jbe...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/devel/fb-adb/work/.build/config.log" including the output
of the failure of your make command. Also, it might be a good idea to provide
an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/fb-adb
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to