You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     nemy...@gmx.ch
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/games/netwalk/Makefile 327730 2013-09-20 
17:36:33Z bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/10amd64-default/2013-10-17_07h20m58s/logs/netwalk-0.4.10_2.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/10amd64-default/2013-10-17_07h20m58s
Log:

====>> Building games/netwalk
build started at Thu Oct 17 17:07:40 UTC 2013
port directory: /usr/ports/games/netwalk
building for: FreeBSD 10amd64-default-job-03 10.0-BETA1 FreeBSD 10.0-BETA1 
r256420 amd64
maintained by: nemy...@gmx.ch
Makefile ident:      $FreeBSD: head/games/netwalk/Makefile 327730 2013-09-20 
17:36:33Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1000500
UNAME_v=FreeBSD 10.0-BETA1 r256420
UNAME_r=10.0-BETA1
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/10amd64-default/ref
PKG_EXT=txz
tpid=69332
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=netwalk-0.4.10_2
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=10amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SDL_CONFIG=/usr/local/bin/sdl-config MAKE=gmake 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SDL_CONFIG=/usr/local/bin/sdl-config SHELL=/bin/sh 
NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" 
CFLAGS="-O2 -pipe -I/usr/local/include -L/usr/local/lib -fno-strict-aliasing"  
CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="c++" CXXFLAGS="-O2 -pipe 
-I/usr/local/include -L/usr/local/lib -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/netwalk
DOCSDIR=/usr/local/share/doc/netwalk
EXAMPLESDIR=/usr/local/share/examples/netwalk
WWWDIR=/usr/local/www/netwalk
ETCDIR=/usr/local/etc/netwalk
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for netwalk-0.4.10_2
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   netwalk-0.4.10_2 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of netwalk-0.4.10_2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License GPLv3 accepted by the user
===> Fetching all distfiles required by netwalk-0.4.10_2 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License GPLv3 accepted by the user
===> Fetching all distfiles required by netwalk-0.4.10_2 for building
=> SHA256 Checksum OK for netwalk/netwalk-0.4.10.tar.gz.
=> SHA256 Checksum OK for netwalk/screenshot-0.4.8.png.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License GPLv3 accepted by the user
===> Fetching all distfiles required by netwalk-0.4.10_2 for building
===>  Extracting for netwalk-0.4.10_2
=> SHA256 Checksum OK for netwalk/netwalk-0.4.10.tar.gz.
=> SHA256 Checksum OK for netwalk/screenshot-0.4.8.png.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for netwalk-0.4.10_2
===========================================================================
=======================<phase: build-depends  >============================
===>   netwalk-0.4.10_2 depends on file: /usr/local/bin/sdl-config - not found
===>    Verifying install for /usr/local/bin/sdl-config in 
/usr/ports/devel/sdl12
===>   Installing existing package /packages/All/sdl-1.2.15_2,2.txz
Installing sdl-1.2.15_2,2...Installing xproto-7.0.24... done
Installing xf86vidmodeproto-2.3.1... done
Installing xextproto-7.2.1... done
Installing renderproto-0.11.1... done
Installing randrproto-1.4.0... done
Installing libxcb-1.9.1...Installing libXdmcp-1.1.1... done
Installing libXau-1.0.8... done
Installing libxml2-2.8.0_2... done
Installing libpthread-stubs-0.3_3... done
 done
Installing libXxf86vm-1.1.3...Installing libXext-1.3.2,1...Installing 
libX11-1.6.2,1...Installing kbproto-1.0.6... done
 done
 done
 done
Installing libXrender-0.9.8... done
Installing libXrandr-1.4.2... done
Installing libXfixes-5.0.1...Installing fixesproto-5.0... done
 done
Installing libXdamage-1.1.4...Installing damageproto-1.2.1... done
 done
Installing dri2proto-2.8... done
Installing expat-2.1.0... done
Installing pciids-20131010... done
Installing libdrm-2.4.17_1...Installing libpciaccess-0.13.2... done
 done
Installing libGLU-9.0.0...Installing libGL-7.6.1_4... done
 done
Installing aalib-1.4.r5_6... done
 done
------------------------------------------------------------------------------
 Your SDL library has been built with libvgl support, which means that you
 can run almost any SDL application straight on your console (VESA 2.0
 compatible videocard is required).

 To do this you have to load the vesa kernel module or enable it in your
 kernel, and set environment variable "SDL_VIDEODRIVER=vgl".
------------------------------------------------------------------------------
===>   Returning to build of netwalk-0.4.10_2
===>   netwalk-0.4.10_2 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1...Installing gettext-0.18.3.1... done
 done
===>   Returning to build of netwalk-0.4.10_2
===>   netwalk-0.4.10_2 depends on file: /usr/local/libdata/pkgconfig/x11.pc - 
found
===>   netwalk-0.4.10_2 depends on file: /usr/local/libdata/pkgconfig/xau.pc - 
found
===>   netwalk-0.4.10_2 depends on file: /usr/local/libdata/pkgconfig/xdmcp.pc 
- found
===========================================================================
=======================<phase: lib-depends    >============================
===>   netwalk-0.4.10_2 depends on shared library: SDL-1.2 - found
===>   netwalk-0.4.10_2 depends on shared library: SDL_ttf-2.0 - not found
===>    Verifying install for SDL_ttf-2.0 in /usr/ports/graphics/sdl_ttf
===>   Installing existing package /packages/All/sdl_ttf-2.0.11.txz
Installing sdl_ttf-2.0.11...Installing freetype2-2.5.0.1... done
 done
===>   Returning to build of netwalk-0.4.10_2
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for netwalk-0.4.10_2
===========================================================================
=======================<phase: build          >============================
===>  Building for netwalk-0.4.10_2
gmake[1]: Entering directory 
`/wrkdirs/usr/ports/games/netwalk/work/blynn-netwalk-634e7c9'
echo '#define VERSION_STRING "'0.4.10'"' > version.h
echo '#define NETWALK_SHARE_DIR "'/usr/local'/share/netwalk"' > sharedir.h
ln -s linux/config_file.c config_file.c
gcc -o netwalk main.c game.c colour.c widget.c config.c config_file.c -O2 -pipe 
-I/usr/local/include -L/usr/local/lib -fno-strict-aliasing -Wall -O2 
-fomit-frame-pointer `/usr/local/bin/sdl-config --cflags` 
`/usr/local/bin/sdl-config --libs` -lSDL_ttf
gcc: not found
gmake[1]: *** [netwalk] Error 127
gmake[1]: Leaving directory 
`/wrkdirs/usr/ports/games/netwalk/work/blynn-netwalk-634e7c9'
*** Error code 1

Stop.
make: stopped in /usr/ports/games/netwalk
===>  Cleaning for netwalk-0.4.10_2
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to