You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     johnp...@gmail.com
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/devel/pecl-pthreads/Makefile 327724 2013-09-20 
17:13:42Z bapt $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/10i386-default/2013-10-17_04h52m04s/logs/pecl-pthreads-0.0.44.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/10i386-default/2013-10-17_04h52m04s
Log:

====>> Building devel/pecl-pthreads
build started at Thu Oct 17 17:38:23 UTC 2013
port directory: /usr/ports/devel/pecl-pthreads
building for: FreeBSD 10i386-default-job-18 10.0-BETA1 FreeBSD 10.0-BETA1 
r256420 i386
maintained by: johnp...@gmail.com
Makefile ident:      $FreeBSD: head/devel/pecl-pthreads/Makefile 327724 
2013-09-20 17:13:42Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=1000500
UNAME_v=FreeBSD 10.0-BETA1 r256420
UNAME_r=10.0-BETA1
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/10i386-default/ref
PKG_EXT=txz
tpid=21948
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=pecl-pthreads-0.0.44
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=10i386-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-php-config=/usr/local/bin/php-config --prefix=/usr/local 
${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh  
AUTOCONF=/usr/local/bin/autoconf-2.69  
AUTOCONF_DIR=/usr/local/share/autoconf-2.69  
AUTOHEADER=/usr/local/bin/autoheader-2.69  
AUTOIFNAMES=/usr/local/bin/ifnames-2.69  AUTOM4TE=/usr/local/bin/autom4te-2.69  
AUTORECONF=/usr/local/bin/autoreconf-2.69  
AUTOSCAN=/usr/local/bin/autoscan-2.69  
AUTOUPDATE=/usr/local/bin/autoupdate-2.69  AUTOCONF_VERSION=2.69  
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES  AUTOCONF=/usr/local/bin/autoconf-2.69  
AUTOCONF_DIR=/usr/local/share/autoconf-2.69  
AUTOHEADER=/usr/local/bin/autoheader-2.69  
AUTOIFNAMES=/usr/local/bin/ifnames-2.69  AUTOM4TE=/usr/local/bin/autom4te-2.69  
AUTORECONF=/usr/local/bin/autoreconf-2.69  
AUTOSCAN=/usr/local/bin/autoscan-2.69  
AUTOUPDATE=/usr/local/bin/autoupdate-2.69  AUTOCONF_VERSION=2.69  
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PHP_EXT_DIR=20100525
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/pthreads
DOCSDIR=/usr/local/share/doc/pthreads
EXAMPLESDIR=/usr/local/share/examples/pthreads
WWWDIR=/usr/local/www/pthreads
ETCDIR=/usr/local/etc/pthreads
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for pecl-pthreads-0.0.44
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   pecl-pthreads-0.0.44 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of pecl-pthreads-0.0.44
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License PHP301 accepted by the user
===> Fetching all distfiles required by pecl-pthreads-0.0.44 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License PHP301 accepted by the user
===> Fetching all distfiles required by pecl-pthreads-0.0.44 for building
=> SHA256 Checksum OK for PECL/pthreads-0.0.44.tgz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License PHP301 accepted by the user
===> Fetching all distfiles required by pecl-pthreads-0.0.44 for building
===>  Extracting for pecl-pthreads-0.0.44
=> SHA256 Checksum OK for PECL/pthreads-0.0.44.tgz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for pecl-pthreads-0.0.44
===========================================================================
=======================<phase: build-depends  >============================
===>   pecl-pthreads-0.0.44 depends on file: /usr/local/include/php/main/php.h 
- not found
===>    Verifying install for /usr/local/include/php/main/php.h in 
/usr/ports/lang/php5
===>   Installing existing package /packages/All/php5-5.4.20.txz
Installing php5-5.4.20...Installing libxml2-2.8.0_2... done
Installing pcre-8.33... done
 done
===>   Returning to build of pecl-pthreads-0.0.44
===>   pecl-pthreads-0.0.44 depends on file: /usr/local/bin/phpize - found
===>   pecl-pthreads-0.0.44 depends on file: /usr/local/bin/autoconf-2.69 - not 
found
===>    Verifying install for /usr/local/bin/autoconf-2.69 in 
/usr/ports/devel/autoconf
===>   Installing existing package /packages/All/autoconf-2.69.txz
Installing autoconf-2.69...Installing autoconf-wrapper-20130530... done
Installing m4-1.4.17,1... done
Installing perl-5.14.4_2...Removing /usr/local/etc/perl5_version... Done.
Creating /usr/local/etc/perl5_version... Done.
Removing stale symlinks from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl5
Done.
 done
 done
===>   Returning to build of pecl-pthreads-0.0.44
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  PHPizing for pecl-pthreads-0.0.44
Configuring for:
PHP Api Version:         20100412
Zend Module Api No:      20100525
Zend Extension Api No:   220100525
===>  Configuring for pecl-pthreads-0.0.44
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/devel/pecl-pthreads/work/pthreads-0.0.44/acinclude.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/devel/pecl-pthreads/work/pthreads-0.0.44/build/libtool.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/devel/pecl-pthreads/work/pthreads-0.0.44/aclocal.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/devel/pecl-pthreads/work/pthreads-0.0.44/configure
configure: loading site script /usr/ports/Templates/config.site
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking for a sed that does not truncate output... /usr/bin/sed
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cpp
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... i386-portbld-freebsd10.0
checking host system type... i386-portbld-freebsd10.0
checking target system type... i386-portbld-freebsd10.0
checking for PHP prefix... /usr/local
checking for PHP includes... -I/usr/local/include/php 
-I/usr/local/include/php/main -I/usr/local/include/php/TSRM 
-I/usr/local/include/php/Zend -I/usr/local/include/php/ext 
-I/usr/local/include/php/ext/date/lib
checking for PHP extension directory... /usr/local/lib/php/20100525
checking for PHP installed headers prefix... /usr/local/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to 
regenerate PHP parsers.
checking for gawk... (cached) /usr/bin/awk
checking if /usr/bin/awk is broken... no
checking whether to enable Threading API... yes, shared
checking checking for ZTS... configure: error: pthreads requires ZTS, please 
re-compile PHP with ZTS enabled
===>  Script "configure" failed unexpectedly.
Please report the problem to johnp...@gmail.com [maintainer] and attach the
"/wrkdirs/usr/ports/devel/pecl-pthreads/work/pthreads-0.0.44/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/pecl-pthreads
===>  Cleaning for pecl-pthreads-0.0.44
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to