You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     m...@aldan.algebra.com
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/x11/gpctool/Makefile 327777 2013-09-20 23:43:19Z 
bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/10amd64-default/2013-10-17_07h20m58s/logs/gpctool-1.0.1_3.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/10amd64-default/2013-10-17_07h20m58s
Log:

====>> Building x11/gpctool
build started at Thu Oct 17 17:51:35 UTC 2013
port directory: /usr/ports/x11/gpctool
building for: FreeBSD 10amd64-default-job-05 10.0-BETA1 FreeBSD 10.0-BETA1 
r256420 amd64
maintained by: m...@aldan.algebra.com
Makefile ident:      $FreeBSD: head/x11/gpctool/Makefile 327777 2013-09-20 
23:43:19Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1000500
UNAME_v=FreeBSD 10.0-BETA1 r256420
UNAME_r=10.0-BETA1
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/10amd64-default/ref
PKG_EXT=txz
tpid=54819
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=gpctool-1.0.1_3
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=10amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local 
 LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/gpctool
DOCSDIR=/usr/local/share/doc/gpctool
EXAMPLESDIR=/usr/local/share/examples/gpctool
WWWDIR=/usr/local/www/gpctool
ETCDIR=/usr/local/etc/gpctool
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for gpctool-1.0.1_3
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   gpctool-1.0.1_3 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of gpctool-1.0.1_3
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by gpctool-1.0.1_3 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by gpctool-1.0.1_3 for building
=> SHA256 Checksum OK for gpct101.zip.
===========================================================================
=======================<phase: extract-depends>============================
===>   gpctool-1.0.1_3 depends on file: /usr/local/bin/unzip - not found
===>    Verifying install for /usr/local/bin/unzip in /usr/ports/archivers/unzip
===>   Installing existing package /packages/All/unzip-6.0_1.txz
Installing unzip-6.0_1... done
===>   Returning to build of gpctool-1.0.1_3
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by gpctool-1.0.1_3 for building
===>  Extracting for gpctool-1.0.1_3
=> SHA256 Checksum OK for gpct101.zip.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for gpctool-1.0.1_3
===>  Applying FreeBSD patches for gpctool-1.0.1_3
/usr/bin/sed -i.bak -e 's|FALSE|false|g'  
/wrkdirs/usr/ports/x11/gpctool/work/gpct101/callbacks.c 
/wrkdirs/usr/ports/x11/gpctool/work/gpct101/graphics.c
===========================================================================
=======================<phase: build-depends  >============================
===>   gpctool-1.0.1_3 depends on file: /usr/local/libdata/pkgconfig/glproto.pc 
- not found
===>    Verifying install for /usr/local/libdata/pkgconfig/glproto.pc in 
/usr/ports/x11/glproto
===>   Installing existing package /packages/All/glproto-1.4.16.txz
Installing glproto-1.4.16... done
===>   Returning to build of gpctool-1.0.1_3
===>   gpctool-1.0.1_3 depends on file: 
/usr/local/libdata/pkgconfig/dri2proto.pc - not found
===>    Verifying install for /usr/local/libdata/pkgconfig/dri2proto.pc in 
/usr/ports/x11/dri2proto
===>   Installing existing package /packages/All/dri2proto-2.8.txz
Installing dri2proto-2.8... done
===>   Returning to build of gpctool-1.0.1_3
===========================================================================
=======================<phase: lib-depends    >============================
===>   gpctool-1.0.1_3 depends on shared library: libGLU.so - not found
===>    Verifying for libGLU.so in /usr/ports/graphics/libGLU
===>   Installing existing package /packages/All/libGLU-9.0.0.txz
Installing libGLU-9.0.0...Installing xproto-7.0.24... done
Installing xf86vidmodeproto-2.3.1... done
Installing xextproto-7.2.1... done
Installing libxcb-1.9.1...Installing libXdmcp-1.1.1... done
Installing libXau-1.0.8... done
Installing libxml2-2.8.0_2... done
Installing libpthread-stubs-0.3_3... done
 done
Installing libXxf86vm-1.1.3...Installing libXext-1.3.2,1...Installing 
libX11-1.6.2,1...Installing kbproto-1.0.6... done
 done
 done
 done
Installing libXfixes-5.0.1...Installing fixesproto-5.0... done
 done
Installing libXdamage-1.1.4...Installing damageproto-1.2.1... done
 done
Installing expat-2.1.0... done
Installing pciids-20131010... done
Installing libdrm-2.4.17_1...Installing libpciaccess-0.13.2... done
 done
Installing libGL-7.6.1_4... done
 done
===>   Returning to build of gpctool-1.0.1_3
===>   gpctool-1.0.1_3 depends on shared library: gpc - not found
===>    Verifying install for gpc in /usr/ports/devel/libgpc
===>   Installing existing package /packages/All/libgpc-2.32.txz
Installing libgpc-2.32... done
===>   Returning to build of gpctool-1.0.1_3
===>   gpctool-1.0.1_3 depends on shared library: formsGL.2 - not found
===>    Verifying install for formsGL.2 in /usr/ports/x11-toolkits/xforms
===>   Installing existing package /packages/All/xforms-1.0.93.s1,1.txz
Installing xforms-1.0.93.s1,1...Installing libXpm-3.5.11...Installing 
libSM-1.2.2,1...Installing libICE-1.0.8,1... done
 done
Installing libXt-1.1.4,1... done
 done
Installing tiff-4.0.3...Installing jpeg-8_4... done
Installing jbigkit-1.6... done
 done
 done
===>   Returning to build of gpctool-1.0.1_3
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for gpctool-1.0.1_3
===========================================================================
=======================<phase: build          >============================
===>  Building for gpctool-1.0.1_3
Warning: Object directory not changed from original 
/wrkdirs/usr/ports/x11/gpctool/work/gpct101
cc -O2 -pipe -fno-strict-aliasing  -I/usr/local/include/X11 
-I/usr/local/include -I/usr/local/include -std=gnu99 -Qunused-arguments 
-fstack-protector -Wsystem-headers -Werror -Wall -Wno-format-y2k 
-Wno-uninitialized -Wno-pointer-sign -Wno-empty-body -Wno-string-plus-int 
-Wno-tautological-compare -Wno-unused-value -Wno-parentheses-equality 
-Wno-unused-function -Wno-conversion -Wno-switch -Wno-switch-enum 
-Wno-knr-promoted-parameter -c gpctool.c
cc -O2 -pipe -fno-strict-aliasing  -I/usr/local/include/X11 
-I/usr/local/include -I/usr/local/include -std=gnu99 -Qunused-arguments 
-fstack-protector -Wsystem-headers -Werror -Wall -Wno-format-y2k 
-Wno-uninitialized -Wno-pointer-sign -Wno-empty-body -Wno-string-plus-int 
-Wno-tautological-compare -Wno-unused-value -Wno-parentheses-equality 
-Wno-unused-function -Wno-conversion -Wno-switch -Wno-switch-enum 
-Wno-knr-promoted-parameter -c main.c
cc -O2 -pipe -fno-strict-aliasing  -I/usr/local/include/X11 
-I/usr/local/include -I/usr/local/include -std=gnu99 -Qunused-arguments 
-fstack-protector -Wsystem-headers -Werror -Wall -Wno-format-y2k 
-Wno-uninitialized -Wno-pointer-sign -Wno-empty-body -Wno-string-plus-int 
-Wno-tautological-compare -Wno-unused-value -Wno-parentheses-equality 
-Wno-unused-function -Wno-conversion -Wno-switch -Wno-switch-enum 
-Wno-knr-promoted-parameter -c callbacks.c
cc -O2 -pipe -fno-strict-aliasing  -I/usr/local/include/X11 
-I/usr/local/include -I/usr/local/include -std=gnu99 -Qunused-arguments 
-fstack-protector -Wsystem-headers -Werror -Wall -Wno-format-y2k 
-Wno-uninitialized -Wno-pointer-sign -Wno-empty-body -Wno-string-plus-int 
-Wno-tautological-compare -Wno-unused-value -Wno-parentheses-equality 
-Wno-unused-function -Wno-conversion -Wno-switch -Wno-switch-enum 
-Wno-knr-promoted-parameter -c graphics.c
cc -O2 -pipe -fno-strict-aliasing  -I/usr/local/include/X11 
-I/usr/local/include -I/usr/local/include -std=gnu99 -Qunused-arguments 
-fstack-protector -Wsystem-headers -Werror -Wall -Wno-format-y2k 
-Wno-uninitialized -Wno-pointer-sign -Wno-empty-body -Wno-string-plus-int 
-Wno-tautological-compare -Wno-unused-value -Wno-parentheses-equality 
-Wno-unused-function -Wno-conversion -Wno-switch -Wno-switch-enum 
-Wno-knr-promoted-parameter -c psdump.c
cc -O2 -pipe -fno-strict-aliasing  -I/usr/local/include/X11 
-I/usr/local/include -I/usr/local/include -std=gnu99 -Qunused-arguments 
-fstack-protector -Wsystem-headers -Werror -Wall -Wno-format-y2k 
-Wno-uninitialized -Wno-pointer-sign -Wno-empty-body -Wno-string-plus-int 
-Wno-tautological-compare -Wno-unused-value -Wno-parentheses-equality 
-Wno-unused-function -Wno-conversion -Wno-switch -Wno-switch-enum 
-Wno-knr-promoted-parameter  -L/usr/local/lib -lformsGL -lGLU -L/usr/local/lib 
-lgpc -lm -o gpctool gpctool.o main.o callbacks.o graphics.o psdump.o 
/usr/bin/ld: 3: invalid DSO for symbol `fl_initialize' definition
/usr/local/lib/libforms.so.2: could not read symbols: Bad value
cc: error: linker command failed with exit code 1 (use -v to see invocation)
*** Error code 1

Stop.
make[1]: stopped in /wrkdirs/usr/ports/x11/gpctool/work/gpct101
*** Error code 1

Stop.
make: stopped in /usr/ports/x11/gpctool
===>  Cleaning for gpctool-1.0.1_3
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to