You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     step...@freebsd.org
Last committer: step...@freebsd.org
Ident:          $FreeBSD: head/math/octave-forge-video/Makefile 406549 
2016-01-18 06:18:50Z stephen $
Log URL:        
http://beefy6.nyi.freebsd.org/data/101amd64-default/406625/logs/octave-forge-video-1.2.1.log
Build URL:      
http://beefy6.nyi.freebsd.org/build.html?mastername=101amd64-default&build=406625
Log:

====>> Building math/octave-forge-video
build started at Tue Jan 19 05:13:40 UTC 2016
port directory: /usr/ports/math/octave-forge-video
building for: FreeBSD 101amd64-default-job-16 10.1-RELEASE-p27 FreeBSD 
10.1-RELEASE-p27 amd64
maintained by: step...@freebsd.org
Makefile ident:      $FreeBSD: head/math/octave-forge-video/Makefile 406549 
2016-01-18 06:18:50Z stephen $
Poudriere version: 3.1.10
Host OSVERSION: 1100091
Jail OSVERSION: 1001000

---Begin Environment---
SHELL=/bin/csh
UNAME_v=FreeBSD 10.1-RELEASE-p27
UNAME_r=10.1-RELEASE-p27
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=amd64
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/101amd64-default/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=octave-forge-video-1.2.1
OSREL=10.1
_OSRELEASE=10.1-RELEASE-p27
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=24
PWD=/usr/local/poudriere/data/.m/101amd64-default/ref/.p/pool
HAVE_COMPAT_IA32_KERN=YES LINUX_OSRELEASE=2.6.32
MASTERNAME=101amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.10
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1001000
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--prefix=/usr/local ${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
HOME=/wrkdirs/usr/ports/math/octave-forge-video/work/video-1.2.1/src 
F77="gfortran48" FC="gfortran48" FFLAGS="-O -Wl,-rpath=/usr/local/lib/gcc48" 
FCFLAGS="-Wl,-rpath=/usr/local/lib/gcc48" MAKE=gmake 
XDG_DATA_HOME=/wrkdirs/usr/ports/math/octave-forge-video/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/math/octave-forge-video/work  
HOME=/wrkdirs/usr/ports/math/octave-forge-video/work TMPDIR="/tmp" 
SHELL=/bin/sh CONFIG_SHELL=/bin/sh ADDR2LINE="/usr/local/bin/addr2line" 
AR="/usr/local/bin/ar" AS="/usr/local/bin/as" CPPFILT="/usr/local/bin/c++filt" 
GPROF="/usr/local/bin/gprof" LD="/usr/local/bin/ld" NM="/usr/local/bin/nm" 
OBJCOPY="/usr/local/bin/objcopy" OBJDUMP="/usr/local/bin/objdump" 
RANLIB="/usr/local/bin/ranlib" READELF="/usr/local/bin/readelf" 
SIZE="/usr/local/bin/size" STRINGS="/usr/local/bin/strings" 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
PACKAGE=/wrkdirs/usr/ports/math/octave-forge-video/work/video-1.2.1.tar.gz 
F77="gfortran48" FC="gfortran48" FFLAGS="-O -Wl,-rpath=/usr/local/lib/gcc48" 
FCFLAGS="-Wl,-rpath=/usr/local/lib/gcc48" 
XDG_DATA_HOME=/wrkdirs/usr/ports/math/octave-forge-video/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/math/octave-forge-video/work  
HOME=/wrkdirs/usr/ports/math/octave-forge-video/work TMPDIR="/tmp" NO_PIE=yes 
NO_DEBUG_FILES=yes SHELL=/bin/sh NO_LINT=YES 
ADDR2LINE="/usr/local/bin/addr2line" AR="/usr/local/bin/ar" 
AS="/usr/local/bin/as" CPPFILT="/usr/local/bin/c++filt" 
GPROF="/usr/local/bin/gprof" LD="/usr/local/bin/ld" NM="/usr/local/bin/nm" 
OBJCOPY="/usr/local/bin/objcopy" OBJDUMP="/usr/local/bin/objdump" 
RANLIB="/usr/local/bin/ranlib" READELF="/usr/local/bin/readelf" 
SIZE="/usr/local/bin/size" STRINGS="/usr/local/bin/strings" PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe  
-fstack-protector -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=" 
-Wl,-rpath=
 /usr/local/lib/gcc48  -L/usr/local/lib/gcc48 -B/usr/local/bin 
-fstack-protector" LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector 
-fno-strict-aliasing "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=10.1
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/octave-forge-video"
EXAMPLESDIR="share/examples/octave-forge-video"
DATADIR="share/octave-forge-video"
WWWDIR="www/octave-forge-video"
ETCDIR="etc/octave-forge-video"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/octave-forge-video
DOCSDIR=/usr/local/share/doc/octave-forge-video
EXAMPLESDIR=/usr/local/share/examples/octave-forge-video
WWWDIR=/usr/local/www/octave-forge-video
ETCDIR=/usr/local/etc/octave-forge-video
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License BSD2CLAUSE accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   octave-forge-video-1.2.1 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.6.2.txz
[101amd64-default-job-16] Installing pkg-1.6.2...
[101amd64-default-job-16] Extracting pkg-1.6.2: .......... done
Message from pkg-1.6.2:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   octave-forge-video-1.2.1 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of octave-forge-video-1.2.1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License BSD2CLAUSE accepted by the user
=> video-1.2.1.tar.gz doesn't seem to exist in /portdistfiles/octave-forge.
=> Attempting to fetch 
http://downloads.sourceforge.net/project/octave/Octave%20Forge%20Packages/Individual%20Package%20Releases/video-1.2.1.tar.gz
video-1.2.1.tar.gz                                       0  B    0  Bps
===> Fetching all distfiles required by octave-forge-video-1.2.1 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License BSD2CLAUSE accepted by the user
===> Fetching all distfiles required by octave-forge-video-1.2.1 for building
=> SHA256 Checksum OK for octave-forge/video-1.2.1.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License BSD2CLAUSE accepted by the user
===> Fetching all distfiles required by octave-forge-video-1.2.1 for building
===>  Extracting for octave-forge-video-1.2.1
=> SHA256 Checksum OK for octave-forge/video-1.2.1.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for octave-forge-video-1.2.1
===========================================================================
=======================<phase: build-depends  >============================
===>   octave-forge-video-1.2.1 depends on executable: octave - not found
===>   Installing existing package /packages/All/octave-4.0.0_1.txz
[101amd64-default-job-16] Installing octave-4.0.0_1...
[101amd64-default-job-16] `-- Installing glpk-4.52.1_3...
[101amd64-default-job-16] |   `-- Installing gmp-5.1.3_2...
[101amd64-default-job-16] |   | `-- Installing indexinfo-0.2.4...
[101amd64-default-job-16] |   | `-- Extracting indexinfo-0.2.4: .... done
[101amd64-default-job-16] |   `-- Extracting gmp-5.1.3_2: .......... done
[101amd64-default-job-16] `-- Extracting glpk-4.52.1_3: .......... done
[101amd64-default-job-16] `-- Installing fftw3-float-3.3.3_2...
[101amd64-default-job-16] `-- Extracting fftw3-float-3.3.3_2: .......... done
[101amd64-default-job-16] `-- Installing openblas-0.2.14,1...
[101amd64-default-job-16] |   `-- Installing gcc-4.8.5_2...
[101amd64-default-job-16] |   | `-- Installing mpc-1.0.3...
[101amd64-default-job-16] |   |   `-- Installing mpfr-3.1.3...
[101amd64-default-job-16] |   |   `-- Extracting mpfr-3.1.3: .......... done
[101amd64-default-job-16] |   | `-- Extracting mpc-1.0.3: ...... done
[101amd64-default-job-16] |   | `-- Installing binutils-2.25.1...
[101amd64-default-job-16] |   |   `-- Installing gettext-runtime-0.19.6...
[101amd64-default-job-16] |   |   `-- Extracting gettext-runtime-0.19.6: 
.......... done
[101amd64-default-job-16] |   | `-- Extracting binutils-2.25.1: .......... done
[101amd64-default-job-16] |   | `-- Installing gcc-ecj-4.5...
[101amd64-default-job-16] |   | `-- Extracting gcc-ecj-4.5: . done
[101amd64-default-job-16] |   `-- Extracting gcc-4.8.5_2: .......... done
[101amd64-default-job-16] `-- Extracting openblas-0.2.14,1: ......... done
[101amd64-default-job-16] `-- Installing GraphicsMagick-1.3.23_2,1...
[101amd64-default-job-16] |   `-- Installing jbigkit-2.1_1...
[101amd64-default-job-16] |   `-- Extracting jbigkit-2.1_1: .......... done
[101amd64-default-job-16] |   `-- Installing jasper-1.900.1_15...
[101amd64-default-job-16] |   | `-- Installing jpeg-turbo-1.4.2...
[101amd64-default-job-16] |   | `-- Extracting jpeg-turbo-1.4.2: .......... done
[101amd64-default-job-16] |   `-- Extracting jasper-1.900.1_15: .......... done
[101amd64-default-job-16] |   `-- Installing libxml2-2.9.3...
[101amd64-default-job-16] |   `-- Extracting libxml2-2.9.3: .......... done
[101amd64-default-job-16] |   `-- Installing lcms2-2.7_2...
[101amd64-default-job-16] |   | `-- Installing tiff-4.0.6_1...
[101amd64-default-job-16] |   | `-- Extracting tiff-4.0.6_1: .......... done
[101amd64-default-job-16] |   `-- Extracting lcms2-2.7_2: .......... done
[101amd64-default-job-16] |   `-- Installing png-1.6.20...
[101amd64-default-job-16] |   `-- Extracting png-1.6.20: .......... done
[101amd64-default-job-16] |   `-- Installing libwmf-0.2.8.4_15...
[101amd64-default-job-16] |   | `-- Installing libX11-1.6.3,1...
[101amd64-default-job-16] |   |   `-- Installing xproto-7.0.28...
[101amd64-default-job-16] |   |   `-- Extracting xproto-7.0.28: .......... done
[101amd64-default-job-16] |   |   `-- Installing kbproto-1.0.7...
[101amd64-default-job-16] |   |   `-- Extracting kbproto-1.0.7: .......... done
[101amd64-default-job-16] |   |   `-- Installing libXdmcp-1.1.2...
[101amd64-default-job-16] |   |   `-- Extracting libXdmcp-1.1.2: ......... done
[101amd64-default-job-16] |   |   `-- Installing libxcb-1.11.1...
[101amd64-default-job-16] |   |   | `-- Installing libpthread-stubs-0.3_6...
[101amd64-default-job-16] |   |   | `-- Extracting libpthread-stubs-0.3_6: 
..... done
[101amd64-default-job-16] |   |   | `-- Installing libXau-1.0.8_3...
[101amd64-default-job-16] |   |   | `-- Extracting libXau-1.0.8_3: .......... 
done
[101amd64-default-job-16] |   |   `-- Extracting libxcb-1.11.1: .......... done
[101amd64-default-job-16] |   | `-- Extracting libX11-1.6.3,1: .......... done
[101amd64-default-job-16] |   | `-- Installing freetype2-2.6.2...
[101amd64-default-job-16] |   | `-- Extracting freetype2-2.6.2: .......... done
[101amd64-default-job-16] |   `-- Extracting libwmf-0.2.8.4_15: .......... done
<snip>
********************************* WARNING *********************************

FreeBSD does not, and can not warrant that the certification authorities
whose certificates are included in this package have in any way been
audited for trustworthiness or RFC 3647 compliance.

Assessment and verification of trust is the complete responsibility of the
system administrator.

*********************************** NOTE **********************************

This package installs symlinks to support root certificates discovery by
default for software that uses OpenSSL.

This enables SSL Certificate Verification by client software without manual
intervention.

If you prefer to do this manually, replace the following symlinks with
either an empty file or your site-local certificate bundle.

  * /etc/ssl/cert.pem
  * /usr/local/etc/ssl/cert.pem
  * /usr/local/openssl/cert.pem

***************************************************************************
Message from python27-2.7.11_1:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
Message from perl5-5.20.3_8:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
Message from dejavu-2.35:
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/share/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
Message from trousers-tddl-0.3.10_7:
To run tcsd automatically, add the following line to /etc/rc.conf

tcsd_enable="YES"

You might want to edit /usr/local/etc/tcsd.conf to reflect your setup.

To use TPM, add your_account to '_tss' group like following:

# pw groupadd _tss -m your_account
Message from openjdk8-8.66.17_3:
======================================================================

This OpenJDK implementation requires fdescfs(5) mounted on /dev/fd and
procfs(5) mounted on /proc.

If you have not done it yet, please do the following:

        mount -t fdescfs fdesc /dev/fd
        mount -t procfs proc /proc

To make it permanent, you need the following lines in /etc/fstab:

        fdesc   /dev/fd         fdescfs         rw      0       0
        proc    /proc           procfs          rw      0       0

======================================================================
Message from qt4-corelib-4.8.7_1:
======================================================================

Qt 4 can be built with optional support for:
 - Common UNIX Printing System (CUPS) (enabled by default)
 - Network Audio System (NAS)
 - Qt style that renders using GTK (QGTKSTYLE)

In order to enable them, you have to add
        QT4_OPTIONS=    CUPS NAS QGTKSTYLE
to your /etc/make.conf and compile devel/qt4-corelib and
x11-toolkits/qt4-gui ports.

Attention! Whenever you change the QT4_OPTIONS both
devel/qt4-corelib and x11-toolkits/qt4-gui ports must be rebuilt!

======================================================================
Message from qt4-sql-4.8.7:
======================================================================

To enable Qt database support, install the database plugin ports. The
following plugin ports are available:
 - databases/qt4-ibase-plugin           InterBase/Firebird
 - databases/qt4-mysql-plugin           MySQL
 - databases/qt4-odbc-plugin            Open Database Connectivity
 - databases/qt4-pgsql-plugin           PostgreSQL
 - databases/qt4-sqlite-plugin          SQLite 2
 - databases/qt4-sqlite3-plugin         SQLite 3

======================================================================
===>   octave-forge-video-1.2.1 depends on executable: octave - found
===>   Returning to build of octave-forge-video-1.2.1
===>   octave-forge-video-1.2.1 depends on executable: gfortran48 - found
===>   octave-forge-video-1.2.1 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.1_2.txz
[101amd64-default-job-16] Installing gmake-4.1_2...
[101amd64-default-job-16] Extracting gmake-4.1_2: .......... done
===>   octave-forge-video-1.2.1 depends on executable: gmake - found
===>   Returning to build of octave-forge-video-1.2.1
===>   octave-forge-video-1.2.1 depends on file: /usr/local/bin/as - found
===========================================================================
=======================<phase: lib-depends    >============================
===>   octave-forge-video-1.2.1 depends on shared library: libavcodec.so - not 
found
===>   Installing existing package /packages/All/ffmpeg-2.8.5,1.txz
[101amd64-default-job-16] Installing ffmpeg-2.8.5,1...
[101amd64-default-job-16] `-- Installing libtheora-1.1.1_6...
[101amd64-default-job-16] |   `-- Installing libvorbis-1.3.5,3...
[101amd64-default-job-16] |   | `-- Installing libogg-1.3.2_1,4...
[101amd64-default-job-16] |   | `-- Extracting libogg-1.3.2_1,4: .......... done
[101amd64-default-job-16] |   `-- Extracting libvorbis-1.3.5,3: .......... done
[101amd64-default-job-16] `-- Extracting libtheora-1.1.1_6: .......... done
[101amd64-default-job-16] `-- Installing libvpx-1.5.0...
[101amd64-default-job-16] `-- Extracting libvpx-1.5.0: .......... done
[101amd64-default-job-16] `-- Installing xvid-1.3.4,1...
[101amd64-default-job-16] `-- Extracting xvid-1.3.4,1: ........ done
[101amd64-default-job-16] `-- Installing schroedinger-1.0.11_4...
[101amd64-default-job-16] `-- Extracting schroedinger-1.0.11_4: .......... done
[101amd64-default-job-16] `-- Installing libx264-0.144.2533_1...
[101amd64-default-job-16] `-- Extracting libx264-0.144.2533_1: ......... done
[101amd64-default-job-16] `-- Installing opencv-core-2.4.9_3...
[101amd64-default-job-16] `-- Extracting opencv-core-2.4.9_3: .......... done
[101amd64-default-job-16] Extracting ffmpeg-2.8.5,1: .......... done
===>   octave-forge-video-1.2.1 depends on shared library: libavcodec.so - 
found (/usr/local/lib/libavcodec.so)
===>   Returning to build of octave-forge-video-1.2.1
===>   octave-forge-video-1.2.1 depends on shared library: libpcre.so - found 
(/usr/local/lib/libpcre.so)
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for octave-forge-video-1.2.1
configure: loading site script /usr/ports/Templates/config.site
checking for pkg-config... no
checking whether the C++ compiler works... yes
checking for C++ compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C++ compiler... yes
checking whether c++ accepts -g... yes
checking for mkoctfile... yes
checking for av_mallocz in -lavutil... yes
checking for av_write_frame in -lavformat... yes
checking for avcodec_alloc_frame in -lavcodec... yes
checking for sws_scale in -lswscale... yes
checking how to run the C++ preprocessor... c++ -E
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking for ANSI C header files... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking ffmpeg/avformat.h usability... no
checking ffmpeg/avformat.h presence... no
checking for ffmpeg/avformat.h... no
checking libavformat/avformat.h usability... no
checking libavformat/avformat.h presence... no
checking for libavformat/avformat.h... no
configure: error: FFMpeg header avformat.h not found
===>  Script "configure" failed unexpectedly.
Please report the problem to step...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/math/octave-forge-video/work/video-1.2.1/src/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/math/octave-forge-video
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to