You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     po...@freebsd.org
Last committer: gbl...@freebsd.org
Ident:          $FreeBSD: head/irc/minbif/Makefile 375663 2014-12-27 00:09:02Z 
gblach $
Log URL:        
http://beefy8.nyi.freebsd.org/data/head-armv6-default/p406714_s293048/logs/minbif-1.0.5_7.log
Build URL:      
http://beefy8.nyi.freebsd.org/build.html?mastername=head-armv6-default&build=p406714_s293048
Log:

====>> Building irc/minbif
build started at Thu Jan 21 22:03:41 UTC 2016
port directory: /usr/ports/irc/minbif
building for: FreeBSD head-armv6-default-job-23 11.0-CURRENT FreeBSD 
11.0-CURRENT r293048 arm
maintained by: po...@freebsd.org
Makefile ident:      $FreeBSD: head/irc/minbif/Makefile 375663 2014-12-27 
00:09:02Z gblach $
Poudriere version: 3.1.10
Host OSVERSION: 1100091
Jail OSVERSION: 1100093




!!! Jail is newer than host. (Jail: 1100093, Host: 1100091) !!!
!!! This is not supported. !!!
!!! Host kernel must be same or newer than jail. !!!
!!! Expect build failures. !!!



---Begin Environment---
SHELL=/bin/csh
UNAME_p=armv6
UNAME_m=arm
ABI_FILE=/usr/lib/crt1.o
UNAME_v=FreeBSD 11.0-CURRENT r293048
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=armv6
LINUX_OSRELEASE=2.6.32
SAVED_TERM=screen
QEMU_EMULATING=1
MASTERMNT=/usr/local/poudriere/data/.m/head-armv6-default/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=minbif-1.0.5_7
OSREL=11.0
_OSRELEASE=11.0-CURRENT
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=24
PWD=/usr/local/poudriere/data/.m/head-armv6-default/ref/.p/pool
MASTERNAME=head-armv6-default
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.10
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1100093
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for minbif-1.0.5_7:
     CACA=on: Buddy icon display using libcaca
     DOCS=on: Build and/or install documentation
     GNUTLS=off: SSL/TLS support via GnuTLS
     PLUGINS=off: Compile additional libpurple-plugins
     VIDEO=off: Webcam display using libcaca (depends on CACA)
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PKG_CONFIG=pkgconf XDG_DATA_HOME=/wrkdirs/usr/ports/irc/minbif/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/irc/minbif/work  
HOME=/wrkdirs/usr/ports/irc/minbif/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/irc/minbif/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/irc/minbif/work  
HOME=/wrkdirs/usr/ports/irc/minbif/work TMPDIR="/tmp" NO_PIE=yes 
NO_DEBUG_FILES=yes SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="/nxb-bin/usr/bin/cc" CFLAGS="-O2 
-pipe -mfloat-abi=softfp  -DX_DISPLAY_MISSING -fno-strict-aliasing"  
CPP="/nxb-bin/usr/bin/cpp" CPPFLAGS=""  LDFLAGS=" -pthread" LIBS=""  
CXX="/nxb-bin/usr/bin/c++" CXXFLAGS="-O2 -pipe -mfloat-abi=softfp 
-DX_DISPLAY_MISSING -fno-strict-aliasing "  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
CMAKE_BUILD_TYPE="release"
OSREL=11.0
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
GTK2_VERSION="2.10.0"
GTK3_VERSION="3.0.0"
DOCSDIR="share/doc/minbif"
EXAMPLESDIR="share/examples/minbif"
DATADIR="share/minbif"
WWWDIR="www/minbif"
ETCDIR="etc/minbif"
--End PLIST_SUB--

--SUB_LIST--
USERS="minbif"
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/minbif
DOCSDIR=/usr/local/share/doc/minbif
EXAMPLESDIR=/usr/local/share/examples/minbif
WWWDIR=/usr/local/www/minbif
ETCDIR=/usr/local/etc/minbif
--End SUB_LIST--

---Begin make.conf---
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
NM=/nxb-bin/usr/bin/nm
MAKE=/nxb-bin/usr/bin/make
STRINGS=/nxb-bin/usr/bin/strings
AWK=/nxb-bin/usr/bin/awk
FLEX=/nxb-bin/usr/bin/flex
CC=/nxb-bin/usr/bin/cc
CPP=/nxb-bin/usr/bin/cpp
CXX=/nxb-bin/usr/bin/c++
AS=/nxb-bin/usr/bin/as
NM=/nxb-bin/usr/bin/nm
LD=/nxb-bin/usr/bin/ld
OBJCOPY=/nxb-bin/usr/bin/objcopy
SIZE=/nxb-bin/usr/bin/size
STRIPBIN=/nxb-bin/usr/bin/strip
SED=/nxb-bin/usr/bin/sed
READELF=/nxb-bin/usr/bin/readelf
RANLIB=/nxb-bin/usr/bin/ranlib
YACC=/nxb-bin/usr/bin/yacc
<snip>
Creating group 'haldaemon' with gid '560'.
Creating user 'haldaemon' with uid '560'.
[head-armv6-default-job-23] |   | `-- Extracting hal-0.5.14_30: .......... done
polkit-read-auth-helper: needs to be setgid polkit
polkit-auth: NotAuthorizedToReadAuthorizationsForOtherUsers: uid 0 is not 
authorized to read authorizations for uid 560 (requires 
org.freedesktop.policykit.read)
===> Creating users and/or groups.
Creating group 'webcamd' with gid '145'.
Creating user 'webcamd' with uid '145'.
[head-armv6-default-job-23] |   `-- Extracting webcamd-4.2.0.9: .......... done
[head-armv6-default-job-23] `-- Extracting gstreamer-plugins-v4l2-0.10.31_1,3: 
.. done
[head-armv6-default-job-23] `-- Installing farstream-0.2.7...
[head-armv6-default-job-23] |   `-- Installing libnice-0.1.13...
[head-armv6-default-job-23] |   `-- Extracting libnice-0.1.13: .......... done
[head-armv6-default-job-23] |   `-- Installing libnice-gst1-0.1.13...
[head-armv6-default-job-23] |   | `-- Installing gstreamer1-plugins-1.6.2...
[head-armv6-default-job-23] |   |   `-- Installing gstreamer1-1.6.2...
[head-armv6-default-job-23] |   |   `-- Extracting gstreamer1-1.6.2: .......... 
done
[head-armv6-default-job-23] |   |   `-- Installing iso-codes-3.63...
[head-armv6-default-job-23] |   |   `-- Extracting iso-codes-3.63: .......... 
done
[head-armv6-default-job-23] |   | `-- Extracting gstreamer1-plugins-1.6.2: 
.......... done
[head-armv6-default-job-23] |   `-- Extracting libnice-gst1-0.1.13: . done
[head-armv6-default-job-23] |   `-- Installing gstreamer1-plugins-bad-1.6.2...
[head-armv6-default-job-23] |   `-- Extracting gstreamer1-plugins-bad-1.6.2: 
.......... done
[head-armv6-default-job-23] |   `-- Installing gstreamer1-plugins-good-1.6.2...
[head-armv6-default-job-23] |   `-- Extracting gstreamer1-plugins-good-1.6.2: 
.......... done
[head-armv6-default-job-23] `-- Extracting farstream-0.2.7: .......... done
[head-armv6-default-job-23] `-- Installing py27-dbus-1.2.0_1...
[head-armv6-default-job-23] |   `-- Installing pydbus-common-1.2.0_1...
[head-armv6-default-job-23] |   `-- Extracting pydbus-common-1.2.0_1: 
.......... done
[head-armv6-default-job-23] `-- Extracting py27-dbus-1.2.0_1: .......... done
[head-armv6-default-job-23] `-- Installing nss-3.21...
[head-armv6-default-job-23] |   `-- Installing sqlite3-3.10.0...
[head-armv6-default-job-23] |   `-- Extracting sqlite3-3.10.0: .......... done
[head-armv6-default-job-23] `-- Extracting nss-3.21: .......... done
[head-armv6-default-job-23] Extracting libpurple-2.10.12_1: .......... done
Message from python27-2.7.11_1:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
Message from perl5-5.20.3_8:
The /usr/bin/perl symlink has been removed starting with Perl 5.20.
For shebangs, you should either use:

#!/usr/local/bin/perl

or

#!/usr/bin/env perl

The first one will only work if you have a /usr/local/bin/perl,
the second will work as long as perl is in PATH.
Message from dejavu-2.35:
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/share/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
Message from trousers-tddl-0.3.10_7:
To run tcsd automatically, add the following line to /etc/rc.conf

tcsd_enable="YES"

You might want to edit /usr/local/etc/tcsd.conf to reflect your setup.

To use TPM, add your_account to '_tss' group like following:

# pw groupadd _tss -m your_account
Message from gcc-4.8.5_2:
To ensure binaries built with this toolchain find appropriate versions
of the necessary run-time libraries, you may want to link using

  -Wl,-rpath=/usr/local/lib/gcc48

For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
transparently.
Message from webcamd-4.2.0.9:
*********************************************************************
1) webcamd requires the cuse4bsd or cuse kernel module, depending on
how webcamd was compiled. Please load this dependency by doing:

       # kldload cuse4bsd
or
       # kldload cuse

or by adding

       cuse4bsd_load="YES"
or
       cuse_load="YES"

to your /boot/loader.conf.

2) add webcamd_enable="YES"

to your /etc/rc.conf

3) Please restart devd to start webcamd

        # service devd restart

4) Optionally add a user to the "webcamd" group

        # pw groupmod webcamd -m <username>

5) If webcamd still did not start, consult the installed webcamd rc.d
script for more help and instructions on how to start webcamd.
*********************************************************************
===>   minbif-1.0.5_7 depends on shared library: libpurple.so - found 
(/usr/local/lib/libpurple.so)
===>   Returning to build of minbif-1.0.5_7
===>   minbif-1.0.5_7 depends on shared library: libcaca.so - not found
===>   Installing existing package /packages/All/libcaca-0.99.b19_1.txz
[head-armv6-default-job-23] Installing libcaca-0.99.b19_1...
[head-armv6-default-job-23] `-- Installing freeglut-3.0.0...
[head-armv6-default-job-23] |   `-- Installing libGLU-9.0.0_2...
[head-armv6-default-job-23] |   `-- Extracting libGLU-9.0.0_2: ...... done
[head-armv6-default-job-23] `-- Extracting freeglut-3.0.0: .......... done
[head-armv6-default-job-23] `-- Installing imlib2-1.4.6_7,2...
[head-armv6-default-job-23] |   `-- Installing giflib-5.1.1...
[head-armv6-default-job-23] |   `-- Extracting giflib-5.1.1: .......... done
[head-armv6-default-job-23] `-- Extracting imlib2-1.4.6_7,2: .......... done
[head-armv6-default-job-23] Extracting libcaca-0.99.b19_1: .......... done
Message from freeglut-3.0.0:
Joystick support is untested and it is unknown if it works.

Do not hesitate to contact x...@freebsd.org if this causes issues.
===>   minbif-1.0.5_7 depends on shared library: libcaca.so - found 
(/usr/local/lib/libcaca.so)
===>   Returning to build of minbif-1.0.5_7
===>   minbif-1.0.5_7 depends on shared library: libImlib2.so - found 
(/usr/local/lib/libImlib2.so)
===>   minbif-1.0.5_7 depends on shared library: libglib-2.0.so - found 
(/usr/local/lib/libglib-2.0.so)
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for minbif-1.0.5_7
===>  Performing in-source build
/bin/mkdir -p /wrkdirs/usr/ports/irc/minbif/work/minbif-1.0.5
-- The C compiler identification is Clang 3.7.0
-- The CXX compiler identification is Clang 3.7.0
-- Check for working C compiler: /nxb-bin/usr/bin/cc
-- Check for working C compiler: /nxb-bin/usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
CMake Error: Generator: execution of make failed. Make command was: 
"/usr/bin/make" "cmTC_a1d77/fast"
-- Detecting C compile features - failed
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++
-- Check for working CXX compiler: /nxb-bin/usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Found PkgConfig: pkgconf (found version "0.28") 
-- Configuring for release
-- Checking for module 'purple>=2.5'
--   Found purple, version 2.10.12
-- Checking for module 'gthread-2.0'
--   Found gthread-2.0, version 2.44.1
-- Checking for module 'imlib2>=1.0'
--   Found imlib2, version 1.4.6
-- Looking for XOpenDisplay in 
/usr/local/lib/libX11.so;/usr/local/lib/libXext.so
-- Looking for XOpenDisplay in 
/usr/local/lib/libX11.so;/usr/local/lib/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/local/lib/libX11.so
-- Checking for module 'caca>=0.99'
--   Found caca, version 0.99.beta19
-- Checking for module 'caca>=0.99.beta17'
--   Found caca, version 0.99.beta19
-- Performing Test PAM_MESSAGE_CONST
-- Performing Test PAM_MESSAGE_CONST - Success
-- Found PAM: /usr/lib/libpam.so
-- Using compiler /nxb-bin/usr/bin/c++
-- Build type: Release
-- Configuring incomplete, errors occurred!
See also 
"/wrkdirs/usr/ports/irc/minbif/work/minbif-1.0.5/CMakeFiles/CMakeOutput.log".
See also 
"/wrkdirs/usr/ports/irc/minbif/work/minbif-1.0.5/CMakeFiles/CMakeError.log".
*** Error code 1

Stop.
make: stopped in /usr/ports/irc/minbif
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to