You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     brendan+free...@bbqsrc.net
Last committer: de...@freebsd.org
Ident:          $FreeBSD: head/databases/mongodb32/Makefile 406969 2016-01-23 
12:46:58Z demon $
Log URL:        
http://beefy5.nyi.freebsd.org/data/101i386-default/407074/logs/mongodb32-3.2.1.log
Build URL:      
http://beefy5.nyi.freebsd.org/build.html?mastername=101i386-default&build=407074
Log:

====>> Building databases/mongodb32
build started at Sun Jan 24 08:47:19 UTC 2016
port directory: /usr/ports/databases/mongodb32
building for: FreeBSD 101i386-default-job-24 10.1-RELEASE-p27 FreeBSD 
10.1-RELEASE-p27 i386
maintained by: brendan+free...@bbqsrc.net
Makefile ident:      $FreeBSD: head/databases/mongodb32/Makefile 406969 
2016-01-23 12:46:58Z demon $
Poudriere version: 3.1.10
Host OSVERSION: 1100091
Jail OSVERSION: 1001000

---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
UNAME_v=FreeBSD 10.1-RELEASE-p27
UNAME_r=10.1-RELEASE-p27
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
OPSYS=FreeBSD
ARCH=i386
LINUX_OSRELEASE=2.6.32
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/101i386-default/ref
UID=0
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
_JAVA_VERSION_LIST_REGEXP=1.6\|1.7\|1.8\|1.6+\|1.7+\|1.8+
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=mongodb32-3.2.1
OSREL=10.1
_OSRELEASE=10.1-RELEASE-p27
PYTHONBASE=/usr/local
OLDPWD=/
_SMP_CPUS=24
PWD=/usr/local/poudriere/data/.m/101i386-default/ref/.p/pool
MASTERNAME=101i386-default
SCRIPTPREFIX=/usr/local/share/poudriere
_JAVA_VENDOR_LIST_REGEXP=openjdk\|oracle\|sun
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.10
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
CONFIGURE_MAX_CMD_LEN=262144
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
_JAVA_OS_LIST_REGEXP=native\|linux
OSVERSION=1001000
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for mongodb32-3.2.1:
     SASL=off: SASL authentication support
     SSL=on: SSL protocol support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PYTHON="/usr/local/bin/python2.7" 
XDG_DATA_HOME=/wrkdirs/usr/ports/databases/mongodb32/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/databases/mongodb32/work  
HOME=/wrkdirs/usr/ports/databases/mongodb32/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
OPENSSLBASE=/usr OPENSSLDIR=/etc/ssl OPENSSLINC=/usr/include 
OPENSSLLIB=/usr/lib XDG_DATA_HOME=/wrkdirs/usr/ports/databases/mongodb32/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/databases/mongodb32/work  
HOME=/wrkdirs/usr/ports/databases/mongodb32/work TMPDIR="/tmp" NO_PIE=yes 
NO_DEBUG_FILES=yes SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe  
-fstack-protector -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS="  
-fstack-protector" LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector 
-fno-strict-aliasing "  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PYTHON_INCLUDEDIR=include/python2.7
PYTHON_LIBDIR=lib/python2.7
PYTHON_PLATFORM=freebsd10
PYTHON_SITELIBDIR=lib/python2.7/site-packages
PYTHON_VER=2.7
PYTHON_VERSION=python2.7
OSREL=10.1
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/mongodb32"
EXAMPLESDIR="share/examples/mongodb32"
DATADIR="share/mongodb32"
WWWDIR="www/mongodb32"
ETCDIR="etc/mongodb32"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/mongodb32
DOCSDIR=/usr/local/share/doc/mongodb32
EXAMPLESDIR=/usr/local/share/examples/mongodb32
WWWDIR=/usr/local/www/mongodb32
ETCDIR=/usr/local/etc/mongodb32
--End SUB_LIST--

---Begin make.conf---
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License AGPLv3 APACHE20 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   mongodb32-3.2.1 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.6.2.txz
[101i386-default-job-24] Installing pkg-1.6.2...
[101i386-default-job-24] Extracting pkg-1.6.2: .......... done
Message from pkg-1.6.2:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   mongodb32-3.2.1 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of mongodb32-3.2.1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License AGPLv3 APACHE20 accepted by the user
=> mongodb-src-r3.2.1.tar.gz doesn't seem to exist in /portdistfiles/.
=> Attempting to fetch https://fastdl.mongodb.org/src/mongodb-src-r3.2.1.tar.gz
mongodb-src-r3.2.1.tar.gz                                0  B    0  Bps
===> Fetching all distfiles required by mongodb32-3.2.1 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License AGPLv3 APACHE20 accepted by the user
===> Fetching all distfiles required by mongodb32-3.2.1 for building
=> SHA256 Checksum OK for mongodb-src-r3.2.1.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License AGPLv3 APACHE20 accepted by the user
===> Fetching all distfiles required by mongodb32-3.2.1 for building
===>  Extracting for mongodb32-3.2.1
=> SHA256 Checksum OK for mongodb-src-r3.2.1.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for mongodb32-3.2.1
===>  Applying FreeBSD patches for mongodb32-3.2.1
===========================================================================
=======================<phase: build-depends  >============================
===>   mongodb32-3.2.1 depends on file: /usr/local/bin/python2.7 - not found
===>   Installing existing package /packages/All/python27-2.7.11_1.txz
[101i386-default-job-24] Installing python27-2.7.11_1...
[101i386-default-job-24] `-- Installing libffi-3.2.1...
[101i386-default-job-24] |   `-- Installing indexinfo-0.2.4...
[101i386-default-job-24] |   `-- Extracting indexinfo-0.2.4: .... done
[101i386-default-job-24] `-- Extracting libffi-3.2.1: .......... done
[101i386-default-job-24] `-- Installing gettext-runtime-0.19.6...
[101i386-default-job-24] `-- Extracting gettext-runtime-0.19.6: .......... done
[101i386-default-job-24] Extracting python27-2.7.11_1: .......... done
Message from python27-2.7.11_1:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
===>   mongodb32-3.2.1 depends on file: /usr/local/bin/python2.7 - found
===>   Returning to build of mongodb32-3.2.1
===>   mongodb32-3.2.1 depends on file: /usr/local/bin/scons - not found
===>   Installing existing package /packages/All/scons-2.3.0_1.txz
[101i386-default-job-24] Installing scons-2.3.0_1...
[101i386-default-job-24] `-- Installing py27-setuptools27-19.2...
[101i386-default-job-24] `-- Extracting py27-setuptools27-19.2: .......... done
[101i386-default-job-24] `-- Installing python2-2_3...
[101i386-default-job-24] `-- Extracting python2-2_3: ...... done
[101i386-default-job-24] `-- Installing m4-1.4.17_1,1...
[101i386-default-job-24] `-- Extracting m4-1.4.17_1,1: .......... done
[101i386-default-job-24] Extracting scons-2.3.0_1: .......... done
===>   mongodb32-3.2.1 depends on file: /usr/local/bin/scons - found
===>   Returning to build of mongodb32-3.2.1
===========================================================================
=======================<phase: lib-depends    >============================
===>   mongodb32-3.2.1 depends on shared library: libpcre.so - not found
===>   Installing existing package /packages/All/pcre-8.37_4.txz
[101i386-default-job-24] Installing pcre-8.37_4...
[101i386-default-job-24] Extracting pcre-8.37_4: .......... done
===>   mongodb32-3.2.1 depends on shared library: libpcre.so - found 
(/usr/local/lib/libpcre.so)
===>   Returning to build of mongodb32-3.2.1
===>   mongodb32-3.2.1 depends on shared library: libsnappy.so - not found
===>   Installing existing package /packages/All/snappy-1.1.3.txz
[101i386-default-job-24] Installing snappy-1.1.3...
[101i386-default-job-24] Extracting snappy-1.1.3: .......... done
===>   mongodb32-3.2.1 depends on shared library: libsnappy.so - found 
(/usr/local/lib/libsnappy.so)
===>   Returning to build of mongodb32-3.2.1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for mongodb32-3.2.1
===========================================================================
=======================<phase: build          >============================
===>  Building for mongodb32-3.2.1
scons: Reading SConscript files ...
Mkdir("build/scons")
scons version: 2.3.0
python version: 2 7 11 'final' 0
Checking whether the C++ compiler worksyes
Checking whether the C compiler worksyes
Checking if C++ compiler "c++" is GCC... no
Checking if C++ compiler "c++" is clang... yes
Checking if C compiler "cc" is clang... yes
Detected a i386 processor
Checking if target OS freebsd is supported by the toolchain yes
WiredTiger is not supported on 32-bit platforms
Re-run scons with --wiredtiger=off to build on 32-bit platforms
*** Error code 1

Stop.
make: stopped in /usr/ports/databases/mongodb32
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to