You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     wenhep...@gmail.com
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/x11-toolkits/py-pyqwt/Makefile 327785 2013-09-20 
23:57:47Z bapt $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/10i386-default/2013-10-17_04h52m04s/logs/py27-pyqwt-5.2.0_6.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/10i386-default/2013-10-17_04h52m04s
Log:

====>> Building x11-toolkits/py-pyqwt
build started at Thu Oct 17 18:44:06 UTC 2013
port directory: /usr/ports/x11-toolkits/py-pyqwt
building for: FreeBSD 10i386-default-job-14 10.0-BETA1 FreeBSD 10.0-BETA1 
r256420 i386
maintained by: wenhep...@gmail.com
Makefile ident:      $FreeBSD: head/x11-toolkits/py-pyqwt/Makefile 327785 
2013-09-20 23:57:47Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=1000500
UNAME_v=FreeBSD 10.0-BETA1 r256420
UNAME_r=10.0-BETA1
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/10i386-default/ref
PKG_EXT=txz
tpid=90239
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=py27-pyqwt-5.2.0_6
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=10i386-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" PYTHON="/usr/local/bin/python2.7" MAKE=gmake SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local 
 LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/pyqwt
DOCSDIR=/usr/local/share/doc/pyqwt
EXAMPLESDIR=/usr/local/share/examples/pyqwt
WWWDIR=/usr/local/www/pyqwt
ETCDIR=/usr/local/etc/pyqwt
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for py27-pyqwt-5.2.0_6
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   py27-pyqwt-5.2.0_6 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of py27-pyqwt-5.2.0_6
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by py27-pyqwt-5.2.0_6 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by py27-pyqwt-5.2.0_6 for building
=> SHA256 Checksum OK for PyQwt-5.2.0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by py27-pyqwt-5.2.0_6 for building
===>  Extracting for py27-pyqwt-5.2.0_6
=> SHA256 Checksum OK for PyQwt-5.2.0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for py27-pyqwt-5.2.0_6
===>  Applying FreeBSD patches for py27-pyqwt-5.2.0_6
/usr/bin/sed -i.bak -e 's#%%LOCALBASE%%#/usr/local#g'  
/wrkdirs/usr/ports/x11-toolkits/py-pyqwt/work/PyQwt-5.2.0/GNUmakefile
===========================================================================
=======================<phase: build-depends  >============================
===>   py27-pyqwt-5.2.0_6 depends on file: /usr/local/bin/qmake-qt4 - not found
===>    Verifying install for /usr/local/bin/qmake-qt4 in 
/usr/ports/devel/qmake4
===>   Installing existing package /packages/All/qt4-qmake-4.8.5.txz
Installing qt4-qmake-4.8.5... done
===>   Returning to build of py27-pyqwt-5.2.0_6
===>   py27-pyqwt-5.2.0_6 depends on file: 
/usr/local/lib/python2.7/site-packages/numpy/core/numeric.py - not found
===>    Verifying install for 
/usr/local/lib/python2.7/site-packages/numpy/core/numeric.py in 
/usr/ports/math/py-numpy
===>   Installing existing package /packages/All/py27-numpy-1.7.0_1,1.txz
Installing py27-numpy-1.7.0_1,1...Installing suitesparse-4.0.2_1...Installing 
mpfr-3.1.2...Installing gmp-5.1.3... done
 done
Installing mpc-0.9... done
Installing lapack-3.4.2...Installing blas-3.4.2...Installing gcc-ecj-4.5... done
Installing gcc-4.6.3...Installing gettext-0.18.3.1... done
Installing binutils-2.23.2... done
 done
 done
 done
 done
Installing python27-2.7.5_3... done
Installing python2-2_1... done
Installing python-2.7_1,2... done
Installing py27-nose-1.3.0...Installing py27-distribute-0.6.35... done
215
238
 done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of py27-pyqwt-5.2.0_6
===>   py27-pyqwt-5.2.0_6 depends on package: py27-qt4-core>=4.5.4 - not found
===>    Verifying install for py27-qt4-core>=4.5.4 in 
/usr/ports/devel/py-qt4-core
===>   Installing existing package /packages/All/py27-qt4-core-4.10.3,1.txz
Installing py27-qt4-core-4.10.3,1...Installing ca_root_nss-3.15.1_1... done
Installing damageproto-1.2.1... done
Installing dbus-1.6.12...Installing xproto-7.0.24... done
Installing libxcb-1.9.1...Installing libXdmcp-1.1.1... done
Installing libXau-1.0.8... done
Installing libxml2-2.8.0_2... done
Installing libpthread-stubs-0.3_3... done
 done
Installing libX11-1.6.2,1...Installing kbproto-1.0.6... done
 done
Installing libSM-1.2.2,1...Installing libICE-1.0.8,1... done
 done
Installing expat-2.1.0... done
Installing gnome_subr-1.0... done
===> Creating users and/or groups.
Creating group 'messagebus' with gid '556'.
Creating user 'messagebus' with uid '556'.
 done
Installing dejavu-2.34...Installing fontconfig-2.10.95,1...Installing 
freetype2-2.5.0.1... done
Running fc-cache to build fontconfig cache...
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
/usr/local/lib/X11/fonts/local: caching, new cache contents: 0 fonts, 0 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/var/db/fontconfig: cleaning cache directory
/root/.cache/fontconfig: not cleaning non-existent cache directory
/root/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded
 done
 done
Installing dri2proto-2.8... done
Installing encodings-1.0.4,1...Installing font-util-1.3.0... done
 done
Installing fixesproto-5.0... done
Installing font-bh-ttf-1.0.3...Installing mkfontscale-1.1.1...Installing 
libfontenc-1.1.2... done
 done
Installing mkfontdir-1.0.7... done
 done
Installing font-misc-ethiopic-1.0.3... done
Installing font-misc-meltho-1.0.3... done
Installing fontcacheproto-0.1.3... done
Installing glib-2.36.3...Installing perl-5.14.4_2...Removing 
/usr/local/etc/perl5_version... Done.
Creating /usr/local/etc/perl5_version... Done.
<snip>
Installing phonon-4.6.0_1...Installing png-1.5.17... done
Installing qt4-corelib-4.8.5... done
Installing qt4-dbus-4.8.5...Installing qt4-xml-4.8.5... done
 done
Installing qt4-declarative-4.8.5...Installing qt4-gui-4.8.5...Installing 
xdg-utils-1.0.2.20130919_1...Installing xprop-1.2.2... done
Installing xset-1.2.3_1... done
 done
Installing xorg-fonts-truetype-7.7_1... done
 done
Installing qt4-network-4.8.5... done
Installing qt4-opengl-4.8.5... done
Installing qt4-script-4.8.5... done
Installing qt4-sql-4.8.5... done
Installing qt4-svg-4.8.5... done
Installing qt4-xmlpatterns-4.8.5... done
 done
Installing qt4-qtestlib-4.8.5... done
Installing qzeitgeist-0.8.0... done
 done
Installing py27-sip-4.15.2,1... done
Installing qscintilla2-2.7.2,1...Installing qt4-assistant-4.8.5...Installing 
qt4-clucene-4.8.5... done
Installing qt4-doc-4.8.5... done
Installing qt4-help-4.8.5...Installing qt4-sqlite-plugin-4.8.5...Installing 
sqlite3-3.8.0.2... done
 done
 done
Installing qt4-webkit-4.8.5... done
 done
Installing qt4-designer-4.8.5...Installing qt4-qt3support-4.8.5... done
 done
 done
 done
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/lib/X11/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
======================================================================

Qt 4 can be built with optional support for:
 - Common UNIX Printing System (CUPS) (enabled by default)
 - Network Audio System (NAS)
 - Qt style that renders using GTK (QGTKSTYLE)

In order to enable them, you have to add
        QT4_OPTIONS=    CUPS NAS QGTKSTYLE
to your /etc/make.conf and compile devel/qt4-corelib and
x11-toolkits/qt4-gui ports.

Attention! Whenever you change the QT4_OPTIONS both
devel/qt4-corelib and x11-toolkits/qt4-gui ports must be rebuilt!

======================================================================
======================================================================

Qt paint engine makes common use of shared memory. To avoid MIT-SHM
errors (i.e., blank windows), you probably need to raise shared memory
limits in loader.conf(5). The following should be safe values for the
KDE Plasma Desktop:

kern.ipc.shmall=32768
kern.ipc.shmmni=1024
kern.ipc.shmseg=1024

======================================================================
*******************************************************************************

        To enable QT's database support, install the database plugin ports.
        The following plugin ports are available:

                IBase/Firebird  - databases/qt4-ibase-plugin
                MySQL           - databases/qt4-mysql-plugin
                ODBC            - databases/qt4-odbc-plugin
                PostgreSQL      - databases/qt4-pgsql-plugin
                SQLite          - databases/qt4-sqlite-plugin                   
        

*******************************************************************************
======================================================================

You'll have to install sysutils/zeitgeist to enable event logging.

======================================================================
======================================================================

Please, consider installing backends for Phonon:
- multimedia/phonon-gstreamer   GStreamer backend
- multimedia/phonon-vlc         VLC backend

======================================================================
===>   Returning to build of py27-pyqwt-5.2.0_6
===>   py27-pyqwt-5.2.0_6 depends on package: py27-qt4-svg>=4.5.4 - not found
===>    Verifying install for py27-qt4-svg>=4.5.4 in 
/usr/ports/graphics/py-qt4-svg
===>   Installing existing package /packages/All/py27-qt4-svg-4.10.3,1.txz
Installing py27-qt4-svg-4.10.3,1...Installing jbigkit-1.6... done
Installing jpeg-8_4... done
Installing lcms-1.19_1,1... done
Installing libmng-1.0.10_2... done
Installing py27-qt4-gui-4.10.3,1...Installing qt4-iconengines-4.8.5... done
Installing qt4-imageformats-4.8.5...Installing tiff-4.0.3... done
 done
Installing qt4-inputmethods-4.8.5... done
 done
 done
===>   Returning to build of py27-pyqwt-5.2.0_6
===>   py27-pyqwt-5.2.0_6 depends on package: py27-qt4-gui>=4.5.4 - found
===>   py27-pyqwt-5.2.0_6 depends on package: py27-qt4-qscintilla2>=2.4.1 - not 
found
===>    Verifying install for py27-qt4-qscintilla2>=2.4.1 in 
/usr/ports/devel/py-qt4-qscintilla2
===>   Installing existing package 
/packages/All/py27-qt4-qscintilla2-2.7.2,1.txz
Installing py27-qt4-qscintilla2-2.7.2,1... done
===>   Returning to build of py27-pyqwt-5.2.0_6
===>   py27-pyqwt-5.2.0_6 depends on package: py27-sip>= - found
===>   py27-pyqwt-5.2.0_6 depends on file: /usr/local/bin/python2.7 - found
===>   py27-pyqwt-5.2.0_6 depends on executable: python - found
===>   py27-pyqwt-5.2.0_6 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1... done
===>   Returning to build of py27-pyqwt-5.2.0_6
===========================================================================
=======================<phase: lib-depends    >============================
===>   py27-pyqwt-5.2.0_6 depends on shared library: qwt.5 - not found
===>    Verifying install for qwt.5 in /usr/ports/x11-toolkits/qwt5
===>   Installing existing package /packages/All/qwt5-5.2.3.txz
Installing qwt5-5.2.3... done
===>   Returning to build of py27-pyqwt-5.2.0_6
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for py27-pyqwt-5.2.0_6
===========================================================================
=======================<phase: build          >============================
===>  Building for py27-pyqwt-5.2.0_6
gmake[1]: Entering directory 
`/wrkdirs/usr/ports/x11-toolkits/py-pyqwt/work/PyQwt-5.2.0'
cd configure \
&& python configure.py -4 -I/usr/local/include/qwt -L/usr/local/lib -lqwt -j 1 \
&& gmake -j 1
size_t_check.cpp:3:9: error: out-of-line definition of 'f' does not match any 
declaration in 'a'
void a::f(unsigned long) {};
        ^
1 error generated.
size_t_check.cpp:3:9: error: out-of-line definition of 'f' does not match any 
declaration in 'a'
void a::f(unsigned long long) {};
        ^
1 error generated.
make[2]: don't know how to make w. Stop

make[2]: stopped in 
/wrkdirs/usr/ports/x11-toolkits/py-pyqwt/work/PyQwt-5.2.0/configure
./qwt_version_info: not found
Command line options:
{'debug': False,
 'disable_numarray': False,
 'disable_numeric': False,
 'disable_numpy': False,
 'excluded_features': [],
 'extra_cflags': [],
 'extra_cxxflags': [],
 'extra_defines': [],
 'extra_include_dirs': ['/usr/local/include/qwt'],
 'extra_lflags': [],
 'extra_lib_dirs': ['/usr/local/lib'],
 'extra_libs': ['qwt'],
 'jobs': '-j 1',
 'module_install_path': '',
 'modules': [],
 'qt': 4,
 'qwt_sources': '',
 'sip_include_dirs': [],
 'subdirs': [],
 'timelines': [],
 'trace': ''}

Found SIP-4.15.2.
Found 'posix' operating system:
2.7.5 (default, Oct 17 2013, 05:03:37) 
[GCC 4.2.1 Compatible FreeBSD Clang 3.3 (tags/RELEASE_33/final 183502)]
Do not get upset by error messages in the next 3 compiler checks:
Check if 'size_t' and 'unsigned int' are the same type:
YES
Check if 'size_t' and 'unsigned long' are the same type:
NO
Check if 'size_t' and 'unsigned long long' are the same type:
NO
Failed to import numarray: PyQwt will be build without support for numarray.

Failed to find Numeric2: PyQwt will be build without support for Numeric.

Found NumPy-1.7.0.

Failed to import qwt_version_info.
gmake[1]: *** [4] Error 1
gmake[1]: Leaving directory 
`/wrkdirs/usr/ports/x11-toolkits/py-pyqwt/work/PyQwt-5.2.0'
*** Error code 1

Stop.
make: stopped in /usr/ports/x11-toolkits/py-pyqwt
===>  Cleaning for py27-pyqwt-5.2.0_6
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to