You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     r...@freebsd.org
Last committer: t...@freebsd.org
Ident:          $FreeBSD: head/security/ruby-password/Makefile 367386 
2014-09-05 20:19:04Z tijl $
Log URL:        
http://beefy1.nyi.freebsd.org/data/93i386-default/408278/logs/ruby21-password-0.5.3_5.log
Build URL:      
http://beefy1.nyi.freebsd.org/build.html?mastername=93i386-default&build=408278
Log:

====>> Building security/ruby-password
build started at Sat Feb  6 09:48:17 UTC 2016
port directory: /usr/ports/security/ruby-password
building for: FreeBSD 93i386-default-job-10 9.3-RELEASE-p36 FreeBSD 
9.3-RELEASE-p36 i386
maintained by: r...@freebsd.org
Makefile ident:      $FreeBSD: head/security/ruby-password/Makefile 367386 
2014-09-05 20:19:04Z tijl $
Poudriere version: 3.1.10
Host OSVERSION: 1100093
Jail OSVERSION: 903000

---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
UNAME_v=FreeBSD 9.3-RELEASE-p36
UNAME_r=9.3-RELEASE-p36
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/93i386-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=ruby21-password-0.5.3_5
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/93i386-default/ref/.p/pool
MASTERNAME=93i386-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.10
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
OSVERSION=903000
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for 
ruby21-password-0.5.3_5:
     DOCS=on: Build and/or install documentation
     EXAMPLES=on: Build and/or install examples
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-crack-dict="/usr/local/libdata/cracklib/pw_dict.pwd" 
--with-opt-dir="/usr/local"
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
RB_USER_INSTALL=yes 
XDG_DATA_HOME=/wrkdirs/usr/ports/security/ruby-password/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/security/ruby-password/work  
HOME=/wrkdirs/usr/ports/security/ruby-password/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/security/ruby-password/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/security/ruby-password/work  
HOME=/wrkdirs/usr/ports/security/ruby-password/work TMPDIR="/tmp" NO_PIE=yes 
NO_DEBUG_FILES=yes SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS="" LIBS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -m 555"  BSD_INSTALL_LIB="install  -s -m 444"  
BSD_INSTALL_SCRIPT="install  -m 555"  BSD_INSTALL_DATA="install  -m 0644"  
BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
RUBY_LIBDIR="lib/ruby/2.1"
RUBY_ARCHLIBDIR="lib/ruby/2.1/i386-freebsd9"
RUBY_SITELIBDIR="lib/ruby/site_ruby/2.1"
RUBY_SITEARCHLIBDIR="lib/ruby/site_ruby/2.1/i386-freebsd9"
RUBY_VENDORLIBDIR="lib/ruby/vendor_ruby/2.1"
RUBY_VENDORARCHLIBDIR="lib/ruby/vendor_ruby/2.1/i386-freebsd9"
RUBY_MODDOCDIR="share/doc/ruby21/password"
RUBY_MODEXAMPLESDIR="share/examples/ruby21/password"
RUBY_DOCDIR="share/doc/ruby21"
RUBY_EXAMPLESDIR="share/examples/ruby21"
RUBY_RIDIR="share/ri/2.1/system"
RUBY_SITERIDIR="share/ri/2.1/site"
RUBY_ELISPDIR="lib/ruby/elisp"
RUBY_VERSION="2.1.8"
RUBY_VER="2.1"
RUBY_SHLIBVER="21"
RUBY_ARCH="i386-freebsd9"
RUBY_SUFFIX="21"
RUBY_NAME="ruby21"
RUBY_DEFAULT_SUFFIX="21"
RUBY20="@comment
"
RUBY21=""
RUBY22="@comment
"
RUBY23="@comment
"
RUBY_RD_HTML_FILES="@comment
"
OSREL=9.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/ruby21/password"
EXAMPLESDIR="share/examples/ruby21/password"
DATADIR="share/password"
WWWDIR="www/password"
ETCDIR="etc/password"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/password
DOCSDIR=/usr/local/share/doc/ruby21/password
EXAMPLESDIR=/usr/local/share/examples/ruby21/password
WWWDIR=/usr/local/www/password
ETCDIR=/usr/local/etc/password
--End SUB_LIST--

---Begin make.conf---
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   ruby21-password-0.5.3_5 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.6.3.txz
[93i386-default-job-10] Installing pkg-1.6.3...
[93i386-default-job-10] Extracting pkg-1.6.3: .......... done
Message from pkg-1.6.3:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   ruby21-password-0.5.3_5 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of ruby21-password-0.5.3_5
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by ruby21-password-0.5.3_5 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by ruby21-password-0.5.3_5 for building
=> SHA256 Checksum OK for ruby/ruby-password-0.5.3.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===>   ruby21-password-0.5.3_5 depends on file: /usr/local/bin/ruby21 - not 
found
===>   Installing existing package /packages/All/ruby-2.1.8,1.txz
[93i386-default-job-10] Installing ruby-2.1.8,1...
[93i386-default-job-10] `-- Installing libedit-3.1.20150325_1...
[93i386-default-job-10] `-- Extracting libedit-3.1.20150325_1: .......... done
[93i386-default-job-10] `-- Installing libyaml-0.1.6_2...
[93i386-default-job-10] `-- Extracting libyaml-0.1.6_2: ......... done
[93i386-default-job-10] `-- Installing libexecinfo-1.1_3...
[93i386-default-job-10] `-- Extracting libexecinfo-1.1_3: ..... done
[93i386-default-job-10] `-- Installing libffi-3.2.1...
[93i386-default-job-10] |   `-- Installing indexinfo-0.2.4...
[93i386-default-job-10] |   `-- Extracting indexinfo-0.2.4: .... done
[93i386-default-job-10] `-- Extracting libffi-3.2.1: .......... done
[93i386-default-job-10] Extracting ruby-2.1.8,1: .......... done
Message from ruby-2.1.8,1:
====
Some of the standard commands are provided as separate ports for ease
of upgrading:

        devel/ruby-gems:        gem - RubyGems package manager
        devel/rubygem-rake:     rake - Ruby Make

And some of the standard libraries are provided as separate ports
since they require extra dependencies:

        databases/ruby-gdbm:    GDBM module

Install them as occasion demands.
====
===>   ruby21-password-0.5.3_5 depends on file: /usr/local/bin/ruby21 - found
===>   Returning to build of ruby21-password-0.5.3_5
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by ruby21-password-0.5.3_5 for building
===>  Extracting for ruby21-password-0.5.3_5
=> SHA256 Checksum OK for ruby/ruby-password-0.5.3.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===>   ruby21-password-0.5.3_5 depends on file: /usr/local/bin/ruby21 - found
===========================================================================
=======================<phase: patch          >============================
===>  Patching for ruby21-password-0.5.3_5
===>  Fixing the #! line of example/example.rb
===>  Fixing the #! line of example/pwgen
===========================================================================
=======================<phase: build-depends  >============================
===>   ruby21-password-0.5.3_5 depends on file: /usr/local/bin/ruby21 - found
===========================================================================
=======================<phase: lib-depends    >============================
===>   ruby21-password-0.5.3_5 depends on shared library: libcrack.so - not 
found
===>   Installing existing package /packages/All/cracklib-2.9.6.txz
[93i386-default-job-10] Installing cracklib-2.9.6...
[93i386-default-job-10] `-- Installing gettext-runtime-0.19.6...
[93i386-default-job-10] |   `-- Installing libiconv-1.14_9...
[93i386-default-job-10] |   `-- Extracting libiconv-1.14_9: .......... done
[93i386-default-job-10] `-- Extracting gettext-runtime-0.19.6: .......... done
[93i386-default-job-10] Extracting cracklib-2.9.6: .......... done
===>   ruby21-password-0.5.3_5 depends on shared library: libcrack.so - found 
(/usr/local/lib/libcrack.so)
===>   Returning to build of ruby21-password-0.5.3_5
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for ruby21-password-0.5.3_5
===>  Running extconf.rb to configure
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
        --with-opt-dir
        --with-opt-include
        --without-opt-include=${opt-dir}/include
        --with-opt-lib
        --without-opt-lib=${opt-dir}/lib
        --with-make-prog
        --without-make-prog
        --srcdir=.
        --curdir
        --ruby=/usr/local/bin/ruby21
        --with-crack-dict
checking for cracklib dictionary... no
Couldn't find a cracklib dictionary on this system
*** [ruby-extconf-configure] Error code 1

Stop in /usr/ports/security/ruby-password.
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to