You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     brendan+free...@bbqsrc.net
Last committer: de...@freebsd.org
Ident:          $FreeBSD: head/databases/mongodb32/Makefile 406969 2016-01-23 
12:46:58Z demon $
Log URL:        
http://beefy2.nyi.freebsd.org/data/93amd64-default/408340/logs/mongodb32-3.2.1.log
Build URL:      
http://beefy2.nyi.freebsd.org/build.html?mastername=93amd64-default&build=408340
Log:

====>> Building databases/mongodb32
build started at Sun Feb  7 08:11:33 UTC 2016
port directory: /usr/ports/databases/mongodb32
building for: FreeBSD 93amd64-default-job-18 9.3-RELEASE-p36 FreeBSD 
9.3-RELEASE-p36 amd64
maintained by: brendan+free...@bbqsrc.net
Makefile ident:      $FreeBSD: head/databases/mongodb32/Makefile 406969 
2016-01-23 12:46:58Z demon $
Poudriere version: 3.1.10
Host OSVERSION: 1100093
Jail OSVERSION: 903000

---Begin Environment---
SHELL=/bin/csh
UNAME_v=FreeBSD 9.3-RELEASE-p36
UNAME_r=9.3-RELEASE-p36
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/93amd64-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=mongodb32-3.2.1
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/93amd64-default/ref/.p/pool
MASTERNAME=93amd64-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.10
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
OSVERSION=903000
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for mongodb32-3.2.1:
     SASL=off: SASL authentication support
     SSL=on: SSL protocol support
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
PYTHON="/usr/local/bin/python2.7" 
XDG_DATA_HOME=/wrkdirs/usr/ports/databases/mongodb32/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/databases/mongodb32/work  
HOME=/wrkdirs/usr/ports/databases/mongodb32/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
OPENSSLBASE=/usr OPENSSLDIR=/etc/ssl OPENSSLINC=/usr/include 
OPENSSLLIB=/usr/lib XDG_DATA_HOME=/wrkdirs/usr/ports/databases/mongodb32/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/databases/mongodb32/work  
HOME=/wrkdirs/usr/ports/databases/mongodb32/work TMPDIR="/tmp" NO_PIE=yes 
NO_DEBUG_FILES=yes SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-fstack-protector -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS="  
-fstack-protector" LIBS=""  CXX="c++" CXXFLAGS="-O2 -pipe -fstack-protector 
-fno-strict-aliasing"  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-m 555"  BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 
555"  BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
PYTHON_INCLUDEDIR=include/python2.7
PYTHON_LIBDIR=lib/python2.7
PYTHON_PLATFORM=freebsd9
PYTHON_SITELIBDIR=lib/python2.7/site-packages
PYTHON_VER=2.7
PYTHON_VERSION=python2.7
OSREL=9.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/mongodb32"
EXAMPLESDIR="share/examples/mongodb32"
DATADIR="share/mongodb32"
WWWDIR="www/mongodb32"
ETCDIR="etc/mongodb32"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/mongodb32
DOCSDIR=/usr/local/share/doc/mongodb32
EXAMPLESDIR=/usr/local/share/examples/mongodb32
WWWDIR=/usr/local/www/mongodb32
ETCDIR=/usr/local/etc/mongodb32
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License AGPLv3 APACHE20 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   mongodb32-3.2.1 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.6.3.txz
[93amd64-default-job-18] Installing pkg-1.6.3...
[93amd64-default-job-18] Extracting pkg-1.6.3: .......... done
Message from pkg-1.6.3:
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   mongodb32-3.2.1 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of mongodb32-3.2.1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License AGPLv3 APACHE20 accepted by the user
===> Fetching all distfiles required by mongodb32-3.2.1 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License AGPLv3 APACHE20 accepted by the user
===> Fetching all distfiles required by mongodb32-3.2.1 for building
=> SHA256 Checksum OK for mongodb-src-r3.2.1.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License AGPLv3 APACHE20 accepted by the user
===> Fetching all distfiles required by mongodb32-3.2.1 for building
===>  Extracting for mongodb32-3.2.1
=> SHA256 Checksum OK for mongodb-src-r3.2.1.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for mongodb32-3.2.1
===>  Applying FreeBSD patches for mongodb32-3.2.1
===========================================================================
=======================<phase: build-depends  >============================
===>   mongodb32-3.2.1 depends on file: /usr/local/bin/python2.7 - not found
===>   Installing existing package /packages/All/python27-2.7.11_1.txz
[93amd64-default-job-18] Installing python27-2.7.11_1...
[93amd64-default-job-18] `-- Installing libffi-3.2.1...
[93amd64-default-job-18] |   `-- Installing indexinfo-0.2.4...
[93amd64-default-job-18] |   `-- Extracting indexinfo-0.2.4: .... done
[93amd64-default-job-18] `-- Extracting libffi-3.2.1: .......... done
[93amd64-default-job-18] `-- Installing gettext-runtime-0.19.6...
[93amd64-default-job-18] |   `-- Installing libiconv-1.14_9...
[93amd64-default-job-18] |   `-- Extracting libiconv-1.14_9: .......... done
[93amd64-default-job-18] `-- Extracting gettext-runtime-0.19.6: .......... done
[93amd64-default-job-18] Extracting python27-2.7.11_1: .......... done
Message from python27-2.7.11_1:
===========================================================================

Note that some standard Python modules are provided as separate ports
as they require additional dependencies. They are available as:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

===========================================================================
===>   mongodb32-3.2.1 depends on file: /usr/local/bin/python2.7 - found
===>   Returning to build of mongodb32-3.2.1
===>   mongodb32-3.2.1 depends on file: /usr/local/bin/scons - not found
===>   Installing existing package /packages/All/scons-2.4.1.txz
[93amd64-default-job-18] Installing scons-2.4.1...
[93amd64-default-job-18] `-- Installing py27-setuptools27-19.2...
[93amd64-default-job-18] `-- Extracting py27-setuptools27-19.2: .......... done
[93amd64-default-job-18] `-- Installing python2-2_3...
[93amd64-default-job-18] `-- Extracting python2-2_3: ...... done
[93amd64-default-job-18] `-- Installing m4-1.4.17_1,1...
[93amd64-default-job-18] `-- Extracting m4-1.4.17_1,1: .......... done
[93amd64-default-job-18] Extracting scons-2.4.1: .......... done
===>   mongodb32-3.2.1 depends on file: /usr/local/bin/scons - found
===>   Returning to build of mongodb32-3.2.1
===========================================================================
=======================<phase: lib-depends    >============================
===>   mongodb32-3.2.1 depends on shared library: libpcre.so - not found
===>   Installing existing package /packages/All/pcre-8.37_4.txz
[93amd64-default-job-18] Installing pcre-8.37_4...
[93amd64-default-job-18] Extracting pcre-8.37_4: .......... done
===>   mongodb32-3.2.1 depends on shared library: libpcre.so - found 
(/usr/local/lib/libpcre.so)
===>   Returning to build of mongodb32-3.2.1
===>   mongodb32-3.2.1 depends on shared library: libsnappy.so - not found
===>   Installing existing package /packages/All/snappy-1.1.3.txz
[93amd64-default-job-18] Installing snappy-1.1.3...
[93amd64-default-job-18] Extracting snappy-1.1.3: .......... done
===>   mongodb32-3.2.1 depends on shared library: libsnappy.so - found 
(/usr/local/lib/libsnappy.so)
===>   Returning to build of mongodb32-3.2.1
===>   mongodb32-3.2.1 depends on shared library: libexecinfo.so - not found
===>   Installing existing package /packages/All/libexecinfo-1.1_3.txz
[93amd64-default-job-18] Installing libexecinfo-1.1_3...
[93amd64-default-job-18] Extracting libexecinfo-1.1_3: ..... done
===>   mongodb32-3.2.1 depends on shared library: libexecinfo.so - found 
(/usr/local/lib/libexecinfo.so)
===>   Returning to build of mongodb32-3.2.1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for mongodb32-3.2.1
===========================================================================
=======================<phase: build          >============================
===>  Building for mongodb32-3.2.1
scons: Reading SConscript files ...
Mkdir("build/scons")
scons version: 2.4.1
python version: 2 7 11 'final' 0
Checking whether the C++ compiler works... yes
Checking whether the C compiler works... yes
Checking if C++ compiler "c++" is GCC... yes
Checking if C compiler "cc" is GCC... yes
Detected a x86_64 processor
Checking if target OS freebsd is supported by the toolchain yes
Checking if C compiler is GCC 4.8.2 or newer...no
Checking if C++ compiler is GCC 4.8.2 or newer...no
ERROR: Refusing to build with compiler that does not meet requirements
See 
/wrkdirs/usr/ports/databases/mongodb32/work/mongodb-src-r3.2.1/build/scons/config.log
 for details
*** [do-build] Error code 1

Stop in /usr/ports/databases/mongodb32.
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to