You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     a...@freebsd.org
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/databases/mongodb/Makefile 327717 2013-09-20 
16:13:47Z bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/10amd64-default/2013-10-17_07h20m58s/logs/mongodb-2.4.6.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/10amd64-default/2013-10-17_07h20m58s
Log:

====>> Building databases/mongodb
build started at Thu Oct 17 20:20:10 UTC 2013
port directory: /usr/ports/databases/mongodb
building for: FreeBSD 10amd64-default-job-18 10.0-BETA1 FreeBSD 10.0-BETA1 
r256420 amd64
maintained by: a...@freebsd.org
Makefile ident:      $FreeBSD: head/databases/mongodb/Makefile 327717 
2013-09-20 16:13:47Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1000500
UNAME_v=FreeBSD 10.0-BETA1 r256420
UNAME_r=10.0-BETA1
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/10amd64-default/ref
PKG_EXT=txz
tpid=17260
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=mongodb-2.4.6
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=10amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for mongodb-2.4.6:
     SASL=off: SASL support
     SM=off: Use SpiderMonkey instead of V8 for JavaScript
     SSL=on: SSL protocol support
     TEST=off: Add support for running regression test
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" OPENSSLLIB=/usr/lib OPENSSLINC=/usr/include  
OPENSSLBASE=/usr OPENSSLDIR=/etc/ssl SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=" 
-Wl,-rpath=/usr/lib:/usr/local/lib"  CXX="c++" CXXFLAGS="-O2 -pipe 
-fno-strict-aliasing"  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s 
-o root -g wheel -m 555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444" 
 BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/mongodb
DOCSDIR=/usr/local/share/doc/mongodb
EXAMPLESDIR=/usr/local/share/examples/mongodb
WWWDIR=/usr/local/www/mongodb
ETCDIR=/usr/local/etc/mongodb
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for mongodb-2.4.6
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   mongodb-2.4.6 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of mongodb-2.4.6
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License AGPLv3 AL2 accepted by the user
===> Fetching all distfiles required by mongodb-2.4.6 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License AGPLv3 AL2 accepted by the user
===> Fetching all distfiles required by mongodb-2.4.6 for building
=> SHA256 Checksum OK for mongodb-src-r2.4.6.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License AGPLv3 AL2 accepted by the user
===> Fetching all distfiles required by mongodb-2.4.6 for building
===>  Extracting for mongodb-2.4.6
=> SHA256 Checksum OK for mongodb-src-r2.4.6.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for mongodb-2.4.6
===>  Applying FreeBSD patches for mongodb-2.4.6
===========================================================================
=======================<phase: build-depends  >============================
===>   mongodb-2.4.6 depends on file: /usr/local/bin/scons - not found
===>    Verifying install for /usr/local/bin/scons in /usr/ports/devel/scons
===>   Installing existing package /packages/All/scons-2.3.0.txz
Installing scons-2.3.0...Installing gettext-0.18.3.1... done
Installing python27-2.7.5_3... done
Installing python2-2_1... done
Installing python-2.7_1,2... done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of mongodb-2.4.6
===========================================================================
=======================<phase: lib-depends    >============================
===>   mongodb-2.4.6 depends on shared library: execinfo - found
===>   mongodb-2.4.6 depends on shared library: pcre - not found
===>    Verifying install for pcre in /usr/ports/devel/pcre
===>   Installing existing package /packages/All/pcre-8.33.txz
Installing pcre-8.33... done
===>   Returning to build of mongodb-2.4.6
===>   mongodb-2.4.6 depends on shared library: snappy - not found
===>    Verifying install for snappy in /usr/ports/archivers/snappy
===>   Installing existing package /packages/All/snappy-1.1.0.txz
Installing snappy-1.1.0... done
===>   Returning to build of mongodb-2.4.6
===>   mongodb-2.4.6 depends on shared library: v8 - not found
===>    Verifying install for v8 in /usr/ports/lang/v8
===>   Installing existing package /packages/All/v8-3.18.5.txz
Installing v8-3.18.5... done
===>   Returning to build of mongodb-2.4.6
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for mongodb-2.4.6
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/databases/mongodb/work/mongodb-src-r2.4.6/src/third_party/pcre-8.30/aclocal.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/databases/mongodb/work/mongodb-src-r2.4.6/src/third_party/pcre-8.30/configure
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/databases/mongodb/work/mongodb-src-r2.4.6/src/third_party/pcre-8.30/libtool
===========================================================================
=======================<phase: build          >============================
===>  Building for mongodb-2.4.6
scons: Reading SConscript files ...
Mkdir(".scons/FreeBSD/nohost")
scons version: 2.3.0
python version: 2 7 5 'final' 0
Checking whether the C++ compiler worksyes
Checking for C library pcrecpp... yes
Checking for C library pcre... yes
Checking for C library snappy... yes
Checking for C header file unistd.h... yes
Checking whether clock_gettime is declared... yes
Checking for C library rt... yes
Checking for C++ header file execinfo.h... yes
Checking whether backtrace is declared... yes
Checking whether backtrace_symbols is declared... yes
Checking whether backtrace_symbols_fd is declared... yes
Checking for C library pcap... yes
Checking for C library v8... yes
Checking for C library execinfo... yes
scons: done reading SConscript files.
scons: Building targets ...
/usr/local/bin/python2 src/mongo/base/generate_error_codes.py 
src/mongo/base/error_codes.err 
build/freebsd/cc_cc/cxx_c++/ssl/use-system-pcre/use-system-snappy/use-system-v8/usev8/mongo/base/error_codes.h
 
build/freebsd/cc_cc/cxx_c++/ssl/use-system-pcre/use-system-snappy/use-system-v8/usev8/mongo/base/error_codes.cpp
c++ -o 
build/freebsd/cc_cc/cxx_c++/ssl/use-system-pcre/use-system-snappy/use-system-v8/usev8/mongo/shell/dbshell.o
 -c -Wnon-virtual-dtor -Woverloaded-virtual -fno-omit-frame-pointer -fPIC 
-fno-strict-aliasing -ggdb -pthread -Wall -Wsign-compare -Wno-unknown-pragmas 
-Winvalid-pch -O2 -pipe -fno-strict-aliasing -DBOOST_ALL_NO_LIB -D_SCONS 
-DMONGO_EXPOSE_MACROS -DSUPPORT_UTF8 -D__freebsd__ -D_FILE_OFFSET_BITS=64 
-DMONGO_SSL -DMONGO_HAVE_HEADER_UNISTD_H -DMONGO_HAVE_EXECINFO_BACKTRACE 
-Ibuild/freebsd/cc_cc/cxx_c++/ssl/use-system-pcre/use-system-snappy/use-system-v8/usev8/third_party/libstemmer_c/include
 -Isrc/third_party/libstemmer_c/include 
-Ibuild/freebsd/cc_cc/cxx_c++/ssl/use-system-pcre/use-system-snappy/use-system-v8/usev8/third_party/s2
 -Isrc/third_party/s2 
-Ibuild/freebsd/cc_cc/cxx_c++/ssl/use-system-pcre/use-system-snappy/use-system-v8/usev8/third_party/boost
 -Isrc/third_party/boost 
-Ibuild/freebsd/cc_cc/cxx_c++/ssl/use-system-pcre/use-system-snappy/use-system-v8/usev8
 -I
 src -Ibu
 
ild/freebsd/cc_cc/cxx_c++/ssl/use-system-pcre/use-system-snappy/use-system-v8/usev8/mongo
 -Isrc/mongo -I/usr/local/include src/mongo/shell/dbshell.cpp
In file included from src/mongo/shell/dbshell.cpp:26:
In file included from src/mongo/base/initializer.h:21:
In file included from src/mongo/base/configuration_variable_manager.h:24:
src/mongo/platform/unordered_map.h:51:16: error: no member named 'tr1' in 
namespace 'std'
    using std::tr1::unordered_map;
          ~~~~~^
In file included from src/mongo/shell/dbshell.cpp:26:
In file included from src/mongo/base/initializer.h:24:
In file included from src/mongo/base/initializer_dependency_graph.h:26:
src/mongo/platform/unordered_set.h:51:16: error: no member named 'tr1' in 
namespace 'std'
    using std::tr1::unordered_set;
          ~~~~~^
2 errors generated.
scons: *** 
[build/freebsd/cc_cc/cxx_c++/ssl/use-system-pcre/use-system-snappy/use-system-v8/usev8/mongo/shell/dbshell.o]
 Error 1
scons: building terminated because of errors.
*** Error code 2

Stop.
make: stopped in /usr/ports/databases/mongodb
===>  Cleaning for mongodb-2.4.6
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to