You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     bey...@cs.ucr.edu
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/audio/xmms-timidity/Makefile 327706 2013-09-20 
14:36:35Z bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/10amd64-default/2013-10-17_07h20m58s/logs/xmms-timidity-0.0.3_1.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/10amd64-default/2013-10-17_07h20m58s
Log:

====>> Building audio/xmms-timidity
build started at Thu Oct 17 21:28:52 UTC 2013
port directory: /usr/ports/audio/xmms-timidity
building for: FreeBSD 10amd64-default-job-19 10.0-BETA1 FreeBSD 10.0-BETA1 
r256420 amd64
maintained by: bey...@cs.ucr.edu
Makefile ident:      $FreeBSD: head/audio/xmms-timidity/Makefile 327706 
2013-09-20 14:36:35Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1000500
UNAME_v=FreeBSD 10.0-BETA1 r256420
UNAME_r=10.0-BETA1
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/10amd64-default/ref
PKG_EXT=txz
tpid=53345
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=xmms-timidity-0.0.3_1
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=10amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh 
GLIB_CONFIG="/usr/local/bin/glib12-config" 
GTK_CONFIG="/usr/local/bin/gtk12-config"
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES 
GLIB_CONFIG="/usr/local/bin/glib12-config" 
GTK_CONFIG="/usr/local/bin/gtk12-config" PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-I/usr/local/include `glib-config --cflags` -g -fPIC -fno-strict-aliasing 
-std=gnu89"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="c++" CXXFLAGS="-O2 -pipe 
-I/usr/local/include `glib-config --cflags` -g -fPIC -fno-strict-aliasing"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 
555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/xmms-timidity
DOCSDIR=/usr/local/share/doc/xmms-timidity
EXAMPLESDIR=/usr/local/share/examples/xmms-timidity
WWWDIR=/usr/local/www/xmms-timidity
ETCDIR=/usr/local/etc/xmms-timidity
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for xmms-timidity-0.0.3_1
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   xmms-timidity-0.0.3_1 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of xmms-timidity-0.0.3_1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by xmms-timidity-0.0.3_1 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by xmms-timidity-0.0.3_1 for building
=> SHA256 Checksum OK for xmms-timidity-0.0.3.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by xmms-timidity-0.0.3_1 for building
===>  Extracting for xmms-timidity-0.0.3_1
=> SHA256 Checksum OK for xmms-timidity-0.0.3.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for xmms-timidity-0.0.3_1
===>  Applying FreeBSD patches for xmms-timidity-0.0.3_1
===========================================================================
=======================<phase: build-depends  >============================
===========================================================================
=======================<phase: lib-depends    >============================
===>   xmms-timidity-0.0.3_1 depends on shared library: xmms.4 - not found
===>    Verifying install for xmms.4 in /usr/ports/multimedia/xmms
===>   Installing existing package /packages/All/xmms-1.2.11_18.txz
Installing xmms-1.2.11_18...Installing xproto-7.0.24... done
Installing xf86vidmodeproto-2.3.1... done
Installing xextproto-7.2.1... done
Installing libxcb-1.9.1...Installing libXdmcp-1.1.1... done
Installing libXau-1.0.8... done
Installing libxml2-2.8.0_2... done
Installing libpthread-stubs-0.3_3... done
 done
Installing libXxf86vm-1.1.3...Installing libXext-1.3.2,1...Installing 
libX11-1.6.2,1...Installing kbproto-1.0.6... done
 done
 done
 done
Installing libXi-1.7.2,1...Installing libXfixes-5.0.1...Installing 
fixesproto-5.0... done
 done
Installing inputproto-2.3... done
 done
Installing libXdamage-1.1.4...Installing damageproto-1.2.1... done
 done
Installing libSM-1.2.2,1...Installing libICE-1.0.8,1... done
 done
Installing dri2proto-2.8... done
Installing gtk1-1.2.10_22...Installing glib12-1.2.10_13... done
Installing gettext-0.18.3.1... done
 done
Installing expat-2.1.0... done
Installing pciids-20131010... done
Installing python27-2.7.5_3... done
Installing python2-2_1... done
Installing python-2.7_1,2... done
Installing perl-5.14.4_2...Removing /usr/local/etc/perl5_version... Done.
Creating /usr/local/etc/perl5_version... Done.
Removing stale symlinks from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl5
Done.
 done
Installing libdrm-2.4.17_1...Installing libpciaccess-0.13.2... done
 done
Installing libGL-7.6.1_4... done
Installing pcre-8.33... done
Installing libffi-3.0.13... done
Installing glib-2.36.3...No schema files found: doing nothing.
 done
Installing desktop-file-utils-0.22... done
Installing libvorbis-1.3.3_1,3...Installing libogg-1.3.1,4... done
 done
Installing libmikmod-3.1.12... done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *

Xmms supports Gzipped and uncompressed skins.  If you would like to use
Zip format skins you will need to ensure archivers/unzip is installed.

* * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * * *
===>   Returning to build of xmms-timidity-0.0.3_1
===>   xmms-timidity-0.0.3_1 depends on shared library: glib-12.3 - found
===>   xmms-timidity-0.0.3_1 depends on shared library: gtk-12.2 - found
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for xmms-timidity-0.0.3_1
===========================================================================
=======================<phase: build          >============================
===>  Building for xmms-timidity-0.0.3_1
(cd /wrkdirs/usr/ports/audio/xmms-timidity/work/xmms-timidity-0.0.3 && c++ -O2 
-pipe -I/usr/local/include `glib-config --cflags` -g -fPIC -fno-strict-aliasing 
-std=gnu89 -c xmms-timidity.cpp -o xmms-timidity.o)
error: invalid argument '-std=gnu89' not allowed with 'C++/ObjC++'
*** Error code 1

Stop.
make: stopped in /usr/ports/audio/xmms-timidity
===>  Cleaning for xmms-timidity-0.0.3_1
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to