You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     mas...@club.kyutech.ac.jp
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/www/mod_spdy/Makefile 327776 2013-09-20 
23:36:50Z bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/10amd64-default/2013-10-17_07h20m58s/logs/mod_spdy-0.9.3.3.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/10amd64-default/2013-10-17_07h20m58s
Log:

====>> Building www/mod_spdy
build started at Thu Oct 17 21:54:00 UTC 2013
port directory: /usr/ports/www/mod_spdy
building for: FreeBSD 10amd64-default-job-02 10.0-BETA1 FreeBSD 10.0-BETA1 
r256420 amd64
maintained by: mas...@club.kyutech.ac.jp
Makefile ident:      $FreeBSD: head/www/mod_spdy/Makefile 327776 2013-09-20 
23:36:50Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1000500
UNAME_v=FreeBSD 10.0-BETA1 r256420
UNAME_r=10.0-BETA1
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/10amd64-default/ref
PKG_EXT=txz
tpid=20937
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=mod_spdy-0.9.3.3
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=10amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
===> The following configuration options are available for mod_spdy-0.9.3.3:
     CLANG=on: Build with Clang instead of GCC 4.6+
     DEBUG=off: Compile with debug symbols and verbose output
===> Use 'make config' to modify these settings
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" PYTHON="/usr/local/bin/python2.7" MAKE=gmake 
TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" V=1 BUILDTYPE=Debug TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh 
NO_LINT=YES PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  
CC="clang" CFLAGS="-O2 -pipe -Wno-error -fno-strict-aliasing"  CPP="cpp" 
CPPFLAGS=""  LDFLAGS=" -L/usr/local/lib"  CXX="clang++" CXXFLAGS="-O2 -pipe 
-Wno-error -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
APACHEMODDIR=libexec/apache22
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/mod_spdy
DOCSDIR=/usr/local/share/doc/mod_spdy
EXAMPLESDIR=/usr/local/share/examples/mod_spdy
WWWDIR=/usr/local/www/mod_spdy
ETCDIR=/usr/local/etc/mod_spdy
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for mod_spdy-0.9.3.3
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   mod_spdy-0.9.3.3 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of mod_spdy-0.9.3.3
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by mod_spdy-0.9.3.3 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by mod_spdy-0.9.3.3 for building
=> SHA256 Checksum OK for mod_spdy/mod_spdy_source_0.9.3.3.tar.xz.
=> SHA256 Checksum OK for mod_spdy/httpd-2.2.22.tar.gz.
=> SHA256 Checksum OK for mod_spdy/openssl-1.0.1c.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by mod_spdy-0.9.3.3 for building
===>  Extracting for mod_spdy-0.9.3.3
=> SHA256 Checksum OK for mod_spdy/mod_spdy_source_0.9.3.3.tar.xz.
=> SHA256 Checksum OK for mod_spdy/httpd-2.2.22.tar.gz.
=> SHA256 Checksum OK for mod_spdy/openssl-1.0.1c.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for mod_spdy-0.9.3.3
===>  Applying FreeBSD patches for mod_spdy-0.9.3.3
===========================================================================
=======================<phase: build-depends  >============================
===>   mod_spdy-0.9.3.3 depends on executable: greadlink - not found
===>    Verifying install for greadlink in /usr/ports/sysutils/coreutils
===>   Installing existing package /packages/All/coreutils-8.20_2.txz
Installing coreutils-8.20_2...Installing gettext-0.18.3.1... done
 done
===>   Returning to build of mod_spdy-0.9.3.3
===>   mod_spdy-0.9.3.3 depends on executable: flock - not found
===>    Verifying install for flock in /usr/ports/sysutils/flock
===>   Installing existing package /packages/All/flock-2.19.txz
Installing flock-2.19... done
===>   Returning to build of mod_spdy-0.9.3.3
===>   mod_spdy-0.9.3.3 depends on executable: svn - not found
===>    Verifying install for svn in /usr/ports/devel/subversion
===>   Installing existing package /packages/All/subversion-1.8.3.txz
Installing subversion-1.8.3...Installing serf-1.2.1_1...Installing 
expat-2.1.0... done
Installing apr-1.4.8.1.5.2...Installing db42-4.2.52_5... done
Installing gdbm-1.10... done
 done
 done
Installing sqlite3-3.8.0.2... done
 done
===>   Returning to build of mod_spdy-0.9.3.3
===>   mod_spdy-0.9.3.3 depends on executable: curl - not found
===>    Verifying install for curl in /usr/ports/ftp/curl
===>   Installing existing package /packages/All/curl-7.32.0.txz
Installing curl-7.32.0...Installing ca_root_nss-3.15.1_1... done
 done
===>   Returning to build of mod_spdy-0.9.3.3
===>   mod_spdy-0.9.3.3 depends on executable: bash - not found
===>    Verifying install for bash in /usr/ports/shells/bash
===>   Installing existing package /packages/All/bash-4.2.45.txz
Installing bash-4.2.45... done
===>   Returning to build of mod_spdy-0.9.3.3
===>   mod_spdy-0.9.3.3 depends on file: /usr/local/bin/python2.7 - not found
===>    Verifying install for /usr/local/bin/python2.7 in 
/usr/ports/lang/python27
===>   Installing existing package /packages/All/python27-2.7.5_3.txz
Installing python27-2.7.5_3... done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of mod_spdy-0.9.3.3
===>   mod_spdy-0.9.3.3 depends on executable: python - not found
===>    Verifying install for python in /usr/ports/lang/python
===>   Installing existing package /packages/All/python-2.7_1,2.txz
Installing python-2.7_1,2...Installing python2-2_1... done
 done
===>   Returning to build of mod_spdy-0.9.3.3
===>   mod_spdy-0.9.3.3 depends on file: /usr/local/sbin/apxs - not found
===>    Verifying install for /usr/local/sbin/apxs in /usr/ports/www/apache22
===>   Installing existing package /packages/All/apache22-2.2.25.txz
Installing apache22-2.2.25...Installing perl-5.14.4_2...Removing 
/usr/local/etc/perl5_version... Done.
Creating /usr/local/etc/perl5_version... Done.
Removing stale symlinks from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl5
Done.
 done
Installing pcre-8.33... done
===> Creating users and/or groups.
Using existing group 'www'.
Using existing user 'www'.
 done
To run apache www server from startup, add apache22_enable="YES"
in your /etc/rc.conf. Extra options can be found in startup script.

Your hostname must be resolvable using at least 1 mechanism in
/etc/nsswitch typically DNS or /etc/hosts or apache might
have issues starting depending on the modules you are using.
===>   Returning to build of mod_spdy-0.9.3.3
===>   mod_spdy-0.9.3.3 depends on executable: gmake - not found
===>    Verifying install for gmake in /usr/ports/devel/gmake
===>   Installing existing package /packages/All/gmake-3.82_1.txz
Installing gmake-3.82_1... done
===>   Returning to build of mod_spdy-0.9.3.3
===========================================================================
=======================<phase: lib-depends    >============================
===>   mod_spdy-0.9.3.3 depends on shared library: execinfo.1 - found
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for mod_spdy-0.9.3.3

________ running '/usr/local/bin/python2.7 src/build/gyp_chromium' in 
'/wrkdirs/usr/ports/www/mod_spdy/work/mod_spdy_source_0.9.3.3/mod_spdy'
Error: Command /usr/local/bin/python2.7 src/build/gyp_chromium returned 
non-zero exit status 1 in 
/wrkdirs/usr/ports/www/mod_spdy/work/mod_spdy_source_0.9.3.3/mod_spdy
Updating projects from gyp files...
g++: not found
compiler_version.py failed to execute: g++ -dumpversion
Command 'g++ -dumpversion' returned non-zero exit status 127
Traceback (most recent call last):
  File "src/build/gyp_chromium", line 24, in <module>
    execfile(os.path.join(chrome_src, 'build', 'gyp_chromium'))
  File "src/third_party/chromium/src/build/gyp_chromium", line 173, in <module>
    sys.exit(gyp.main(args))
  File 
"/wrkdirs/usr/ports/www/mod_spdy/work/mod_spdy_source_0.9.3.3/mod_spdy/src/tools/gyp/pylib/gyp/__init__.py",
 line 471, in main
    options.circular_check)
  File 
"/wrkdirs/usr/ports/www/mod_spdy/work/mod_spdy_source_0.9.3.3/mod_spdy/src/tools/gyp/pylib/gyp/__init__.py",
 line 111, in Load
    depth, generator_input_info, check, circular_check)
  File 
"/wrkdirs/usr/ports/www/mod_spdy/work/mod_spdy_source_0.9.3.3/mod_spdy/src/tools/gyp/pylib/gyp/input.py",
 line 2378, in Load
    depth, check)
  File 
"/wrkdirs/usr/ports/www/mod_spdy/work/mod_spdy_source_0.9.3.3/mod_spdy/src/tools/gyp/pylib/gyp/input.py",
 line 384, in LoadTargetBuildFile
    build_file_data, PHASE_EARLY, variables, build_file_path)
  File 
"/wrkdirs/usr/ports/www/mod_spdy/work/mod_spdy_source_0.9.3.3/mod_spdy/src/tools/gyp/pylib/gyp/input.py",
 line 975, in ProcessVariablesAndConditionsInDict
    variables, build_file, 'variables')
  File 
"/wrkdirs/usr/ports/www/mod_spdy/work/mod_spdy_source_0.9.3.3/mod_spdy/src/tools/gyp/pylib/gyp/input.py",
 line 1027, in ProcessVariablesAndConditionsInDict
    ProcessConditionsInDict(the_dict, phase, variables, build_file)
  File 
"/wrkdirs/usr/ports/www/mod_spdy/work/mod_spdy_source_0.9.3.3/mod_spdy/src/tools/gyp/pylib/gyp/input.py",
 line 904, in ProcessConditionsInDict
    variables, build_file)
  File 
"/wrkdirs/usr/ports/www/mod_spdy/work/mod_spdy_source_0.9.3.3/mod_spdy/src/tools/gyp/pylib/gyp/input.py",
 line 982, in ProcessVariablesAndConditionsInDict
    expanded = ExpandVariables(value, phase, variables, build_file)
  File 
"/wrkdirs/usr/ports/www/mod_spdy/work/mod_spdy_source_0.9.3.3/mod_spdy/src/tools/gyp/pylib/gyp/input.py",
 line 714, in ExpandVariables
    (contents, p.returncode))
Exception: Call to 'python ../build/compiler_version.py' returned exit status 
1. while trying to load 
/wrkdirs/usr/ports/www/mod_spdy/work/mod_spdy_source_0.9.3.3/mod_spdy/src/build/all.gyp
*** Error code 2

Stop.
make: stopped in /usr/ports/www/mod_spdy
===>  Cleaning for mod_spdy-0.9.3.3
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to