You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     gasol...@gmail.com
Last committer: vani...@freebsd.org
Ident:          $FreeBSD: head/devel/jsonnet/Makefile 407358 2016-01-27 
14:09:11Z vanilla $
Log URL:        
http://beefy1.nyi.freebsd.org/data/93i386-default/409991/logs/jsonnet-0.8.6.log
Build URL:      
http://beefy1.nyi.freebsd.org/build.html?mastername=93i386-default&build=409991
Log:

====>> Building devel/jsonnet
build started at Thu Mar  3 03:25:40 UTC 2016
port directory: /usr/ports/devel/jsonnet
building for: FreeBSD 93i386-default-job-15 9.3-RELEASE-p36 FreeBSD 
9.3-RELEASE-p36 i386
maintained by: gasol...@gmail.com
Makefile ident:      $FreeBSD: head/devel/jsonnet/Makefile 407358 2016-01-27 
14:09:11Z vanilla $
Poudriere version: 3.1.12
Host OSVERSION: 1100097
Jail OSVERSION: 903000

---Begin Environment---
SHELL=/bin/csh
UNAME_p=i386
UNAME_m=i386
UNAME_v=FreeBSD 9.3-RELEASE-p36
UNAME_r=9.3-RELEASE-p36
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
SAVED_TERM=
MASTERMNT=/usr/local/poudriere/data/.m/93i386-default/ref
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
POUDRIERE_BUILD_TYPE=bulk
PKGNAME=jsonnet-0.8.6
OLDPWD=/
PWD=/usr/local/poudriere/data/.m/93i386-default/ref/.p/pool
MASTERNAME=93i386-default
SCRIPTPREFIX=/usr/local/share/poudriere
USER=root
HOME=/root
POUDRIERE_VERSION=3.1.12
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
LIBEXECPREFIX=/usr/local/libexec/poudriere
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
OSVERSION=903000
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
MAKE=gmake XDG_DATA_HOME=/wrkdirs/usr/ports/devel/jsonnet/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/jsonnet/work  
HOME=/wrkdirs/usr/ports/devel/jsonnet/work TMPDIR="/tmp" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
XDG_DATA_HOME=/wrkdirs/usr/ports/devel/jsonnet/work  
XDG_CONFIG_HOME=/wrkdirs/usr/ports/devel/jsonnet/work  
HOME=/wrkdirs/usr/ports/devel/jsonnet/work TMPDIR="/tmp" NO_PIE=yes 
WITHOUT_DEBUG_FILES=yes WITHOUT_KERNEL_SYMBOLS=yes SHELL=/bin/sh NO_LINT=YES 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS="" LIBS=""  
CXX="c++" CXXFLAGS="-O2 -pipe -fno-strict-aliasing -fPIC -Iinclude -std=c++11"  
MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -m 555"  
BSD_INSTALL_LIB="install  -s -m 444"  BSD_INSTALL_SCRIPT="install  -m 555"  
BSD_INSTALL_DATA="install  -m 0644"  BSD_INSTALL_MAN="install  -m 444"
--End MAKE_ENV--

--PLIST_SUB--
OSREL=9.3
PREFIX=%D
LOCALBASE=/usr/local
RESETPREFIX=/usr/local
PORTDOCS=""
PORTEXAMPLES=""
LIB32DIR=lib
DOCSDIR="share/doc/jsonnet"
EXAMPLESDIR="share/examples/jsonnet"
DATADIR="share/jsonnet"
WWWDIR="www/jsonnet"
ETCDIR="etc/jsonnet"
--End PLIST_SUB--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/jsonnet
DOCSDIR=/usr/local/share/doc/jsonnet
EXAMPLESDIR=/usr/local/share/examples/jsonnet
WWWDIR=/usr/local/www/jsonnet
ETCDIR=/usr/local/etc/jsonnet
--End SUB_LIST--

---Begin make.conf---
MACHINE=i386
MACHINE_ARCH=i386
ARCH=${MACHINE_ARCH}
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
=======================<phase: check-sanity   >============================
===>  License APACHE20 accepted by the user
===========================================================================
=======================<phase: pkg-depends    >============================
===>   jsonnet-0.8.6 depends on file: /usr/local/sbin/pkg - not found
===>   Installing existing package /packages/All/pkg-1.6.4_1.txz
[93i386-default-job-15] Installing pkg-1.6.4_1...
[93i386-default-job-15] Extracting pkg-1.6.4_1: .......... done
===>   jsonnet-0.8.6 depends on file: /usr/local/sbin/pkg - found
===>   Returning to build of jsonnet-0.8.6
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License APACHE20 accepted by the user
===> Fetching all distfiles required by jsonnet-0.8.6 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License APACHE20 accepted by the user
===> Fetching all distfiles required by jsonnet-0.8.6 for building
=> SHA256 Checksum OK for google-jsonnet-v0.8.6_GH0.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License APACHE20 accepted by the user
===> Fetching all distfiles required by jsonnet-0.8.6 for building
===>  Extracting for jsonnet-0.8.6
=> SHA256 Checksum OK for google-jsonnet-v0.8.6_GH0.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for jsonnet-0.8.6
===========================================================================
=======================<phase: build-depends  >============================
===>   jsonnet-0.8.6 depends on executable: gmake - not found
===>   Installing existing package /packages/All/gmake-4.1_2.txz
[93i386-default-job-15] Installing gmake-4.1_2...
[93i386-default-job-15] `-- Installing indexinfo-0.2.4...
[93i386-default-job-15] `-- Extracting indexinfo-0.2.4: .... done
[93i386-default-job-15] `-- Installing libiconv-1.14_9...
[93i386-default-job-15] `-- Extracting libiconv-1.14_9: .......... done
[93i386-default-job-15] `-- Installing gettext-runtime-0.19.7...
[93i386-default-job-15] `-- Extracting gettext-runtime-0.19.7: .......... done
[93i386-default-job-15] Extracting gmake-4.1_2: .......... done
===>   jsonnet-0.8.6 depends on executable: gmake - found
===>   Returning to build of jsonnet-0.8.6
===========================================================================
=======================<phase: lib-depends    >============================
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for jsonnet-0.8.6
===========================================================================
=======================<phase: build          >============================
===>  Building for jsonnet-0.8.6
((od -v -Anone -t u1 stdlib/std.jsonnet \
        | tr " " "\n" \
        | grep -v "^$" \
        | tr "\n" "," ) && echo "0") > core/std.jsonnet.h
echo >> core/std.jsonnet.h
c++ -c -O2 -pipe -fno-strict-aliasing -fPIC -Iinclude -std=c++11 
core/desugaring.cpp -o core/desugaring.o
cc1plus: error: unrecognized command line option "-std=c++11"
Makefile:99: recipe for target 'core/desugaring.o' failed
gmake: *** [core/desugaring.o] Error 1
*** [do-build] Error code 1

Stop in /usr/ports/devel/jsonnet.
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to