You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     jh...@freebsd.org
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/graphics/py-opencv/Makefile 327733 2013-09-20 
18:35:44Z bapt $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/head-i386-default/2013-10-17_19h54m49s/logs/py27-opencv-2.3.1_7.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/head-i386-default/2013-10-17_19h54m49s
Log:

====>> Building graphics/py-opencv
build started at Thu Oct 17 23:17:14 UTC 2013
port directory: /usr/ports/graphics/py-opencv
building for: FreeBSD head-i386-default-job-17 11.0-CURRENT FreeBSD 
11.0-CURRENT r256430 i386
maintained by: jh...@freebsd.org
Makefile ident:      $FreeBSD: head/graphics/py-opencv/Makefile 327733 
2013-09-20 18:35:44Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=1100000
UNAME_v=FreeBSD 11.0-CURRENT r256430
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/head-i386-default/ref
PKG_EXT=txz
tpid=87563
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=py27-opencv-2.3.1_7
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=head-i386-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" PYTHON="/usr/local/bin/python2.7" PKG_CONFIG=pkgconf 
TMPDIR="/tmp" SHELL=/bin/sh CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 -pipe 
-fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing -Wno-error -Wno-c++11-narrowing 
-std=gnu++11"  MANPREFIX="/usr/local" BSD_INSTALL_PROGRAM="install  -s -o root 
-g wheel -m 555"  BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/OpenCV
DOCSDIR=/usr/local/share/doc/opencv
EXAMPLESDIR=/usr/local/share/examples/opencv
WWWDIR=/usr/local/www/opencv
ETCDIR=/usr/local/etc/opencv
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for py27-opencv-2.3.1_7
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   py27-opencv-2.3.1_7 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of py27-opencv-2.3.1_7
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License BSD accepted by the user
===> Fetching all distfiles required by py27-opencv-2.3.1_7 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License BSD accepted by the user
===> Fetching all distfiles required by py27-opencv-2.3.1_7 for building
=> SHA256 Checksum OK for OpenCV-2.3.1a.tar.bz2.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License BSD accepted by the user
===> Fetching all distfiles required by py27-opencv-2.3.1_7 for building
===>  Extracting for py27-opencv-2.3.1_7
=> SHA256 Checksum OK for OpenCV-2.3.1a.tar.bz2.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for py27-opencv-2.3.1_7
===>  Applying extra patch 
/usr/ports/graphics/py-opencv/../opencv/files/extra-patch-opencv-python
===>  Applying FreeBSD patches for py27-opencv-2.3.1_7
===========================================================================
=======================<phase: build-depends  >============================
===>   py27-opencv-2.3.1_7 depends on file: 
/usr/local/lib/python2.7/site-packages/numpy/core/numeric.py - not found
===>    Verifying install for 
/usr/local/lib/python2.7/site-packages/numpy/core/numeric.py in 
/usr/ports/math/py-numpy
===>   Installing existing package /packages/All/py27-numpy-1.7.0_1,1.txz
Installing py27-numpy-1.7.0_1,1...Installing suitesparse-4.0.2_1...Installing 
mpfr-3.1.2...Installing gmp-5.1.3... done
 done
Installing mpc-0.9... done
Installing lapack-3.4.2...Installing blas-3.4.2...Installing gcc-ecj-4.5... done
Installing gcc-4.6.3...Installing gettext-0.18.3.1... done
Installing binutils-2.23.2... done
 done
 done
 done
 done
Installing python27-2.7.5_3... done
Installing python2-2_1... done
Installing python-2.7_1,2... done
Installing py27-nose-1.3.0...Installing py27-distribute-0.6.35... done
215
238
 done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of py27-opencv-2.3.1_7
===>   py27-opencv-2.3.1_7 depends on file: /usr/local/bin/python2.7 - found
===>   py27-opencv-2.3.1_7 depends on executable: python - found
===>   py27-opencv-2.3.1_7 depends on file: /usr/local/bin/cmake - not found
===>    Verifying install for /usr/local/bin/cmake in /usr/ports/devel/cmake
===>   Installing existing package /packages/All/cmake-2.8.11.2.txz
Installing cmake-2.8.11.2...Installing cmake-modules-2.8.11.2_1... done
 done
===>   Returning to build of py27-opencv-2.3.1_7
===>   py27-opencv-2.3.1_7 depends on executable: pkgconf - not found
===>    Verifying install for pkgconf in /usr/ports/devel/pkgconf
===>   Installing existing package /packages/All/pkgconf-0.9.3.txz
Installing pkgconf-0.9.3... done
===>   Returning to build of py27-opencv-2.3.1_7
===========================================================================
=======================<phase: lib-depends    >============================
===>   py27-opencv-2.3.1_7 depends on shared library: opencv_legacy.2 - not 
found
===>    Verifying install for opencv_legacy.2 in /usr/ports/graphics/opencv
===>   Installing existing package /packages/All/opencv-2.3.1_7.txz
Installing opencv-2.3.1_7...Installing libv4l-0.8.8_1...Installing jpeg-8_4... 
done
 done
Installing tiff-4.0.3...Installing jbigkit-1.6... done
 done
Installing png-1.5.17... done
Installing opencv-core-2.3.1_7... done
Installing jasper-1.900.1_12... done
 done
===>   Returning to build of py27-opencv-2.3.1_7
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for py27-opencv-2.3.1_7
===>  Performing in-source build
/bin/mkdir -p /wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1
-- The C compiler identification is Clang 3.3.0
-- The CXX compiler identification is Clang 3.3.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Found ZLIB: /usr/lib/libz.so (found version "1.2.8") 
-- Looking for alloca.h
-- Looking for alloca.h - not found
-- Looking for alloca
-- Looking for alloca - not found
-- Looking for unistd.h
-- Looking for unistd.h - found
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Found PythonInterp: /usr/local/bin/python2.7 (found suitable version 
"2.7.5", minimum required is "2.7") 
-- Found PythonLibs: /usr/local/lib/libpython2.7.so (found suitable version 
"2.7.5", minimum required is "2.7") 
--     Use NumPy headers from: 
/usr/local/lib/python2.7/site-packages/numpy/core/include
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named sphinx
-- Parsing 'cvconfig.h.cmake'
-- 
-- General configuration for opencv 2.3.1 =====================================
-- 
--     Built as dynamic libs?:     YES
--     Compiler:                   /usr/bin/c++
--     C++ flags (Release):        -O2 -pipe -fno-strict-aliasing -Wno-error 
-Wno-c++11-narrowing -std=gnu++11   -O2 -pipe -fno-strict-aliasing -Wno-error 
-Wno-c++11-narrowing -std=gnu++11  
--     C++ flags (Debug):          -O2 -pipe -fno-strict-aliasing -Wno-error 
-Wno-c++11-narrowing -std=gnu++11   -O2 -pipe -fno-strict-aliasing -Wno-error 
-Wno-c++11-narrowing -std=gnu++11  
--     Linker flags (Release):
--     Linker flags (Debug):
-- 
--   GUI: 
--     GTK+ 2.x:                   NO
--     GThread:                    NO
-- 
--   Media I/O: 
--     ZLib:                       YES
--     JPEG:                       FALSE
--     PNG:                        FALSE
--     TIFF:                       FALSE
--     JPEG 2000:                  FALSE
--     OpenEXR:                    NO
--     OpenNI:                     NO
--     OpenNI PrimeSensor Modules: NO
--     XIMEA:                      NO
-- 
--   Video I/O:
--     DC1394 1.x:                 NO
--     DC1394 2.x:                 NO
--     FFMPEG:                     NO
--       codec:                    NO
--       format:                   NO
--       util:                     NO
--       swscale:                  NO
--       gentoo-style:             NO
--     GStreamer:                  NO
--     UniCap:                     NO
--     PvAPI:                      NO
--     V4L/V4L2:                   FALSE/FALSE
--     Xine:                       NO
-- 
--   Other third-party libraries:
--     Use IPP:                    NO
--     Use TBB:                    NO
--     Use ThreadingFramework:     NO
--     Use Cuda:                   NO
--     Use Eigen:                  NO
-- 
--   Interfaces:
--     Python:                     YES
--     Python interpreter:         /usr/local/bin/python2.7 -B (ver 2.7)
--     Python numpy:               YES
--     Java:                       NO
-- 
--   Documentation:
--     Sphinx:                     NO
--     PdfLaTeX compiler:          NO
--     Build Documentation:        NO
-- 
--   Tests and samples:
--     Tests:                      NO
--     Examples:                   NO
-- 
--   Install path:                 /usr/local
-- 
--   cvconfig.h is in:             
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1
-- -----------------------------------------------------------------
-- 
CMake Warning at CMakeLists.txt:1754 (message):
  The source directory is the same as binary directory.  "make clean" may
  damage the source tree


-- Configuring done
-- Generating done
CMake Warning:
  Manually-specified variables were not used by the project:

    CMAKE_MODULE_LINKER_FLAGS
    DWITH_EIGEN2
    THREADS_HAVE_PTHREAD_ARG


-- Build files have been written to: 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1
===========================================================================
=======================<phase: build          >============================
===>  Building for py27-opencv-2.3.1_7
/usr/local/bin/cmake -H/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1 
-B/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1 --check-build-system 
CMakeFiles/Makefile.cmake 0
/usr/local/bin/cmake -E cmake_progress_start 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/CMakeFiles 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/CMakeFiles/progress.marks
/usr/bin/make -f CMakeFiles/Makefile2 all
/usr/bin/make -f modules/python/CMakeFiles/opencv_python.dir/build.make 
modules/python/CMakeFiles/opencv_python.dir/depend
/usr/local/bin/cmake -E cmake_progress_report 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/CMakeFiles 1
[ 33%] Generating generated0.i
cd /wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/python && 
/usr/local/bin/python2.7 -B 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/python/src2/gen.py
 /wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/python/src2
PolarToCart [False, False, False, False, True]
Generated 377 functions
/usr/local/bin/cmake -E cmake_progress_report 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/CMakeFiles 2
[ 66%] Generating pyopencv_generated_funcs.h, pyopencv_generated_func_tab.h, 
pyopencv_generated_types.h, pyopencv_generated_type_reg.h, 
pyopencv_generated_const_reg.h
cd /wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/python && 
/usr/local/bin/python2.7 -B 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/python/src2/gen2.py
 /wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/python 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/core/include/opencv2/core/core.hpp
 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/flann/include/opencv2/flann/miniflann.hpp
 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/imgproc/include/opencv2/imgproc/imgproc.hpp
 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/video/include/opencv2/video/background_segm.hpp
 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/video/include/opencv2/video/tracking.hpp
 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/highgui/include/opencv2/highgui/highgui.hpp
 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/ml/include/opencv2/ml/ml.hpp
  /wrkdir
 
s/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/features2d/include/opencv2/features2d/features2d.hpp
 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/calib3d/include/opencv2/calib3d/calib3d.hpp
 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/objdetect/include/opencv2/objdetect/objdetect.hpp
cd /wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1 && 
/usr/local/bin/cmake -E cmake_depends "Unix Makefiles" 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/python 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/python 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/python/CMakeFiles/opencv_python.dir/DependInfo.cmake
Scanning dependencies of target opencv_python
/usr/bin/make -f modules/python/CMakeFiles/opencv_python.dir/build.make 
modules/python/CMakeFiles/opencv_python.dir/build
/usr/local/bin/cmake -E cmake_progress_report 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/CMakeFiles 3
[100%] Building CXX object 
modules/python/CMakeFiles/opencv_python.dir/src2/cv2.o
cd /wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/python && 
/usr/bin/c++   -DHAVE_CVCONFIG_H -Dopencv_python_EXPORTS -O2 -pipe 
-fno-strict-aliasing -Wno-error -Wno-c++11-narrowing -std=gnu++11   -O2 -pipe 
-fno-strict-aliasing -Wno-error -Wno-c++11-narrowing -std=gnu++11   -fPIC 
-I/usr/local/lib/python2.7/site-packages/numpy/core/include 
-I/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/. 
-I/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1 
-I/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/include 
-I/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/include/opencv 
-I/usr/local/include/python2.7 
-I/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/python/src2 
-I/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/core/include 
-I/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/flann/include 
-I/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/imgproc/include
 -I/wrkdirs/usr/ports/graphi
 cs/py-op
 encv/work/OpenCV-2.3.1/modules/video/include 
-I/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/highgui/include
 -I/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/ml/include 
-I/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/features2d/include
 
-I/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/calib3d/include
 
-I/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/objdetect/include
 
-I/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/legacy/include
 
-I/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/contrib/include
 -I/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/python    -D 
PYTHON_USE_NUMPY=1 -o CMakeFiles/opencv_python.dir/src2/cv2.o -c 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/python/src2/cv2.cpp
In file included from 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/python/src2/cv2.cpp:9:
In file included from 
/usr/local/lib/python2.7/site-packages/numpy/core/include/numpy/ndarrayobject.h:17:
In file included from 
/usr/local/lib/python2.7/site-packages/numpy/core/include/numpy/ndarraytypes.h:1728:
/usr/local/lib/python2.7/site-packages/numpy/core/include/numpy/npy_deprecated_api.h:11:2:
 warning: "Using deprecated NumPy API, disable it by #defining 
NPY_NO_DEPRECATED_API NPY_1_7_API_VERSION" [-W#warnings]
#warning "Using deprecated NumPy API, disable it by #defining 
NPY_NO_DEPRECATED_API NPY_1_7_API_VERSION"
 ^
In file included from 
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/python/src2/cv2.cpp:900:
/wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1/modules/python/src2/cv2.cv.hpp:2172:12:
 error: C-style cast from 'nullptr_t' to 'CvNextEdgeType' is not allowed
    *dst = (CvNextEdgeType)NULL;
           ^~~~~~~~~~~~~~~~~~~~
1 warning and 1 error generated.
*** Error code 1

Stop.
make[3]: stopped in /wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1
*** Error code 1

Stop.
make[2]: stopped in /wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1
*** Error code 1

Stop.
make[1]: stopped in /wrkdirs/usr/ports/graphics/py-opencv/work/OpenCV-2.3.1
*** Error code 1

Stop.
make: stopped in /usr/ports/graphics/py-opencv
===>  Cleaning for py27-opencv-2.3.1_7
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to