You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     martin.dierin...@gmx.de
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/graphics/py-poppler-qt4/Makefile 327733 
2013-09-20 18:35:44Z bapt $
Log URL:        
http://beefy1.isc.freebsd.org/bulk/head-i386-default/2013-10-17_19h54m49s/logs/py27-poppler-qt4-0.16.3_2.log
Build URL:      
http://beefy1.isc.freebsd.org/bulk/head-i386-default/2013-10-17_19h54m49s
Log:

====>> Building graphics/py-poppler-qt4
build started at Fri Oct 18 03:05:30 UTC 2013
port directory: /usr/ports/graphics/py-poppler-qt4
building for: FreeBSD head-i386-default-job-19 11.0-CURRENT FreeBSD 
11.0-CURRENT r256430 i386
maintained by: martin.dierin...@gmx.de
Makefile ident:      $FreeBSD: head/graphics/py-poppler-qt4/Makefile 327733 
2013-09-20 18:35:44Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
UNAME_m=i386
UNAME_p=i386
OSVERSION=1100000
UNAME_v=FreeBSD 11.0-CURRENT r256430
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/head-i386-default/ref
PKG_EXT=txz
tpid=24830
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=py27-poppler-qt4-0.16.3_2
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=head-i386-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--

--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
TMPDIR="/tmp" PYTHON="/usr/local/bin/python2.7" SHELL=/bin/sh 
CONFIG_SHELL=/bin/sh
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" _PYTHON_HOST_PLATFORM=-freebsd-11-i386 SHELL=/bin/sh NO_LINT=YES 
LDSHARED="cc -shared" PYTHONDONTWRITEBYTECODE= PYTHONOPTIMIZE= 
PREFIX=/usr/local  LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="cc" CFLAGS="-O2 
-pipe -fno-strict-aliasing"  CPP="cpp" CPPFLAGS=""  LDFLAGS=""  CXX="c++" 
CXXFLAGS="-O2 -pipe -fno-strict-aliasing"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o root -g wheel -m 444"  BSD_INSTALL_MAN="install  
-o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/poppler-qt4
DOCSDIR=/usr/local/share/doc/poppler-qt4
EXAMPLESDIR=/usr/local/share/examples/poppler-qt4
WWWDIR=/usr/local/www/poppler-qt4
ETCDIR=/usr/local/etc/poppler-qt4
--End SUB_LIST--

---Begin make.conf---
ARCH=i386
MACHINE=i386
MACHINE_ARCH=i386
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for py27-poppler-qt4-0.16.3_2
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   py27-poppler-qt4-0.16.3_2 depends on file: /usr/local/sbin/pkg - not 
found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of py27-poppler-qt4-0.16.3_2
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===>  License LGPL21 LGPL3 accepted by the user
===> Fetching all distfiles required by py27-poppler-qt4-0.16.3_2 for building
===========================================================================
=======================<phase: checksum       >============================
===>  License LGPL21 LGPL3 accepted by the user
===> Fetching all distfiles required by py27-poppler-qt4-0.16.3_2 for building
=> SHA256 Checksum OK for python-poppler-qt4-0.16.3.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===>  License LGPL21 LGPL3 accepted by the user
===> Fetching all distfiles required by py27-poppler-qt4-0.16.3_2 for building
===>  Extracting for py27-poppler-qt4-0.16.3_2
=> SHA256 Checksum OK for python-poppler-qt4-0.16.3.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for py27-poppler-qt4-0.16.3_2
===>  Applying FreeBSD patches for py27-poppler-qt4-0.16.3_2
===========================================================================
=======================<phase: build-depends  >============================
===>   py27-poppler-qt4-0.16.3_2 depends on executable: sip - not found
===>    Verifying install for sip in /usr/ports/devel/py-sip
===>   Installing existing package /packages/All/py27-sip-4.15.2,1.txz
Installing py27-sip-4.15.2,1...Installing gettext-0.18.3.1... done
Installing python27-2.7.5_3... done
Installing python2-2_1... done
Installing python-2.7_1,2... done
 done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of py27-poppler-qt4-0.16.3_2
===>   py27-poppler-qt4-0.16.3_2 depends on package: py27-qt4-gui>=0 - not found
===>    Verifying install for py27-qt4-gui>=0 in 
/usr/ports/x11-toolkits/py-qt4-gui
===>   Installing existing package /packages/All/py27-qt4-gui-4.10.3,1.txz
Installing py27-qt4-gui-4.10.3,1...Installing binutils-2.23.2... done
Installing ca_root_nss-3.15.1_1... done
Installing damageproto-1.2.1... done
Installing dbus-1.6.12...Installing xproto-7.0.24... done
Installing libxcb-1.9.1...Installing libXdmcp-1.1.1... done
Installing libXau-1.0.8... done
Installing libxml2-2.8.0_2... done
Installing libpthread-stubs-0.3_3... done
 done
Installing libX11-1.6.2,1...Installing kbproto-1.0.6... done
 done
Installing libSM-1.2.2,1...Installing libICE-1.0.8,1... done
 done
Installing expat-2.1.0... done
Installing gnome_subr-1.0... done
===> Creating users and/or groups.
Creating group 'messagebus' with gid '556'.
Creating user 'messagebus' with uid '556'.
 done
Installing dejavu-2.34...Installing fontconfig-2.10.95,1...Installing 
freetype2-2.5.0.1... done
Running fc-cache to build fontconfig cache...
/usr/local/share/fonts: skipping, no such directory
/usr/local/lib/X11/fonts: caching, new cache contents: 0 fonts, 1 dirs
/usr/local/lib/X11/fonts/local: caching, new cache contents: 0 fonts, 0 dirs
/root/.local/share/fonts: skipping, no such directory
/root/.fonts: skipping, no such directory
/var/db/fontconfig: cleaning cache directory
/root/.cache/fontconfig: not cleaning non-existent cache directory
/root/.fontconfig: not cleaning non-existent cache directory
fc-cache: succeeded
 done
 done
Installing dri2proto-2.8... done
Installing encodings-1.0.4,1...Installing font-util-1.3.0... done
 done
Installing fixesproto-5.0... done
Installing font-bh-ttf-1.0.3...Installing mkfontscale-1.1.1...Installing 
libfontenc-1.1.2... done
 done
Installing mkfontdir-1.0.7... done
 done
Installing font-misc-ethiopic-1.0.3... done
Installing font-misc-meltho-1.0.3... done
Installing fontcacheproto-0.1.3... done
Installing gcc-ecj-4.5... done
Installing gcc-4.6.3...Installing mpfr-3.1.2...Installing gmp-5.1.3... done
 done
Installing mpc-0.9... done
 done
Installing glib-2.36.3...Installing perl-5.14.4_2...Removing 
/usr/local/etc/perl5_version... Done.
Creating /usr/local/etc/perl5_version... Done.
Removing stale symlinks from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl5
Done.
 done
Installing pcre-8.33... done
<snip>
Installing orc-0.4.18... done
 done
Installing hicolor-icon-theme-0.12... done
Installing icu-50.1.2... done
Installing inputproto-2.3... done
Installing jbigkit-1.6... done
Installing jpeg-8_4... done
Installing kdehier4-1.1.1... done
Installing lcms-1.19_1,1... done
Installing libGL-7.6.1_4...Installing xf86vidmodeproto-2.3.1... done
Installing libXxf86vm-1.1.3... done
Installing libXfixes-5.0.1... done
Installing libXdamage-1.1.4... done
Installing pciids-20131010... done
Installing libdrm-2.4.17_1...Installing libpciaccess-0.13.2... done
 done
 done
Installing libXcursor-1.1.14...Installing renderproto-0.11.1... done
Installing libXrender-0.9.8... done
 done
Installing libXfontcache-1.0.5... done
Installing libXi-1.7.2,1... done
Installing libXinerama-1.1.3,1...Installing xineramaproto-1.2.1... done
 done
Installing libXmu-1.1.2,1...Installing libXt-1.1.4,1... done
 done
Installing libXrandr-1.4.2...Installing randrproto-1.4.0... done
 done
Installing libmng-1.0.10_2... done
Installing phonon-4.6.0_1...Installing png-1.5.17... done
Installing qt4-corelib-4.8.5... done
Installing qt4-dbus-4.8.5...Installing qt4-xml-4.8.5... done
 done
Installing qt4-declarative-4.8.5...Installing qt4-gui-4.8.5...Installing 
xdg-utils-1.0.2.20130919_1...Installing xprop-1.2.2... done
Installing xset-1.2.3_1... done
 done
Installing xorg-fonts-truetype-7.7_1... done
 done
Installing qt4-network-4.8.5... done
Installing qt4-opengl-4.8.5... done
Installing qt4-script-4.8.5... done
Installing qt4-sql-4.8.5... done
Installing qt4-svg-4.8.5... done
Installing qt4-xmlpatterns-4.8.5... done
 done
Installing qt4-qtestlib-4.8.5... done
Installing qzeitgeist-0.8.0... done
 done
Installing py27-qt4-core-4.10.3,1...Installing qscintilla2-2.7.2,1...Installing 
qt4-assistant-4.8.5...Installing qt4-clucene-4.8.5... done
Installing qt4-doc-4.8.5... done
Installing qt4-help-4.8.5...Installing qt4-sqlite-plugin-4.8.5...Installing 
sqlite3-3.8.0.2... done
 done
 done
Installing qt4-webkit-4.8.5... done
 done
Installing qt4-designer-4.8.5...Installing qt4-qt3support-4.8.5... done
 done
 done
 done
Installing qt4-iconengines-4.8.5... done
Installing qt4-imageformats-4.8.5...Installing tiff-4.0.3... done
 done
Installing qt4-inputmethods-4.8.5... done
 done
Make sure that the freetype module is loaded.  If it is not, add the following
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/lib/X11/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
======================================================================

Qt 4 can be built with optional support for:
 - Common UNIX Printing System (CUPS) (enabled by default)
 - Network Audio System (NAS)
 - Qt style that renders using GTK (QGTKSTYLE)

In order to enable them, you have to add
        QT4_OPTIONS=    CUPS NAS QGTKSTYLE
to your /etc/make.conf and compile devel/qt4-corelib and
x11-toolkits/qt4-gui ports.

Attention! Whenever you change the QT4_OPTIONS both
devel/qt4-corelib and x11-toolkits/qt4-gui ports must be rebuilt!

======================================================================
======================================================================

Qt paint engine makes common use of shared memory. To avoid MIT-SHM
errors (i.e., blank windows), you probably need to raise shared memory
limits in loader.conf(5). The following should be safe values for the
KDE Plasma Desktop:

kern.ipc.shmall=32768
kern.ipc.shmmni=1024
kern.ipc.shmseg=1024

======================================================================
*******************************************************************************

        To enable QT's database support, install the database plugin ports.
        The following plugin ports are available:

                IBase/Firebird  - databases/qt4-ibase-plugin
                MySQL           - databases/qt4-mysql-plugin
                ODBC            - databases/qt4-odbc-plugin
                PostgreSQL      - databases/qt4-pgsql-plugin
                SQLite          - databases/qt4-sqlite-plugin                   
        

*******************************************************************************
======================================================================

You'll have to install sysutils/zeitgeist to enable event logging.

======================================================================
======================================================================

Please, consider installing backends for Phonon:
- multimedia/phonon-gstreamer   GStreamer backend
- multimedia/phonon-vlc         VLC backend

======================================================================
===>   Returning to build of py27-poppler-qt4-0.16.3_2
===>   py27-poppler-qt4-0.16.3_2 depends on package: py27-qt4-xml>=0 - not found
===>    Verifying install for py27-qt4-xml>=0 in /usr/ports/textproc/py-qt4-xml
===>   Installing existing package /packages/All/py27-qt4-xml-4.10.3,1.txz
Installing py27-qt4-xml-4.10.3,1... done
===>   Returning to build of py27-poppler-qt4-0.16.3_2
===>   py27-poppler-qt4-0.16.3_2 depends on file: 
/usr/local/bin/easy_install-2.7 - not found
===>    Verifying install for /usr/local/bin/easy_install-2.7 in 
/usr/ports/devel/py-distribute
===>   Installing existing package /packages/All/py27-distribute-0.6.35.txz
Installing py27-distribute-0.6.35... done
===>   Returning to build of py27-poppler-qt4-0.16.3_2
===>   py27-poppler-qt4-0.16.3_2 depends on file: /usr/local/bin/python2.7 - 
found
===>   py27-poppler-qt4-0.16.3_2 depends on executable: python - found
===========================================================================
=======================<phase: lib-depends    >============================
===>   py27-poppler-qt4-0.16.3_2 depends on shared library: poppler-qt4 - not 
found
===>    Verifying install for poppler-qt4 in /usr/ports/graphics/poppler-qt4
===>   Installing existing package /packages/All/poppler-qt4-0.22.2.txz
Installing poppler-qt4-0.22.2...Installing 
xcb-util-renderutil-0.3.8...Installing xcb-util-0.3.9_1,1... done
 done
Installing pixman-0.30.2... done
Installing poppler-data-0.4.6... done
Installing poppler-0.22.2...Installing openjpeg-1.5.0_2...Installing 
lcms2-2.5... done
 done
Installing cairo-1.10.2_6,2... done
 done
 done
===>   Returning to build of py27-poppler-qt4-0.16.3_2
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for py27-poppler-qt4-0.16.3_2
running config
===========================================================================
=======================<phase: build          >============================
===>  Building for py27-poppler-qt4-0.16.3_2
running setopt
Writing setup.cfg
running setopt
Writing setup.cfg
running setopt
Writing setup.cfg
running setopt
Writing setup.cfg
running bdist_egg
running egg_info
writing python_poppler_qt4.egg-info/PKG-INFO
writing top-level names to python_poppler_qt4.egg-info/top_level.txt
writing dependency_links to python_poppler_qt4.egg-info/dependency_links.txt
reading manifest file 'python_poppler_qt4.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
writing manifest file 'python_poppler_qt4.egg-info/SOURCES.txt'
installing library code to build/bdist.freebsd-11-i386/egg
running install_lib
running build_ext
building 'popplerqt4' extension
Can't determine version of poppler-qt4
/usr/local/bin/sip -I /usr/local/share/py-sip -t POPPLER_V0_12_0 -c 
temp.freebsd-11-i386-2.7 -b temp.freebsd-11-i386-2.7/poppler-qt4.sbf -I 
/usr/local/share/py-sip -x VendorID -t WS_X11 -x PyQt_NoPrintRangeBug -t 
Qt_4_8_4 -x Py_v3 -g poppler-qt4.sip
sip: Deprecation warning: poppler-qt4.sip:1: %Module version number should be 
specified using the 'version' argument
sip: Deprecation warning: poppler-annotation.sip:378: %GetCode should be used a 
sub-directive
sip: Deprecation warning: poppler-annotation.sip:378: %SetCode should be used a 
sub-directive
creating temp.freebsd-11-i386-2.7/temp.freebsd-11-i386-2.7
cc -DNDEBUG -O2 -pipe -fno-strict-aliasing -fPIC -I/usr/local/include/qt4 
-I/usr/local/include/qt4/QtCore -I/usr/local/include/qt4/QtGui 
-I/usr/local/include/qt4/QtXml -I/usr/local/include/python2.7 
-I/usr/local/include/python2.7 -c 
temp.freebsd-11-i386-2.7/sippopplerqt4cmodule.cpp -o 
temp.freebsd-11-i386-2.7/temp.freebsd-11-i386-2.7/sippopplerqt4cmodule.o
In file included from temp.freebsd-11-i386-2.7/sippopplerqt4cmodule.cpp:7:
poppler-qt4.sip:24:10: fatal error: 'qt4/poppler-qt4.h' file not found
#include <qt4/poppler-qt4.h>
         ^
1 error generated.
error: command 'cc' failed with exit status 1
*** Error code 1

Stop.
make: stopped in /usr/ports/graphics/py-poppler-qt4
===>  Cleaning for py27-poppler-qt4-0.16.3_2
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to