You are receiving this mail as a port that you maintain
is failing to build on the FreeBSD package build server.
Please investigate the failure and submit a PR to fix
build.

Maintainer:     g...@freebsd.org
Last committer: b...@freebsd.org
Ident:          $FreeBSD: head/print/lilypond/Makefile 327765 2013-09-20 
22:43:59Z bapt $
Log URL:        
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-10-17_23h06m42s/logs/lilypond-2.16.1.log
Build URL:      
http://beefy2.isc.freebsd.org/bulk/head-amd64-default/2013-10-17_23h06m42s
Log:

====>> Building print/lilypond
build started at Fri Oct 18 03:52:49 UTC 2013
port directory: /usr/ports/print/lilypond
building for: FreeBSD head-amd64-default-job-07 11.0-CURRENT FreeBSD 
11.0-CURRENT r256430 amd64
maintained by: g...@freebsd.org
Makefile ident:      $FreeBSD: head/print/lilypond/Makefile 327765 2013-09-20 
22:43:59Z bapt $
Poudriere version: 3.1-pre

---Begin Environment---
OSVERSION=1100000
UNAME_v=FreeBSD 11.0-CURRENT r256430
UNAME_r=11.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/games:/usr/local/sbin:/usr/local/bin:/root/bin
STATUS=1
MASTERMNT=/usr/local/poudriere/data/build/head-amd64-default/ref
PKG_EXT=txz
tpid=57291
POUDRIERE_BUILD_TYPE=bulk
PKGNG=1
PKGNAME=lilypond-2.16.1
PKG_DELETE=/usr/local/sbin/pkg-static delete -y -f
PKG_ADD=/usr/local/sbin/pkg-static add
PWD=/root
MASTERNAME=head-amd64-default
USER=root
HOME=/root
POUDRIERE_VERSION=3.1-pre
LOCALBASE=/usr/local
PACKAGE_BUILDING=yes
PKG_VERSION=/poudriere/pkg-static version
PKG_BIN=/usr/local/sbin/pkg-static
---End Environment---

---Begin OPTIONS List---
---End OPTIONS List---

--CONFIGURE_ARGS--
--with-ncsb-dir=/usr/local/share/ghostscript/fonts --prefix=/usr/local 
${_LATE_CONFIGURE_ARGS}
--End CONFIGURE_ARGS--

--CONFIGURE_ENV--
ac_cv_prog_MAKEINFO="/usr/local/bin/makeinfo"  FLEX=/usr/bin/flex YACC=yacc 
TMPDIR="/tmp" TMPDIR="/tmp" PYTHON="/usr/local/bin/python2.7" MAKE=gmake 
PKG_CONFIG=pkgconf SHELL=/bin/sh CONFIG_SHELL=/bin/sh 
ADDR2LINE="/usr/local/bin/addr2line" AR="/usr/local/bin/ar" 
AS="/usr/local/bin/as" CPPFILT="/usr/local/bin/c++filt" 
GPROF="/usr/local/bin/gprof" LD="/usr/local/bin/ld" NM="/usr/local/bin/nm" 
OBJCOPY="/usr/local/bin/objcopy" OBJDUMP="/usr/local/bin/objdump" 
RANLIB="/usr/local/bin/ranlib" READELF="/usr/local/bin/readelf" 
SIZE="/usr/local/bin/size" STRINGS="/usr/local/bin/strings" 
CONFIG_SITE=/usr/ports/Templates/config.site lt_cv_sys_max_cmd_len=262144
--End CONFIGURE_ENV--

--MAKE_ENV--
TMPDIR="/tmp" TMPDIR="/tmp" SHELL=/bin/sh NO_LINT=YES 
ADDR2LINE="/usr/local/bin/addr2line" AR="/usr/local/bin/ar" 
AS="/usr/local/bin/as" CPPFILT="/usr/local/bin/c++filt" 
GPROF="/usr/local/bin/gprof" LD="/usr/local/bin/ld" NM="/usr/local/bin/nm" 
OBJCOPY="/usr/local/bin/objcopy" OBJDUMP="/usr/local/bin/objdump" 
RANLIB="/usr/local/bin/ranlib" READELF="/usr/local/bin/readelf" 
SIZE="/usr/local/bin/size" STRINGS="/usr/local/bin/strings" PREFIX=/usr/local  
LOCALBASE=/usr/local  LIBDIR="/usr/lib"  CC="gcc46" CFLAGS="-O2 -pipe 
-Wl,-rpath=/usr/local/lib/gcc46 -fno-strict-aliasing"  CPP="cpp46" CPPFLAGS=""  
LDFLAGS=" -Wl,-rpath=/usr/local/lib/gcc46"  CXX="g++46" CXXFLAGS="-O2 -pipe 
-Wl,-rpath=/usr/local/lib/gcc46 -fno-strict-aliasing 
-Wl,-rpath=/usr/local/lib/gcc46"  MANPREFIX="/usr/local" 
BSD_INSTALL_PROGRAM="install  -s -o root -g wheel -m 555"  
BSD_INSTALL_LIB="install  -s -o root -g wheel -m 444"  
BSD_INSTALL_SCRIPT="install  -o root -g wheel -m 555"  
BSD_INSTALL_DATA="install  -o r
 oot -g w
 heel -m 444"  BSD_INSTALL_MAN="install  -o root -g wheel -m 444"
--End MAKE_ENV--

--SUB_LIST--
PREFIX=/usr/local
LOCALBASE=/usr/local
DATADIR=/usr/local/share/lilypond
DOCSDIR=/usr/local/share/doc/lilypond
EXAMPLESDIR=/usr/local/share/examples/lilypond
WWWDIR=/usr/local/www/lilypond
ETCDIR=/usr/local/etc/lilypond
--End SUB_LIST--

---Begin make.conf---
USE_PACKAGE_DEPENDS=yes
BATCH=yes
WRKDIRPREFIX=/wrkdirs
PORTSDIR=/usr/ports
PACKAGES=/packages
DISTDIR=/distfiles
#### /usr/local/etc/poudriere.d/make.conf ####
WITH_PKGNG=yes
NO_RESTRICTED=yes
DISABLE_MAKE_JOBS=poudriere
---End make.conf---
===>  Cleaning for lilypond-2.16.1
=======================<phase: check-config   >============================
===========================================================================
=======================<phase: pkg-depends    >============================
===>   lilypond-2.16.1 depends on file: /usr/local/sbin/pkg - not found
===>    Verifying install for /usr/local/sbin/pkg in /usr/ports/ports-mgmt/pkg
===>   Installing existing package /packages/All/pkg-1.1.4_8.txz
Installing pkg-1.1.4_8... done
If you are upgrading from the old package format, first run:

  # pkg2ng
===>   Returning to build of lilypond-2.16.1
===========================================================================
=======================<phase: fetch-depends  >============================
===========================================================================
=======================<phase: fetch          >============================
===> Fetching all distfiles required by lilypond-2.16.1 for building
===========================================================================
=======================<phase: checksum       >============================
===> Fetching all distfiles required by lilypond-2.16.1 for building
=> SHA256 Checksum OK for lilypond-2.16.1.tar.gz.
===========================================================================
=======================<phase: extract-depends>============================
===========================================================================
=======================<phase: extract        >============================
===> Fetching all distfiles required by lilypond-2.16.1 for building
===>  Extracting for lilypond-2.16.1
=> SHA256 Checksum OK for lilypond-2.16.1.tar.gz.
===========================================================================
=======================<phase: patch-depends  >============================
===========================================================================
=======================<phase: patch          >============================
===>  Patching for lilypond-2.16.1
===>  Applying FreeBSD patches for lilypond-2.16.1
/usr/bin/sed -i.bak -e 's|<FlexLexer.h>|"/usr/include/FlexLexer.h"|'  
/wrkdirs/usr/ports/print/lilypond/work/lilypond-2.16.1/lily/include/includable-lexer.hh
/usr/bin/sed -i.bak -e '/^PO_FILES/s|= |= #|' 
/wrkdirs/usr/ports/print/lilypond/work/lilypond-2.16.1/GNUmakefile.in
===========================================================================
=======================<phase: build-depends  >============================
===>   lilypond-2.16.1 depends on executable: pdftexi2dvi - not found
===>    Verifying install for pdftexi2dvi in /usr/ports/print/texinfo
===>   Installing existing package /packages/All/texinfo-5.2.20130926_1.txz
Installing texinfo-5.2.20130926_1...Installing gettext-0.18.3.1... done
Installing perl-5.14.4_2...Removing /usr/local/etc/perl5_version... Done.
Creating /usr/local/etc/perl5_version... Done.
Removing stale symlinks from /usr/bin...
    Skipping /usr/bin/perl
    Skipping /usr/bin/perl5
Done.
Creating various symlinks in /usr/bin...
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl
    Symlinking /usr/local/bin/perl5.14.4 to /usr/bin/perl5
Done.
 done
 done
===>   Returning to build of lilypond-2.16.1
===>   lilypond-2.16.1 depends on executable: t1ascii - not found
===>    Verifying install for t1ascii in /usr/ports/print/t1utils
===>   Installing existing package /packages/All/t1utils-1.32.txz
Installing t1utils-1.32... done
===>   Returning to build of lilypond-2.16.1
===>   lilypond-2.16.1 depends on executable: bash - not found
===>    Verifying install for bash in /usr/ports/shells/bash
===>   Installing existing package /packages/All/bash-4.2.45.txz
Installing bash-4.2.45... done
===>   Returning to build of lilypond-2.16.1
===>   lilypond-2.16.1 depends on executable: fontforge - not found
===>    Verifying install for fontforge in /usr/ports/print/fontforge
===>   Installing existing package /packages/All/fontforge-20120731.b_2.txz
Installing fontforge-20120731.b_2...Installing xproto-7.0.24... done
Installing xextproto-7.2.1... done
Installing libxkbui-1.0.2_1...Installing kbproto-1.0.6... done
Installing libICE-1.0.8,1... done
Installing libSM-1.2.2,1... done
Installing libX11-1.6.2,1...Installing libXau-1.0.8... done
Installing libXdmcp-1.1.1... done
Installing libpthread-stubs-0.3_3... done
Installing libxcb-1.9.1...Installing libxml2-2.8.0_2... done
 done
 done
Installing libXt-1.1.4,1... done
Installing libxkbfile-1.0.8... done
 done
Installing libXi-1.7.2,1...Installing libXfixes-5.0.1...Installing 
fixesproto-5.0... done
 done
Installing libXext-1.3.2,1... done
Installing inputproto-2.3... done
 done
Installing libuninameslist-20091231... done
Installing tiff-4.0.3...Installing jpeg-8_4... done
Installing jbigkit-1.6... done
 done
Installing png-1.5.17... done
Installing libspiro-20071029... done
Installing giflib-nox11-4.2.3... done
 done
===>   Returning to build of lilypond-2.16.1
===>   lilypond-2.16.1 depends on file: 
/usr/local/share/ghostscript/fonts/c059033l.pfb - not found
===>    Verifying install for /usr/local/share/ghostscript/fonts/c059033l.pfb 
in /usr/ports/print/gsfonts
===>   Installing existing package /packages/All/gsfonts-8.11_6.txz
Installing gsfonts-8.11_6... done
===>   Returning to build of lilypond-2.16.1
===>   lilypond-2.16.1 depends on file: /usr/local/bin/python2.7 - not found
===>    Verifying install for /usr/local/bin/python2.7 in 
/usr/ports/lang/python27
===>   Installing existing package /packages/All/python27-2.7.5_3.txz
Installing python27-2.7.5_3... done
====
Note that some of the standard modules are provided as separate
ports since they require extra dependencies:

bsddb           databases/py-bsddb
gdbm            databases/py-gdbm
sqlite3         databases/py-sqlite3
tkinter         x11-toolkits/py-tkinter

Install them as needed.
====
===>   Returning to build of lilypond-2.16.1
===>   lilypond-2.16.1 depends on executable: python - not found
===>    Verifying install for python in /usr/ports/lang/python
===>   Installing existing package /packages/All/python-2.7_1,2.txz
Installing python-2.7_1,2...Installing python2-2_1... done
 done
===>   Returning to build of lilypond-2.16.1
===>   lilypond-2.16.1 depends on file: 
/usr/local/share/texmf-dist/LICENSE.texmf - not found
===>    Verifying install for /usr/local/share/texmf-dist/LICENSE.texmf in 
/usr/ports/print/teTeX-texmf
===>   Installing existing package /packages/All/teTeX-texmf-3.0_9.txz
Installing teTeX-texmf-3.0_9...Installing tex-texmflocal-1.9... done
<snip>
line to the "Modules" section of your X Windows configuration file:

        Load "freetype"

Add the following line to the "Files" section of X Windows configuration file:

        FontPath "/usr/local/lib/X11/fonts/dejavu/"

Note: your X Windows configuration file is typically /etc/X11/XF86Config
if you are using XFree86, and /etc/X11/xorg.conf if you are using X.Org.
===>   Returning to build of lilypond-2.16.1
===========================================================================
=======================<phase: configure      >============================
===>  Configuring for lilypond-2.16.1
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/print/lilypond/work/lilypond-2.16.1/stepmake/aclocal.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/print/lilypond/work/lilypond-2.16.1/aclocal.m4
===>   FreeBSD 10 autotools fix applied to 
/wrkdirs/usr/ports/print/lilypond/work/lilypond-2.16.1/configure
configure: loading site script /usr/ports/Templates/config.site
checking build system type... amd64-portbld-freebsd11.0
checking Package... LILYPOND
checking builddir... /wrkdirs/usr/ports/print/lilypond/work/lilypond-2.16.1
checking for stepmake... ./stepmake  (${datarootdir}/stepmake not found)
checking host system type... amd64-portbld-freebsd11.0
checking for gmake... gmake
checking for find... find
checking for tar... tar
checking for bash... /usr/local/bin/bash
checking for python... /usr/local/bin/python2.7
checking /usr/local/bin/python2.7 version... 2.7.5
checking for /usr/local/bin/python2.7... /usr/local/bin/python2.7
checking for gcc... gcc46
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc46 accepts -g... yes
checking for gcc46 option to accept ISO C89... none needed
checking whether compiler understands -pipe... yes
checking for IEEE-conformance compiler flags... none
checking for fc-list... fc-list
checking New Century Schoolbook PFB files... 
/usr/local/share/ghostscript/fonts/c059013l.pfb 
/usr/local/share/ghostscript/fonts/c059016l.pfb 
/usr/local/share/ghostscript/fonts/c059033l.pfb 
/usr/local/share/ghostscript/fonts/c059036l.pfb 
checking for python... /usr/local/bin/python2.7
checking /usr/local/bin/python2.7 version... 2.7.5
checking for /usr/local/bin/python2.7... /usr/local/bin/python2.7
checking whether we are using the GNU C++ compiler... yes
checking whether g++46 accepts -g... yes
checking how to run the C++ preprocessor... g++46 -E
checking for grep that handles long lines and -e... (cached) /usr/bin/grep
checking for egrep... (cached) /usr/bin/egrep
checking gcc46 version... 4.6.3
checking whether we are using the GNU C++ compiler... (cached) yes
checking whether g++46 accepts -g... (cached) yes
checking g++46 version... 4.6.3
checking options for known g++ bugs... none
checking whether explicit instantiation is needed... no
checking for stl.data () method... yes
checking for ar... /usr/local/bin/ar
checking for ranlib... /usr/local/bin/ranlib
checking for dlopen in -ldl... no
checking for dlopen... (cached) yes
checking for bison... yacc
checking for bison... bison
checking bison version... 2.7.12
checking for flex... /usr/bin/flex
checking for ANSI C header files... (cached) yes
checking for sys/types.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for stdlib.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for strings.h... (cached) yes
checking for inttypes.h... (cached) yes
checking for stdint.h... (cached) yes
checking for unistd.h... (cached) yes
checking FlexLexer.h usability... yes
checking FlexLexer.h presence... yes
checking for FlexLexer.h... yes
checking for yyFlexLexer.yy_current_buffer... no
checking FlexLexer.h location... /usr/include/FlexLexer.h
checking language... English
checking for gettext in -lintl... yes
checking for gettext... yes
checking for msgfmt... msgfmt
checking for mf-nowin... mf-nowin
checking for mpost... mpost
checking for working metafont mode... ljfour
checking for kpsewhich... kpsewhich
checking for guile-config... guile-config
checking guile-config version... 1.8.8
checking guile compile flags... -I/usr/local/include -I/usr/local/include 
-D_THREAD_SAFE -pthread
checking guile link flags... -I/usr/local/include -D_THREAD_SAFE -pthread 
-L/usr/local/lib -lguile -lltdl -L/usr/local/lib 
-Wl,-rpath=/usr/lib:/usr/local/lib -lgmp -lcrypt -lm -lltdl
checking libguile.h usability... yes
checking libguile.h presence... yes
checking for libguile.h... yes
checking for scm_boot_guile in -lguile... yes
checking for scm_boot_guile... yes
checking for scm_t_hash_fold_fn... no
checking for scm_t_hash_handle_fn... no
checking for scm_t_subr... no
checking for usable C++ demangler... yes
checking GUILE rational bugfix... ok
checking for python-config... python-config
checking Python.h usability... no
checking Python.h presence... no
checking for Python.h... no
checking for gs... gs
checking for gs... /usr/local/bin/gs
checking /usr/local/bin/gs version... 9.06
checking for fontforge... fontforge
checking for fontforge... /usr/local/bin/fontforge
checking /usr/local/bin/fontforge version... 20120731
checking for t1asm... t1asm
checking for t1asm... /usr/local/bin/t1asm
checking assert.h usability... no
checking assert.h presence... no
checking for assert.h... no
checking grp.h usability... no
checking grp.h presence... no
checking for grp.h... no
checking libio.h usability... no
checking libio.h presence... no
checking for libio.h... no
checking for pwd.h... (cached) yes
checking for sys/stat.h... (cached) yes
checking for wchar.h... (cached) yes
checking fpu_control.h usability... no
checking fpu_control.h presence... no
checking for fpu_control.h... no
checking sstream usability... no
checking sstream presence... no
checking for sstream... no
checking whether stat file-mode macros are broken... yes
checking for working memcmp... no
checking for vprintf... (cached) yes
checking for _doprnt... no
checking for chroot... no
checking for fopencookie... no
checking for gettext... (cached) yes
checking for isinf... no
checking for memmem... no
checking for snprintf... (cached) yes
checking for vsnprintf... (cached) yes
checking for pkg-config... pkgconf
checking pkgconf version... 0.28
checking whether to enable dynamic relocation... no
checking for rpath linkage... no
checking for pangoft2 >= 1.6.0... yes
checking PANGO_FT2_CFLAGS... -I/usr/local/include/pango-1.0 -pthread 
-I/usr/local/include/glib-2.0  -I/usr/local/include/freetype2 
-I/usr/local/include -I/usr/local/include/harfbuzz  
checking PANGO_FT2_LIBS... -lpangoft2-1.0 -lpango-1.0 -lgobject-2.0 -lglib-2.0 
-lintl -lfontconfig -L/usr/local/lib -lfreetype  
checking pango/pangoft2.h usability... no
checking pango/pangoft2.h presence... no
checking for pango/pangoft2.h... no
checking for pango_ft2_font_map_create_context... no
checking for fontconfig >= 2.4.0... yes
checking FONTCONFIG_CFLAGS...  -I/usr/local/include/freetype2 
-I/usr/local/include  
checking FONTCONFIG_LIBS... -lfontconfig -L/usr/local/lib -lfreetype  
checking for freetype2 >= 2.1.10... yes
checking FREETYPE2_CFLAGS... -I/usr/local/include/freetype2 
-I/usr/local/include  
checking FREETYPE2_LIBS... -L/usr/local/lib -lfreetype  
checking host system type... (cached) amd64-portbld-freebsd11.0
checking host system type... (cached) amd64-portbld-freebsd11.0
checking for some flavor of Windows... no
checking for -windres... no
checking for windres... no
checking for guile... guile
checking for guile... /usr/local/bin/guile
checking for perl... perl
checking for perl... /usr/bin/perl
checking for makeinfo... (cached) /usr/local/bin/makeinfo
checking /usr/local/bin/makeinfo version... 5.2
checking for texi2html... texi2html
checking texi2html version... 5.0
checking for dblatex... no
checking for pdflatex... pdflatex
checking for pngtopnm... no
checking for convert... no
checking for zip... no
checking for rsync... no
configure: creating ./config.status
config.status: creating config.make
config.status: creating config.hh

WARNING: Please consider installing optional programs:  dblatex pngtopnm 
convert zip rsync

ERROR: Please install required programs:  Python.h (python-devel, python-dev or 
libpython-dev package)

See INSTALL.txt for more information on how to build LilyPond
===>  Script "configure" failed unexpectedly.
Please report the problem to g...@freebsd.org [maintainer] and attach the
"/wrkdirs/usr/ports/print/lilypond/work/lilypond-2.16.1/config.log" including
the output of the failure of your make command. Also, it might be a good idea
to provide an overview of all packages installed on your system (e.g. a
/usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop.
make: stopped in /usr/ports/print/lilypond
===>  Cleaning for lilypond-2.16.1
_______________________________________________
freebsd-pkg-fallout@freebsd.org mailing list
https://lists.freebsd.org/mailman/listinfo/freebsd-pkg-fallout
To unsubscribe, send any mail to "freebsd-pkg-fallout-unsubscr...@freebsd.org"

Reply via email to